Reimplemented multi-byte and wide-chars functions to not depend on
[wine/multimedia.git] / dlls / crtdll / crtdll.spec
blob177c33be70b90dddce9c9be7fbc38fdb9b1aaaca
1 # C RunTime DLL. All functions use cdecl!
2 name crtdll
3 type win32
4 init CRTDLL_Init
6 1 cdecl ??2@YAPAXI@Z(long) CRTDLL_new
7 2 cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
8 3 cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
9 4 stub _CIacos
10 5 stub _CIasin
11 6 stub _CIatan
12 7 stub _CIatan2
13 8 stub _CIcos
14 9 stub _CIcosh
15 10 stub _CIexp
16 11 stub _CIfmod
17 12 stub _CIlog
18 13 stub _CIlog10
19 14 cdecl _CIpow() CRTDLL__CIpow
20 15 stub _CIsin
21 16 stub _CIsinh
22 17 stub _CIsqrt
23 18 stub _CItan
24 19 stub _CItanh
25 20 stub _HUGE_dll
26 21 stub _XcptFilter
27 22 cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
28 23 extern __argc_dll CRTDLL_argc_dll
29 24 extern __argv_dll CRTDLL_argv_dll
30 25 cdecl __dllonexit() CRTDLL__dllonexit
31 26 stub __doserrno
32 27 stub __fpecode
33 28 stub __isascii
34 29 stub __iscsym
35 30 stub __iscsymf
36 31 stub __mb_cur_max_dll
37 32 stub __pxcptinfoptrs
38 33 cdecl __threadhandle() GetCurrentThread
39 34 cdecl __threadid() GetCurrentThreadId
40 35 stub __toascii
41 36 cdecl _abnormal_termination() CRTDLL__abnormal_termination
42 37 cdecl _access(str long) CRTDLL__access
43 38 extern _acmdln_dll CRTDLL_acmdln_dll
44 39 stub _aexit_rtn_dll
45 40 stub _amsg_exit
46 41 stub _assert
47 42 extern _basemajor_dll CRTDLL_basemajor_dll
48 43 extern _baseminor_dll CRTDLL_baseminor_dll
49 44 extern _baseversion_dll CRTDLL_baseversion_dll
50 45 stub _beep
51 46 stub _beginthread
52 47 stub _c_exit
53 48 stub _cabs
54 49 cdecl _cexit(long) CRTDLL__cexit
55 50 stub _cgets
56 51 cdecl _chdir(str) CRTDLL__chdir
57 52 cdecl _chdrive(long) CRTDLL__chdrive
58 53 stub _chgsign
59 54 stub _chmod
60 55 stub _chsize
61 56 stub _clearfp
62 57 cdecl _close(long) CRTDLL__close
63 58 stub _commit
64 59 extern _commode_dll CRTDLL_commode_dll
65 60 stub _control87
66 61 stub _controlfp
67 62 stub _copysign
68 63 stub _cprintf
69 64 stub _cpumode_dll
70 65 stub _cputs
71 66 stub _creat
72 67 stub _cscanf
73 68 stub _ctype
74 69 stub _cwait
75 70 stub _daylight_dll
76 71 stub _dup
77 72 stub _dup2
78 73 stub _ecvt
79 74 stub _endthread
80 75 extern _environ_dll CRTDLL_environ_dll
81 76 stub _eof
82 77 cdecl _errno() CRTDLL__errno
83 78 cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
84 79 stub _execl
85 80 stub _execle
86 81 stub _execlp
87 82 stub _execlpe
88 83 stub _execv
89 84 stub _execve
90 85 stub _execvp
91 86 stub _execvpe
92 87 stub _exit
93 88 stub _expand
94 89 stub _fcloseall
95 90 stub _fcvt
96 91 cdecl _fdopen(long ptr) CRTDLL__fdopen
97 92 stub _fgetchar
98 93 stub _fgetwchar
99 94 stub _filbuf
100 95 stub _fileinfo_dll
101 96 stub _filelength
102 97 stub _fileno
103 98 stub _findclose
104 99 cdecl _findfirst(str ptr) CRTDLL__findfirst
105 100 cdecl _findnext(long ptr) CRTDLL__findnext
106 101 stub _finite
107 102 stub _flsbuf
108 103 stub _flushall
109 104 extern _fmode_dll CRTDLL_fmode_dll
110 105 stub _fpclass
111 106 stub _fpieee_flt
112 107 cdecl _fpreset() CRTDLL__fpreset
113 108 stub _fputchar
114 109 stub _fputwchar
115 110 cdecl _fsopen(str str long) CRTDLL__fsopen
116 111 cdecl _fstat(long ptr) CRTDLL__fstat
117 112 stub _ftime
118 113 cdecl _ftol() CRTDLL__ftol
119 114 cdecl _fullpath(ptr str long) CRTDLL__fullpath
120 115 stub _futime
121 116 stub _gcvt
122 117 stub _get_osfhandle
123 118 stub _getch
124 119 stub _getche
125 120 cdecl _getcwd(ptr long) CRTDLL__getcwd
126 121 cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
127 122 stub _getdiskfree
128 123 stub _getdllprocaddr
129 124 cdecl _getdrive() CRTDLL__getdrive
130 125 stub _getdrives
131 126 stub _getpid
132 127 stub _getsystime
133 128 stub _getw
134 129 cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
135 130 stub _heapchk
136 131 stub _heapmin
137 132 stub _heapset
138 133 stub _heapwalk
139 134 cdecl _hypot(double double) hypot
140 135 cdecl _initterm(ptr ptr) CRTDLL__initterm
141 136 extern _iob CRTDLL_iob
142 137 cdecl _isatty(long) CRTDLL__isatty
143 138 cdecl _isctype(long long) CRTDLL__isctype
144 139 stub _ismbbalnum
145 140 stub _ismbbalpha
146 141 stub _ismbbgraph
147 142 stub _ismbbkalnum
148 143 stub _ismbbkana
149 144 stub _ismbbkpunct
150 145 stub _ismbblead
151 146 stub _ismbbprint
152 147 stub _ismbbpunct
153 148 stub _ismbbtrail
154 149 stub _ismbcalpha
155 150 stub _ismbcdigit
156 151 stub _ismbchira
157 152 stub _ismbckata
158 153 stub _ismbcl0
159 154 stub _ismbcl1
160 155 stub _ismbcl2
161 156 stub _ismbclegal
162 157 stub _ismbclower
163 158 stub _ismbcprint
164 159 stub _ismbcspace
165 160 stub _ismbcsymbol
166 161 stub _ismbcupper
167 162 stub _ismbslead
168 163 stub _ismbstrail
169 164 stub _isnan
170 165 cdecl _itoa(long ptr long) CRTDLL__itoa
171 166 stub _itow
172 167 cdecl _j0(double) j0
173 168 cdecl _j1(double) j1
174 169 cdecl _jn(long double) jn
175 170 stub _kbhit
176 171 stub _lfind
177 172 stub _loaddll
178 173 cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
179 174 stub _locking
180 175 stub _logb
181 176 cdecl _lrotl (long long) CRTDLL__lrotl
182 177 stub _lrotr
183 178 stub _lsearch
184 179 stub _lseek
185 180 cdecl _ltoa(long str long) CRTDLL__ltoa
186 181 stub _ltow
187 182 cdecl _makepath (ptr str str str str) CRTDLL__makepath
188 183 stub _matherr
189 184 stub _mbbtombc
190 185 stub _mbbtype
191 186 stub _mbccpy
192 187 stub _mbcjistojms
193 188 stub _mbcjmstojis
194 189 stub _mbclen
195 190 stub _mbctohira
196 191 stub _mbctokata
197 192 stub _mbctolower
198 193 stub _mbctombb
199 194 stub _mbctoupper
200 195 stub _mbctype
201 196 stub _mbsbtype
202 197 cdecl _mbscat(str str) strcat
203 198 stub _mbschr
204 199 stub _mbscmp
205 200 cdecl _mbscpy(ptr str) strcpy
206 201 stub _mbscspn
207 202 stub _mbsdec
208 203 cdecl _mbsdup(str) CRTDLL__strdup
209 204 cdecl _mbsicmp(str str) CRTDLL__mbsicmp
210 205 cdecl _mbsinc(str) CRTDLL__mbsinc
211 206 cdecl _mbslen(str) CRTDLL__mbslen
212 207 stub _mbslwr
213 208 stub _mbsnbcat
214 209 stub _mbsnbcmp
215 210 stub _mbsnbcnt
216 211 stub _mbsnbcpy
217 212 stub _mbsnbicmp
218 213 stub _mbsnbset
219 214 stub _mbsncat
220 215 stub _mbsnccnt
221 216 stub _mbsncmp
222 217 stub _mbsncpy
223 218 stub _mbsnextc
224 219 stub _mbsnicmp
225 220 stub _mbsninc
226 221 stub _mbsnset
227 222 stub _mbspbrk
228 223 cdecl _mbsrchr(str long) CRTDLL__mbsrchr
229 224 stub _mbsrev
230 225 stub _mbsset
231 226 stub _mbsspn
232 227 stub _mbsspnp
233 228 stub _mbsstr
234 229 stub _mbstok
235 230 stub _mbstrlen
236 231 stub _mbsupr
237 232 stub _memccpy
238 233 cdecl _memicmp(str str long) CRTDLL__memicmp
239 234 cdecl _mkdir(str) CRTDLL__mkdir
240 235 stub _mktemp
241 236 stub _msize
242 237 stub _nextafter
243 238 stub _onexit
244 239 cdecl _open(str long) CRTDLL__open
245 240 cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
246 241 extern _osmajor_dll CRTDLL_osmajor_dll
247 242 extern _osminor_dll CRTDLL_osminor_dll
248 243 extern _osmode_dll CRTDLL_osmode_dll
249 244 extern _osver_dll CRTDLL_osver_dll
250 245 extern _osversion_dll CRTDLL_osversion_dll
251 246 stub _pclose
252 247 stub _pctype_dll
253 248 stub _pgmptr_dll
254 249 stub _pipe
255 250 stub _popen
256 251 stub _purecall
257 252 stub _putch
258 253 stub _putenv
259 254 stub _putw
260 255 stub _pwctype_dll
261 256 cdecl _read(long ptr long) CRTDLL__read
262 257 stub _rmdir
263 258 stub _rmtmp
264 259 cdecl _rotl (long long) CRTDLL__rotl
265 260 stub _rotr
266 261 stub _scalb
267 262 stub _searchenv
268 263 stub _seterrormode
269 264 stub _setjmp
270 265 cdecl _setmode(long long) CRTDLL__setmode
271 266 stub _setsystime
272 267 cdecl _sleep(long) CRTDLL__sleep
273 268 stub _snprintf
274 269 stub _snwprintf
275 270 stub _sopen
276 271 stub _spawnl
277 272 stub _spawnle
278 273 stub _spawnlp
279 274 stub _spawnlpe
280 275 stub _spawnv
281 276 stub _spawnve
282 277 stub _spawnvp
283 278 stub _spawnvpe
284 279 cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
285 280 cdecl _stat (str ptr) CRTDLL__stat
286 281 stub _statusfp
287 282 cdecl _strcmpi(str str) CRTDLL__strcmpi
288 283 cdecl _strdate(str) CRTDLL__strdate
289 284 stub _strdec
290 285 cdecl _strdup(str) CRTDLL__strdup
291 286 stub _strerror
292 287 cdecl _stricmp(str str) CRTDLL__strcmpi
293 288 stub _stricoll
294 289 stub _strinc
295 290 cdecl _strlwr(str) CRTDLL__strlwr
296 291 stub _strncnt
297 292 stub _strnextc
298 293 cdecl _strnicmp(str str long) CRTDLL__strnicmp
299 294 stub _strninc
300 295 stub _strnset
301 296 stub _strrev
302 297 stub _strset
303 298 stub _strspnp
304 299 cdecl _strtime(str) CRTDLL__strtime
305 300 cdecl _strupr(str) CRTDLL__strupr
306 301 stub _swab
307 302 stub _sys_errlist
308 303 stub _sys_nerr_dll
309 304 stub _tell
310 305 cdecl _tempnam(str ptr) CRTDLL__tempnam
311 306 stub _timezone_dll
312 307 stub _tolower
313 308 stub _toupper
314 309 stub _tzname
315 310 stub _tzset
316 311 cdecl _ultoa(long ptr long) CRTDLL__ultoa
317 312 stub _ultow
318 313 stub _umask
319 314 stub _ungetch
320 315 cdecl _unlink(str) CRTDLL__unlink
321 316 stub _unloaddll
322 317 stub _utime
323 318 stub _vsnprintf
324 319 stub _vsnwprintf
325 320 cdecl _wcsdup(wstr) CRTDLL__wcsdup
326 321 cdecl _wcsicmp(wstr wstr) CRTDLL__wcsicmp
327 322 cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
328 323 cdecl _wcslwr(wstr) CRTDLL__wcslwr
329 324 cdecl _wcsnicmp(wstr wstr long) CRTDLL__wcsnicmp
330 325 cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
331 326 cdecl _wcsrev(wstr) CRTDLL__wcsrev
332 327 cdecl _wcsset(wstr long) CRTDLL__wcsset
333 328 cdecl _wcsupr(wstr) CRTDLL__wcsupr
334 329 extern _winmajor_dll CRTDLL_winmajor_dll
335 330 extern _winminor_dll CRTDLL_winminor_dll
336 331 extern _winver_dll CRTDLL_winver_dll
337 332 cdecl _write(long ptr long) CRTDLL__write
338 333 stub _wtoi
339 334 stub _wtol
340 335 cdecl _y0(double) y0
341 336 cdecl _y1(double) y1
342 337 cdecl _yn(long double) yn
343 338 stub abort
344 339 cdecl abs(long) abs
345 340 cdecl acos(double) acos
346 341 cdecl asctime(ptr) asctime
347 342 cdecl asin(double) asin
348 343 cdecl atan(double) atan
349 344 cdecl atan2(double double) atan2
350 345 cdecl atexit(ptr) CRTDLL_atexit
351 346 cdecl atof(str) atof
352 347 cdecl atoi(str) atoi
353 348 cdecl atol(str) atol
354 349 stub bsearch
355 350 cdecl calloc(long long) CRTDLL_calloc
356 351 cdecl ceil(double) ceil
357 352 stub clearerr
358 353 cdecl clock() CRTDLL_clock
359 354 cdecl cos(double) cos
360 355 cdecl cosh(double) cosh
361 356 cdecl ctime(ptr) ctime
362 357 stub difftime
363 358 cdecl div(long long) div
364 359 cdecl exit(long) CRTDLL_exit
365 360 cdecl exp(double) exp
366 361 cdecl fabs(double) fabs
367 362 cdecl fclose(ptr) CRTDLL_fclose
368 363 cdecl feof(ptr) CRTDLL_feof
369 364 stub ferror
370 365 cdecl fflush(ptr) CRTDLL_fflush
371 366 cdecl fgetc(ptr) CRTDLL_fgetc
372 367 stub fgetpos
373 368 cdecl fgets(ptr long ptr) CRTDLL_fgets
374 369 stub fgetwc
375 370 cdecl floor(double) floor
376 371 cdecl fmod(double double) fmod
377 372 cdecl fopen(str str) CRTDLL_fopen
378 373 varargs fprintf() CRTDLL_fprintf
379 374 cdecl fputc(long ptr) CRTDLL_fputc
380 375 cdecl fputs(str ptr) CRTDLL_fputs
381 376 stub fputwc
382 377 cdecl fread(ptr long long ptr) CRTDLL_fread
383 378 cdecl free(ptr) CRTDLL_free
384 379 cdecl freopen(str str ptr) CRTDLL_freopen
385 380 cdecl frexp(double ptr) frexp
386 381 varargs fscanf() CRTDLL_fscanf
387 382 cdecl fseek(ptr long long) CRTDLL_fseek
388 383 cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
389 384 cdecl ftell(ptr) CRTDLL_ftell
390 385 stub fwprintf
391 386 cdecl fwrite(ptr long long ptr) CRTDLL_fwrite
392 387 stub fwscanf
393 388 cdecl getc(ptr) CRTDLL_getc
394 389 stub getchar
395 390 cdecl getenv (str) CRTDLL_getenv
396 391 cdecl gets(ptr) CRTDLL_gets
397 392 cdecl gmtime(ptr) gmtime
398 393 stub is_wctype
399 394 cdecl isalnum(long) isalnum
400 395 cdecl isalpha(long) isalpha
401 396 cdecl iscntrl(long) iscntrl
402 397 cdecl isdigit(long) isdigit
403 398 cdecl isgraph(long) isgraph
404 399 stub isleadbyte
405 400 cdecl islower(long) islower
406 401 cdecl isprint(long) isprint
407 402 cdecl ispunct(long) ispunct
408 403 cdecl isspace(long) isspace
409 404 cdecl isupper(long) isupper
410 405 stub iswalnum
411 406 stub iswalpha
412 407 stub iswascii
413 408 stub iswcntrl
414 409 stub iswctype
415 410 stub iswdigit
416 411 stub iswgraph
417 412 stub iswlower
418 413 stub iswprint
419 414 stub iswpunct
420 415 stub iswspace
421 416 stub iswupper
422 417 stub iswxdigit
423 418 cdecl isxdigit(long) isxdigit
424 419 cdecl labs(long) labs
425 420 cdecl ldexp(double long) ldexp
426 421 cdecl ldiv(long long) ldiv
427 422 stub localeconv
428 423 cdecl localtime(ptr) localtime
429 424 cdecl log(double) log
430 425 cdecl log10(double) log10
431 426 cdecl longjmp(ptr long) CRTDLL_longjmp
432 427 cdecl malloc(ptr) CRTDLL_malloc
433 428 cdecl mblen(str long) mblen
434 429 cdecl mbstowcs(ptr str long) CRTDLL_mbstowcs
435 430 cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
436 431 cdecl memchr(ptr long long) memchr
437 432 cdecl memcmp(ptr ptr long) memcmp
438 433 cdecl memcpy(ptr ptr long) memcpy
439 434 cdecl memmove(ptr ptr long) memmove
440 435 cdecl memset(ptr long long) memset
441 436 cdecl mktime(ptr) mktime
442 437 cdecl modf(double ptr) modf
443 438 stub perror
444 439 cdecl pow(double double) pow
445 440 varargs printf() printf
446 441 cdecl putc(long ptr) CRTDLL_putc
447 442 cdecl putchar(long) CRTDLL_putchar
448 443 cdecl puts(str) CRTDLL_puts
449 444 cdecl qsort(ptr long long ptr) qsort
450 445 stub raise
451 446 cdecl rand() CRTDLL_rand
452 447 cdecl realloc(ptr long) CRTDLL_realloc
453 448 cdecl remove(str) CRTDLL_remove
454 449 cdecl rename(str str) CRTDLL_rename
455 450 stub rewind
456 451 stub scanf
457 452 cdecl setbuf(ptr ptr) CRTDLL_setbuf
458 453 cdecl setlocale(long ptr) CRTDLL_setlocale
459 454 stub setvbuf
460 455 cdecl signal(long ptr) CRTDLL_signal
461 456 cdecl sin(double) sin
462 457 cdecl sinh(double) sinh
463 458 varargs sprintf() sprintf
464 459 cdecl sqrt(double) sqrt
465 460 cdecl srand(long) CRTDLL_srand
466 461 varargs sscanf() sscanf
467 462 cdecl strcat(str str) strcat
468 463 cdecl strchr(str long) strchr
469 464 cdecl strcmp(str str) strcmp
470 465 cdecl strcoll(str str) strcoll
471 466 cdecl strcpy(ptr str) strcpy
472 467 cdecl strcspn(str str) strcspn
473 468 stub strerror
474 469 cdecl strftime(ptr long str ptr) strftime
475 470 cdecl strlen(str) strlen
476 471 cdecl strncat(str str long) strncat
477 472 cdecl strncmp(str str long) strncmp
478 473 cdecl strncpy(ptr str long) strncpy
479 474 cdecl strpbrk(str str) strpbrk
480 475 cdecl strrchr(str long) strrchr
481 476 cdecl strspn(str str) strspn
482 477 cdecl strstr(str str) strstr
483 478 cdecl strtod(str ptr) strtod
484 479 cdecl strtok(str str) strtok
485 480 cdecl strtol(str ptr long) strtol
486 481 cdecl strtoul(str ptr long) strtoul
487 482 cdecl strxfrm(ptr str long) strxfrm
488 483 varargs swprintf() wsprintfW
489 484 stub swscanf
490 485 cdecl system(str) CRTDLL_system
491 486 cdecl tan(double) tan
492 487 cdecl tanh(double) tanh
493 488 cdecl time(ptr) CRTDLL_time
494 489 stub tmpfile
495 490 cdecl tmpnam(str) CRTDLL_tmpnam
496 491 cdecl tolower(long) tolower
497 492 cdecl toupper(long) toupper
498 493 cdecl towlower(long) towlower
499 494 cdecl towupper(long) towupper
500 495 stub ungetc
501 496 stub ungetwc
502 497 cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
503 498 stub vfwprintf
504 499 stub vprintf
505 500 cdecl vsprintf(ptr str ptr) CRTDLL_vsprintf
506 501 cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
507 502 stub vwprintf
508 503 cdecl wcscat(wstr wstr) CRTDLL_wcscat
509 504 cdecl wcschr(wstr long) CRTDLL_wcschr
510 505 cdecl wcscmp(wstr wstr) CRTDLL_wcscmp
511 506 cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
512 507 cdecl wcscpy(ptr wstr) CRTDLL_wcscpy
513 508 cdecl wcscspn(wstr wstr) CRTDLL_wcscspn
514 509 stub wcsftime
515 510 cdecl wcslen(wstr) CRTDLL_wcslen
516 511 cdecl wcsncat(wstr wstr long) CRTDLL_wcsncat
517 512 cdecl wcsncmp(wstr wstr long) CRTDLL_wcsncmp
518 513 cdecl wcsncpy(ptr wstr long) CRTDLL_wcsncpy
519 514 cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
520 515 cdecl wcsrchr(wstr long) CRTDLL_wcsrchr
521 516 cdecl wcsspn(wstr wstr) CRTDLL_wcsspn
522 517 cdecl wcsstr(wstr wstr) CRTDLL_wcsstr
523 518 stub wcstod
524 519 cdecl wcstok(wstr wstr) CRTDLL_wcstok
525 520 cdecl wcstol(wstr ptr long) CRTDLL_wcstol
526 521 cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
527 522 stub wcstoul
528 523 stub wcsxfrm
529 524 cdecl wctomb(ptr long) CRTDLL_wctomb
530 525 stub wprintf
531 526 stub wscanf