libwine: Improve bin directory detection on FreeBSD.
[wine/multimedia.git] / dlls / msvideo.dll16 / msvideo.dll16.spec
blob894fc9c4e61b9cde1b522bb450d394ccd302dd42
1 #1 pascal WEP(word)
2 2 pascal VideoForWindowsVersion() VideoForWindowsVersion
3 3 pascal DllEntryPoint(long word word word long word) VIDEO_LibMain
4 20 stub VIDEOGETNUMDEVS
5 21 stub VIDEOGETERRORTEXT
6 22 pascal VideoCapDriverDescAndVer(word ptr word ptr word) VideoCapDriverDescAndVer16
7 28 stub VIDEOOPEN
8 29 stub VIDEOCLOSE
9 30 stub VIDEODIALOG
10 31 stub VIDEOFRAME
11 32 stub VIDEOCONFIGURE
12 33 stub VIDEOCONFIGURESTORAGE
13 34 stub VIDEOGETCHANNELCAPS
14 35 stub VIDEOUPDATE
15 40 stub VIDEOSTREAMADDBUFFER
16 41 stub VIDEOSTREAMFINI
17 42 stub VIDEOSTREAMGETERROR
18 43 stub VIDEOSTREAMGETPOSITION
19 44 stub VIDEOSTREAMINIT
20 46 stub VIDEOSTREAMPREPAREHEADER
21 47 stub VIDEOSTREAMRESET
22 49 stub VIDEOSTREAMSTART
23 50 stub VIDEOSTREAMSTOP
24 51 stub VIDEOSTREAMUNPREPAREHEADER
25 52 stub VIDEOSTREAMALLOCHDRANDBUFFER
26 53 stub VIDEOSTREAMFREEHDRANDBUFFER
27 60 stub VIDEOMESSAGE
28 102 pascal -ret16 DrawDibOpen() DrawDibOpen16
29 103 pascal -ret16 DrawDibClose(word) DrawDibClose16
30 104 pascal -ret16 DrawDibBegin(word word s_word s_word ptr s_word s_word word) DrawDibBegin16
31 105 pascal -ret16 DrawDibEnd(word) DrawDibEnd16
32 106 pascal -ret16 DrawDibDraw(word word s_word s_word s_word s_word ptr ptr s_word s_word s_word s_word word) DrawDibDraw16
33 108 pascal -ret16 DrawDibGetPalette(word) DrawDibGetPalette16
34 110 pascal -ret16 DrawDibSetPalette(word word) DrawDibSetPalette16
35 111 stub DRAWDIBCHANGEPALETTE
36 112 pascal -ret16 DrawDibRealize(word word word) DrawDibRealize16
37 113 stub DRAWDIBTIME
38 114 stub DRAWDIBPROFILEDISPLAY
39 115 stub STRETCHDIB
40 118 pascal -ret16 DrawDibStart(word long) DrawDibStart16
41 119 pascal -ret16 DrawDibStop(word) DrawDibStop16
42 120 stub DRAWDIBGETBUFFER
43 200 pascal -ret16 ICInfo(long long segptr) ICInfo16
44 201 stub ICINSTALL
45 202 stub ICREMOVE
46 203 pascal -ret16 ICOpen(long long word) ICOpen16
47 204 pascal ICClose(word) ICClose16
48 205 pascal ICSendMessage(word word long long) ICSendMessage16
49 206 pascal -ret16 ICOpenFunction(long long word segptr) ICOpenFunction16
50 207 varargs _ICMessage(word word word) ICMessage16
51 212 pascal ICGetInfo(word segptr long) ICGetInfo16
52 213 pascal -ret16 ICLocate(long long ptr ptr word) ICLocate16
53 224 cdecl _ICCompress(word long segptr segptr segptr segptr segptr segptr long long long segptr segptr) ICCompress16
54 230 cdecl _ICDecompress(word long segptr segptr segptr segptr) ICDecompress16
55 232 cdecl _ICDrawBegin(word long word word word s_word s_word s_word s_word segptr s_word s_word s_word s_word long long) ICDrawBegin16
56 234 cdecl _ICDraw(word long segptr segptr long long) ICDraw16
57 239 pascal -ret16 ICGetDisplayFormat(word ptr ptr s_word s_word s_word) ICGetDisplayFormat16
58 240 stub ICIMAGECOMPRESS
59 241 stub ICIMAGEDECOMPRESS
60 242 stub ICCOMPRESSORCHOOSE
61 243 stub ICCOMPRESSORFREE
62 244 stub ICSEQCOMPRESSFRAMESTART
63 245 stub ICSEQCOMPRESSFRAMEEND
64 246 stub ICSEQCOMPRESSFRAME
65 250 cdecl _MCIWndCreate(word word long str) MCIWndCreate16
66 251 stub _MCIWNDREGISTERCLASS
67 252 stub GETOPENFILENAMEPREVIEW
68 253 stub GETSAVEFILENAMEPREVIEW