Release 961215
[wine/multimedia.git] / if1632 / wsock32.spec
blob8503c3d20e1aab9ce374213a708d8190ba8efd97
1 name wsock32
2 type win32
3 base 0
5 001 stub accept
6 002 stub bind
7 003 stub closesocket
8 004 stub connect
9 005 stub getpeername
10 006 stub getsockname
11 007 stub getsockopt
12 008 stdcall htonl(long) htonl
13 009 stdcall htons(long) htons
14 010 stdcall inet_addr(ptr) inet_addr
15 011 stdcall inet_ntoa(ptr) inet_ntoa
16 012 stub ioctlsocket
17 013 stub listen
18 014 stub ntohl
19 015 stdcall ntohs(long) ntohs
20 016 stub recv
21 017 stub recvfrom
22 018 stub select
23 019 stub send
24 020 stub sendto
25 021 stub setsockopt
26 022 stub shutdown
27 023 stub socket
28 051 stdcall gethostbyaddr(ptr long long) gethostbyaddr
29 052 stdcall gethostbyname(ptr) gethostbyname
30 053 stub getprotobyname
31 054 stub getprotobynumber
32 055 stdcall getservbyname(ptr ptr) getservbyname
33 056 stub getservbyport
34 057 stdcall gethostname(ptr long) gethostname
35 101 stub WSAAsyncSelect
36 102 stub WSAAsyncGetHostByAddr
37 103 stub WSAAsyncGetHostByName
38 104 stub WSAAsyncGetProtoByNumber
39 105 stub WSAAsyncGetProtoByName
40 106 stub WSAAsyncGetServByPort
41 107 stub WSAAsyncGetServByName
42 108 stub WSACancelAsyncRequest
43 109 stub WSASetBlockingHook
44 110 stub WSAUnhookBlockingHook
45 111 stub WSAGetLastError
46 112 stub WSASetLastError
47 113 stub WSACancelBlockingCall
48 114 stub WSAIsBlocking
49 115 stdcall WSAStartup(long ptr) WSAStartup
50 116 stdcall WSACleanup() WSACleanup
51 151 stub __WSAFDIsSet
52 #500 stub WEP
53 # applications *should* 'degrade gracefully if these are not present
54 # ... as it is, they don't
55 #1000 stub WSApSetPostRoutine
56 1001 stdcall WsControl(long long long long long long) WsControl
57 1100 stdcall inet_network(ptr) inet_network
58 1101 stdcall getnetbyname(ptr) getnetbyname
59 #1102 stub rcmd
60 #1103 stub rexec
61 #1104 stub rresvport
62 #1105 stub sethostname
63 #1106 stub dn_expand
64 1107 stub WSARecvEx
65 1108 stub s_perror
66 1109 stub GetAddressByNameA
67 1110 stub GetAddressByNameW
68 #1111 stub EnumProtocolsA
69 #1112 stub EnumProtocolsW
70 #1113 stub GetTypeByNameA
71 #1114 stub GetTypeByNameW
72 #1115 stub GetNameByTypeA
73 #1116 stub GetNameByTypeW
74 #1117 stub SetServiceA
75 #1118 stub SetServiceW
76 #1119 stub GetServiceA
77 #1120 stub GetServiceW
78 #1130 stub NPLoadNameSpaces
79 #1140 stub TransmitFile
80 #1141 stub AcceptEx
81 #1142 stub GetAcceptExSockaddrs