msvcrt: Reimplement rand() and srand() to use per-thread data for the
[wine/multimedia.git] / dlls / msvcrt / msvcrt.spec
bloba24f11b49e25e1f09adafb31a6b790729fc17d02
1 # msvcrt.dll - MS VC++ Run Time Library
3 @ cdecl $I10_OUTPUT() MSVCRT_I10_OUTPUT
4 @ cdecl -i386 -norelay ??0__non_rtti_object@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT___non_rtti_object_copy_ctor
5 @ cdecl -i386 -norelay ??0__non_rtti_object@@QAE@PBD@Z(ptr) __thiscall_MSVCRT___non_rtti_object_ctor
6 @ cdecl -i386 -norelay ??0bad_cast@@QAE@ABQBD@Z(ptr) __thiscall_MSVCRT_bad_cast_ctor
7 @ cdecl -i386 -norelay ??0bad_cast@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_cast_copy_ctor
8 @ cdecl -i386 -norelay ??0bad_typeid@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_typeid_copy_ctor
9 @ cdecl -i386 -norelay ??0bad_typeid@@QAE@PBD@Z(ptr) __thiscall_MSVCRT_bad_typeid_ctor
10 @ cdecl -i386 -norelay ??0exception@@QAE@ABQBD@Z(ptr) __thiscall_MSVCRT_exception_ctor
11 @ cdecl -i386 -norelay ??0exception@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_exception_copy_ctor
12 @ cdecl -i386 -norelay ??0exception@@QAE@XZ() __thiscall_MSVCRT_exception_default_ctor
13 @ cdecl -i386 -norelay ??1__non_rtti_object@@UAE@XZ() __thiscall_MSVCRT___non_rtti_object_dtor
14 @ cdecl -i386 -norelay ??1bad_cast@@UAE@XZ() __thiscall_MSVCRT_bad_cast_dtor
15 @ cdecl -i386 -norelay ??1bad_typeid@@UAE@XZ() __thiscall_MSVCRT_bad_typeid_dtor
16 @ cdecl -i386 -norelay ??1exception@@UAE@XZ() __thiscall_MSVCRT_exception_dtor
17 @ cdecl -i386 -norelay ??1type_info@@UAE@XZ() __thiscall_MSVCRT_type_info_dtor
18 @ cdecl ??2@YAPAXI@Z(long) MSVCRT_operator_new
19 @ cdecl ??_U@YAPAXI@Z(long) MSVCRT_operator_new
20 @ cdecl ??3@YAXPAX@Z(ptr) MSVCRT_operator_delete
21 @ cdecl ??_V@YAXPAX@Z(ptr) MSVCRT_operator_delete
22 @ cdecl -i386 -norelay ??4__non_rtti_object@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT___non_rtti_object_opequals
23 @ cdecl -i386 -norelay ??4bad_cast@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_cast_opequals
24 @ cdecl -i386 -norelay ??4bad_typeid@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_typeid_opequals
25 @ cdecl -i386 -norelay ??4exception@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_exception_opequals
26 @ cdecl -i386 -norelay ??8type_info@@QBEHABV0@@Z(ptr) __thiscall_MSVCRT_type_info_opequals_equals
27 @ cdecl -i386 -norelay ??9type_info@@QBEHABV0@@Z(ptr) __thiscall_MSVCRT_type_info_opnot_equals
28 @ extern -i386 ??_7__non_rtti_object@@6B@ MSVCRT___non_rtti_object_vtable
29 @ extern -i386 ??_7bad_cast@@6B@ MSVCRT_bad_cast_vtable
30 @ extern -i386 ??_7bad_typeid@@6B@ MSVCRT_bad_typeid_vtable
31 @ extern -i386 ??_7exception@@6B@ MSVCRT_exception_vtable
32 @ cdecl -i386 -norelay ??_E__non_rtti_object@@UAEPAXI@Z(long) __thiscall_MSVCRT___non_rtti_object_vector_dtor
33 @ cdecl -i386 -norelay ??_Ebad_cast@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_cast_vector_dtor
34 @ cdecl -i386 -norelay ??_Ebad_typeid@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_typeid_vector_dtor
35 @ cdecl -i386 -norelay ??_Eexception@@UAEPAXI@Z(long) __thiscall_MSVCRT_exception_vector_dtor
36 @ cdecl -i386 -norelay ??_G__non_rtti_object@@UAEPAXI@Z(long) __thiscall_MSVCRT___non_rtti_object_scalar_dtor
37 @ cdecl -i386 -norelay ??_Gbad_cast@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_cast_scalar_dtor
38 @ cdecl -i386 -norelay ??_Gbad_typeid@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_typeid_scalar_dtor
39 @ cdecl -i386 -norelay ??_Gexception@@UAEPAXI@Z(long) __thiscall_MSVCRT_exception_scalar_dtor
40 @ cdecl ?_query_new_handler@@YAP6AHI@ZXZ() MSVCRT__query_new_handler
41 @ cdecl ?_query_new_mode@@YAHXZ() MSVCRT__query_new_mode
42 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) MSVCRT__set_new_handler
43 @ cdecl ?_set_new_mode@@YAHH@Z(long) MSVCRT__set_new_mode
44 @ cdecl ?_set_se_translator@@YAP6AXIPAU_EXCEPTION_POINTERS@@@ZP6AXI0@Z@Z(ptr) MSVCRT__set_se_translator
45 @ cdecl -i386 -norelay ?before@type_info@@QBEHABV1@@Z(ptr) __thiscall_MSVCRT_type_info_before
46 @ cdecl -i386 -norelay ?name@type_info@@QBEPBDXZ() __thiscall_MSVCRT_type_info_name
47 @ cdecl -i386 -norelay ?raw_name@type_info@@QBEPBDXZ() __thiscall_MSVCRT_type_info_raw_name
48 @ cdecl ?set_new_handler@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT__set_new_handler
49 @ cdecl ?set_terminate@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT_set_terminate
50 @ cdecl ?set_unexpected@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT_set_unexpected
51 @ cdecl ?terminate@@YAXXZ() MSVCRT_terminate
52 @ cdecl ?unexpected@@YAXXZ() MSVCRT_unexpected
53 @ cdecl -i386 -norelay ?what@exception@@UBEPBDXZ() __thiscall_MSVCRT_what_exception
54 @ cdecl _CIacos()
55 @ cdecl _CIasin()
56 @ cdecl _CIatan()
57 @ cdecl _CIatan2()
58 @ cdecl _CIcos()
59 @ cdecl _CIcosh()
60 @ cdecl _CIexp()
61 @ cdecl _CIfmod()
62 @ cdecl _CIlog()
63 @ cdecl _CIlog10()
64 @ cdecl _CIpow()
65 @ cdecl _CIsin()
66 @ cdecl _CIsinh()
67 @ cdecl _CIsqrt()
68 @ cdecl _CItan()
69 @ cdecl _CItanh()
70 @ cdecl _CxxThrowException(long long)
71 @ cdecl -i386 -norelay _EH_prolog()
72 @ cdecl _Getdays()
73 @ cdecl _Getmonths()
74 @ cdecl _Gettnames()
75 @ extern _HUGE MSVCRT__HUGE
76 @ cdecl _Strftime(str long str ptr ptr)
77 @ cdecl _XcptFilter(long ptr)
78 @ cdecl -i386 -norelay __CxxFrameHandler(ptr ptr ptr ptr)
79 @ stub __CxxLongjmpUnwind #(ptr) stdcall
80 @ cdecl __RTCastToVoid(ptr) MSVCRT___RTCastToVoid
81 @ cdecl __RTDynamicCast(ptr long ptr ptr long) MSVCRT___RTDynamicCast
82 @ cdecl __RTtypeid(ptr) MSVCRT___RTtypeid
83 @ stub __STRINGTOLD #(ptr ptr str long)
84 @ extern __argc MSVCRT___argc
85 @ extern __argv MSVCRT___argv
86 @ extern __badioinfo MSVCRT___badioinfo
87 @ stub __crtCompareStringA
88 @ stub __crtGetLocaleInfoW
89 @ cdecl __crtLCMapStringA(long long str long ptr long long long)
90 @ cdecl __dllonexit(ptr ptr ptr)
91 @ cdecl __doserrno() MSVCRT___doserrno
92 @ cdecl __fpecode()
93 @ cdecl __getmainargs(ptr ptr ptr long ptr)
94 @ extern __initenv MSVCRT___initenv
95 @ cdecl __isascii(long) MSVCRT___isascii
96 @ cdecl __iscsym(long) MSVCRT___iscsym
97 @ cdecl __iscsymf(long) MSVCRT___iscsymf
98 # extern __lc_codepage
99 @ stub __lc_collate
100 # extern __lc_handle
101 @ cdecl __lconv_init()
102 @ extern __mb_cur_max MSVCRT___mb_cur_max
103 @ cdecl __p___argc()
104 @ cdecl __p___argv()
105 @ cdecl __p___initenv()
106 @ cdecl __p___mb_cur_max()
107 @ cdecl __p___wargv()
108 @ cdecl __p___winitenv()
109 @ cdecl __p__acmdln()
110 @ cdecl __p__amblksiz()
111 @ cdecl __p__commode()
112 @ cdecl __p__daylight() MSVCRT___p__daylight
113 @ cdecl __p__dstbias()
114 @ cdecl __p__environ()
115 @ stub __p__fileinfo #()
116 @ cdecl __p__fmode()
117 @ cdecl __p__iob()
118 @ stub __p__mbcasemap #()
119 @ cdecl __p__mbctype()
120 @ cdecl __p__osver()
121 @ cdecl __p__pctype()
122 @ cdecl __p__pgmptr()
123 @ stub __p__pwctype #()
124 @ cdecl __p__timezone() MSVCRT___p__timezone
125 @ cdecl __p__tzname()
126 @ cdecl __p__wcmdln()
127 @ cdecl __p__wenviron()
128 @ cdecl __p__winmajor()
129 @ cdecl __p__winminor()
130 @ cdecl __p__winver()
131 @ cdecl __p__wpgmptr()
132 @ extern __pioinfo MSVCRT___pioinfo
133 @ stub __pxcptinfoptrs #()
134 @ cdecl __set_app_type(long) MSVCRT___set_app_type
135 @ extern __setlc_active MSVCRT___setlc_active
136 @ cdecl __setusermatherr(ptr) MSVCRT___setusermatherr
137 @ cdecl __threadhandle() kernel32.GetCurrentThread
138 @ cdecl __threadid() kernel32.GetCurrentThreadId
139 @ cdecl __toascii(long) MSVCRT___toascii
140 @ cdecl __unDName(ptr str long ptr ptr long)
141 @ cdecl __unDNameEx(ptr str long ptr ptr ptr long)
142 @ extern __unguarded_readlc_active MSVCRT___unguarded_readlc_active
143 @ extern __wargv MSVCRT___wargv
144 @ cdecl __wgetmainargs(ptr ptr ptr long ptr)
145 @ extern __winitenv MSVCRT___winitenv
146 @ cdecl _abnormal_termination()
147 @ cdecl _access(str long)
148 @ extern _acmdln MSVCRT__acmdln
149 @ stdcall _adj_fdiv_m16i(long)
150 @ stdcall _adj_fdiv_m32(long)
151 @ stdcall _adj_fdiv_m32i(long)
152 @ stdcall _adj_fdiv_m64(double)
153 @ cdecl _adj_fdiv_r()
154 @ stdcall _adj_fdivr_m16i(long)
155 @ stdcall _adj_fdivr_m32(long)
156 @ stdcall _adj_fdivr_m32i(long)
157 @ stdcall _adj_fdivr_m64(double)
158 @ cdecl _adj_fpatan()
159 @ cdecl _adj_fprem()
160 @ cdecl _adj_fprem1()
161 @ cdecl _adj_fptan()
162 @ extern _adjust_fdiv MSVCRT__adjust_fdiv
163 # extern _aexit_rtn
164 @ cdecl _amsg_exit(long)
165 @ cdecl _assert(str str long) MSVCRT__assert
166 @ stub _atodbl #(ptr str)
167 @ cdecl -ret64 _atoi64(str) ntdll._atoi64
168 @ stub _atoldbl #(ptr str)
169 @ cdecl _beep(long long)
170 @ cdecl _beginthread (ptr long ptr)
171 @ cdecl _beginthreadex (ptr long ptr ptr long ptr)
172 @ cdecl _c_exit() MSVCRT__c_exit
173 @ cdecl _cabs(long) MSVCRT__cabs
174 @ cdecl _callnewh(long)
175 @ cdecl _cexit() MSVCRT__cexit
176 @ cdecl _cgets(str)
177 @ cdecl _chdir(str)
178 @ cdecl _chdrive(long)
179 @ cdecl _chgsign( double )
180 @ cdecl -i386 -norelay _chkesp()
181 @ cdecl _chmod(str long)
182 @ cdecl _chsize (long long)
183 @ cdecl _clearfp()
184 @ cdecl _close(long)
185 @ cdecl _commit(long)
186 @ extern _commode MSVCRT__commode
187 @ cdecl _control87(long long)
188 @ cdecl _controlfp(long long)
189 @ cdecl _copysign( double double )
190 @ varargs _cprintf(str)
191 @ cdecl _cputs(str)
192 @ cdecl _creat(str long)
193 @ varargs _cscanf(str)
194 @ extern _ctype MSVCRT__ctype
195 @ cdecl _cwait(ptr long long)
196 @ extern _daylight MSVCRT___daylight
197 @ extern _dstbias MSVCRT__dstbias
198 @ cdecl _dup (long)
199 @ cdecl _dup2 (long long)
200 @ cdecl _ecvt(double long ptr ptr)
201 @ cdecl _endthread ()
202 @ cdecl _endthreadex(long)
203 @ extern _environ
204 @ cdecl _eof(long)
205 @ cdecl _errno() MSVCRT__errno
206 @ cdecl _except_handler2(ptr ptr ptr ptr)
207 @ cdecl _except_handler3(ptr ptr ptr ptr)
208 @ varargs _execl(str str)
209 @ varargs _execle(str str)
210 @ varargs _execlp(str str)
211 @ varargs _execlpe(str str)
212 @ cdecl _execv(str str)
213 @ cdecl _execve(str str str)
214 @ cdecl _execvp(str str)
215 @ cdecl _execvpe(str str str)
216 @ cdecl _exit(long) MSVCRT__exit
217 @ cdecl _expand(ptr long)
218 @ cdecl _fcloseall() MSVCRT__fcloseall
219 @ cdecl _fcvt(double long ptr ptr)
220 @ cdecl _fdopen(long str) MSVCRT__fdopen
221 @ cdecl _fgetchar()
222 @ cdecl _fgetwchar()
223 @ cdecl _filbuf(ptr) MSVCRT__filbuf
224 # extern _fileinfo
225 @ cdecl _filelength(long)
226 @ cdecl -ret64 _filelengthi64(long)
227 @ cdecl _fileno(ptr) MSVCRT__fileno
228 @ cdecl _findclose(long) MSVCRT__findclose
229 @ cdecl _findfirst(str ptr) MSVCRT__findfirst
230 @ cdecl _findfirsti64(str ptr) MSVCRT__findfirsti64
231 @ cdecl _findnext(long ptr) MSVCRT__findnext
232 @ cdecl _findnexti64(long ptr) MSVCRT__findnexti64
233 @ cdecl _finite( double )
234 @ cdecl _flsbuf(long ptr) MSVCRT__flsbuf
235 @ cdecl _flushall()
236 @ extern _fmode MSVCRT__fmode
237 @ cdecl _fpclass(double)
238 @ stub _fpieee_flt #(long ptr ptr)
239 @ cdecl _fpreset()
240 @ cdecl _fputchar(long)
241 @ cdecl _fputwchar(long)
242 @ cdecl _fsopen(str str long) MSVCRT__fsopen
243 @ cdecl _fstat(long ptr) MSVCRT__fstat
244 @ cdecl _fstati64(long ptr) MSVCRT__fstati64
245 @ cdecl _ftime(ptr)
246 @ cdecl -ret64 _ftol() ntdll._ftol
247 @ cdecl _fullpath(ptr str long)
248 @ cdecl _futime(long ptr)
249 @ cdecl _gcvt(double long str)
250 @ cdecl _get_osfhandle(long)
251 @ cdecl _get_sbh_threshold()
252 @ cdecl _getch()
253 @ cdecl _getche()
254 @ cdecl _getcwd(str long)
255 @ cdecl _getdcwd(long str long)
256 @ cdecl _getdiskfree(long ptr) MSVCRT__getdiskfree
257 @ cdecl _getdllprocaddr(long str long)
258 @ cdecl _getdrive()
259 @ cdecl _getdrives() kernel32.GetLogicalDrives
260 @ stub _getmaxstdio #()
261 @ cdecl _getmbcp()
262 @ cdecl _getpid() kernel32.GetCurrentProcessId
263 @ stub _getsystime #(ptr)
264 @ cdecl _getw(ptr) MSVCRT__getw
265 @ cdecl _getws(ptr) MSVCRT__getws
266 @ cdecl _global_unwind2(ptr)
267 @ cdecl _heapadd (ptr long)
268 @ cdecl _heapchk()
269 @ cdecl _heapmin()
270 @ cdecl _heapset(long)
271 @ stub _heapused #(ptr ptr)
272 @ cdecl _heapwalk(ptr)
273 @ cdecl _hypot(double double) hypot
274 @ cdecl _i64toa(long long ptr long) ntdll._i64toa
275 @ cdecl _i64tow(long long ptr long) ntdll._i64tow
276 @ cdecl _initterm(ptr ptr)
277 @ stub _inp #(long) -i386
278 @ stub _inpd #(long) -i386
279 @ stub _inpw #(long) -i386
280 @ extern _iob MSVCRT__iob
281 @ cdecl _isatty(long)
282 @ cdecl _isctype(long long)
283 @ stub _ismbbalnum #(long)
284 @ stub _ismbbalpha #(long)
285 @ stub _ismbbgraph #(long)
286 @ stub _ismbbkalnum #(long)
287 @ cdecl _ismbbkana(long)
288 @ stub _ismbbkprint #(long)
289 @ stub _ismbbkpunct #(long)
290 @ cdecl _ismbblead(long)
291 @ stub _ismbbprint #(long)
292 @ stub _ismbbpunct #(long)
293 @ cdecl _ismbbtrail(long)
294 @ cdecl _ismbcalnum(long)
295 @ cdecl _ismbcalpha(long)
296 @ cdecl _ismbcdigit(long)
297 @ cdecl _ismbcgraph(long)
298 @ cdecl _ismbchira(long)
299 @ cdecl _ismbckata(long)
300 @ stub _ismbcl0 #(long)
301 @ stub _ismbcl1 #(long)
302 @ stub _ismbcl2 #(long)
303 @ stub _ismbclegal #(long)
304 @ cdecl _ismbclower(long)
305 @ cdecl _ismbcprint(long)
306 @ cdecl _ismbcpunct(long)
307 @ cdecl _ismbcspace(long)
308 @ cdecl _ismbcsymbol(long)
309 @ cdecl _ismbcupper(long)
310 @ cdecl _ismbslead(ptr ptr)
311 @ cdecl _ismbstrail(ptr ptr)
312 @ cdecl _isnan( double )
313 @ cdecl _itoa(long ptr long) ntdll._itoa
314 @ cdecl _itow(long ptr long) ntdll._itow
315 @ cdecl _j0(double) j0
316 @ cdecl _j1(double) j1
317 @ cdecl _jn(long double) jn
318 @ cdecl _kbhit()
319 @ cdecl _lfind(ptr ptr ptr long ptr)
320 @ cdecl _loaddll(str)
321 @ cdecl _local_unwind2(ptr long)
322 @ cdecl _lock(long)
323 @ cdecl _locking(long long long)
324 @ cdecl _logb( double )
325 @ cdecl -i386 _longjmpex(ptr long) MSVCRT_longjmp
326 @ cdecl _lrotl(long long)
327 @ cdecl _lrotr(long long)
328 @ cdecl _lsearch(ptr ptr long long ptr)
329 @ cdecl _lseek(long long long)
330 @ cdecl -ret64 _lseeki64(long double long)
331 @ cdecl _ltoa(long ptr long) ntdll._ltoa
332 @ cdecl _ltow(long ptr long) ntdll._ltow
333 @ cdecl _makepath(str str str str str)
334 @ cdecl _matherr(ptr) MSVCRT__matherr
335 @ cdecl _mbbtombc(long)
336 @ stub _mbbtype #(long long)
337 # extern _mbcasemap
338 @ cdecl _mbccpy (str str)
339 @ stub _mbcjistojms #(long)
340 @ stub _mbcjmstojis #(long)
341 @ cdecl _mbclen(ptr)
342 @ stub _mbctohira #(long)
343 @ stub _mbctokata #(long)
344 @ cdecl _mbctolower(long)
345 @ stub _mbctombb #(long)
346 @ cdecl _mbctoupper(long)
347 @ extern _mbctype MSVCRT_mbctype
348 @ stub _mbsbtype #(str long)
349 @ cdecl _mbscat(str str) strcat
350 @ cdecl _mbschr(str long)
351 @ cdecl _mbscmp(str str)
352 @ cdecl _mbscoll(str str)
353 @ cdecl _mbscpy(ptr str) strcpy
354 @ cdecl _mbscspn (str str)
355 @ cdecl _mbsdec(ptr ptr)
356 @ cdecl _mbsdup(str) _strdup
357 @ cdecl _mbsicmp(str str)
358 @ cdecl _mbsicoll(str str)
359 @ cdecl _mbsinc(str)
360 @ cdecl _mbslen(str)
361 @ cdecl _mbslwr(str)
362 @ cdecl _mbsnbcat (str str long)
363 @ cdecl _mbsnbcmp(str str long)
364 @ cdecl _mbsnbcnt(ptr long)
365 @ stub _mbsnbcoll #(str str long)
366 @ cdecl _mbsnbcpy(ptr str long)
367 @ cdecl _mbsnbicmp(str str long)
368 @ stub _mbsnbicoll #(str str long)
369 @ cdecl _mbsnbset(str long long)
370 @ cdecl _mbsncat(str str long)
371 @ cdecl _mbsnccnt(str long)
372 @ cdecl _mbsncmp(str str long)
373 @ stub _mbsncoll #(str str long)
374 @ cdecl _mbsncpy(str str long)
375 @ cdecl _mbsnextc(str)
376 @ cdecl _mbsnicmp(str str long)
377 @ stub _mbsnicoll #(str str long)
378 @ cdecl _mbsninc(str long)
379 @ cdecl _mbsnset(str long long)
380 @ cdecl _mbspbrk(str str)
381 @ cdecl _mbsrchr(str long)
382 @ cdecl _mbsrev(str)
383 @ cdecl _mbsset(str long)
384 @ cdecl _mbsspn(str str)
385 @ stub _mbsspnp #(str str)
386 @ cdecl _mbsstr(str str) strstr
387 @ cdecl _mbstok(str str)
388 @ cdecl _mbstrlen(str)
389 @ cdecl _mbsupr(str)
390 @ cdecl _memccpy(ptr ptr long long) memccpy
391 @ cdecl _memicmp(str str long) ntdll._memicmp
392 @ cdecl _mkdir(str)
393 @ cdecl _mktemp(str)
394 @ cdecl _msize(ptr)
395 @ cdecl _nextafter(double double)
396 @ cdecl _onexit(ptr) MSVCRT__onexit
397 @ varargs _open(str long)
398 @ cdecl _open_osfhandle(long long)
399 @ extern _osver MSVCRT__osver
400 @ stub _outp #(long long)
401 @ stub _outpd #(long long)
402 @ stub _outpw #(long long)
403 @ cdecl _pclose (ptr) MSVCRT__pclose
404 @ extern _pctype MSVCRT__pctype
405 @ extern _pgmptr MSVCRT__pgmptr
406 @ cdecl _pipe (ptr long long)
407 @ cdecl _popen (str str) MSVCRT__popen
408 @ cdecl _purecall()
409 @ cdecl _putch(long)
410 @ cdecl _putenv(str)
411 @ cdecl _putw(long ptr) MSVCRT__putw
412 @ cdecl _putws(wstr)
413 # extern _pwctype
414 @ cdecl _read(long ptr long)
415 @ cdecl _rmdir(str)
416 @ cdecl _rmtmp()
417 @ cdecl _rotl(long long)
418 @ cdecl _rotr(long long)
419 @ cdecl _safe_fdiv()
420 @ cdecl _safe_fdivr()
421 @ cdecl _safe_fprem()
422 @ cdecl _safe_fprem1()
423 @ cdecl _scalb( double long)
424 @ cdecl _searchenv(str str ptr)
425 @ stdcall -i386 _seh_longjmp_unwind(ptr)
426 @ cdecl _set_error_mode(long)
427 @ cdecl _set_sbh_threshold(long)
428 @ cdecl _seterrormode(long)
429 @ cdecl -i386 -norelay _setjmp(ptr) MSVCRT__setjmp
430 @ cdecl -i386 -norelay _setjmp3(ptr long) MSVCRT__setjmp3
431 @ stub _setmaxstdio #(long)
432 @ cdecl _setmbcp(long)
433 @ cdecl _setmode(long long)
434 @ stub _setsystime #(ptr long)
435 @ cdecl _sleep(long)
436 @ varargs _snprintf(str long str) snprintf
437 @ varargs _snwprintf(wstr long wstr) ntdll._snwprintf
438 @ varargs _sopen(str long long) MSVCRT__sopen
439 @ varargs _spawnl(long str str)
440 @ varargs _spawnle(long str str)
441 @ varargs _spawnlp(long str str)
442 @ varargs _spawnlpe(long str str)
443 @ cdecl _spawnv(long str ptr)
444 @ cdecl _spawnve(long str ptr ptr)
445 @ cdecl _spawnvp(long str ptr)
446 @ cdecl _spawnvpe(long str ptr ptr)
447 @ cdecl _splitpath(str ptr ptr ptr ptr) ntdll._splitpath
448 @ cdecl _stat(str ptr) MSVCRT__stat
449 @ cdecl _stati64(str ptr) MSVCRT__stati64
450 @ cdecl _statusfp()
451 @ cdecl _strcmpi(str str) strcasecmp
452 @ cdecl _strdate(ptr)
453 @ cdecl _strdup(str)
454 @ cdecl _strerror(long)
455 @ cdecl _stricmp(str str) strcasecmp
456 @ cdecl _stricoll(str str) MSVCRT__stricoll
457 @ cdecl _strlwr(str) ntdll._strlwr
458 @ stub _strncoll #(str str long)
459 @ cdecl _strnicmp(str str long) strncasecmp
460 @ stub _strnicoll #(str str long)
461 @ cdecl _strnset(str long long)
462 @ cdecl _strrev(str)
463 @ cdecl _strset(str long)
464 @ cdecl _strtime(ptr)
465 @ cdecl _strupr(str) ntdll._strupr
466 @ cdecl _swab(str str long) MSVCRT__swab
467 @ extern _sys_errlist MSVCRT__sys_errlist
468 @ extern _sys_nerr MSVCRT__sys_nerr
469 @ cdecl _tell(long)
470 @ cdecl -ret64 _telli64(long)
471 @ cdecl _tempnam(str str)
472 @ extern _timezone MSVCRT___timezone
473 @ cdecl _tolower(long) MSVCRT__tolower
474 @ cdecl _toupper(long) MSVCRT__toupper
475 @ extern _tzname MSVCRT__tzname
476 @ cdecl _tzset() MSVCRT__tzset
477 @ cdecl _ui64toa(long long ptr long) ntdll._ui64toa
478 @ cdecl _ui64tow(long long ptr long) ntdll._ui64tow
479 @ cdecl _ultoa(long ptr long) ntdll._ultoa
480 @ cdecl _ultow(long ptr long) ntdll._ultow
481 @ cdecl _umask(long)
482 @ cdecl _ungetch(long)
483 @ cdecl _unlink(str)
484 @ cdecl _unloaddll(long)
485 @ cdecl _unlock(long)
486 @ cdecl _utime(str ptr)
487 @ cdecl _vsnprintf(ptr long ptr ptr) MSVCRT_vsnprintf
488 @ cdecl _vsnwprintf(ptr long wstr long) MSVCRT_vsnwprintf
489 @ cdecl _waccess(wstr long)
490 @ cdecl _wasctime(ptr) MSVCRT__wasctime
491 @ cdecl _wchdir(wstr)
492 @ cdecl _wchmod(wstr long)
493 @ extern _wcmdln MSVCRT__wcmdln
494 @ cdecl _wcreat(wstr long)
495 @ cdecl _wcsdup(wstr)
496 @ cdecl _wcsicmp(wstr wstr) ntdll._wcsicmp
497 @ cdecl _wcsicoll(wstr wstr)
498 @ cdecl _wcslwr(wstr) ntdll._wcslwr
499 @ stub _wcsncoll #(wstr wstr long)
500 @ cdecl _wcsnicmp(wstr wstr long) ntdll._wcsnicmp
501 @ stub _wcsnicoll #(wstr wstr long)
502 @ cdecl _wcsnset(wstr long long)
503 @ cdecl _wcsrev(wstr)
504 @ cdecl _wcsset(wstr long)
505 @ cdecl _wcsupr(wstr) ntdll._wcsupr
506 @ cdecl _wctime(ptr) MSVCRT__wctime
507 @ extern _wenviron
508 @ stub _wexecl #(wstr wstr) varargs
509 @ stub _wexecle #(wstr wstr) varargs
510 @ stub _wexeclp #(wstr wstr) varargs
511 @ stub _wexeclpe #(wstr wstr) varargs
512 @ stub _wexecv #(wstr ptr)
513 @ stub _wexecve #(wstr ptr ptr)
514 @ stub _wexecvp #(wstr ptr)
515 @ stub _wexecvpe #(wstr ptr ptr)
516 @ cdecl _wfdopen(long wstr) MSVCRT__wfdopen
517 @ cdecl _wfindfirst(wstr ptr) MSVCRT__wfindfirst
518 @ cdecl _wfindfirsti64(wstr ptr) MSVCRT__wfindfirsti64
519 @ cdecl _wfindnext(long ptr) MSVCRT__wfindnext
520 @ cdecl _wfindnexti64(long ptr) MSVCRT__wfindnexti64
521 @ cdecl _wfopen(wstr wstr) MSVCRT__wfopen
522 @ stub _wfreopen #(wstr wstr ptr) MSVCRT__wfreopen
523 @ cdecl _wfsopen(wstr wstr long) MSVCRT__wfsopen
524 @ cdecl _wfullpath(ptr wstr long)
525 @ cdecl _wgetcwd(wstr long)
526 @ cdecl _wgetdcwd(long wstr long)
527 @ cdecl _wgetenv(wstr)
528 @ extern _winmajor MSVCRT__winmajor
529 @ extern _winminor MSVCRT__winminor
530 @ extern _winver MSVCRT__winver
531 @ cdecl _wmakepath(wstr wstr wstr wstr wstr)
532 @ cdecl _wmkdir(wstr)
533 @ cdecl _wmktemp(wstr)
534 @ varargs _wopen(wstr long)
535 @ stub _wperror #(wstr)
536 @ extern _wpgmptr MSVCRT__wpgmptr
537 @ cdecl _wpopen (wstr wstr) MSVCRT__wpopen
538 @ cdecl _wputenv(wstr)
539 @ cdecl _wremove(wstr)
540 @ cdecl _wrename(wstr wstr)
541 @ cdecl _write(long ptr long)
542 @ cdecl _wrmdir(wstr)
543 @ stub _wsearchenv #(wstr wstr ptr)
544 @ stub _wsetlocale #(long wstr)
545 @ varargs _wsopen (wstr long long) MSVCRT__wsopen
546 @ stub _wspawnl #(long wstr wstr) varargs
547 @ stub _wspawnle #(long wstr wstr) varargs
548 @ stub _wspawnlp #(long wstr wstr) varargs
549 @ stub _wspawnlpe #(long wstr wstr) varargs
550 @ stub _wspawnv #(long wstr ptr)
551 @ stub _wspawnve #(long wstr ptr ptr)
552 @ stub _wspawnvp #(long wstr ptr)
553 @ stub _wspawnvpe #(long wstr ptr ptr)
554 @ cdecl _wsplitpath(wstr wstr wstr wstr wstr)
555 @ cdecl _wstat(wstr ptr) MSVCRT__wstat
556 @ cdecl _wstati64(wstr ptr) MSVCRT__wstati64
557 @ cdecl _wstrdate(ptr)
558 @ cdecl _wstrtime(ptr)
559 @ stub _wsystem #(wstr)
560 @ cdecl _wtempnam(wstr wstr)
561 @ stub _wtmpnam #(ptr)
562 @ cdecl _wtoi(wstr) ntdll._wtoi
563 @ cdecl _wtoi64(wstr) ntdll._wtoi64
564 @ cdecl _wtol(wstr) ntdll._wtol
565 @ cdecl _wunlink(wstr)
566 @ cdecl _wutime(wstr ptr)
567 @ cdecl _y0(double)
568 @ cdecl _y1(double)
569 @ cdecl _yn(long double )
570 @ cdecl abort() MSVCRT_abort
571 @ cdecl abs(long)
572 @ cdecl acos(double)
573 @ cdecl asctime(ptr) MSVCRT_asctime
574 @ cdecl asin(double)
575 @ cdecl atan(double)
576 @ cdecl atan2(double double)
577 @ cdecl atexit(ptr) MSVCRT_atexit
578 @ cdecl atof(str)
579 @ cdecl atoi(str)
580 @ cdecl atol(str)
581 @ cdecl bsearch(ptr ptr long long ptr)
582 @ cdecl calloc(long long) MSVCRT_calloc
583 @ cdecl ceil(double)
584 @ cdecl clearerr(ptr) MSVCRT_clearerr
585 @ cdecl clock() MSVCRT_clock
586 @ cdecl cos(double)
587 @ cdecl cosh(double)
588 @ cdecl ctime(ptr) MSVCRT_ctime
589 @ cdecl difftime(long long) MSVCRT_difftime
590 @ cdecl div(long long) MSVCRT_div
591 @ cdecl exit(long) MSVCRT_exit
592 @ cdecl exp(double)
593 @ cdecl fabs(double)
594 @ cdecl fclose(ptr) MSVCRT_fclose
595 @ cdecl feof(ptr) MSVCRT_feof
596 @ cdecl ferror(ptr) MSVCRT_ferror
597 @ cdecl fflush(ptr) MSVCRT_fflush
598 @ cdecl fgetc(ptr) MSVCRT_fgetc
599 @ cdecl fgetpos(ptr ptr) MSVCRT_fgetpos
600 @ cdecl fgets(ptr long ptr) MSVCRT_fgets
601 @ cdecl fgetwc(ptr) MSVCRT_fgetwc
602 @ cdecl fgetws(ptr long ptr) MSVCRT_fgetws
603 @ cdecl floor(double)
604 @ cdecl fmod(double double)
605 @ cdecl fopen(str str) MSVCRT_fopen
606 @ varargs fprintf(ptr str) MSVCRT_fprintf
607 @ cdecl fputc(long ptr) MSVCRT_fputc
608 @ cdecl fputs(str ptr) MSVCRT_fputs
609 @ cdecl fputwc(long ptr) MSVCRT_fputwc
610 @ cdecl fputws(wstr ptr) MSVCRT_fputws
611 @ cdecl fread(ptr long long ptr) MSVCRT_fread
612 @ cdecl free(ptr) MSVCRT_free
613 @ cdecl freopen(str str ptr) MSVCRT_freopen
614 @ cdecl frexp(double ptr)
615 @ varargs fscanf(ptr str) MSVCRT_fscanf
616 @ cdecl fseek(ptr long long) MSVCRT_fseek
617 @ cdecl fsetpos(ptr ptr) MSVCRT_fsetpos
618 @ cdecl ftell(ptr) MSVCRT_ftell
619 @ varargs fwprintf(ptr wstr) MSVCRT_fwprintf
620 @ cdecl fwrite(ptr long long ptr) MSVCRT_fwrite
621 @ varargs fwscanf(ptr wstr) MSVCRT_fwscanf
622 @ cdecl getc(ptr) MSVCRT_getc
623 @ cdecl getchar() MSVCRT_getchar
624 @ cdecl getenv(str) MSVCRT_getenv
625 @ cdecl gets(str) MSVCRT_gets
626 @ cdecl getwc(ptr) MSVCRT_getwc
627 @ cdecl getwchar() MSVCRT_getwchar
628 @ cdecl gmtime(ptr) MSVCRT_gmtime
629 @ cdecl is_wctype(long long) ntdll.iswctype
630 @ cdecl isalnum(long) MSVCRT_isalnum
631 @ cdecl isalpha(long) MSVCRT_isalpha
632 @ cdecl iscntrl(long) MSVCRT_iscntrl
633 @ cdecl isdigit(long) MSVCRT_isdigit
634 @ cdecl isgraph(long) MSVCRT_isgraph
635 @ cdecl isleadbyte(long) MSVCRT_isleadbyte
636 @ cdecl islower(long) MSVCRT_islower
637 @ cdecl isprint(long) MSVCRT_isprint
638 @ cdecl ispunct(long) MSVCRT_ispunct
639 @ cdecl isspace(long) MSVCRT_isspace
640 @ cdecl isupper(long) MSVCRT_isupper
641 @ cdecl iswalnum(long) MSVCRT_iswalnum
642 @ cdecl iswalpha(long) ntdll.iswalpha
643 @ cdecl iswascii(long) MSVCRT_iswascii
644 @ cdecl iswcntrl(long) MSVCRT_iswcntrl
645 @ cdecl iswctype(long long) ntdll.iswctype
646 @ cdecl iswdigit(long) MSVCRT_iswdigit
647 @ cdecl iswgraph(long) MSVCRT_iswgraph
648 @ cdecl iswlower(long) MSVCRT_iswlower
649 @ cdecl iswprint(long) MSVCRT_iswprint
650 @ cdecl iswpunct(long) MSVCRT_iswpunct
651 @ cdecl iswspace(long) MSVCRT_iswspace
652 @ cdecl iswupper(long) MSVCRT_iswupper
653 @ cdecl iswxdigit(long) MSVCRT_iswxdigit
654 @ cdecl isxdigit(long) MSVCRT_isxdigit
655 @ cdecl labs(long)
656 @ cdecl ldexp( double long) MSVCRT_ldexp
657 @ cdecl ldiv(long long) MSVCRT_ldiv
658 @ cdecl localeconv() MSVCRT_localeconv
659 @ cdecl localtime(ptr) MSVCRT_localtime
660 @ cdecl log(double)
661 @ cdecl log10(double)
662 @ cdecl -i386 longjmp(ptr long) MSVCRT_longjmp
663 @ cdecl malloc(long) MSVCRT_malloc
664 @ cdecl mblen(ptr long) MSVCRT_mblen
665 @ cdecl mbstowcs(ptr str long) ntdll.mbstowcs
666 @ cdecl mbtowc(wstr str long) MSVCRT_mbtowc
667 @ cdecl memchr(ptr long long)
668 @ cdecl memcmp(ptr ptr long)
669 @ cdecl memcpy(ptr ptr long) memmove
670 @ cdecl memmove(ptr ptr long)
671 @ cdecl memset(ptr long long)
672 @ cdecl mktime(ptr) MSVCRT_mktime
673 @ cdecl modf(double ptr)
674 @ cdecl perror(str) MSVCRT_perror
675 @ cdecl pow(double double)
676 @ varargs printf(str) MSVCRT_printf
677 @ cdecl putc(long ptr) MSVCRT_putc
678 @ cdecl putchar(long) MSVCRT_putchar
679 @ cdecl puts(str) MSVCRT_puts
680 @ cdecl putwc(long ptr) MSVCRT_fputwc
681 @ cdecl putwchar(long) _fputwchar
682 @ cdecl qsort(ptr long long ptr)
683 @ stub raise #(long)
684 @ cdecl rand() MSVCRT_rand
685 @ cdecl realloc(ptr long) MSVCRT_realloc
686 @ cdecl remove(str) MSVCRT_remove
687 @ cdecl rename(str str) MSVCRT_rename
688 @ cdecl rewind(ptr) MSVCRT_rewind
689 @ varargs scanf(str) MSVCRT_scanf
690 @ cdecl setbuf(ptr ptr) MSVCRT_setbuf
691 @ cdecl setlocale(long str) MSVCRT_setlocale
692 @ cdecl setvbuf(ptr str long long) MSVCRT_setvbuf
693 @ cdecl signal(long long) MSVCRT_signal
694 @ cdecl sin(double)
695 @ cdecl sinh(double)
696 @ varargs sprintf(ptr str) MSVCRT_sprintf
697 @ cdecl sqrt(double)
698 @ cdecl srand(long) MSVCRT_srand
699 @ varargs sscanf(str str) MSVCRT_sscanf
700 @ cdecl strcat(str str)
701 @ cdecl strchr(str long)
702 @ cdecl strcmp(str str)
703 @ cdecl strcoll(str str)
704 @ cdecl strcpy(ptr str)
705 @ cdecl strcspn(str str)
706 @ cdecl strerror(long) MSVCRT_strerror
707 @ cdecl strftime(str long str ptr) MSVCRT_strftime
708 @ cdecl strlen(str)
709 @ cdecl strncat(str str long)
710 @ cdecl strncmp(str str long)
711 @ cdecl strncpy(ptr str long)
712 @ cdecl strpbrk(str str)
713 @ cdecl strrchr(str long)
714 @ cdecl strspn(str str)
715 @ cdecl strstr(str str)
716 @ cdecl strtod(str ptr)
717 @ cdecl strtok(str str) MSVCRT_strtok
718 @ cdecl strtol(str ptr long)
719 @ cdecl strtoul(str ptr long)
720 @ cdecl strxfrm(ptr str long)
721 @ varargs swprintf(wstr wstr) MSVCRT_swprintf
722 @ varargs swscanf(wstr wstr) MSVCRT_swscanf
723 @ cdecl system(str) MSVCRT_system
724 @ cdecl tan(double)
725 @ cdecl tanh(double)
726 @ cdecl time(ptr) MSVCRT_time
727 @ cdecl tmpfile() MSVCRT_tmpfile
728 @ cdecl tmpnam(ptr) MSVCRT_tmpnam
729 @ cdecl tolower(long)
730 @ cdecl toupper(long)
731 @ cdecl towlower(long) ntdll.towlower
732 @ cdecl towupper(long) ntdll.towupper
733 @ cdecl ungetc(long ptr) MSVCRT_ungetc
734 @ cdecl ungetwc(long ptr) MSVCRT_ungetwc
735 @ cdecl vfprintf(ptr str long) MSVCRT_vfprintf
736 @ cdecl vfwprintf(ptr wstr long) MSVCRT_vfwprintf
737 @ cdecl vprintf(str long) MSVCRT_vprintf
738 @ cdecl vsprintf(ptr str ptr)
739 @ cdecl vswprintf(ptr wstr long) MSVCRT_vswprintf
740 @ cdecl vwprintf(wstr long) MSVCRT_vwprintf
741 @ cdecl wcscat(wstr wstr) ntdll.wcscat
742 @ cdecl wcschr(wstr long) ntdll.wcschr
743 @ cdecl wcscmp(wstr wstr) ntdll.wcscmp
744 @ cdecl wcscoll(wstr wstr) MSVCRT_wcscoll
745 @ cdecl wcscpy(ptr wstr) ntdll.wcscpy
746 @ cdecl wcscspn(wstr wstr) ntdll.wcscspn
747 @ stub wcsftime #(ptr long wstr ptr) MSVCRT_wcsftime
748 @ cdecl wcslen(wstr) ntdll.wcslen
749 @ cdecl wcsncat(wstr wstr long) ntdll.wcsncat
750 @ cdecl wcsncmp(wstr wstr long) ntdll.wcsncmp
751 @ cdecl wcsncpy(ptr wstr long) ntdll.wcsncpy
752 @ cdecl wcspbrk(wstr wstr) MSVCRT_wcspbrk
753 @ cdecl wcsrchr(wstr long) ntdll.wcsrchr
754 @ cdecl wcsspn(wstr wstr) ntdll.wcsspn
755 @ cdecl wcsstr(wstr wstr) ntdll.wcsstr
756 @ cdecl wcstod(wstr ptr) MSVCRT_wcstod
757 @ cdecl wcstok(wstr wstr) MSVCRT_wcstok
758 @ cdecl wcstol(wstr ptr long) ntdll.wcstol
759 @ cdecl wcstombs(ptr ptr long) ntdll.wcstombs
760 @ cdecl wcstoul(wstr ptr long) ntdll.wcstoul
761 @ stub wcsxfrm #(ptr wstr long)
762 @ cdecl wctomb(ptr long) MSVCRT_wctomb
763 @ varargs wprintf(wstr) MSVCRT_wprintf
764 @ varargs wscanf(wstr) MSVCRT_wscanf
765 # extern __lc_collate_cp