Release 980913
[wine/multimedia.git] / if1632 / kernel.spec
blobf15d568b1e8333be0cd01cc2051cbb5db5494d1a
1 name kernel
2 type win16
3 file krnl386.exe
5 1 stub FatalExit
6 2 stub ExitKernel
7 3 pascal GetVersion() GetVersion16
8 4 pascal16 LocalInit(word word word) LocalInit
9 5 pascal16 LocalAlloc(word word) LocalAlloc16
10 6 pascal16 LocalReAlloc(word word word) LocalReAlloc16
11 7 pascal16 LocalFree(word) LocalFree16
12 8 pascal16 LocalLock(word) LocalLock16
13 9 pascal16 LocalUnlock(word) LocalUnlock16
14 10 pascal16 LocalSize(word) LocalSize16
15 11 pascal16 LocalHandle(word) LocalHandle16
16 12 pascal16 LocalFlags(word) LocalFlags16
17 13 pascal16 LocalCompact(word) LocalCompact16
18 14 pascal16 LocalNotify(long) LocalNotify
19 15 pascal16 GlobalAlloc(word long) GlobalAlloc16
20 16 pascal16 GlobalReAlloc(word long word) GlobalReAlloc16
21 17 pascal16 GlobalFree(word) GlobalFree16
22 18 pascal GlobalLock(word) WIN16_GlobalLock16
23 19 pascal16 GlobalUnlock(word) GlobalUnlock16
24 20 pascal GlobalSize(word) GlobalSize16
25 21 pascal GlobalHandle(word) GlobalHandle16
26 22 pascal16 GlobalFlags(word) GlobalFlags16
27 23 pascal16 LockSegment(word) LockSegment16
28 24 pascal16 UnlockSegment(word) UnlockSegment16
29 25 pascal GlobalCompact(long) GlobalCompact16
30 26 pascal16 GlobalFreeAll(word) GlobalFreeAll
31 27 pascal16 GetModuleName(word ptr word) GetModuleName
32 28 stub GlobalMasterHandle
33 29 pascal16 Yield() Yield16
34 30 pascal16 WaitEvent(word) WaitEvent
35 31 pascal16 PostEvent(word) PostEvent
36 32 pascal16 SetPriority(word s_word) SetPriority
37 33 pascal16 LockCurrentTask(word) LockCurrentTask
38 34 pascal SetTaskQueue(word word) SetTaskQueue
39 35 pascal16 GetTaskQueue(word) GetTaskQueue
40 36 pascal GetCurrentTask() WIN16_GetCurrentTask
41 37 pascal GetCurrentPDB() GetCurrentPDB
42 38 pascal SetTaskSignalProc(word segptr) THUNK_SetTaskSignalProc
43 41 return EnableDos 0 0
44 42 return DisableDos 0 0
45 45 pascal16 LoadModule(str ptr) LoadModule16
46 46 pascal16 FreeModule(word) FreeModule16
47 47 pascal GetModuleHandle(segstr) WIN16_GetModuleHandle
48 48 pascal16 GetModuleUsage(word) GetModuleUsage
49 49 pascal16 GetModuleFileName(word ptr s_word) GetModuleFileName16
50 50 pascal GetProcAddress(word segstr) GetProcAddress16
51 51 pascal MakeProcInstance(segptr word) MakeProcInstance16
52 52 pascal16 FreeProcInstance(segptr) FreeProcInstance16
53 53 stub CallProcInstance
54 54 pascal16 GetInstanceData(word word word) GetInstanceData
55 55 register Catch(segptr) Catch
56 56 register Throw(segptr word) Throw
57 57 pascal16 GetProfileInt(str str s_word) GetProfileInt16
58 58 pascal16 GetProfileString(str str str ptr word) GetProfileString16
59 59 pascal16 WriteProfileString(str str str) WriteProfileString16
60 60 pascal16 FindResource(word segstr segstr) FindResource16
61 61 pascal16 LoadResource(word word) LoadResource16
62 62 pascal LockResource(word) WIN16_LockResource16
63 63 pascal16 FreeResource(word) FreeResource16
64 64 pascal16 AccessResource(word word) AccessResource16
65 65 pascal SizeofResource(word word) SizeofResource16
66 66 pascal16 AllocResource(word word long) AllocResource
67 67 pascal SetResourceHandler(word segstr segptr) SetResourceHandler
68 68 pascal16 InitAtomTable(word) InitAtomTable16
69 69 pascal16 FindAtom(segstr) FindAtom16
70 70 pascal16 AddAtom(segstr) AddAtom16
71 71 pascal16 DeleteAtom(word) DeleteAtom16
72 72 pascal16 GetAtomName(word ptr word) GetAtomName16
73 73 pascal16 GetAtomHandle(word) GetAtomHandle
74 74 pascal16 OpenFile(str ptr word) OpenFile16
75 75 stub OpenPathName
76 76 stub DeletePathName
77 # Reserved*: old Win 2.x functions now moved to USER (Win 3.0+)
78 77 pascal Reserved1(segptr) AnsiNext16
79 78 pascal Reserved2(segptr segptr) AnsiPrev16
80 79 pascal Reserved3(segstr) AnsiUpper16
81 80 pascal Reserved4(segstr) AnsiLower16
82 81 pascal16 _lclose(word) _lclose16
83 82 pascal16 _lread(word segptr word) WIN16_lread
84 83 pascal16 _lcreat(str word) _lcreat16
85 84 pascal _llseek(word long word) _llseek16
86 85 pascal16 _lopen(str word) _lopen16
87 86 pascal16 _lwrite(word ptr word) _lwrite16
88 87 pascal16 Reserved5(str str) lstrcmp16
89 88 pascal lstrcpy(segptr str) lstrcpy16
90 89 pascal lstrcat(segstr str) lstrcat16
91 90 pascal16 lstrlen(str) lstrlen16
92 91 register InitTask() InitTask
93 92 pascal GetTempDrive(word) WIN16_GetTempDrive
94 93 pascal16 GetCodeHandle(segptr) GetCodeHandle
95 94 pascal16 DefineHandleTable(word) DefineHandleTable16
96 95 pascal16 LoadLibrary(str) LoadLibrary16
97 96 pascal16 FreeLibrary(word) FreeLibrary16
98 97 pascal16 GetTempFileName(word str word ptr) GetTempFileName16
99 98 return GetLastDiskChange 0 0
100 99 stub GetLPErrMode
101 100 return ValidateCodeSegments 0 0
102 101 stub NoHookDosCall
103 102 register DOS3Call() DOS3Call
104 103 register NetBIOSCall() NetBIOSCall
105 104 stub GetCodeInfo
106 105 pascal16 GetExeVersion() GetExeVersion
107 106 pascal SetSwapAreaSize(word) SetSwapAreaSize16
108 107 pascal16 SetErrorMode(word) SetErrorMode16
109 108 pascal16 SwitchStackTo(word word word) SwitchStackTo
110 109 register SwitchStackBack() SwitchStackBack
111 110 pascal16 PatchCodeHandle(word) PatchCodeHandle
112 111 pascal GlobalWire(word) GlobalWire16
113 112 pascal16 GlobalUnWire(word) GlobalUnWire16
114 113 equate __AHSHIFT 3
115 114 equate __AHINCR 8
116 115 pascal16 OutputDebugString(str) OutputDebugString16
117 116 stub InitLib
118 117 pascal16 OldYield() OldYield
119 118 register GetTaskQueueDS() GetTaskQueueDS
120 119 register GetTaskQueueES() GetTaskQueueES
121 120 stub UndefDynLink
122 121 pascal16 LocalShrink(word word) LocalShrink16
123 122 pascal16 IsTaskLocked() IsTaskLocked
124 123 return KbdRst 0 0
125 124 return EnableKernel 0 0
126 125 return DisableKernel 0 0
127 126 stub MemoryFreed
128 127 pascal16 GetPrivateProfileInt(str str s_word str) GetPrivateProfileInt16
129 128 pascal16 GetPrivateProfileString(str str str ptr word str)
130 GetPrivateProfileString16
131 129 pascal16 WritePrivateProfileString(str str str str)
132 WritePrivateProfileString16
133 130 pascal FileCDR(ptr) FileCDR
134 131 pascal GetDOSEnvironment() GetDOSEnvironment
135 132 pascal GetWinFlags() GetWinFlags
136 133 register GetExePtr(word) WIN16_GetExePtr
137 134 pascal16 GetWindowsDirectory(ptr word) GetWindowsDirectory16
138 135 pascal16 GetSystemDirectory(ptr word) GetSystemDirectory16
139 136 pascal16 GetDriveType(word) GetDriveType16
140 137 pascal16 FatalAppExit(word str) FatalAppExit16
141 138 pascal GetHeapSpaces(word) GetHeapSpaces
142 139 stub DoSignal
143 140 pascal16 SetSigHandler(segptr ptr ptr word word) SetSigHandler
144 141 stub InitTask1
145 142 pascal16 GetProfileSectionNames(ptr word) GetProfileSectionNames16
146 143 pascal16 GetPrivateProfileSectionNames(ptr word str) GetPrivateProfileSectionNames16
147 144 pascal16 CreateDirectory(ptr ptr) CreateDirectory16
148 145 pascal16 RemoveDirectory(ptr) RemoveDirectory16
149 146 pascal16 DeleteFile(ptr) DeleteFile16
150 147 pascal16 SetLastError(long) SetLastError
151 148 pascal GetLastError() GetLastError
152 149 pascal16 GetVersionEx(ptr) GetVersionEx16
153 150 pascal16 DirectedYield(word) DirectedYield
154 151 stub WinOldApCall
155 152 pascal16 GetNumTasks() GetNumTasks
156 154 pascal16 GlobalNotify(segptr) GlobalNotify
157 155 pascal16 GetTaskDS() GetTaskDS
158 156 return LimitEMSPages 4 0
159 157 return GetCurPID 4 0
160 158 return IsWinOldApTask 2 0
161 159 pascal GlobalHandleNoRIP(word) GlobalHandleNoRIP
162 160 stub EMSCopy
163 161 pascal16 LocalCountFree() LocalCountFree
164 162 pascal16 LocalHeapSize() LocalHeapSize
165 163 pascal16 GlobalLRUOldest(word) GlobalLRUOldest
166 164 pascal16 GlobalLRUNewest(word) GlobalLRUNewest
167 165 return A20Proc 2 0
168 166 pascal16 WinExec(str word) WinExec16
169 167 pascal16 GetExpWinVer(word) GetExpWinVer
170 168 pascal16 DirectResAlloc(word word word) DirectResAlloc
171 169 pascal GetFreeSpace(word) GetFreeSpace16
172 170 pascal16 AllocCStoDSAlias(word) AllocCStoDSAlias
173 171 pascal16 AllocDStoCSAlias(word) AllocDStoCSAlias
174 172 pascal16 AllocAlias(word) AllocCStoDSAlias
175 173 equate __ROMBIOS 0
176 174 equate __A000H 0
177 175 pascal16 AllocSelector(word) AllocSelector
178 176 pascal16 FreeSelector(word) FreeSelector
179 177 pascal16 PrestoChangoSelector(word word) PrestoChangoSelector
180 178 equate __WINFLAGS 0x413
181 179 equate __D000H 0
182 180 pascal16 LongPtrAdd(long long) LongPtrAdd
183 181 equate __B000H 0
184 182 equate __B800H 0
185 183 equate __0000H 0
186 184 pascal GlobalDOSAlloc(long) GlobalDOSAlloc
187 185 pascal16 GlobalDOSFree(word) GlobalDOSFree
188 186 pascal GetSelectorBase(word) GetSelectorBase
189 187 pascal16 SetSelectorBase(word long) SetSelectorBase
190 188 pascal GetSelectorLimit(word) GetSelectorLimit
191 189 pascal16 SetSelectorLimit(word long) SetSelectorLimit
192 190 equate __E000H 0
193 191 pascal16 GlobalPageLock(word) GlobalPageLock
194 192 pascal16 GlobalPageUnlock(word) GlobalPageUnlock
195 193 equate __0040H 0
196 194 equate __F000H 0
197 195 equate __C000H 0
198 196 pascal16 SelectorAccessRights(word word word) SelectorAccessRights
199 197 pascal16 GlobalFix(word) GlobalFix16
200 198 pascal16 GlobalUnfix(word) GlobalUnfix16
201 199 pascal16 SetHandleCount(word) SetHandleCount16
202 200 return ValidateFreeSpaces 0 0
203 201 stub ReplaceInst
204 202 stub RegisterPtrace
205 203 register DebugBreak() DebugBreak
206 204 stub SwapRecording
207 205 stub CVWBreak
208 206 pascal16 AllocSelectorArray(word) AllocSelectorArray
209 207 pascal16 IsDBCSLeadByte(word) IsDBCSLeadByte16
210 208 stub KERNEL_208
211 209 stub KERNEL_209
212 210 stub KERNEL_210
213 211 stub KERNEL_211
214 213 stub KERNEL_213
215 214 stub KERNEL_214
216 216 pascal RegEnumKey(long long ptr long) RegEnumKey16
217 217 pascal RegOpenKey(long str ptr) RegOpenKey16
218 218 pascal RegCreateKey(long str ptr) RegCreateKey16
219 219 pascal RegDeleteKey(long str) RegDeleteKey16
220 220 pascal RegCloseKey(long) RegCloseKey
221 221 pascal RegSetValue(long str long ptr long) RegSetValue16
222 222 pascal RegDeleteValue(long str) RegDeleteValue16
223 223 pascal RegEnumValue(long long ptr ptr ptr ptr ptr ptr) RegEnumValue16
224 224 pascal RegQueryValue(long str ptr ptr) RegQueryValue16
225 225 pascal RegQueryValueEx(long str ptr ptr ptr ptr) RegQueryValueEx16
226 226 pascal RegSetValueEx(long str long long ptr long) RegSetValueEx16
227 227 pascal RegFlushKey(long) RegFlushKey
228 228 stub K228
229 229 stub K229
230 230 pascal GlobalSmartPageLock(word) GlobalPageLock #?
231 231 stub GlobalSmartPageUnlock
232 232 stub RegLoadKey
233 233 stub RegUnloadKey
234 234 stub RegSaveKey
235 235 stub InvalidateNlsCache
236 236 stub GetProductName
237 237 stub KERNEL_237
238 262 stub KERNEL_262
239 263 stub KERNEL_263
240 310 pascal16 LocalHandleDelta(word) LocalHandleDelta
241 311 pascal GetSetKernelDOSProc(ptr) GetSetKernelDOSProc
242 314 stub DebugDefineSegment
243 315 pascal16 WriteOutProfiles() WriteOutProfiles
244 316 pascal GetFreeMemInfo() GetFreeMemInfo
245 318 stub FatalExitHook
246 319 stub FlushCachedFileHandle
247 320 pascal16 IsTask(word) IsTask
248 321 stub KERNEL_321
249 323 return IsRomModule 2 0
250 324 pascal16 LogError(word ptr) LogError
251 325 pascal16 LogParamError(word ptr ptr) LogParamError
252 326 return IsRomFile 2 0
253 327 stub KERNEL_327
254 328 stub _DebugOutput
255 329 pascal16 K329(str word) DebugFillBuffer
256 332 long THHOOK(0 0 0 0 0 0 0 0)
257 334 pascal16 IsBadReadPtr(segptr word) IsBadReadPtr16
258 335 pascal16 IsBadWritePtr(segptr word) IsBadWritePtr16
259 336 pascal16 IsBadCodePtr(segptr) IsBadCodePtr16
260 337 pascal16 IsBadStringPtr(segptr word) IsBadStringPtr16
261 338 stub HasGPHandler
262 339 pascal16 DiagQuery() DiagQuery
263 340 pascal16 DiagOutput(str) DiagOutput
264 341 pascal ToolHelpHook(ptr) ToolHelpHook
265 342 stub __GP
266 343 stub RegisterWinOldApHook
267 344 stub GetWinOldApHooks
268 345 pascal16 IsSharedSelector(word) IsSharedSelector
269 346 pascal16 IsBadHugeReadPtr(segptr long) IsBadHugeReadPtr16
270 347 pascal16 IsBadHugeWritePtr(segptr long) IsBadHugeWritePtr16
271 348 pascal16 hmemcpy(ptr ptr long) hmemcpy
272 349 pascal _hread(word segptr long) WIN16_hread
273 350 pascal _hwrite(word ptr long) _hwrite16
274 #351 BUNNY_351
275 352 pascal lstrcatn(segstr str word) lstrcatn16
276 353 pascal lstrcpyn(segptr str word) lstrcpyn16
277 354 pascal GetAppCompatFlags(word) GetAppCompatFlags16
278 355 pascal16 GetWinDebugInfo(ptr word) GetWinDebugInfo
279 356 pascal16 SetWinDebugInfo(ptr) SetWinDebugInfo
280 357 pascal MapSL(segptr) MapSL
281 358 pascal MapLS(long) MapLS
282 359 pascal UnMapLS(segptr) UnMapLS
283 360 pascal16 OpenFileEx(str ptr word) OpenFile16
284 #361 PIGLET_361
285 365 stub KERNEL_365
286 403 pascal16 FarSetOwner(word word) FarSetOwner
287 404 pascal16 FarGetOwner(word) FarGetOwner
288 406 stub WritePrivateProfileStruct
289 407 stub GetPrivateProfileStruct
290 411 pascal GetCurrentDirectory(long ptr) GetCurrentDirectory16
291 412 pascal16 SetCurrentDirectory(ptr) SetCurrentDirectory16
292 413 pascal16 FindFirstFile(ptr ptr) FindFirstFile16
293 414 pascal16 FindNextFile(word ptr) FindNextFile16
294 415 pascal16 FindClose(word) FindClose16
295 416 stub WritePrivateProfileSection
296 417 stub WriteProfileSection
297 418 stub GetPrivateProfileSection
298 419 stub GetProfileSection
299 420 pascal GetFileAttributes(ptr) GetFileAttributes16
300 421 pascal16 SetFileAttributes(ptr long) SetFileAttributes16
301 422 pascal16 GetDiskFreeSpace(ptr ptr ptr ptr ptr) GetDiskFreeSpace16
302 431 pascal16 IsPeFormat(str word) IsPeFormat
303 432 stub FileTimeToLocalFileTime
304 434 stub KERNEL_434
305 435 stub KERNEL_435
306 439 stub KERNEL_439
307 440 stub KERNEL_440
308 444 stub KERNEL_444
309 445 stub KERNEL_445
310 446 stub KERNEL_446
311 447 stub KERNEL_447
312 449 pascal GetpWin16Lock() GetpWin16Lock16
313 450 pascal16 KERNEL_450() stub_KERNEL_450
314 452 stub KERNEL_452
315 453 stub KERNEL_453
316 454 equate __FLATCS 0 # initialized by BUILTIN_Init()
317 455 equate __FLATDS 0 # initialized by BUILTIN_Init()
318 471 pascal KERNEL_471() _KERNEL_471
319 472 register KERNEL_472() _KERNEL_472
320 473 stub KERNEL_473
321 475 register KERNEL_475() _KERNEL_475
322 480 stub KERNEL_480
323 481 stub KERNEL_481
324 482 pascal LoadLibrary32(str) LoadLibrary32A
325 485 pascal GetProcessDWORD(long s_word) GetProcessDword
326 486 stub KERNEL_486
327 491 stub RegisterServiceProcess
329 # Those stubs can be found in WindowNT3.51 krnl386.exe. Some are used by Win95
330 # too, some seem to specify different functions in Win95... Ugh.
331 500 pascal WOW16Call(word word word) WOW16Call
332 501 stub KDDBGOUT
333 502 stub WOWGETNEXTVDMCOMMAND
334 503 stub WOWREGISTERSHELLWINDOWHANDLE
335 504 stub WOWLOADMODULE
336 505 stub WOWQUERYPERFORMANCECOUNTER
337 506 stub WOWCURSORICONOP
338 507 stub WOWFAILEDEXEC
339 508 stub WOWCLOSECOMPORT
340 509 stub WOWKILLREMOTETASK
341 511 stub WOWKILLREMOTETASK
342 512 stub WOWQUERYDEBUG
343 513 pascal LoadLibraryEx32W(ptr long long) LoadLibraryEx32W16
344 514 pascal16 FreeLibrary32W(long) FreeLibrary32
345 515 pascal GetProcAddress32W(long str) GetProcAddress32
346 516 pascal GetVDMPointer32W(segptr long) GetVDMPointer32W
347 517 pascal CallProc32W() WIN16_CallProc32W
348 518 pascal CallProcEx32W() WIN16_CallProcEx32W
349 519 stub EXITKERNELTHUNK
350 # the __MOD_ variables are WORD datareferences.
351 520 equate __MOD_KERNEL 4200
352 521 equate __MOD_DKERNEL 4201
353 522 equate __MOD_USER 4203
354 523 equate __MOD_DUSER 4204
355 524 equate __MOD_GDI 4205
356 525 equate __MOD_DGDI 4206
357 526 equate __MOD_KEYBOARD 4207
358 527 equate __MOD_SOUND 4208
359 528 equate __MOD_SHELL 4209
360 529 equate __MOD_WINSOCK 4210
361 530 equate __MOD_TOOLHELP 4211
362 531 equate __MOD_MMEDIA 4212
363 532 equate __MOD_COMMDLG 4213
364 540 stub KERNEL_540
365 541 stub WOWSETEXITONLASTAPP
366 544 stub WOWSETCOMPATHANDLE
368 600 stub KERNEL_600
369 601 stub KERNEL_601
370 604 stub KERNEL_604
371 605 stub KERNEL_605
372 606 stub KERNEL_606
373 607 pascal KERNEL_607(long long long) _KERNEL_607
374 608 pascal KERNEL_608(long long long) _KERNEL_608
375 611 pascal KERNEL_611(long long) _KERNEL_611
376 612 stub KERNEL_612
377 613 stub KERNEL_613
378 614 stub KERNEL_614
379 619 pascal KERNEL_619(word long long) _KERNEL_619
380 621 stub KERNEL_621
381 627 stub IsBadFlatReadWritePtr
382 630 register C16ThkSL() C16ThkSL
383 631 register C16ThkSL01() C16ThkSL01
384 651 pascal ThunkConnect16(str str word long ptr str word) ThunkConnect16
385 700 pascal KERNEL_700() stub_KERNEL_700