Release 980726
[wine/multimedia.git] / relay32 / shell32.spec
blob524063a4ff62e56946f5d983b618af4f604899b0
1 name shell32
2 type win32
4 # Functions exported by the Win95 shell32.dll
5 # (these need to have these exact ordinals, for some
6 # win95 and winNT dlls import shell32.dll by ordinal)
7 # This list was updated to dll version 4.72
9 2 stdcall SHChangeNotifyRegister(long long long long long long) SHChangeNotifyRegister
10 3 stub CheckEscapesA@8 # exported by name
11 4 stdcall SHChangeNotifyDeregister (long long) SHChangeNotifyDeregister
12 5 stub SHChangeNotifyUpdateEntryList@16
13 6 stub CheckEscapesW@8 # exported by name
14 7 stdcall CommandLineToArgvW(wstr ptr) CommandLineToArgvW # exported by name
15 8 stub Control_FillCache_RunDLL@16 # exported by name
16 9 stub PifMgr_OpenProperties@16
17 10 stub PifMgr_GetProperties@20
18 11 stub PifMgr_SetProperties@20
19 12 stub Control_FillCache_RunDLLA # exported by name
20 13 stub PifMgr_CloseProperties@8
21 14 stub Control_FillCache_RunDLLW@16 # exported by name
22 15 stdcall ILGetDisplayName(ptr ptr) ILGetDisplayName
23 16 stdcall ILFindLastID(ptr) ILFindLastID
24 17 stub ILRemoveLastID@4
25 18 stdcall ILClone(ptr) ILClone
26 19 stub ILCloneFirst@4
27 20 stub ILGlobalClone@4
28 21 stub ILIsEqual@8
29 22 stdcall Control_RunDLL(long long long long) Control_RunDLL # exported by name
30 23 stub ILIsParent@12
31 24 stub ILFindChild@8
32 25 stdcall ILCombine(ptr ptr) ILCombine
33 26 stub ILLoadFromStream@8
34 27 stub ILSaveToStream@8
35 28 stub SHILCreateFromPath@12
36 29 stdcall PathIsRoot(str) PathIsRoot
37 30 stdcall PathBuildRoot(ptr long) PathBuildRoot
38 31 stdcall PathFindExtension(str) PathFindExtension
39 32 stdcall PathAddBackslash(str) PathAddBackslash
40 33 stdcall PathRemoveBlanks(str) PathRemoveBlanks
41 34 stdcall PathFindFilename(str) PathFindFilename
42 35 stdcall PathRemoveFileSpec(str) PathRemoveFileSpec
43 36 stdcall PathAppend(str str) PathAppend
44 37 stdcall PathCombine(ptr str str) PathCombine
45 38 stub PathStripPath
46 39 stdcall PathIsUNC(str) PathIsUNC
47 40 stub PathIsRelative
48 41 stub Control_RunDLLA # exported by name
49 42 stub Control_RunDLLW # exported by name
50 43 stub PathIsExe
51 44 stub DoEnvironmentSubstA # exported by name
52 45 stdcall PathFileExists(str) PathFileExists
53 46 stub PathMatchSpec
54 47 stub PathMakeUniqueName
55 48 stub PathSetDlgItemPath
56 49 stub PathQualify
57 50 stub PathStripToRoot
58 51 stdcall PathResolve(str long long) PathResolve
59 52 stdcall PathGetArgs(str) PathGetArgs
60 53 stub DoEnvironmentSubstW # exported by name
61 54 stdcall DragAcceptFiles(long long) DragAcceptFiles # exported by name
62 55 stub PathQuoteSpaces
63 56 stdcall PathUnquoteSpaces(str) PathUnquoteSpaces
64 57 stub PathGetDriveNumber
65 58 stdcall ParseField(str long str long) ParseField
66 59 stub RestartDialog
67 60 stdcall ExitWindowsDialog(long) ExitWindowsDialog
68 61 stdcall RunFileDlg(long long long str str long) RunFileDlg
69 62 stdcall PickIconDlg(long long long long) PickIconDlg
70 63 stdcall GetFileNameFromBrowse(long long long long str str str) GetFileNameFromBrowse
71 64 stub DriveType
72 65 stub InvalidateDriveType
73 66 stub IsNetDrive
74 67 stub Shell_MergeMenus
75 68 stdcall SHGetSettings(long long long) SHGetSettings
76 69 stub SHGetNetResource
77 70 stub SHCreateDefClassObject
78 71 stdcall Shell_GetImageList(ptr ptr) Shell_GetImageList
79 72 stdcall Shell_GetCachedImageIndex(ptr ptr long) Shell_GetCachedImageIndex
80 73 stub SHShellFolderView_Message
81 74 stub SHCreateStdEnumFmtEtc
82 75 stdcall PathYetAnotherMakeUniqueName(ptr ptr) PathYetAnotherMakeUniqueName
83 76 stub DragQueryInfo
84 77 stdcall SHMapPIDLToSystemImageListIndex(long long long) SHMapPIDLToSystemImageListIndex
85 78 stdcall OleStrToStrN(str long wstr long) OleStrToStrN
86 79 stdcall StrToOleStrN(wstr long str long) StrToOleStrN
87 80 stub DragFinish # exported by name
88 81 stub DragQueryFile # exported by name
89 82 stub DragQueryFileA # exported by name
90 83 stub CIDLData_CreateFromIDArray
91 84 stub SHIsBadInterfacePtr
92 85 stdcall OpenRegStream(long long long long) OpenRegStream
93 86 stdcall SHRegisterDragDrop(long ptr) SHRegisterDragDrop
94 87 stdcall SHRevokeDragDrop(long) SHRevokeDragDrop
95 88 stub SHDoDragDrop
96 89 stdcall SHCloneSpecialIDList(long long long) SHCloneSpecialIDList
97 90 stub SHFindFiles
98 91 stub SHFindComputer
99 92 stub PathGetShortPath
100 93 stub Win32CreateDirectory
101 94 stub Win32RemoveDirectory
102 95 stub SHLogILFromFSIL
103 96 stub StrRetToStrN
104 97 stub SHWaitForFileToOpen
105 98 stub SHGetRealIDL
106 99 stub SetAppStartingCursor
107 100 stdcall SHRestricted(long) SHRestricted
108 101 stub DragQueryFileAorW # exported by name
109 102 stdcall SHCoCreateInstance(ptr ptr long ptr ptr) SHCoCreateInstance
110 103 stdcall SignalFileOpen(long) SignalFileOpen
111 104 stub FileMenu_DeleteAllItems
112 105 stub FileMenu_DrawItem
113 106 stub FileMenu_FindSubMenuByPidl
114 107 stub FileMenu_GetLastSelectedItemPidls
115 108 stub FileMenu_HandleMenuChar
116 109 stub FileMenu_InitMenuPopup
117 110 stub FileMenu_InsertUsingPidl
118 111 stub FileMenu_Invalidate
119 112 stub FileMenu_MeasureItem
120 113 stub FileMenu_ReplaceUsingPidl
121 114 stub FileMenu_Create
122 115 stub FileMenu_AppendItem
123 116 stub FileMenu_TrackPopupMenuEx
124 117 stub FileMenu_DeleteItemByCmd
125 118 stub FileMenu_Destroy
126 119 stdcall IsLFNDrive(ptr) IsLFNDrive
127 120 stub FileMenu_AbortInitMenu
128 121 stub SHFlushClipboard
129 122 stub RunDLL_CallEntry16
130 123 stub SHFreeUnusedLibraries
131 124 stub FileMenu_AppendFilesForPidl
132 125 stub FileMenu_AddFilesForPidl
133 126 stub SHOutOfMemoryMessageBox
134 127 stub SHWinHelp
135 128 stdcall DllGetClassObject(long long ptr) SHELL32_DllGetClassObject
136 129 stub DAD_AutoScroll
137 130 stub DAD_DragEnter
138 131 stub DAD_DragEnterEx
139 132 stub DAD_DragLeave
140 133 stub DragQueryFileW # exported by name
141 134 stub DAD_DragMove
142 135 stub DragQueryPoint # exported by name
143 136 stub DAD_SetDragImage
144 137 stub DAD_ShowDragImage
145 138 stub DuplicateIcon # exported by name
146 139 stub Desktop_UpdateBriefcaseOnEvent
147 140 stub FileMenu_DeleteItemByIndex
148 141 stub FileMenu_DeleteItemByFirstID
149 142 stub FileMenu_DeleteSeparator
150 143 stub FileMenu_EnableItemByCmd
151 144 stub FileMenu_GetItemExtent
152 145 stub PathFindOnPath
153 146 stub RLBuildListOfPaths
154 147 stdcall SHCLSIDFromString(long long) SHCLSIDFromString
155 148 stdcall ExtractAssociatedIconA(long ptr long) ExtractAssociatedIcon32A # exported by name
156 149 stub SHFind_InitMenuPopup
157 150 stub ExtractAssociatedIconExA # exported by name
158 151 stub SHLoadOLE
159 152 stdcall ILGetSize(ptr) ILGetSize
160 153 stub ILGetNext
161 154 stub ILAppend
162 155 stdcall ILFree(ptr) ILFree
163 156 stub ILGlobalFree
164 157 stub ILCreateFromPath
165 158 stdcall PathGetExtension(str long long) PathGetExtension
166 159 stub PathIsDirectory
167 160 stub SHNetConnectionDialog
168 161 stub SHRunConrolPanel
169 162 stub SHSimpleIDListFromPath
170 163 stub StrToOleStr
171 164 stub Win32DeleteFile
172 165 stdcall SHCreateDirectory(long long) SHCreateDirectory
173 166 stub CallCPLEntry16
174 167 stub SHAddFromPropSheetExtArray
175 168 stub SHCreatePropSheetExtArray
176 169 stub SHDestroyPropSheetExtArray
177 170 stub SHReplaceFromPropSheetExtArray
178 171 stub PathCleanupSpec
179 172 stub SHCreateLinks
180 173 stub SHValidateUNC
181 174 stdcall SHCreateShellFolderViewEx (ptr ptr) SHCreateShellFolderViewEx32
182 175 stdcall SHGetSpecialFolderPath(long long long long) SHGetSpecialFolderPath
183 176 stub SHSetInstanceExplorer
184 177 stub DAD_SetDragImageFromListView
185 178 stub SHObjectProperties
186 179 stub SHGetNewLinkInfoA
187 180 stub SHGetNewLinkInfoW
188 181 stdcall RegisterShellHook(long long) RegisterShellHook32
189 182 stub ShellMessageBoxW
190 183 cdecl ShellMessageBoxA(long long long long long long) ShellMessageBoxA
191 184 stdcall ArrangeWindows(long long long long long) ArrangeWindows
192 185 stub SHHandleDiskFull
193 186 stub ExtractAssociatedIconExW # exported by name
194 187 stub ExtractAssociatedIconW # exported by name
195 188 stdcall ExtractIconA(long str long) ExtractIcon32A # exported by name
196 189 stub ExtractIconEx # exported by name
197 190 stub ExtractIconExA # exported by name
198 191 stub ExtractIconExW # exported by name
199 192 stub ExtractIconResInfoA # exported by name
200 193 stub ExtractIconResInfoW # exported by name
201 194 stdcall ExtractIconW(long wstr long) ExtractIcon32W # exported by name
202 195 stdcall SHFree(ptr) SHFree
203 196 stdcall SHAlloc(long) SHAlloc
204 197 stub SHGlobalDefect
205 198 stub SHAbortInvokeCommand
206 199 stub SHGetFileIcon
207 200 stub SHLocalAlloc
208 201 stub SHLocalFree
209 202 stub SHLocalReAlloc
210 203 stub AddCommasW
211 204 stub ShortSizeFormatW
212 205 stub Printer_LoadIconsW
213 206 stub Link_AddExtraDataSection
214 207 stub Link_ReadExtraDataSection
215 208 stub Link_RemoveExtraDataSection
216 209 stub Int64ToString
217 210 stub LargeIntegerToString
218 211 stub Printers_GetPidl
219 212 stub Printer_AddPrinterPropPages
220 213 stub Printers_RegisterWindowW
221 214 stub Printers_UnregisterWindow
222 215 stub SHStartNetConnectionDialog@12
223 216 stub ExtractVersionResource16W # exported by name
224 217 stub FindExeDlgProc # exported by name
225 218 stdcall FindExecutableA(ptr ptr ptr) FindExecutable32A # exported by name
226 219 stub FindExecutableW # exported by name
227 220 stdcall FreeIconList(long) FreeIconList # exported by name
228 221 stub InternalExtractIconListA # exported by name
229 222 stub InternalExtractIconListW # exported by name
230 223 stub OpenAs_RunDLL # exported by name
231 224 stub OpenAs_RunDLLA # exported by name
232 225 stub OpenAs_RunDLLW # exported by name
233 226 stub PrintersGetCommand_RunDLL # exported by name
234 227 stub PrintersGetCommand_RunDLLA # exported by name
235 228 stub PrintersGetCommand_RunDLLW # exported by name
236 229 stub RealShellExecuteA # exported by name
237 230 stub RealShellExecuteExA # exported by name
238 231 stub RealShellExecuteExW # exported by name
239 232 stub RealShellExecuteW # exported by name
240 233 stub RegenerateUserEnvironment@8 # exported by name
241 234 stdcall SHAddToRecentDocs (long ptr) SHAddToRecentDocs32 # exported by name
242 235 stdcall SHAppBarMessage(long ptr) SHAppBarMessage32 # exported by name
243 236 stdcall SHBrowseForFolder(ptr) SHBrowseForFolder32A # exported by name
244 237 stdcall SHBrowseForFolderA(ptr) SHBrowseForFolder32A # exported by name
245 238 stub SHBrowseForFolderW@4 # exported by name
246 239 stdcall SHChangeNotify (long long ptr ptr) SHChangeNotify32 # exported by name
247 240 stub SHEmptyRecycleBinA@12 # exported by name
248 241 stub SHEmptyRecycleBinW@12 # exported by name
249 242 stdcall SHFileOperation(ptr) SHFileOperation32 # exported by name
250 243 stub SHFileOperationA@4 # exported by name
251 244 stub SHFileOperationW@4 # exported by name
252 245 stub SHFormatDrive@16 # exported by name
253 246 stub SHFreeNameMappings@4 # exported by name
254 247 stub SHGetDataFromIDListA@20 # exported by name
255 248 stub SHGetDataFromIDListW@20 # exported by name
256 249 stub PathParseIconLocation@4
257 250 stub PathRemoveExtension@4
258 251 stub PathRemoveArgs@4
259 252 stdcall SHGetDesktopFolder(ptr) SHGetDesktopFolder # exported by name
260 253 stdcall SHGetFileInfo(ptr long ptr long long) SHGetFileInfo32A # exported by name
261 254 stdcall SHGetFileInfoA(ptr long ptr long long) SHGetFileInfo32A # exported by name
262 255 stub SHGetFileInfoW@20 # exported by name
263 256 stub SHGetInstanceExplorer # exported by name
264 257 stdcall SHGetMalloc(ptr) SHGetMalloc # exported by name
265 258 stub SHGetNewLinkInfo@20 # exported by name
266 259 stdcall SHGetPathFromIDList(ptr ptr) SHGetPathFromIDList # exported by name
267 260 stub SHGetPathFromIDList@8 # exported by name
268 261 stdcall SHGetPathFromIDListA (long long) SHGetPathFromIDList32A # exported by name
269 262 stdcall SHGetPathFromIDListW (long long) SHGetPathFromIDList32W # exported by name
270 263 stdcall SHGetSpecialFolderLocation(long long ptr) SHGetSpecialFolderLocation # exported by name
271 264 stdcall SHHelpShortcuts_RunDLL(long long long long) SHHelpShortcuts_RunDLL # exported by name
272 265 stub SHHelpShortcuts_RunDLLA@16 # exported by name
273 266 stub SHHelpShortcuts_RunDLLW@16 # exported by name
274 267 stdcall SHLoadInProc(long) SHLoadInProc # exported by name
275 268 stub SHQueryRecycleBinA@8 # exported by name
276 269 stub SHQueryRecycleBinW@8 # exported by name
277 270 stub SHUpdateRecycleBinIcon@0 # exported by name
279 271 stub SheChangeDirA
280 272 stub SheChangeDirExA
281 273 stub SheChangeDirExW
282 274 stub SheChangeDirW
283 275 stub SheConvertPathW
284 276 stub SheFullPathA
285 277 stub SheFullPathW
286 278 stub SheGetCurDrive
287 279 stub SheGetDirA
288 280 stub SheGetDirExW
289 281 stub SheGetDirW
290 282 stub SheGetPathOffsetW
291 283 stub SheRemoveQuotesA
292 284 stub SheRemoveQuotesW
293 285 stub SheSetCurDrive
294 286 stub SheShortenPathA
295 287 stub SheShortenPathW
296 288 stdcall ShellAboutA(long str str long) ShellAbout32A
297 289 stdcall ShellAboutW(long wstr wstr long) ShellAbout32W
298 290 stdcall ShellExecuteA(long str str str str long) ShellExecute32A
299 291 stub ShellExecuteEx
300 292 stub ShellExecuteExA
301 293 stub ShellExecuteExW
302 294 stub ShellExecuteW
303 295 stub ShellHookProc # exported by name
304 296 stdcall Shell_NotifyIcon(long ptr) Shell_NotifyIcon
305 297 stdcall Shell_NotifyIconA(long ptr) Shell_NotifyIconA
306 298 stub Shell_NotifyIconW # exported by name
307 299 stub Shl1632_ThunkData32
308 300 stub Shl3216_ThunkData32
309 301 stub StrChrA # proper ordinal unknown
310 302 stub StrChrIA # proper ordinal unknown
311 303 stub StrChrIW # proper ordinal unknown
312 304 stub StrChrW # proper ordinal unknown
313 305 stub StrCmpNA # proper ordinal unknown
314 306 stub StrCmpNIA # proper ordinal unknown
315 307 stub StrCmpNIW # proper ordinal unknown
316 308 stub StrCmpNW # proper ordinal unknown
317 309 stub StrCpyNA # proper ordinal unknown
318 310 stub StrCpyNW # proper ordinal unknown
319 311 stub StrNCmpA # proper ordinal unknown
320 312 stub StrNCmpIA # proper ordinal unknown
321 313 stub StrNCmpIW # proper ordinal unknown
322 314 stub StrNCmpW # proper ordinal unknown
323 315 stub StrNCpyA # proper ordinal unknown
324 316 stub StrNCpyW # proper ordinal unknown
325 317 stub StrRChrA # proper ordinal unknown
326 318 stub StrRChrIA # proper ordinal unknown
327 319 stub StrRChrIW # proper ordinal unknown
328 320 stub StrRChrW # proper ordinal unknown
329 321 stub StrRStrA # proper ordinal unknown
330 322 stub StrRStrIA # proper ordinal unknown
331 323 stub StrRStrIW # proper ordinal unknown
332 324 stub StrRStrW # proper ordinal unknown
333 325 stub StrStrA # proper ordinal unknown
334 326 stub StrStrIA # proper ordinal unknown
335 327 stub StrStrIW # proper ordinal unknown
336 328 stub StrStrW # proper ordinal unknown
337 329 stub WOWShellExecute # proper ordinal unknown
339 505 stub SHRegCloseKey@4
340 506 stub SHRegOpenKeyA@12
341 507 stub SHRegOpenKeyW@12
342 508 stub SHRegQueryValueA@16
343 509 stub SHRegQueryValueExA@24
344 510 stub SHRegQueryValueW@16
345 511 stub SHRegQueryValueExW@24
346 512 stub SHRegDeleteKeyW@8
348 520 stub SHAllocShared@12
349 521 stub SHLockShared@8
350 522 stub SHUnlockShared@4
351 523 stub SHFreeShared@8
352 524 stub RealDriveType@8
353 525 stub RealDriveTypeFlags@8
355 640 stub NTSHChangeNotifyRegister@24
356 641 stub NTSHChangeNotifyDeregister@4
358 643 stub SHChangeNotifyReceive@16
359 644 stub SHChangeNotification_Lock@16
360 645 stub SHChangeNotification_Unlock@4
361 646 stub SHChangeRegistrationReceive@8
362 647 stub ReceiveAddToRecentDocs
363 648 stub SHWaitOp_Operate@8
365 650 stub PathIsSameRoot
366 651 stub ReadCabinetState
367 652 stub WriteCabinetState@4
368 653 stub PathProcessCommand
370 660 stub FileIconInit
372 680 stub IsUserAdmin
374 1217 stub FOOBAR1217 # no joke! This is the real name!!