winejoystick: Fix a crash on accessing a CFArray past its end due to an off-by-one...
[wine/multimedia.git] / dlls / storage.dll16 / storage.dll16.spec
blobc38bc872a9df36b218e2e73c4244362743915d4d
1 # Compound Storage DLL.
2 # (FIXME: some methods are commented out. Commenting them in _WILL_
3 # result in dataloss. Do it at your own risk.)
5 1 pascal StgCreateDocFileA(str long long ptr) StgCreateDocFile16
6 2 stub StgCreateDocFileOnILockBytes
7 # 2 pascal StgCreateDocFileOnILockBytes(ptr long long ptr) StgCreateDocFileOnILockBytes16
8 3 pascal StgOpenStorage(str ptr long ptr long ptr) StgOpenStorage16
9 4 pascal StgOpenStorageOnILockBytes(segptr ptr long long long ptr) StgOpenStorageOnILockBytes16
10 5 pascal StgIsStorageFile(str) StgIsStorageFile16
11 6 pascal StgIsStorageILockBytes(segptr) StgIsStorageILockBytes16
12 7 stub StgSetTimes
13 #8 WEP
14 #9 ___EXPORTEDSTUB
15 103 stub DllGetClassObject
17 # Storage Interface functions. Starting at 500
18 # these are not exported in the real storage.dll, we use them
19 # as 16->32 relays. They use the cdecl calling convention.
21 # IStorage
22 500 cdecl IStorage16_QueryInterface(ptr ptr ptr) IStorage16_fnQueryInterface
23 501 cdecl IStorage16_AddRef(ptr) IStorage16_fnAddRef
24 502 cdecl IStorage16_Release(ptr) IStorage16_fnRelease
25 503 cdecl IStorage16_CreateStream(ptr str long long long ptr) IStorage16_fnCreateStream
27 504 cdecl IStorage16_OpenStream(ptr str ptr long long ptr) IStorage16_fnOpenStream
28 505 cdecl IStorage16_CreateStorage(ptr str long long long ptr) IStorage16_fnCreateStorage
29 506 cdecl IStorage16_OpenStorage(ptr str ptr long ptr long ptr) IStorage16_fnOpenStorage
30 507 cdecl IStorage16_CopyTo(ptr long ptr ptr ptr) IStorage16_fnCopyTo
31 508 stub IStorage16_MoveElementTo
32 509 cdecl IStorage16_Commit(ptr long) IStorage16_fnCommit
33 510 stub IStorage16_Revert
34 511 stub IStorage16_EnumElements
35 512 stub IStorage16_DestroyElement
36 513 stub IStorage16_RenameElement
37 514 stub IStorage16_SetElementTimes
38 515 stub IStorage16_SetClass
39 516 stub IStorage16_SetStateBits
40 517 cdecl IStorage16_Stat(ptr ptr long) IStorage16_fnStat
42 # IStream
43 518 cdecl IStream16_QueryInterface(ptr ptr ptr) IStream16_fnQueryInterface
44 519 cdecl IStream16_AddRef(ptr) IStream16_fnAddRef
45 520 cdecl IStream16_Release(ptr) IStream16_fnRelease
46 521 cdecl IStream16_Read(ptr ptr long ptr) IStream16_fnRead
47 522 cdecl IStream16_Write(ptr ptr long ptr) IStream16_fnWrite
48 523 cdecl IStream16_Seek(ptr int64 long ptr) IStream16_fnSeek
49 524 stub IStream16_SetSize
50 525 stub IStream16_CopyTo
51 526 stub IStream16_Commit
52 527 stub IStream16_Revert
53 528 stub IStream16_LockRegion
54 529 stub IStream16_UnlockRegion
55 530 stub IStream16_Stat
56 531 stub IStream16_Clone