winejoystick: Fix a crash on accessing a CFArray past its end due to an off-by-one...
[wine/multimedia.git] / dlls / api-ms-win-core-shlwapi-legacy-l1-1-0 / api-ms-win-core-shlwapi-legacy-l1-1-0.spec
blob1a568383c6cabf113a6705f0fa5205d67545abc7
1 @ stdcall IsCharBlankW(long) shlwapi.IsCharBlankW
2 @ stdcall IsCharCntrlW(ptr) shlwapi.IsCharCntrlW
3 @ stdcall IsCharDigitW(long) shlwapi.IsCharDigitW
4 @ stdcall IsCharPunctW(long) shlwapi.IsCharPunctW
5 @ stdcall IsCharSpaceA(long) shlwapi.IsCharSpaceA
6 @ stdcall IsCharSpaceW(long) shlwapi.IsCharSpaceW
7 @ stdcall IsCharXDigitW(long) shlwapi.IsCharXDigitW
8 @ stdcall PathAddBackslashA(str) shlwapi.PathAddBackslashA
9 @ stdcall PathAddBackslashW(wstr) shlwapi.PathAddBackslashW
10 @ stdcall PathAddExtensionA(str str) shlwapi.PathAddExtensionA
11 @ stdcall PathAddExtensionW(wstr wstr) shlwapi.PathAddExtensionW
12 @ stdcall PathAppendA(str str) shlwapi.PathAppendA
13 @ stdcall PathAppendW(wstr wstr) shlwapi.PathAppendW
14 @ stdcall PathCanonicalizeA(ptr str) shlwapi.PathCanonicalizeA
15 @ stdcall PathCanonicalizeW(ptr wstr) shlwapi.PathCanonicalizeW
16 @ stdcall PathCombineA(ptr str str) shlwapi.PathCombineA
17 @ stdcall PathCombineW(ptr wstr wstr) shlwapi.PathCombineW
18 @ stdcall PathCommonPrefixA(str str ptr) shlwapi.PathCommonPrefixA
19 @ stdcall PathCommonPrefixW(wstr wstr ptr) shlwapi.PathCommonPrefixW
20 @ stdcall PathFileExistsA(str) shlwapi.PathFileExistsA
21 @ stdcall PathFileExistsW(wstr) shlwapi.PathFileExistsW
22 @ stdcall PathFindExtensionA(str) shlwapi.PathFindExtensionA
23 @ stdcall PathFindExtensionW(wstr) shlwapi.PathFindExtensionW
24 @ stdcall PathFindFileNameA(str) shlwapi.PathFindFileNameA
25 @ stdcall PathFindFileNameW(wstr) shlwapi.PathFindFileNameW
26 @ stdcall PathFindNextComponentA(str) shlwapi.PathFindNextComponentA
27 @ stdcall PathFindNextComponentW(wstr) shlwapi.PathFindNextComponentW
28 @ stdcall PathGetArgsA(str) shlwapi.PathGetArgsA
29 @ stdcall PathGetArgsW(wstr) shlwapi.PathGetArgsW
30 @ stdcall PathGetCharTypeA(long) shlwapi.PathGetCharTypeA
31 @ stdcall PathGetCharTypeW(long) shlwapi.PathGetCharTypeW
32 @ stdcall PathGetDriveNumberA(str) shlwapi.PathGetDriveNumberA
33 @ stdcall PathGetDriveNumberW(wstr) shlwapi.PathGetDriveNumberW
34 @ stdcall PathIsFileSpecA(str) shlwapi.PathIsFileSpecA
35 @ stdcall PathIsFileSpecW(wstr) shlwapi.PathIsFileSpecW
36 @ stdcall PathIsLFNFileSpecA(str) shlwapi.PathIsLFNFileSpecA
37 @ stdcall PathIsLFNFileSpecW(wstr) shlwapi.PathIsLFNFileSpecW
38 @ stdcall PathIsPrefixA(str str) shlwapi.PathIsPrefixA
39 @ stdcall PathIsPrefixW(wstr wstr) shlwapi.PathIsPrefixW
40 @ stdcall PathIsRelativeA(str) shlwapi.PathIsRelativeA
41 @ stdcall PathIsRelativeW(wstr) shlwapi.PathIsRelativeW
42 @ stdcall PathIsRootA(str) shlwapi.PathIsRootA
43 @ stdcall PathIsRootW(wstr) shlwapi.PathIsRootW
44 @ stdcall PathIsSameRootA(str str) shlwapi.PathIsSameRootA
45 @ stdcall PathIsSameRootW(wstr wstr) shlwapi.PathIsSameRootW
46 @ stdcall PathIsUNCA(str) shlwapi.PathIsUNCA
47 @ stdcall PathIsUNCServerA(str) shlwapi.PathIsUNCServerA
48 @ stdcall PathIsUNCServerShareA(str) shlwapi.PathIsUNCServerShareA
49 @ stdcall PathIsUNCServerShareW(wstr) shlwapi.PathIsUNCServerShareW
50 @ stdcall PathIsUNCServerW(wstr) shlwapi.PathIsUNCServerW
51 @ stdcall PathIsUNCW(wstr) shlwapi.PathIsUNCW
52 @ stdcall PathIsValidCharA(long long) shlwapi.PathIsValidCharA
53 @ stdcall PathIsValidCharW(long long) shlwapi.PathIsValidCharW
54 @ stdcall PathMatchSpecA(str str) shlwapi.PathMatchSpecA
55 @ stub PathMatchSpecExA
56 @ stub PathMatchSpecExW
57 @ stdcall PathMatchSpecW(wstr wstr) shlwapi.PathMatchSpecW
58 @ stdcall PathParseIconLocationA(str) shlwapi.PathParseIconLocationA
59 @ stdcall PathParseIconLocationW(wstr) shlwapi.PathParseIconLocationW
60 @ stdcall PathQuoteSpacesA(str) shlwapi.PathQuoteSpacesA
61 @ stdcall PathQuoteSpacesW(wstr) shlwapi.PathQuoteSpacesW
62 @ stdcall PathRelativePathToA(ptr str long str long) shlwapi.PathRelativePathToA
63 @ stdcall PathRelativePathToW(ptr wstr long wstr long) shlwapi.PathRelativePathToW
64 @ stdcall PathRemoveBackslashA(str) shlwapi.PathRemoveBackslashA
65 @ stdcall PathRemoveBackslashW(wstr) shlwapi.PathRemoveBackslashW
66 @ stdcall PathRemoveBlanksA(str) shlwapi.PathRemoveBlanksA
67 @ stdcall PathRemoveBlanksW(wstr) shlwapi.PathRemoveBlanksW
68 @ stdcall PathRemoveExtensionA(str) shlwapi.PathRemoveExtensionA
69 @ stdcall PathRemoveExtensionW(wstr) shlwapi.PathRemoveExtensionW
70 @ stdcall PathRemoveFileSpecA(str) shlwapi.PathRemoveFileSpecA
71 @ stdcall PathRemoveFileSpecW(wstr) shlwapi.PathRemoveFileSpecW
72 @ stdcall PathRenameExtensionA(str str) shlwapi.PathRenameExtensionA
73 @ stdcall PathRenameExtensionW(wstr wstr) shlwapi.PathRenameExtensionW
74 @ stdcall PathSearchAndQualifyA(str ptr long) shlwapi.PathSearchAndQualifyA
75 @ stdcall PathSearchAndQualifyW(wstr ptr long) shlwapi.PathSearchAndQualifyW
76 @ stdcall PathSkipRootA(str) shlwapi.PathSkipRootA
77 @ stdcall PathSkipRootW(wstr) shlwapi.PathSkipRootW
78 @ stdcall PathStripPathA(str) shlwapi.PathStripPathA
79 @ stdcall PathStripPathW(wstr) shlwapi.PathStripPathW
80 @ stdcall PathStripToRootA(str) shlwapi.PathStripToRootA
81 @ stdcall PathStripToRootW(wstr) shlwapi.PathStripToRootW
82 @ stdcall PathUnExpandEnvStringsA(str ptr long) shlwapi.PathUnExpandEnvStringsA
83 @ stdcall PathUnExpandEnvStringsW(wstr ptr long) shlwapi.PathUnExpandEnvStringsW
84 @ stdcall PathUnquoteSpacesA(str) shlwapi.PathUnquoteSpacesA
85 @ stdcall PathUnquoteSpacesW(wstr) shlwapi.PathUnquoteSpacesW
86 @ stdcall SHExpandEnvironmentStringsA(str ptr long) shlwapi.SHExpandEnvironmentStringsA
87 @ stdcall SHExpandEnvironmentStringsW(wstr ptr long) shlwapi.SHExpandEnvironmentStringsW
88 @ stdcall SHTruncateString(str long) shlwapi.SHTruncateString