Release 940518
[wine/multimedia.git] / if1632 / kernel.spec
blob2f00be8faf1f5ec03b19328bccf89eb2270d904b
1 # $Id: kernel.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
3 name kernel
4 id 1
5 length 415
7 #1 FATALEXIT
8 #2 EXITKERNEL
9 3 pascal GetVersion() GetVersion()
10 4 pascal LocalInit(word word word) WIN16_LocalInit(1 2 3)
11 5 pascal LocalAlloc(word word) WIN16_LocalAlloc(1 2)
12 6 pascal LocalReAlloc(word word word) WIN16_LocalReAlloc(1 2 3)
13 7 pascal LocalFree(word) WIN16_LocalFree(1)
14 8 pascal LocalLock(word) WIN16_LocalLock(1)
15 9 pascal LocalUnlock(word) WIN16_LocalUnlock(1)
16 10 pascal LocalSize(word) WIN16_LocalSize(1)
17 11 pascal LocalHandle(word) ReturnArg(1)
18 12 pascal LocalFlags(word) WIN16_LocalFlags(1)
19 13 pascal LocalCompact(word) WIN16_LocalCompact(1)
20 14 return LocalNotify 4 0
21 15 pascal GlobalAlloc(word long) GlobalAlloc(1 2)
22 16 pascal GlobalReAlloc(word long word) GlobalReAlloc(1 2 3)
23 17 pascal GlobalFree(word) GlobalFree(1)
24 18 pascal GlobalLock(word) GlobalLock(1)
25 19 pascal GlobalUnlock(word) GlobalUnlock(1)
26 20 pascal GlobalSize(word) GlobalSize(1)
27 21 pascal GlobalHandle(word) GlobalHandle(1)
28 22 pascal GlobalFlags(word) GlobalFlags(1)
29 23 pascal LockSegment(s_word) KERNEL_LockSegment(1)
30 24 pascal UnlockSegment(s_word) KERNEL_UnlockSegment(1)
31 25 pascal GlobalCompact(long) GlobalCompact(1)
32 #26 GLOBALFREEALL
33 #28 GLOBALMASTERHANDLE
34 29 return Yield 0 0
35 30 pascal WaitEvent(word) KERNEL_WaitEvent(1)
36 #31 POSTEVENT
37 #32 SETPRIORITY
38 #33 LOCKCURRENTTASK
39 34 pascal SetTaskQueue(word word) SetTaskQueue(1 2)
40 35 pascal GetTaskQueue(word) GetTaskQueue(1)
41 36 pascal GetCurrentTask() GetCurrentTask()
42 #37 GETCURRENTPDB
43 #38 SETTASKSIGNALPROC
44 #41 ENABLEDOS
45 #42 DISABLEDOS
46 45 pascal LoadModule(ptr ptr) LoadModule(1 2)
47 #46 FREEMODULE
48 47 pascal GetModuleHandle(ptr) GetModuleHandle(1)
49 48 pascal GetModuleUsage(word) GetModuleUsage(1)
50 49 pascal GetModuleFileName(word ptr s_word) GetModuleFileName(1 2 3)
51 50 pascal GetProcAddress(word ptr) GetProcAddress(1 2)
52 51 pascal MakeProcInstance(ptr word) CALLBACK_MakeProcInstance(1 2)
53 52 pascal FreeProcInstance(ptr) FreeProcInstance(1)
54 #53 CALLPROCINSTANCE
55 #54 GETINSTANCEDATA
56 55 pascal Catch(ptr) Catch (1)
57 56 pascal Throw(ptr word) Throw(1 2)
58 57 pascal GetProfileInt(ptr ptr word) GetProfileInt(1 2 3)
59 58 pascal GetProfileString(ptr ptr ptr ptr word) GetProfileString(1 2 3 4 5)
60 59 pascal WriteProfileString(ptr ptr ptr) WriteProfileString(1 2 3)
61 60 pascal FindResource(word ptr ptr) FindResource(1 2 3)
62 61 pascal LoadResource(word word) LoadResource(1 2)
63 62 pascal LockResource(word) LockResource(1)
64 63 pascal FreeResource(word) FreeResource(1)
65 64 pascal AccessResource(word word) AccessResource(1 2)
66 #65 SIZEOFRESOURCE
67 #66 ALLOCRESOURCE
68 #67 SETRESOURCEHANDLER
69 68 pascal InitAtomTable(word) InitAtomTable(1)
70 69 pascal FindAtom(ptr) FindAtom(1)
71 70 pascal AddAtom(ptr) AddAtom(1)
72 71 pascal DeleteAtom(word) DeleteAtom(1)
73 72 pascal GetAtomName(word ptr word) GetAtomName(1 2 3)
74 73 pascal GetAtomHandle(word) GetAtomHandle(1)
75 74 pascal OpenFile(ptr ptr word) OpenFile(1 2 3)
76 #75 OPENPATHNAME
77 #76 DELETEPATHNAME
78 #77 RESERVED1
79 #78 RESERVED2
80 #79 RESERVED3
81 #80 RESERVED4
82 81 pascal _lclose(word) _lclose(1)
83 82 pascal _lread(word ptr word) _lread(1 2 3)
84 83 pascal _lcreat(ptr word) _lcreat(1 2)
85 84 pascal _llseek(word long word) _llseek(1 2 3)
86 85 pascal _lopen(ptr word) _lopen(1 2)
87 86 pascal _lwrite(word ptr word) _lwrite(1 2 3)
88 #87 RESERVED5
89 88 pascal lstrcpy(ptr ptr) lstrcpy(1 2)
90 89 pascal lstrcat(ptr ptr) lstrcat(1 2)
91 90 pascal lstrlen(ptr) lstrlen(1)
92 91 register InitTask(word word word word word
93 word word word word word)
94 KERNEL_InitTask()
95 92 pascal GetTempDrive(byte) GetTempDrive(1)
96 #93 GETCODEHANDLE
97 #94 DEFINEHANDLETABLE
98 95 pascal LoadLibrary(ptr) LoadLibrary(1)
99 96 pascal FreeLibrary(word) FreeLibrary(1)
100 97 pascal GetTempFileName(byte ptr word ptr) GetTempFileName(1 2 3 4)
101 #98 GETLASTDISKCHANGE
102 #99 GETLPERRMODE
103 #100 VALIDATECODESEGMENTS
104 #101 NOHOOKDOSCALL
105 102 register DOS3Call(word word word word word
106 word word word word word)
107 DOS3Call()
108 #103 NETBIOSCALL
109 #104 GETCODEINFO
110 #105 GETEXEVERSION
111 #106 SETSWAPAREASIZE
112 107 pascal SetErrorMode(word) SetErrorMode(1)
113 #108 SWITCHSTACKTO
114 #109 SWITCHSTACKBACK
115 #110 PATCHCODEHANDLE
116 111 pascal GlobalWire(word) GlobalLock(1)
117 112 pascal GlobalUnWire(word) GlobalUnlock(1)
118 #113 __AHSHIFT
119 #114 __AHINCR
120 115 pascal OutputDebugString(ptr) OutputDebugString(1)
121 #116 INITLIB
122 117 return OldYield 0 0
123 #118 GETTASKQUEUEDS
124 #119 GETTASKQUEUEES
125 #120 UNDEFDYNLINK
126 121 return LocalShrink 4 0
127 #122 ISTASKLOCKED
128 #123 KBDRST
129 #124 ENABLEKERNEL
130 #125 DISABLEKERNEL
131 #126 MEMORYFREED
132 127 pascal GetPrivateProfileInt(ptr ptr s_word ptr)
133 GetPrivateProfileInt(1 2 3 4)
134 128 pascal GetPrivateProfileString(ptr ptr ptr ptr s_word ptr)
135 GetPrivateProfileString(1 2 3 4 5 6)
136 129 pascal WritePrivateProfileString(ptr ptr ptr ptr)
137 WritePrivateProfileString(1 2 3 4)
138 #130 FILECBR
139 131 pascal GetDOSEnvironment() GetDOSEnvironment()
140 132 pascal GetWinFlags() GetWinFlags()
141 #133 GETEXEPTR
142 134 pascal GetWindowsDirectory(ptr word) GetWindowsDirectory(1 2)
143 135 pascal GetSystemDirectory(ptr word) GetSystemDirectory(1 2)
144 136 pascal GetDriveType(byte) GetDriveType(1)
145 137 pascal FatalAppExit(word ptr) FatalAppExit(1 2)
146 #138 GETHEAPSPACES
147 #139 DOSIGNAL
148 #140 SETSIGHANDLER
149 #141 INITTASK1
150 150 return DirectedYield 2 0
151 #151 WINOLDAPCALL
152 152 pascal GetNumTasks() GetNumTasks()
153 154 return GlobalNotify 4 0
154 #155 GETTASKDS
155 #156 LIMITEMSPAGES
156 #157 GETCURPID
157 #158 ISWINOLDAPTASK
158 #159 GLOBALHANDLENORIP
159 #160 EMSCOPY
160 #161 LOCALCOUNTFREE
161 #162 LOCALHEAPSIZE
162 163 pascal GlobalLRUOldest(word) ReturnArg(1)
163 164 pascal GlobalLRUNewest(word) ReturnArg(1)
164 #165 A20PROC
165 166 pascal WinExec(ptr word) WinExec(1 2)
166 #167 GETEXPWINVER
167 #168 DIRECTRESALLOC
168 169 pascal GetFreeSpace(word) GetFreeSpace(1)
169 170 pascal AllocCStoDSAlias(word) AllocDStoCSAlias(1)
170 171 pascal AllocDStoCSAlias(word) AllocDStoCSAlias(1)
171 #172 ALLOCALIAS
172 #173 __ROMBIOS
173 #174 __A000H
174 175 pascal AllocSelector(word) AllocSelector(1)
175 176 pascal FreeSelector(word) FreeSelector(1)
176 177 pascal PrestoChangoSelector(word word) PrestoChangoSelector(1 2)
177 178 equate __WINFLAGS 0x413
178 #179 __D000H
179 #180 LONGPTRADD
180 #181 __B000H
181 #182 __B800H
182 #183 __0000H
183 184 return GlobalDOSAlloc 4 0
184 185 return GlobalDOSFree 2 0
185 #186 GETSELECTORBASE
186 #187 SETSELECTORBASE
187 #188 GETSELECTORLIMIT
188 #189 SETSELECTORLIMIT
189 #190 __E000H
190 191 pascal GlobalPageLock(word) GlobalLock(1)
191 192 pascal GlobalPageUnlock(word) GlobalUnlock(1)
192 #193 __0040H
193 #194 __F000H
194 #195 __C000H
195 #196 SELECTORACCESSRIGHTS
196 197 pascal GlobalFix(word) GlobalLock(1)
197 198 pascal GlobalUnfix(word) GlobalUnlock(1)
198 199 pascal SetHandleCount(word) SetHandleCount(1)
199 #200 VALIDATEFREESPACES
200 #201 REPLACEINST
201 #202 REGISTERPTRACE
202 #203 DEBUGBREAK
203 #204 SWAPRECORDING
204 #205 CVWBREAK
205 #206 ALLOCSELECTORARRAY
206 #207 ISDBCSLEADBYTE
207 #310 LOCALHANDLEDELTA
208 #311 GETSETKERNELDOSPROC
209 #314 DEBUGDEFINESEGMENT
210 315 pascal WriteOutProfiles() sync_profiles()
211 #316 GETFREEMEMINFO
212 #318 FATALEXITHOOK
213 #319 FLUSHCACHEDFILEHANDLE
214 #320 ISTASK
215 #323 ISROMMODULE
216 #324 LOGERROR
217 #325 LOGPARAMERROR
218 #326 ISROMFILE
219 #327 K327
220 #328 _DEBUGOUTPUT
221 #329 K329
222 #332 THHOOK
223 #334 ISBADREADPTR
224 #335 ISBADWRITEPTR
225 #336 ISBADCODEPTR
226 #337 ISBADSTRINGPTR
227 #338 HASGPHANDLER
228 #339 DIAGQUERY
229 #340 DIAGOUTPUT
230 #341 TOOLHELPHOOK
231 #342 __GP
232 #343 REGISTERWINOLDAPHOOK
233 #344 GETWINOLDAPHOOKS
234 #345 ISSHAREDSELECTOR
235 #346 ISBADHUGEREADPTR
236 #347 ISBADHUGEWRITEPTR
237 348 pascal hmemcpy(ptr ptr long) hmemcpy(1 2 3)
238 349 pascal _hread(word ptr long) _hread(1 2 3)
239 350 pascal _hwrite(word ptr long) _hwrite(1 2 3)
240 #351 BUNNY_351
241 353 pascal lstrcpyn(ptr ptr word) lstrcpyn(1 2 3)
242 #354 GETAPPCOMPATFLAGS
243 #355 GETWINDEBUGINFO
244 #356 SETWINDEBUGINFO
245 #403 K403
246 #404 K404