Release 941227
[wine/multimedia.git] / if1632 / sound.spec
blob9ce9349172d197c44a04322d9403389813564b09
1 # $Id: sound.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
3 name sound
4 id 7
5 length 20
7 1 pascal OPENSOUND() OpenSound()
8 2 pascal CLOSESOUND() CloseSound()
9 3 pascal SETVOICEQUEUESIZE(word word) SetVoiceQueueSize(1 2)
10 4 pascal SETVOICENOTE(word word word word) SetVoiceNote(1 2 3 4)
11 5 pascal SETVOICEACCENT(word word word word word)
12 SetVoiceAccent(1 2 3 4 5)
13 6 pascal SETVOICEENVELOPE(word word word) SetVoiceEnvelope(1 2 3)
14 7 pascal SETSOUNDNOISE(word word) SetSoundNoise(1 2)
15 8 pascal SETVOICESOUND(word long word) SetVoiceSound(1 2 3)
16 9 pascal STARTSOUND() StartSound()
17 10 pascal STOPSOUND() StopSound()
18 11 pascal WAITSOUNDSTATE(word) WaitSoundState(1)
19 12 pascal SYNCALLVOICES() SyncAllVoices()
20 13 pascal COUNTVOICENOTES(word) CountVoiceNotes(1)
21 14 pascal GETTHRESHOLDEVENT() GetThresholdEvent()
22 15 pascal GETTHRESHOLDSTATUS() GetThresholdStatus()
23 16 pascal SETVOICETHRESHOLD(word word) SetVoiceThreshold(1 2)
24 17 pascal DOBEEP() DoBeep()