Release 980104
[wine/multimedia.git] / relay32 / ntdll.spec
blob531ef80883fb3647f4ae7d7c8b75d0cf39ba4888
1 name ntdll
2 type win32
4 001 stub CsrAllocateCaptureBuffer
5 002 stub CsrAllocateCapturePointer
6 003 stub CsrAllocateMessagePointer
7 004 stub CsrCaptureMessageBuffer
8 005 stub CsrCaptureMessageString
9 006 stub CsrCaptureTimeout
10 007 stub CsrClientCallServer
11 008 stub CsrClientConnectToServer
12 009 stub CsrClientMaxMessage
13 010 stub CsrClientSendMessage
14 011 stub CsrClientThreadConnect
15 012 stub CsrFreeCaptureBuffer
16 013 stub CsrIdentifyAlertableThread
17 014 stub CsrNewThread
18 015 stub CsrProbeForRead
19 016 stub CsrProbeForWrite
20 017 stub CsrSetPriorityClass
21 018 stub CsrpProcessCallbackRequest
22 019 stub DbgBreakPoint
23 020 stub DbgPrint
24 021 stub DbgPrompt
25 022 stub DbgSsHandleKmApiMsg
26 023 stub DbgSsInitialize
27 024 stub DbgUiConnectToDbg
28 025 stub DbgUiContinue
29 026 stub DbgUiWaitStateChange
30 027 stub DbgUserBreakPoint
31 028 stub KiUserApcDispatcher
32 029 stub KiUserCallbackDispatcher
33 030 stub KiUserExceptionDispatcher
34 031 stub LdrAccessResource
35 032 stub LdrDisableThreadCalloutsForDll
36 033 stub LdrEnumResources
37 034 stub LdrFindEntryForAddress
38 035 stub LdrFindResourceDirectory_U
39 036 stub LdrFindResource_U
40 037 stub LdrGetDllHandle
41 038 stub LdrGetProcedureAddress
42 039 stub LdrInitializeThunk
43 040 stub LdrLoadDll
44 041 stub LdrProcessRelocationBlock
45 042 stub LdrQueryImageFileExecutionOptions
46 043 stub LdrQueryProcessModuleInformation
47 044 stub LdrShutdownProcess
48 045 stub LdrShutdownThread
49 046 stub LdrUnloadDll
50 047 stub LdrVerifyImageMatchesChecksum
51 048 stub NPXEMULATORTABLE
52 049 stub NlsMbCodePageTag
53 050 stub NlsMbOemCodePageTag
54 051 stub NtAcceptConnectPort
55 052 stub NtAccessCheck
56 053 stub NtAccessCheckAndAuditAlarm
57 054 stub NtAdjustGroupsToken
58 055 stub NtAdjustPrivilegesToken
59 056 stub NtAlertResumeThread
60 057 stub NtAlertThread
61 058 stub NtAllocateLocallyUniqueId
62 059 stub NtAllocateUuids
63 060 stub NtAllocateVirtualMemory
64 061 stub NtCallbackReturn
65 062 stub NtCancelIoFile
66 063 stub NtCancelTimer
67 064 stub NtClearEvent
68 065 stub NtClose
69 066 stub NtCloseObjectAuditAlarm
70 067 stub NtCompleteConnectPort
71 068 stub NtConnectPort
72 069 stub NtContinue
73 070 stub NtCreateDirectoryObject
74 071 stub NtCreateEvent
75 072 stub NtCreateEventPair
76 073 stub NtCreateFile
77 074 stub NtCreateIoCompletion
78 075 stub NtCreateKey
79 076 stub NtCreateMailslotFile
80 077 stub NtCreateMutant
81 078 stub NtCreateNamedPipeFile
82 079 stub NtCreatePagingFile
83 080 stub NtCreatePort
84 081 stub NtCreateProcess
85 082 stub NtCreateProfile
86 083 stub NtCreateSection
87 084 stub NtCreateSemaphore
88 085 stub NtCreateSymbolicLinkObject
89 086 stub NtCreateThread
90 087 stub NtCreateTimer
91 088 stub NtCreateToken
92 089 stdcall NtCurrentTeb() NtCurrentTeb
93 090 stub NtDelayExecution
94 091 stub NtDeleteFile
95 092 stub NtDeleteKey
96 093 stub NtDeleteValueKey
97 094 stub NtDeviceIoControlFile
98 095 stub NtDisplayString
99 096 stub NtDuplicateObject
100 097 stub NtDuplicateToken
101 098 stub NtEnumerateBus
102 099 stub NtEnumerateKey
103 100 stub NtEnumerateValueKey
104 101 stub NtExtendSection
105 102 stub NtFlushBuffersFile
106 103 stub NtFlushInstructionCache
107 104 stub NtFlushKey
108 105 stub NtFlushVirtualMemory
109 106 stub NtFlushWriteBuffer
110 107 stub NtFreeVirtualMemory
111 108 stub NtFsControlFile
112 109 stub NtGetContextThread
113 110 stub NtGetPlugPlayEvent
114 111 stub NtGetTickCount
115 112 stub NtImpersonateClientOfPort
116 113 stub NtImpersonateThread
117 114 stub NtInitializeRegistry
118 115 stub NtListenPort
119 116 stub NtLoadDriver
120 117 stub NtLoadKey
121 118 stub NtLockFile
122 119 stub NtLockVirtualMemory
123 120 stub NtMakeTemporaryObject
124 121 stub NtMapViewOfSection
125 122 stub NtNotifyChangeDirectoryFile
126 123 stub NtNotifyChangeKey
127 124 stub NtOpenDirectoryObject
128 125 stub NtOpenEvent
129 126 stub NtOpenEventPair
130 127 stdcall NtOpenFile(ptr long ptr ptr long long) NtOpenFile
131 128 stub NtOpenIoCompletion
132 129 stub NtOpenKey
133 130 stub NtOpenMutant
134 131 stub NtOpenObjectAuditAlarm
135 132 stub NtOpenProcess
136 133 stub NtOpenProcessToken
137 134 stub NtOpenSection
138 135 stub NtOpenSemaphore
139 136 stub NtOpenSymbolicLinkObject
140 137 stub NtOpenThread
141 138 stub NtOpenThreadToken
142 139 stub NtOpenTimer
143 140 stub NtPlugPlayControl
144 141 stub NtPrivilegeCheck
145 142 stub NtPrivilegeObjectAuditAlarm
146 143 stub NtPrivilegedServiceAuditAlarm
147 144 stub NtProtectVirtualMemory
148 145 stub NtPulseEvent
149 146 stub NtQueryAttributesFile
150 147 stub NtQueryDefaultLocale
151 148 stub NtQueryDirectoryFile
152 149 stub NtQueryDirectoryObject
153 150 stub NtQueryEaFile
154 151 stub NtQueryEvent
155 152 stub NtQueryInformationFile
156 153 stub NtQueryInformationPort
157 154 stub NtQueryInformationProcess
158 155 stub NtQueryInformationThread
159 156 stub NtQueryInformationToken
160 157 stub NtQueryIntervalProfile
161 158 stub NtQueryIoCompletion
162 159 stub NtQueryKey
163 160 stub NtQueryMutant
164 161 stub NtQueryObject
165 162 stub NtQueryPerformanceCounter
166 163 stub NtQuerySection
167 164 stub NtQuerySecurityObject
168 165 stub NtQuerySemaphore
169 166 stub NtQuerySymbolicLinkObject
170 167 stub NtQuerySystemEnvironmentValue
171 168 stub NtQuerySystemInformation
172 169 stub NtQuerySystemTime
173 170 stub NtQueryTimer
174 171 stub NtQueryTimerResolution
175 172 stub NtQueryValueKey
176 173 stub NtQueryVirtualMemory
177 174 stub NtQueryVolumeInformationFile
178 175 stub NtRaiseException
179 176 stub NtRaiseHardError
180 177 stub NtReadFile
181 178 stub NtReadRequestData
182 179 stub NtReadVirtualMemory
183 180 stub NtRegisterNewDevice
184 181 stub NtRegisterThreadTerminatePort
185 182 stub NtReleaseMutant
186 183 stub NtReleaseProcessMutant
187 184 stub NtReleaseSemaphore
188 185 stub NtRemoveIoCompletion
189 186 stub NtReplaceKey
190 187 stub NtReplyPort
191 188 stub NtReplyWaitReceivePort
192 189 stub NtReplyWaitReplyPort
193 190 stub NtRequestPort
194 191 stub NtRequestWaitReplyPort
195 192 stub NtResetEvent
196 193 stub NtRestoreKey
197 194 stub NtResumeThread
198 195 stub NtSaveKey
199 196 stub NtSetContextThread
200 197 stub NtSetDefaultHardErrorPort
201 198 stub NtSetDefaultLocale
202 199 stub NtSetEaFile
203 200 stub NtSetEvent
204 201 stub NtSetHighEventPair
205 202 stub NtSetHighWaitLowEventPair
206 203 stub NtSetHighWaitLowThread
207 204 stub NtSetInformationFile
208 205 stub NtSetInformationKey
209 206 stub NtSetInformationObject
210 207 stub NtSetInformationProcess
211 208 stub NtSetInformationThread
212 209 stub NtSetInformationToken
213 210 stub NtSetIntervalProfile
214 211 stub NtSetIoCompletion
215 212 stub NtSetLdtEntries
216 213 stub NtSetLowEventPair
217 214 stub NtSetLowWaitHighEventPair
218 215 stub NtSetLowWaitHighThread
219 216 stub NtSetSecurityObject
220 217 stub NtSetSystemEnvironmentValue
221 218 stub NtSetSystemInformation
222 219 stub NtSetSystemPowerState
223 220 stub NtSetSystemTime
224 221 stub NtSetTimer
225 222 stub NtSetTimerResolution
226 223 stub NtSetValueKey
227 224 stub NtSetVolumeInformationFile
228 225 stub NtShutdownSystem
229 226 stub NtStartProfile
230 227 stub NtStopProfile
231 228 stub NtSuspendThread
232 229 stub NtSystemDebugControl
233 230 stub NtTerminateProcess
234 231 stub NtTerminateThread
235 232 stub NtTestAlert
236 233 stub NtUnloadDriver
237 234 stub NtUnloadKey
238 235 stub NtUnlockFile
239 236 stub NtUnlockVirtualMemory
240 237 stub NtUnmapViewOfSection
241 238 stub NtVdmControl
242 239 stub NtW32Call
243 240 stub NtWaitForMultipleObjects
244 241 stub NtWaitForProcessMutant
245 242 stub NtWaitForSingleObject
246 243 stub NtWaitHighEventPair
247 244 stub NtWaitLowEventPair
248 245 stub NtWriteFile
249 246 stub NtWriteRequestData
250 247 stub NtWriteVirtualMemory
251 248 stub PfxFindPrefix
252 249 stub PfxInitialize
253 250 stub PfxInsertPrefix
254 251 stub PfxRemovePrefix
255 252 stub RestoreEm87Context
256 253 stub RtlAbortRXact
257 254 stub RtlAbsoluteToSelfRelativeSD
258 255 stub RtlAcquirePebLock
259 256 stub RtlAcquireResourceExclusive
260 257 stub RtlAcquireResourceShared
261 258 stub RtlAddAccessAllowedAce
262 259 stub RtlAddAccessDeniedAce
263 260 stdcall RtlAddAce(ptr long long ptr long) RtlAddAce
264 261 stub RtlAddActionToRXact
265 262 stub RtlAddAttributeActionToRXact
266 263 stub RtlAddAuditAccessAce
267 264 stub RtlAdjustPrivilege
268 265 stub RtlAllocateAndInitializeSid
269 266 stdcall RtlAllocateHeap(long long long) HeapAlloc
270 267 stub RtlAnsiCharToUnicodeChar
271 268 stub RtlAnsiStringToUnicodeSize
272 269 stdcall RtlAnsiStringToUnicodeString(ptr ptr long) RtlAnsiStringToUnicodeString
273 270 stub RtlAppendAsciizToString
274 271 stub RtlAppendStringToString
275 272 stub RtlAppendUnicodeStringToString
276 273 stub RtlAppendUnicodeToString
277 274 stub RtlApplyRXact
278 275 stub RtlApplyRXactNoFlush
279 276 stub RtlAreAllAccessesGranted
280 277 stub RtlAreAnyAccessesGranted
281 278 stub RtlAreBitsClear
282 279 stub RtlAreBitsSet
283 280 stub RtlAssert
284 281 stub RtlCaptureStackBackTrace
285 282 stub RtlCharToInteger
286 283 stub RtlCheckRegistryKey
287 284 stub RtlClearAllBits
288 285 stub RtlClearBits
289 286 stub RtlCompactHeap
290 287 stub RtlCompareMemory
291 288 stub RtlCompareMemoryUlong
292 289 stub RtlCompareString
293 290 stub RtlCompareUnicodeString
294 291 stub RtlCompressBuffer
295 292 stub RtlConsoleMultiByteToUnicodeN
296 293 stub RtlConvertExclusiveToShared
297 294 stub RtlConvertLongToLargeInteger
298 295 stub RtlConvertSharedToExclusive
299 296 stub RtlConvertSidToUnicodeString
300 297 stub RtlConvertUiListToApiList
301 298 stub RtlConvertUlongToLargeInteger
302 299 stub RtlCopyLuid
303 300 stub RtlCopyLuidAndAttributesArray
304 301 stub RtlCopySecurityDescriptor
305 302 stdcall RtlCopySid(long ptr ptr) RtlCopySid
306 303 stub RtlCopySidAndAttributesArray
307 304 stub RtlCopyString
308 305 stub RtlCopyUnicodeString
309 306 stdcall RtlCreateAcl(ptr long long) RtlCreateAcl
310 307 stub RtlCreateAndSetSD
311 308 stub RtlCreateEnvironment
312 309 stdcall RtlCreateHeap(long long long) HeapCreate
313 310 stub RtlCreateProcessParameters
314 311 stub RtlCreateQueryDebugBuffer
315 312 stub RtlCreateRegistryKey
316 313 stdcall RtlCreateSecurityDescriptor(ptr long) RtlCreateSecurityDescriptor
317 314 stub RtlCreateTagHeap
318 315 stub RtlCreateUnicodeString
319 316 stub RtlCreateUnicodeStringFromAsciiz
320 317 stub RtlCreateUserProcess
321 318 stub RtlCreateUserSecurityObject
322 319 stub RtlCreateUserThread
323 320 stub RtlCustomCPToUnicodeN
324 321 stub RtlCutoverTimeToSystemTime
325 322 stub RtlDeNormalizeProcessParams
326 323 stub RtlDecompressBuffer
327 324 stub RtlDecompressFragment
328 325 stub RtlDelete
329 326 stub RtlDeleteAce
330 327 stdcall RtlDeleteCriticalSection(ptr) DeleteCriticalSection
331 328 stub RtlDeleteElementGenericTable
332 329 stub RtlDeleteRegistryValue
333 330 stub RtlDeleteResource
334 331 stub RtlDeleteSecurityObject
335 332 stub RtlDestroyEnvironment
336 333 stub RtlDestroyHeap
337 334 stub RtlDestroyProcessParameters
338 335 stub RtlDestroyQueryDebugBuffer
339 336 stub RtlDetermineDosPathNameType_U
340 337 stub RtlDoesFileExists_U
341 338 stdcall RtlDosPathNameToNtPathName_U(ptr ptr long long) RtlDosPathNameToNtPathName_U
342 339 stub RtlDosSearchPath_U
343 340 stub RtlDumpResource
344 341 stub RtlEnlargedIntegerMultiply
345 342 stub RtlEnlargedUnsignedDivide
346 343 stub RtlEnlargedUnsignedMultiply
347 344 stdcall RtlEnterCriticalSection(ptr) EnterCriticalSection
348 345 stub RtlEnumProcessHeaps
349 346 stub RtlEnumerateGenericTable
350 347 stub RtlEnumerateGenericTableWithoutSplaying
351 348 stub RtlEqualComputerName
352 349 stub RtlEqualDomainName
353 350 stub RtlEqualLuid
354 351 stub RtlEqualPrefixSid
355 352 stub RtlEqualSid
356 353 stub RtlEqualString
357 354 stub RtlEqualUnicodeString
358 355 stub RtlEraseUnicodeString
359 356 stub RtlExpandEnvironmentStrings_U
360 357 stub RtlExtendHeap
361 358 stub RtlExtendedIntegerMultiply
362 359 stub RtlExtendedLargeIntegerDivide
363 360 stub RtlExtendedMagicDivide
364 361 stdcall RtlFillMemory(ptr long long) RtlFillMemory
365 362 stub RtlFillMemoryUlong
366 363 stub RtlFindClearBits
367 364 stub RtlFindClearBitsAndSet
368 365 stub RtlFindLongestRunClear
369 366 stub RtlFindLongestRunSet
370 367 stub RtlFindMessage
371 368 stub RtlFindSetBits
372 369 stub RtlFindSetBitsAndClear
373 370 stdcall RtlFirstFreeAce(ptr ptr) RtlFirstFreeAce
374 371 stub RtlFormatCurrentUserKeyPath
375 372 stub RtlFormatMessage
376 373 stub RtlFreeAnsiString
377 374 stdcall RtlFreeHeap(long long long) HeapFree
378 375 stub RtlFreeOemString
379 376 stub RtlFreeSid
380 377 stdcall RtlFreeUnicodeString(ptr) RtlFreeUnicodeString
381 378 stub RtlGenerate8dot3Name
382 379 stub RtlGetAce
383 380 stub RtlGetCallersAddress
384 381 stub RtlGetCompressionWorkSpaceSize
385 382 stub RtlGetControlSecurityDescriptor
386 383 stub RtlGetCurrentDirectory_U
387 384 stub RtlGetDaclSecurityDescriptor
388 385 stub RtlGetElementGenericTable
389 386 stub RtlGetFullPathName_U
390 387 stub RtlGetGroupSecurityDescriptor
391 388 stub RtlGetLongestNtPathLength
392 389 stub RtlGetNtGlobalFlags
393 390 stdcall RtlGetNtProductType(ptr) RtlGetNtProductType
394 391 stub RtlGetOwnerSecurityDescriptor
395 392 stub RtlGetProcessHeaps
396 393 stub RtlGetSaclSecurityDescriptor
397 394 stub RtlGetUserInfoHeap
398 395 stub RtlIdentifierAuthoritySid
399 396 stub RtlImageDirectoryEntryToData
400 397 stdcall RtlImageNtHeader(long) RtlImageNtHeader
401 398 stub RtlImpersonateSelf
402 399 stdcall RtlInitAnsiString(ptr ptr) RtlInitAnsiString
403 400 stub RtlInitCodePageTable
404 401 stub RtlInitNlsTables
405 402 stdcall RtlInitString(ptr ptr) RtlInitString
406 403 stdcall RtlInitUnicodeString(ptr ptr) RtlInitUnicodeString
407 404 stub RtlInitializeBitMap
408 405 stub RtlInitializeContext
409 406 stdcall RtlInitializeCriticalSection(ptr) InitializeCriticalSection
410 407 stub RtlInitializeGenericTable
411 408 stub RtlInitializeRXact
412 409 stub RtlInitializeResource
413 410 stdcall RtlInitializeSid(ptr ptr long) RtlInitializeSid
414 411 stub RtlInsertElementGenericTable
415 412 stub RtlIntegerToChar
416 413 stub RtlIntegerToUnicodeString
417 414 stub RtlIsDosDeviceName_U
418 415 stub RtlIsGenericTableEmpty
419 416 stub RtlIsNameLegalDOS8Dot3
420 417 stub RtlIsTextUnicode
421 418 stub RtlLargeIntegerAdd
422 419 stub RtlLargeIntegerArithmeticShift
423 420 stub RtlLargeIntegerDivide
424 421 stub RtlLargeIntegerNegate
425 422 stub RtlLargeIntegerShiftLeft
426 423 stub RtlLargeIntegerShiftRight
427 424 stub RtlLargeIntegerSubtract
428 425 stub RtlLargeIntegerToChar
429 426 stdcall RtlLeaveCriticalSection(ptr) LeaveCriticalSection
430 427 stdcall RtlLengthRequiredSid(long) RtlLengthRequiredSid
431 428 stub RtlLengthSecurityDescriptor
432 429 stdcall RtlLengthSid(ptr) RtlLengthSid
433 430 stub RtlLocalTimeToSystemTime
434 431 stub RtlLockHeap
435 432 stub RtlLookupElementGenericTable
436 433 stub RtlMakeSelfRelativeSD
437 434 stub RtlMapGenericMask
438 435 stdcall RtlMoveMemory(ptr ptr long) RtlMoveMemory
439 436 stdcall RtlMultiByteToUnicodeN(ptr long ptr ptr long) RtlMultiByteToUnicodeN
440 437 stub RtlMultiByteToUnicodeSize
441 438 stub RtlNewInstanceSecurityObject
442 439 stub RtlNewSecurityGrantedAccess
443 440 stub RtlNewSecurityObject
444 441 stdcall RtlNormalizeProcessParams(ptr) RtlNormalizeProcessParams
445 442 stdcall RtlNtStatusToDosError(long) RtlNtStatusToDosError
446 443 stub RtlNumberGenericTableElements
447 444 stub RtlNumberOfClearBits
448 445 stub RtlNumberOfSetBits
449 446 stub RtlOemStringToUnicodeSize
450 447 stdcall RtlOemStringToUnicodeString(ptr ptr long) RtlOemStringToUnicodeString
451 448 stdcall RtlOemToUnicodeN(ptr long ptr ptr long) RtlOemToUnicodeN
452 449 stub RtlOpenCurrentUser
453 450 stub RtlPcToFileHeader
454 451 stub RtlPrefixString
455 452 stub RtlPrefixUnicodeString
456 453 stub RtlProtectHeap
457 454 stub RtlQueryEnvironmentVariable_U
458 455 stub RtlQueryInformationAcl
459 456 stub RtlQueryProcessBackTraceInformation
460 457 stub RtlQueryProcessDebugInformation
461 458 stub RtlQueryProcessHeapInformation
462 459 stub RtlQueryProcessLockInformation
463 460 stub RtlQueryRegistryValues
464 461 stub RtlQuerySecurityObject
465 462 stub RtlQueryTagHeap
466 463 stub RtlQueryTimeZoneInformation
467 464 stub RtlRaiseException
468 465 stub RtlRaiseStatus
469 466 stub RtlRandom
470 467 stub RtlReAllocateHeap
471 468 stub RtlRealPredecessor
472 469 stub RtlRealSuccessor
473 470 stub RtlReleasePebLock
474 471 stub RtlReleaseResource
475 472 stub RtlRemoteCall
476 473 stub RtlResetRtlTranslations
477 474 stub RtlRunDecodeUnicodeString
478 475 stub RtlRunEncodeUnicodeString
479 476 stub RtlSecondsSince1970ToTime
480 477 stub RtlSecondsSince1980ToTime
481 478 stub RtlSelfRelativeToAbsoluteSD
482 479 stub RtlSetAllBits
483 480 stub RtlSetBits
484 481 stub RtlSetCurrentDirectory_U
485 482 stub RtlSetCurrentEnvironment
486 483 stdcall RtlSetDaclSecurityDescriptor(ptr long ptr long) RtlSetDaclSecurityDescriptor
487 484 stub RtlSetEnvironmentVariable
488 485 stdcall RtlSetGroupSecurityDescriptor(ptr ptr long) RtlSetGroupSecurityDescriptor
489 486 stub RtlSetInformationAcl
490 487 stdcall RtlSetOwnerSecurityDescriptor(ptr ptr long) RtlSetOwnerSecurityDescriptor
491 488 stdcall RtlSetSaclSecurityDescriptor(ptr long ptr long) RtlSetSaclSecurityDescriptor
492 489 stub RtlSetSecurityObject
493 490 stub RtlSetTimeZoneInformation
494 491 stub RtlSetUserFlagsHeap
495 492 stub RtlSetUserValueHeap
496 493 stdcall RtlSizeHeap(long long long) HeapSize
497 494 stub RtlSplay
498 495 stub RtlStartRXact
499 496 stdcall RtlSubAuthorityCountSid(ptr) RtlSubAuthorityCountSid
500 497 stdcall RtlSubAuthoritySid(ptr long) RtlSubAuthoritySid
501 498 stub RtlSubtreePredecessor
502 499 stub RtlSubtreeSuccessor
503 500 stub RtlSystemTimeToLocalTime
504 501 stub RtlTimeFieldsToTime
505 502 stub RtlTimeToElapsedTimeFields
506 503 stub RtlTimeToSecondsSince1970
507 504 stub RtlTimeToSecondsSince1980
508 505 stub RtlTimeToTimeFields
509 506 stub RtlUnicodeStringToAnsiSize
510 507 stdcall RtlUnicodeStringToAnsiString(ptr ptr long) RtlUnicodeStringToAnsiString
511 508 stub RtlUnicodeStringToCountedOemString
512 509 stub RtlUnicodeStringToInteger
513 510 stub RtlUnicodeStringToOemSize
514 511 stdcall RtlUnicodeStringToOemString(ptr ptr long) RtlUnicodeStringToOemString
515 512 stub RtlUnicodeToCustomCPN
516 513 stub RtlUnicodeToMultiByteN
517 514 stub RtlUnicodeToMultiByteSize
518 515 stdcall RtlUnicodeToOemN(ptr long ptr ptr long) RtlUnicodeToOemN
519 516 stub RtlUniform
520 517 stub RtlUnlockHeap
521 518 stub RtlUnwind
522 519 stub RtlUpcaseUnicodeChar
523 520 stdcall RtlUpcaseUnicodeString(ptr ptr long) RtlUpcaseUnicodeString
524 521 stub RtlUpcaseUnicodeStringToAnsiString
525 522 stub RtlUpcaseUnicodeStringToCountedOemString
526 523 stub RtlUpcaseUnicodeStringToOemString
527 524 stub RtlUpcaseUnicodeToCustomCPN
528 525 stub RtlUpcaseUnicodeToMultiByteN
529 526 stub RtlUpcaseUnicodeToOemN
530 527 stub RtlUpperChar
531 528 stub RtlUpperString
532 529 stub RtlUsageHeap
533 530 stub RtlValidAcl
534 531 stub RtlValidSecurityDescriptor
535 532 stub RtlValidSid
536 533 stub RtlValidateHeap
537 534 stub RtlValidateProcessHeaps
538 535 stub RtlWalkHeap
539 536 stub RtlWriteRegistryValue
540 537 stub RtlZeroHeap
541 538 stdcall RtlZeroMemory(ptr long) RtlZeroMemory
542 539 stub RtlpInitializeRtl
543 540 stub RtlpNtCreateKey
544 541 stub RtlpNtEnumerateSubKey
545 542 stub RtlpNtMakeTemporaryKey
546 543 stub RtlpNtOpenKey
547 544 stub RtlpNtQueryValueKey
548 545 stub RtlpNtSetValueKey
549 546 stub RtlpUnWaitCriticalSection
550 547 stub RtlpWaitForCriticalSection
551 548 stdcall RtlxAnsiStringToUnicodeSize(ptr) RtlxAnsiStringToUnicodeSize
552 549 stdcall RtlxOemStringToUnicodeSize(ptr) RtlxOemStringToUnicodeSize
553 550 stub RtlxUnicodeStringToAnsiSize
554 551 stub RtlxUnicodeStringToOemSize
555 552 stub SaveEm87Context
556 553 stub ZwAcceptConnectPort
557 554 stub ZwAccessCheck
558 555 stub ZwAccessCheckAndAuditAlarm
559 556 stub ZwAdjustGroupsToken
560 557 stub ZwAdjustPrivilegesToken
561 558 stub ZwAlertResumeThread
562 559 stub ZwAlertThread
563 560 stub ZwAllocateLocallyUniqueId
564 561 stub ZwAllocateUuids
565 562 stub ZwAllocateVirtualMemory
566 563 stub ZwCallbackReturn
567 564 stub ZwCancelIoFile
568 565 stub ZwCancelTimer
569 566 stub ZwClearEvent
570 567 stub ZwClose
571 568 stub ZwCloseObjectAuditAlarm
572 569 stub ZwCompleteConnectPort
573 570 stub ZwConnectPort
574 571 stub ZwContinue
575 572 stub ZwCreateDirectoryObject
576 573 stub ZwCreateEvent
577 574 stub ZwCreateEventPair
578 575 stub ZwCreateFile
579 576 stub ZwCreateIoCompletion
580 577 stub ZwCreateKey
581 578 stub ZwCreateMailslotFile
582 579 stub ZwCreateMutant
583 580 stub ZwCreateNamedPipeFile
584 581 stub ZwCreatePagingFile
585 582 stub ZwCreatePort
586 583 stub ZwCreateProcess
587 584 stub ZwCreateProfile
588 585 stub ZwCreateSection
589 586 stub ZwCreateSemaphore
590 587 stub ZwCreateSymbolicLinkObject
591 588 stub ZwCreateThread
592 589 stub ZwCreateTimer
593 590 stub ZwCreateToken
594 591 stub ZwDelayExecution
595 592 stub ZwDeleteFile
596 593 stub ZwDeleteKey
597 594 stub ZwDeleteValueKey
598 595 stub ZwDeviceIoControlFile
599 596 stub ZwDisplayString
600 597 stub ZwDuplicateObject
601 598 stub ZwDuplicateToken
602 599 stub ZwEnumerateBus
603 600 stub ZwEnumerateKey
604 601 stub ZwEnumerateValueKey
605 602 stub ZwExtendSection
606 603 stub ZwFlushBuffersFile
607 604 stub ZwFlushInstructionCache
608 605 stub ZwFlushKey
609 606 stub ZwFlushVirtualMemory
610 607 stub ZwFlushWriteBuffer
611 608 stub ZwFreeVirtualMemory
612 609 stub ZwFsControlFile
613 610 stub ZwGetContextThread
614 611 stub ZwGetPlugPlayEvent
615 612 stub ZwGetTickCount
616 613 stub ZwImpersonateClientOfPort
617 614 stub ZwImpersonateThread
618 615 stub ZwInitializeRegistry
619 616 stub ZwListenPort
620 617 stub ZwLoadDriver
621 618 stub ZwLoadKey
622 619 stub ZwLockFile
623 620 stub ZwLockVirtualMemory
624 621 stub ZwMakeTemporaryObject
625 622 stub ZwMapViewOfSection
626 623 stub ZwNotifyChangeDirectoryFile
627 624 stub ZwNotifyChangeKey
628 625 stub ZwOpenDirectoryObject
629 626 stub ZwOpenEvent
630 627 stub ZwOpenEventPair
631 628 stub ZwOpenFile
632 629 stub ZwOpenIoCompletion
633 630 stub ZwOpenKey
634 631 stub ZwOpenMutant
635 632 stub ZwOpenObjectAuditAlarm
636 633 stub ZwOpenProcess
637 634 stub ZwOpenProcessToken
638 635 stub ZwOpenSection
639 636 stub ZwOpenSemaphore
640 637 stub ZwOpenSymbolicLinkObject
641 638 stub ZwOpenThread
642 639 stub ZwOpenThreadToken
643 640 stub ZwOpenTimer
644 641 stub ZwPlugPlayControl
645 642 stub ZwPrivilegeCheck
646 643 stub ZwPrivilegeObjectAuditAlarm
647 644 stub ZwPrivilegedServiceAuditAlarm
648 645 stub ZwProtectVirtualMemory
649 646 stub ZwPulseEvent
650 647 stub ZwQueryAttributesFile
651 648 stub ZwQueryDefaultLocale
652 649 stub ZwQueryDirectoryFile
653 650 stub ZwQueryDirectoryObject
654 651 stub ZwQueryEaFile
655 652 stub ZwQueryEvent
656 653 stub ZwQueryInformationFile
657 654 stub ZwQueryInformationPort
658 655 stub ZwQueryInformationProcess
659 656 stub ZwQueryInformationThread
660 657 stub ZwQueryInformationToken
661 658 stub ZwQueryIntervalProfile
662 659 stub ZwQueryIoCompletion
663 660 stub ZwQueryKey
664 661 stub ZwQueryMutant
665 662 stub ZwQueryObject
666 663 stub ZwQueryPerformanceCounter
667 664 stub ZwQuerySection
668 665 stub ZwQuerySecurityObject
669 666 stub ZwQuerySemaphore
670 667 stub ZwQuerySymbolicLinkObject
671 668 stub ZwQuerySystemEnvironmentValue
672 669 stub ZwQuerySystemInformation
673 670 stub ZwQuerySystemTime
674 671 stub ZwQueryTimer
675 672 stub ZwQueryTimerResolution
676 673 stub ZwQueryValueKey
677 674 stub ZwQueryVirtualMemory
678 675 stub ZwQueryVolumeInformationFile
679 676 stub ZwRaiseException
680 677 stub ZwRaiseHardError
681 678 stub ZwReadFile
682 679 stub ZwReadRequestData
683 680 stub ZwReadVirtualMemory
684 681 stub ZwRegisterNewDevice
685 682 stub ZwRegisterThreadTerminatePort
686 683 stub ZwReleaseMutant
687 684 stub ZwReleaseProcessMutant
688 685 stub ZwReleaseSemaphore
689 686 stub ZwRemoveIoCompletion
690 687 stub ZwReplaceKey
691 688 stub ZwReplyPort
692 689 stub ZwReplyWaitReceivePort
693 690 stub ZwReplyWaitReplyPort
694 691 stub ZwRequestPort
695 692 stub ZwRequestWaitReplyPort
696 693 stub ZwResetEvent
697 694 stub ZwRestoreKey
698 695 stub ZwResumeThread
699 696 stub ZwSaveKey
700 697 stub ZwSetContextThread
701 698 stub ZwSetDefaultHardErrorPort
702 699 stub ZwSetDefaultLocale
703 700 stub ZwSetEaFile
704 701 stub ZwSetEvent
705 702 stub ZwSetHighEventPair
706 703 stub ZwSetHighWaitLowEventPair
707 704 stub ZwSetHighWaitLowThread
708 705 stub ZwSetInformationFile
709 706 stub ZwSetInformationKey
710 707 stub ZwSetInformationObject
711 708 stub ZwSetInformationProcess
712 709 stub ZwSetInformationThread
713 710 stub ZwSetInformationToken
714 711 stub ZwSetIntervalProfile
715 712 stub ZwSetIoCompletion
716 713 stub ZwSetLdtEntries
717 714 stub ZwSetLowEventPair
718 715 stub ZwSetLowWaitHighEventPair
719 716 stub ZwSetLowWaitHighThread
720 717 stub ZwSetSecurityObject
721 718 stub ZwSetSystemEnvironmentValue
722 719 stub ZwSetSystemInformation
723 720 stub ZwSetSystemPowerState
724 721 stub ZwSetSystemTime
725 722 stub ZwSetTimer
726 723 stub ZwSetTimerResolution
727 724 stub ZwSetValueKey
728 725 stub ZwSetVolumeInformationFile
729 726 stub ZwShutdownSystem
730 727 stub ZwStartProfile
731 728 stub ZwStopProfile
732 729 stub ZwSuspendThread
733 730 stub ZwSystemDebugControl
734 731 stub ZwTerminateProcess
735 732 stub ZwTerminateThread
736 733 stub ZwTestAlert
737 734 stub ZwUnloadDriver
738 735 stub ZwUnloadKey
739 736 stub ZwUnlockFile
740 737 stub ZwUnlockVirtualMemory
741 738 stub ZwUnmapViewOfSection
742 739 stub ZwVdmControl
743 740 stub ZwW32Call
744 741 stub ZwWaitForMultipleObjects
745 742 stub ZwWaitForProcessMutant
746 743 stub ZwWaitForSingleObject
747 744 stub ZwWaitHighEventPair
748 745 stub ZwWaitLowEventPair
749 746 stub ZwWriteFile
750 747 stub ZwWriteRequestData
751 748 stub ZwWriteVirtualMemory
752 749 stub _CIpow
753 750 stub __eCommonExceptions
754 751 stub __eEmulatorInit
755 752 stub __eF2XM1
756 753 stub __eFABS
757 754 stub __eFADD32
758 755 stub __eFADD64
759 756 stub __eFADDPreg
760 757 stub __eFADDreg
761 758 stub __eFADDtop
762 759 stub __eFCHS
763 760 stub __eFCOM
764 761 stub __eFCOM32
765 762 stub __eFCOM64
766 763 stub __eFCOMP
767 764 stub __eFCOMP32
768 765 stub __eFCOMP64
769 766 stub __eFCOMPP
770 767 stub __eFCOS
771 768 stub __eFDECSTP
772 769 stub __eFDIV32
773 770 stub __eFDIV64
774 771 stub __eFDIVPreg
775 772 stub __eFDIVR32
776 773 stub __eFDIVR64
777 774 stub __eFDIVRPreg
778 775 stub __eFDIVRreg
779 776 stub __eFDIVRtop
780 777 stub __eFDIVreg
781 778 stub __eFDIVtop
782 779 stub __eFFREE
783 780 stub __eFIADD16
784 781 stub __eFIADD32
785 782 stub __eFICOM16
786 783 stub __eFICOM32
787 784 stub __eFICOMP16
788 785 stub __eFICOMP32
789 786 stub __eFIDIV16
790 787 stub __eFIDIV32
791 788 stub __eFIDIVR16
792 789 stub __eFIDIVR32
793 790 stub __eFILD16
794 791 stub __eFILD32
795 792 stub __eFILD64
796 793 stub __eFIMUL16
797 794 stub __eFIMUL32
798 795 stub __eFINCSTP
799 796 stub __eFINIT
800 797 stub __eFIST16
801 798 stub __eFIST32
802 799 stub __eFISTP16
803 800 stub __eFISTP32
804 801 stub __eFISTP64
805 802 stub __eFISUB16
806 803 stub __eFISUB32
807 804 stub __eFISUBR16
808 805 stub __eFISUBR32
809 806 stub __eFLD1
810 807 stub __eFLD32
811 808 stub __eFLD64
812 809 stub __eFLD80
813 810 stub __eFLDCW
814 811 stub __eFLDENV
815 812 stub __eFLDL2E
816 813 stub __eFLDLN2
817 814 stub __eFLDPI
818 815 stub __eFLDZ
819 816 stub __eFMUL32
820 817 stub __eFMUL64
821 818 stub __eFMULPreg
822 819 stub __eFMULreg
823 820 stub __eFMULtop
824 821 stub __eFPATAN
825 822 stub __eFPREM
826 823 stub __eFPREM1
827 824 stub __eFPTAN
828 825 stub __eFRNDINT
829 826 stub __eFRSTOR
830 827 stub __eFSAVE
831 828 stub __eFSCALE
832 829 stub __eFSIN
833 830 stub __eFSQRT
834 831 stub __eFST
835 832 stub __eFST32
836 833 stub __eFST64
837 834 stub __eFSTCW
838 835 stub __eFSTENV
839 836 stub __eFSTP
840 837 stub __eFSTP32
841 838 stub __eFSTP64
842 839 stub __eFSTP80
843 840 stub __eFSTSW
844 841 stub __eFSUB32
845 842 stub __eFSUB64
846 843 stub __eFSUBPreg
847 844 stub __eFSUBR32
848 845 stub __eFSUBR64
849 846 stub __eFSUBRPreg
850 847 stub __eFSUBRreg
851 848 stub __eFSUBRtop
852 849 stub __eFSUBreg
853 850 stub __eFSUBtop
854 851 stub __eFTST
855 852 stub __eFUCOM
856 853 stub __eFUCOMP
857 854 stub __eFUCOMPP
858 855 stub __eFXAM
859 856 stub __eFXCH
860 857 stub __eFXTRACT
861 858 stub __eFYL2X
862 859 stub __eFYL2XP1
863 860 stub __eGetStatusWord
864 861 stub _alloca_probe
865 862 cdecl _chkstk() NTDLL_chkstk
866 863 stub _fltused
867 864 cdecl _ftol(double) CRTDLL__ftol
868 865 stub _itoa
869 866 stub _ltoa
870 867 stub _memccpy
871 868 stub _memicmp
872 869 stub _snprintf
873 870 stub _snwprintf
874 871 stub _splitpath
875 872 cdecl _strcmpi(ptr ptr) CRTDLL__strcmpi
876 873 cdecl _stricmp(ptr ptr) CRTDLL__strcmpi
877 874 stub _strlwr
878 875 cdecl _strnicmp(ptr ptr long) CRTDLL__strnicmp
879 876 cdecl _strupr(ptr) CRTDLL__strupr
880 877 stub _ultoa
881 878 stub _vsnprintf
882 879 cdecl _wcsicmp(ptr ptr) CRTDLL__wcsicmp
883 880 cdecl _wcslwr(ptr) CRTDLL__wcslwr
884 881 cdecl _wcsnicmp(ptr ptr long) CRTDLL__wcsnicmp
885 882 cdecl _wcsupr(ptr) CRTDLL__wcsupr
886 883 stub abs
887 884 stub atan
888 885 cdecl atoi(ptr) atoi
889 886 cdecl atol(ptr) atol
890 887 stub ceil
891 888 stub cos
892 889 stub fabs
893 890 stub floor
894 891 cdecl isalpha(long) isalpha
895 892 cdecl isdigit(long) isdigit
896 893 cdecl islower(long) islower
897 894 cdecl isprint(long) isprint
898 895 cdecl isspace(long) isspace
899 896 cdecl isupper(long) isupper
900 897 stub iswalpha
901 898 stub iswctype
902 899 cdecl isxdigit(long) isxdigit
903 900 stub labs
904 901 stub log
905 902 stub mbstowcs
906 903 cdecl memchr(ptr long long) memchr
907 904 cdecl memcmp(ptr ptr long) memcmp
908 905 cdecl memcpy(ptr ptr long) memcpy
909 906 cdecl memmove(ptr ptr long) memmove
910 907 cdecl memset(ptr long long) memset
911 908 stub pow
912 909 stub qsort
913 910 stub sin
914 911 varargs sprintf() wsprintf32A
915 912 stub sqrt
916 913 varargs sscanf() sscanf
917 914 cdecl strcat(ptr ptr) strcat
918 915 cdecl strchr(ptr long) strchr
919 916 cdecl strcmp(ptr ptr) strcmp
920 917 cdecl strcpy(ptr ptr) strcpy
921 918 cdecl strcspn(ptr ptr) strcspn
922 919 cdecl strlen(ptr) strlen
923 920 cdecl strncat(ptr ptr long) strncat
924 921 cdecl strncmp(ptr ptr long) strncmp
925 922 cdecl strncpy(ptr ptr long) strncpy
926 923 cdecl strpbrk(ptr ptr long) strpbrk
927 924 cdecl strrchr(ptr long) strrchr
928 925 cdecl strspn(ptr ptr) strspn
929 926 cdecl strstr(ptr ptr) strstr
930 927 varargs swprintf() wsprintf32W
931 928 stub tan
932 929 cdecl tolower(long) tolower
933 930 cdecl toupper(long) toupper
934 931 stub towlower
935 932 stub towupper
936 933 cdecl vsprintf(ptr ptr ptr) CRTDLL_vsprintf
937 934 cdecl wcscat(ptr ptr) CRTDLL_wcscat
938 935 cdecl wcschr(ptr long) CRTDLL_wcschr
939 936 stub wcscmp
940 937 cdecl wcscpy(ptr ptr) CRTDLL_wcscpy
941 938 stub wcscspn
942 939 cdecl wcslen(ptr) CRTDLL_wcslen
943 940 stub wcsncat
944 941 stub wcsncmp
945 942 cdecl wcsncpy(ptr ptr long) CRTDLL_wcsncpy
946 943 stub wcspbrk
947 944 cdecl wcsrchr(ptr long) CRTDLL_wcsrchr
948 945 stub wcsspn
949 946 cdecl wcsstr(ptr ptr) CRTDLL_wcsstr
950 947 stub wcstok
951 948 stub wcstol
952 949 cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
953 950 stub wcstoul
955 # NT 4 additions
956 951 stub NtAddAtom
957 952 stub NtDeleteAtom
958 953 stub NtFindAtom
959 954 stub NtQueryFullAttributesFile
960 955 stub NtQueueApcThread
961 956 stub NtReadFileScatter
962 957 stub NtSignalAndWaitForSingleObject
963 958 stub NtWriteFileGather
964 959 stub NtYieldExecution
965 960 stub RtlAddAtomToAtomTable
966 961 stub RtlAllocateHandle
967 962 stub RtlCreateAtomTable
968 963 stub RtlDeleteAtomFromAtomTable
969 964 stub RtlFreeHandle
970 965 stub RtlInitializeHandleTable
971 966 stub RtlIsValidHandle
972 967 stub RtlLookupAtomInAtomTable
973 968 stub RtlQueryAtomInAtomTable
974 969 stdcall RtlTryEnterCriticalSection(ptr) TryEnterCriticalSection