Release 980104
[wine/multimedia.git] / if1632 / kernel.spec
blob69ee55f89b9e2c2c4172df1a2671c2212d1556e7
1 name kernel
2 type win16
3 file krnl386.exe
5 1 stub FatalExit
6 2 stub ExitKernel
7 3 pascal GetVersion() GetVersion16
8 4 pascal16 LocalInit(word word word) LocalInit
9 5 pascal16 LocalAlloc(word word) LocalAlloc16
10 6 pascal16 LocalReAlloc(word word word) LocalReAlloc16
11 7 pascal16 LocalFree(word) LocalFree16
12 8 pascal16 LocalLock(word) LocalLock16
13 9 pascal16 LocalUnlock(word) LocalUnlock16
14 10 pascal16 LocalSize(word) LocalSize16
15 11 pascal16 LocalHandle(word) LocalHandle16
16 12 pascal16 LocalFlags(word) LocalFlags16
17 13 pascal16 LocalCompact(word) LocalCompact16
18 14 pascal16 LocalNotify(long) LocalNotify
19 15 pascal16 GlobalAlloc(word long) GlobalAlloc16
20 16 pascal16 GlobalReAlloc(word long word) GlobalReAlloc16
21 17 pascal16 GlobalFree(word) GlobalFree16
22 18 pascal GlobalLock(word) WIN16_GlobalLock16
23 19 pascal16 GlobalUnlock(word) GlobalUnlock16
24 20 pascal GlobalSize(word) GlobalSize16
25 21 pascal GlobalHandle(word) GlobalHandle16
26 22 pascal16 GlobalFlags(word) GlobalFlags16
27 23 pascal16 LockSegment(word) LockSegment16
28 24 pascal16 UnlockSegment(word) UnlockSegment16
29 25 pascal GlobalCompact(long) GlobalCompact16
30 26 pascal16 GlobalFreeAll(word) GlobalFreeAll
31 27 pascal16 GetModuleName(word ptr word) GetModuleName
32 28 stub GlobalMasterHandle
33 29 pascal16 Yield() Yield16
34 30 pascal16 WaitEvent(word) WaitEvent
35 31 pascal16 PostEvent(word) PostEvent
36 32 pascal16 SetPriority(word s_word) SetPriority
37 33 pascal16 LockCurrentTask(word) LockCurrentTask
38 34 pascal SetTaskQueue(word word) SetTaskQueue
39 35 pascal16 GetTaskQueue(word) GetTaskQueue
40 36 pascal GetCurrentTask() WIN16_GetCurrentTask
41 37 pascal GetCurrentPDB() GetCurrentPDB
42 38 pascal SetTaskSignalProc(word segptr) THUNK_SetTaskSignalProc
43 41 return EnableDos 0 0
44 42 return DisableDos 0 0
45 45 pascal16 LoadModule(str ptr) LoadModule16
46 46 pascal16 FreeModule(word) FreeModule16
47 47 pascal16 GetModuleHandle(segstr) WIN16_GetModuleHandle
48 48 pascal16 GetModuleUsage(word) GetModuleUsage
49 49 pascal16 GetModuleFileName(word ptr s_word) GetModuleFileName16
50 50 pascal GetProcAddress(word segstr) GetProcAddress16
51 51 pascal MakeProcInstance(segptr word) MakeProcInstance16
52 52 pascal16 FreeProcInstance(segptr) FreeProcInstance16
53 53 stub CallProcInstance
54 54 pascal16 GetInstanceData(word word word) GetInstanceData
55 55 register Catch(segptr) Catch
56 56 register Throw(segptr word) Throw
57 57 pascal16 GetProfileInt(str str s_word) GetProfileInt16
58 58 pascal16 GetProfileString(str str str ptr word) GetProfileString16
59 59 pascal16 WriteProfileString(str str str) WriteProfileString16
60 60 pascal16 FindResource(word segstr segstr) FindResource16
61 61 pascal16 LoadResource(word word) LoadResource16
62 62 pascal LockResource(word) WIN16_LockResource16
63 63 pascal16 FreeResource(word) FreeResource16
64 64 pascal16 AccessResource(word word) AccessResource16
65 65 pascal SizeofResource(word word) SizeofResource16
66 66 pascal16 AllocResource(word word long) AllocResource16
67 67 pascal SetResourceHandler(word segstr segptr) THUNK_SetResourceHandler
68 68 pascal16 InitAtomTable(word) InitAtomTable16
69 69 pascal16 FindAtom(segstr) FindAtom16
70 70 pascal16 AddAtom(segstr) AddAtom16
71 71 pascal16 DeleteAtom(word) DeleteAtom16
72 72 pascal16 GetAtomName(word ptr word) GetAtomName16
73 73 pascal16 GetAtomHandle(word) GetAtomHandle
74 74 pascal16 OpenFile(str ptr word) OpenFile16
75 75 stub OpenPathName
76 76 stub DeletePathName
77 77 stub KERNEL_77 #RESERVED1
78 78 stub KERNEL_78 #RESERVED2
79 #79 RESERVED3
80 #80 RESERVED4
81 81 pascal16 _lclose(word) _lclose16
82 82 pascal16 _lread(word segptr word) WIN16_lread
83 83 pascal16 _lcreat(str word) _lcreat16
84 84 pascal _llseek(word long word) _llseek16
85 85 pascal16 _lopen(str word) _lopen16
86 86 pascal16 _lwrite(word ptr word) _lwrite16
87 87 pascal16 RESERVED5(str str) lstrcmp16
88 88 pascal lstrcpy(segptr str) lstrcpy16
89 89 pascal lstrcat(segstr str) lstrcat16
90 90 pascal16 lstrlen(str) lstrlen16
91 91 register InitTask() InitTask
92 92 pascal GetTempDrive(word) WIN16_GetTempDrive
93 93 pascal16 GetCodeHandle(segptr) GetCodeHandle
94 94 pascal16 DefineHandleTable(word) DefineHandleTable16
95 95 pascal16 LoadLibrary(str) LoadLibrary16
96 96 pascal16 FreeLibrary(word) FreeLibrary16
97 97 pascal16 GetTempFileName(word str word ptr) GetTempFileName16
98 98 return GetLastDiskChange 0 0
99 99 stub GetLPErrMode
100 100 return ValidateCodeSegments 0 0
101 101 stub NoHookDosCall
102 102 register DOS3Call() DOS3Call
103 103 register NetBIOSCall() NetBIOSCall
104 104 stub GetCodeInfo
105 105 pascal16 GetExeVersion() GetExeVersion
106 106 pascal SetSwapAreaSize(word) SetSwapAreaSize16
107 107 pascal16 SetErrorMode(word) SetErrorMode16
108 108 pascal16 SwitchStackTo(word word word) SwitchStackTo
109 109 register SwitchStackBack(word word word) SwitchStackBack
110 110 pascal16 PatchCodeHandle(word) PatchCodeHandle
111 111 pascal GlobalWire(word) GlobalWire16
112 112 pascal16 GlobalUnWire(word) GlobalUnWire16
113 113 equate __AHSHIFT 3
114 114 equate __AHINCR 8
115 115 pascal16 OutputDebugString(str) OutputDebugString16
116 116 stub InitLib
117 117 pascal16 OldYield() OldYield
118 118 register GetTaskQueueDS() GetTaskQueueDS
119 119 register GetTaskQueueES() GetTaskQueueES
120 120 stub UndefDynLink
121 121 pascal16 LocalShrink(word word) LocalShrink16
122 122 pascal16 IsTaskLocked() IsTaskLocked
123 123 stub KbdRst
124 124 return EnableKernel 0 0
125 125 return DisableKernel 0 0
126 126 stub MemoryFreed
127 127 pascal16 GetPrivateProfileInt(str str s_word str) GetPrivateProfileInt16
128 128 pascal16 GetPrivateProfileString(str str str ptr word str)
129 GetPrivateProfileString16
130 129 pascal16 WritePrivateProfileString(str str str str)
131 WritePrivateProfileString16
132 130 pascal FileCDR(ptr) FileCDR
133 131 pascal GetDOSEnvironment() GetDOSEnvironment
134 132 pascal GetWinFlags() GetWinFlags
135 133 pascal16 GetExePtr(word) GetExePtr
136 134 pascal16 GetWindowsDirectory(ptr word) GetWindowsDirectory16
137 135 pascal16 GetSystemDirectory(ptr word) GetSystemDirectory16
138 136 pascal16 GetDriveType(word) GetDriveType16
139 137 pascal16 FatalAppExit(word str) FatalAppExit16
140 138 pascal GetHeapSpaces(word) GetHeapSpaces
141 139 stub DoSignal
142 140 pascal16 SetSigHandler(segptr ptr ptr word word) SetSigHandler
143 141 stub InitTask1
144 142 stub GetProfileSectionNames
145 143 stub GetPrivateProfileSectionNames
146 144 pascal16 CreateDirectory(ptr ptr) CreateDirectory16
147 145 pascal16 RemoveDirectory(ptr) RemoveDirectory16
148 146 pascal16 DeleteFile(ptr) DeleteFile16
149 147 pascal16 SetLastError(long) SetLastError
150 148 pascal GetLastError() GetLastError
151 149 stub GetVersionEx
152 150 pascal16 DirectedYield(word) DirectedYield
153 151 stub WinOldApCall
154 152 pascal16 GetNumTasks() GetNumTasks
155 154 pascal16 GlobalNotify(segptr) GlobalNotify
156 155 pascal16 GetTaskDS() GetTaskDS
157 156 return LimitEMSPages 4 0
158 157 return GetCurPID 4 0
159 158 return IsWinOldApTask 2 0
160 159 stub GlobalHandleNoRIP
161 160 stub EMSCopy
162 161 pascal16 LocalCountFree() LocalCountFree
163 162 pascal16 LocalHeapSize() LocalHeapSize
164 163 pascal16 GlobalLRUOldest(word) GlobalLRUOldest
165 164 pascal16 GlobalLRUNewest(word) GlobalLRUNewest
166 165 return A20Proc 2 0
167 166 pascal16 WinExec(str word) WinExec16
168 167 pascal16 GetExpWinVer(word) GetExpWinVer
169 168 pascal16 DirectResAlloc(word word word) DirectResAlloc
170 169 pascal GetFreeSpace(word) GetFreeSpace16
171 170 pascal16 AllocCStoDSAlias(word) AllocCStoDSAlias
172 171 pascal16 AllocDStoCSAlias(word) AllocDStoCSAlias
173 172 pascal16 AllocAlias(word) AllocCStoDSAlias
174 173 equate __ROMBIOS 0
175 174 equate __A000H 0
176 175 pascal16 AllocSelector(word) AllocSelector
177 176 pascal16 FreeSelector(word) FreeSelector
178 177 pascal16 PrestoChangoSelector(word word) PrestoChangoSelector
179 178 equate __WINFLAGS 0x413
180 179 equate __D000H 0
181 180 pascal16 LongPtrAdd(long long) LongPtrAdd
182 181 equate __B000H 0
183 182 equate __B800H 0
184 183 equate __0000H 0
185 184 pascal GlobalDOSAlloc(long) GlobalDOSAlloc
186 185 pascal16 GlobalDOSFree(word) GlobalDOSFree
187 186 pascal GetSelectorBase(word) GetSelectorBase
188 187 pascal16 SetSelectorBase(word long) SetSelectorBase
189 188 pascal GetSelectorLimit(word) GetSelectorLimit
190 189 pascal16 SetSelectorLimit(word long) SetSelectorLimit
191 190 equate __E000H 0
192 191 pascal16 GlobalPageLock(word) GlobalPageLock
193 192 pascal16 GlobalPageUnlock(word) GlobalPageUnlock
194 193 equate __0040H 0
195 194 equate __F000H 0
196 195 equate __C000H 0
197 196 pascal16 SelectorAccessRights(word word word) SelectorAccessRights
198 197 pascal16 GlobalFix(word) GlobalFix16
199 198 pascal16 GlobalUnfix(word) GlobalUnfix16
200 199 pascal16 SetHandleCount(word) SetHandleCount16
201 200 return ValidateFreeSpaces 0 0
202 201 stub ReplaceInst
203 202 stub RegisterPtrace
204 203 register DebugBreak() DebugBreak16
205 204 stub SwapRecording
206 205 stub CVWBreak
207 206 pascal16 AllocSelectorArray(word) AllocSelectorArray
208 207 pascal16 IsDBCSLeadByte(word) IsDBCSLeadByte16
209 208 stub KERNEL_208
210 209 stub KERNEL_209
211 210 stub KERNEL_210
212 211 stub KERNEL_211
213 213 stub KERNEL_213
214 214 stub KERNEL_214
215 216 pascal RegEnumKey(long long ptr long) RegEnumKey16
216 217 pascal RegOpenKey(long str ptr) RegOpenKey16
217 218 pascal RegCreateKey(long str ptr) RegCreateKey16
218 219 pascal RegDeleteKey(long str) RegDeleteKey16
219 220 pascal RegCloseKey(long) RegCloseKey
220 221 pascal RegSetValue(long str long ptr long) RegSetValue16
221 222 pascal RegDeleteValue(long str) RegDeleteValue16
222 223 pascal RegEnumValue(long long ptr ptr ptr ptr ptr ptr) RegEnumValue16
223 224 pascal RegQueryValue(long str ptr ptr) RegQueryValue16
224 225 pascal RegQueryValueEx(long str ptr ptr ptr ptr) RegQueryValueEx16
225 226 pascal RegSetValueEx(long str long long ptr long) RegSetValueEx16
226 227 pascal RegFlushKey(long) RegFlushKey
227 228 stub K228
228 229 stub K229
229 230 pascal GlobalSmartPageLock(word) GlobalPageLock #?
230 231 stub GlobalSmartPageUnlock
231 232 stub RegLoadKey
232 233 stub RegUnloadKey
233 234 stub RegSaveKey
234 235 stub InvalidateNlsCache
235 236 stub GetProductName
236 237 stub KERNEL_237
237 262 stub KERNEL_262
238 263 stub KERNEL_263
239 310 pascal16 LocalHandleDelta(word) LocalHandleDelta
240 311 stub GetSetKernelDosProc
241 314 stub DebugDefineSegment
242 315 pascal16 WriteOutProfiles() WriteOutProfiles
243 316 stub GetFreeMemInfo
244 318 stub FatalExitHook
245 319 stub FlushCachedFileHandle
246 320 pascal16 IsTask(word) IsTask
247 321 stub KERNEL_321
248 323 return IsRomModule 2 0
249 324 pascal16 LogError(word ptr) LogError
250 325 pascal16 LogParamError(word ptr ptr) LogParamError
251 326 return IsRomFile 2 0
252 327 stub KERNEL_327
253 328 stub _DebugOutput
254 #329 K329
255 #332 stub THHOOK
256 334 pascal16 IsBadReadPtr(segptr word) IsBadReadPtr16
257 335 pascal16 IsBadWritePtr(segptr word) IsBadWritePtr16
258 336 pascal16 IsBadCodePtr(segptr) IsBadCodePtr16
259 337 pascal16 IsBadStringPtr(segptr word) IsBadStringPtr16
260 338 stub HasGPHandler
261 339 stub DiagQuery
262 340 stub DiagOutput
263 341 stub ToolHelpHook
264 342 stub __GP
265 343 stub RegisterWinOldApHook
266 344 stub GetWinOldApHooks
267 345 pascal16 IsSharedSelector(word) IsSharedSelector
268 346 pascal16 IsBadHugeReadPtr(segptr long) IsBadHugeReadPtr16
269 347 pascal16 IsBadHugeWritePtr(segptr long) IsBadHugeWritePtr16
270 348 pascal16 hmemcpy(ptr ptr long) hmemcpy
271 349 pascal _hread(word segptr long) WIN16_hread
272 350 pascal _hwrite(word ptr long) _hwrite16
273 #351 BUNNY_351
274 352 pascal lstrcatn(segstr str word) lstrcatn16
275 353 pascal lstrcpyn(segptr str word) lstrcpyn16
276 354 pascal GetAppCompatFlags(word) GetAppCompatFlags16
277 355 pascal16 GetWinDebugInfo(ptr word) GetWinDebugInfo
278 356 pascal16 SetWinDebugInfo(ptr) SetWinDebugInfo
279 357 stub KERNEL_357
280 358 pascal KERNEL_358(long) _KERNEL_358
281 359 pascal KERNEL_359(long) _KERNEL_359
282 360 stub OpenFileEx
283 #361 PIGLET_361
284 365 stub KERNEL_365
285 403 pascal16 FarSetOwner(word word) FarSetOwner
286 404 pascal16 FarGetOwner(word) FarGetOwner
287 406 stub WritePrivateProfileStruct
288 407 stub GetPrivateProfileStruct
289 411 pascal GetCurrentDirectory(long ptr) GetCurrentDirectory16
290 412 pascal16 SetCurrentDirectory(ptr) SetCurrentDirectory16
291 413 pascal16 FindFirstFile(ptr ptr) FindFirstFile16
292 414 pascal16 FindNextFile(word ptr) FindNextFile16
293 415 pascal16 FindClose(word) FindClose16
294 416 stub WritePrivateProfileSection
295 417 stub WriteProfileSection
296 418 stub GetPrivateProfileSection
297 419 stub GetProfileSection
298 420 pascal GetFileAttributes(ptr) GetFileAttributes16
299 421 pascal16 SetFileAttributes(ptr long) SetFileAttributes16
300 422 pascal16 GetDiskFreeSpace(ptr ptr ptr ptr ptr) GetDiskFreeSpace16
301 431 pascal16 KERNEL_431(str word) KERNEL_431
302 432 stub FileTimeToLocalFileTime
303 435 stub KERNEL_435
304 439 stub KERNEL_439
305 440 stub KERNEL_440
306 444 stub KERNEL_444
307 445 stub KERNEL_445
308 446 stub KERNEL_446
309 447 stub KERNEL_447
310 449 pascal KERNEL_449() stub_KERNEL_449
311 450 pascal16 KERNEL_450() stub_KERNEL_450
312 454 stub KERNEL_454
313 455 stub KERNEL_455
314 471 stub KERNEL_471
315 472 register KERNEL_472() _KERNEL_472
316 473 stub KERNEL_473
317 475 stub KERNEL_475
318 482 stub KERNEL_482
319 485 stub KERNEL_485
320 491 stub RegisterServiceProcess
321 500 stub KERNEL_500
322 502 stub KERNEL_502
323 503 stub KERNEL_503
324 511 stub KERNEL_511
325 513 pascal LoadLibraryEx32W(ptr long long) LoadLibraryEx32W16
326 514 pascal16 FreeLibrary32W(long) FreeLibrary32
327 515 pascal GetProcAddress32W(long str) GetProcAddress32
328 516 pascal GetVDMPointer32W(segptr long) GetVDMPointer32W
329 517 pascal CallProc32W() WIN16_CallProc32W
330 518 pascal CallProcEx32W() WIN16_CallProcEx32W
331 519 stub KERNEL_519
332 522 stub KERNEL_522
333 523 stub KERNEL_523
334 525 stub KERNEL_525
335 531 stub KERNEL_531
336 532 stub KERNEL_532
337 540 stub KERNEL_540
338 541 stub KERNEL_541
339 544 stub KERNEL_544
340 600 stub KERNEL_600
341 601 stub KERNEL_601
342 604 stub KERNEL_604
343 605 stub KERNEL_605
344 606 stub KERNEL_606
345 607 stub KERNEL_607
346 608 stub KERNEL_608
347 611 stub KERNEL_611
348 612 stub KERNEL_612
349 613 stub KERNEL_613
350 614 stub KERNEL_614
351 619 pascal KERNEL_619(word long long) _KERNEL_619
352 621 stub KERNEL_621
353 627 stub IsBadFlatReadWritePtr
354 630 stub KERNEL_630
355 631 pascal FUNC004(word word long) FUNC004 #C16ThkSl01?
356 651 stub KERNEL_651 #ThunkConnect16?
357 700 pascal KERNEL_700() stub_KERNEL_700