configure: Changes from running autconf after previous patch.
[wine/hacks.git] / dlls / iphlpapi / iphlpapi.spec
blob794ece20936336ce97feb6d5d1b4f93c919cd4bc
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
8 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
9 @ stdcall CreateIpForwardEntry( ptr )
10 @ stdcall CreateIpNetEntry( ptr )
11 @ stdcall CreateProxyArpEntry( long long long )
12 @ stdcall DeleteIPAddress( long )
13 @ stdcall DeleteIpForwardEntry( ptr )
14 @ stdcall DeleteIpNetEntry( ptr )
15 @ stdcall DeleteProxyArpEntry( long long long )
16 @ stdcall EnableRouter( ptr ptr )
17 @ stdcall FlushIpNetTable( long )
18 @ stub FlushIpNetTableFromStack
19 @ stdcall GetAdapterIndex( wstr ptr )
20 @ stub GetAdapterOrderMap
21 @ stdcall GetAdaptersAddresses( long long ptr ptr ptr )
22 @ stdcall GetAdaptersInfo( ptr ptr )
23 @ stdcall GetBestInterface( long ptr )
24 @ stdcall GetBestInterfaceEx( ptr ptr )
25 @ stub GetBestInterfaceFromStack
26 @ stdcall GetBestRoute( long long long )
27 @ stub GetBestRouteFromStack
28 @ stdcall GetFriendlyIfIndex( long )
29 @ stdcall GetIcmpStatistics( ptr )
30 @ stub GetIcmpStatsFromStack
31 @ stdcall GetIfEntry( ptr )
32 @ stub GetIfEntryFromStack
33 @ stdcall GetIfTable( ptr ptr long )
34 @ stub GetIfTableFromStack
35 @ stub GetIgmpList
36 @ stdcall GetInterfaceInfo( ptr ptr )
37 @ stdcall GetIpAddrTable( ptr ptr long )
38 @ stub GetIpAddrTableFromStack
39 @ stdcall GetIpForwardTable( ptr ptr long )
40 @ stub GetIpForwardTableFromStack
41 @ stdcall GetIpNetTable( ptr ptr long )
42 @ stub GetIpNetTableFromStack
43 @ stdcall GetIpStatistics( ptr )
44 @ stub GetIpStatsFromStack
45 @ stdcall GetNetworkParams( ptr ptr )
46 @ stdcall GetNumberOfInterfaces( ptr )
47 @ stdcall GetPerAdapterInfo( long ptr ptr )
48 @ stdcall GetRTTAndHopCount( long ptr long ptr )
49 @ stdcall GetTcpStatistics( ptr )
50 @ stub GetTcpStatsFromStack
51 @ stdcall GetTcpTable( ptr ptr long )
52 @ stub GetTcpTableFromStack
53 @ stdcall GetUdpStatistics( ptr )
54 @ stub GetUdpStatsFromStack
55 @ stdcall GetUdpTable( ptr ptr long )
56 @ stub GetUdpTableFromStack
57 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
58 @ stdcall IcmpCloseHandle(ptr)
59 @ stdcall IcmpCreateFile()
60 @ stub IcmpParseReplies
61 @ stdcall IcmpSendEcho2(ptr ptr ptr ptr long ptr long ptr ptr long long)
62 @ stdcall IcmpSendEcho(ptr long ptr long ptr ptr long long)
63 @ stub InternalCreateIpForwardEntry
64 @ stub InternalCreateIpNetEntry
65 @ stub InternalDeleteIpForwardEntry
66 @ stub InternalDeleteIpNetEntry
67 @ stub InternalGetIfTable
68 @ stub InternalGetIpAddrTable
69 @ stub InternalGetIpForwardTable
70 @ stub InternalGetIpNetTable
71 @ stub InternalGetTcpTable
72 @ stub InternalGetUdpTable
73 @ stub InternalSetIfEntry
74 @ stub InternalSetIpForwardEntry
75 @ stub InternalSetIpNetEntry
76 @ stub InternalSetIpStats
77 @ stub InternalSetTcpEntry
78 @ stdcall IpReleaseAddress( ptr )
79 @ stdcall IpRenewAddress( ptr )
80 @ stub IsLocalAddress
81 @ stub NTPTimeToNTFileTime
82 @ stub NTTimeToNTPTime
83 @ stub NhGetGuidFromInterfaceName
84 @ stub NhGetInterfaceNameFromGuid
85 @ stub NhpAllocateAndGetInterfaceInfoFromStack
86 @ stub NhpGetInterfaceIndexFromStack
87 @ stdcall NotifyAddrChange( ptr ptr )
88 @ stdcall NotifyRouteChange( ptr ptr )
89 @ stub NotifyRouteChangeEx
90 @ stub _PfAddFiltersToInterface@24
91 @ stub _PfAddGlobalFilterToInterface@8
92 @ stub _PfBindInterfaceToIPAddress@12
93 @ stub _PfBindInterfaceToIndex@16
94 @ stub _PfCreateInterface@24
95 @ stub _PfDeleteInterface@4
96 @ stub _PfDeleteLog@0
97 @ stub _PfGetInterfaceStatistics@16
98 @ stub _PfMakeLog@4
99 @ stub _PfRebindFilters@8
100 @ stub _PfRemoveFilterHandles@12
101 @ stub _PfRemoveFiltersFromInterface@20
102 @ stub _PfRemoveGlobalFilterFromInterface@8
103 @ stub _PfSetLogBuffer@28
104 @ stub _PfTestPacket@20
105 @ stub _PfUnBindInterface@4
106 @ stdcall SendARP( long long ptr ptr )
107 @ stub SetAdapterIpAddress
108 @ stub SetBlockRoutes
109 @ stdcall SetIfEntry( ptr )
110 @ stub SetIfEntryToStack
111 @ stdcall SetIpForwardEntry( ptr )
112 @ stub SetIpForwardEntryToStack
113 @ stub SetIpMultihopRouteEntryToStack
114 @ stdcall SetIpNetEntry( ptr )
115 @ stub SetIpNetEntryToStack
116 @ stub SetIpRouteEntryToStack
117 @ stdcall SetIpStatistics( ptr )
118 @ stub SetIpStatsToStack
119 @ stdcall SetIpTTL( long )
120 @ stub SetProxyArpEntryToStack
121 @ stub SetRouteWithRef
122 @ stdcall SetTcpEntry( ptr )
123 @ stub SetTcpEntryToStack
124 @ stdcall UnenableRouter( ptr ptr )