push eb25bf65c4616aa55a810ed5c29198b1a080b208
[wine/hacks.git] / dlls / display.drv16 / display.drv16.spec
blobdc4ee5db8825c69acba70b5e1708febda852a351
1 1 stub BitBlt
2 2 stub ColorInfo
3 3 stub Control
4 4 stub Disable
5 5 stub Enable
6 6 stub EnumFonts
7 7 stub EnumObj
8 8 stub Output
9 9 stub Pixel
10 10 stub RealizeObject
11 11 stub StrBlt
12 12 stub ScanLR
13 13 stub DeviceMode
14 14 stub ExtTextOut
15 15 stub GetCharWidth
16 16 stub DeviceBitmap
17 17 stub FastBorder
18 18 stub SetAttribute
19 19 stub DeviceBitmapBits
20 20 stub CreateBitmap
21 21 stub DIBScreenBlt
23 # ATI driver exports
24 22 stub SetPalette
25 23 stub GetPalette
26 24 stub SetPaletteTranslate
27 25 stub GetPaletteTranslate
28 26 stub UpdateColors
29 27 stub StretchBlt
30 28 stub StretchDIBits
31 29 stub SelectBitmap
32 30 stub BitmapBits
33 31 stub ReEnable
34 # these conflict with ordinals 19-21, thus relocated to 39-41 !
35 39 stub DIBBlt
36 40 stub CreateDIBitmap
37 41 stub DIBToDevice
38 # ATI driver end
40 90 stub Do_Polylines
41 91 stub Do_Scanlines
42 92 stub SaveScreenBitmap
43 101 pascal -ret16 Inquire(ptr) Inquire16
44 102 pascal -ret16 SetCursor(ptr) DISPLAY_SetCursor
45 103 pascal -ret16 MoveCursor(word word) MoveCursor16
46 104 pascal -ret16 CheckCursor() CheckCursor16
47 400 stub PExtTextOut
48 401 stub PStrBlt
49 402 stub RExtTextOut
50 403 stub RStrBlt
51 450 pascal GetDriverResourceID(word str) GetDriverResourceID16
52 500 pascal -ret16 UserRepaintDisable(word) UserRepaintDisable16
53 501 stub ORDINAL_ONLY1
54 502 stub ORDINAL_ONLY2
55 600 stub InkReady
56 601 stub GetLPDevice