Release 970329
[wine.git] / if1632 / shell.spec
blob6fc4f64a78bb1d495adb302f292d8df0dd103a37
1 name shell
2 type win16
4 1 pascal RegOpenKey(long ptr ptr) RegOpenKey16
5 2 pascal RegCreateKey(long ptr ptr) RegCreateKey16
6 3 pascal RegCloseKey(long) RegCloseKey
7 4 pascal RegDeleteKey(long ptr) RegDeleteKey16
8 5 pascal RegSetValue(long ptr long ptr long) RegSetValue16
9 6 pascal RegQueryValue(long ptr ptr ptr) RegQueryValue16
10 7 pascal RegEnumKey(long long ptr long) RegEnumKey16
11 9 pascal16 DragAcceptFiles(word word) DragAcceptFiles
12 11 pascal16 DragQueryFile(word s_word ptr s_word) DragQueryFile
13 12 pascal16 DragFinish(word) DragFinish
14 13 pascal16 DragQueryPoint(word ptr) DragQueryPoint
15 20 pascal16 ShellExecute(word ptr ptr ptr ptr s_word) ShellExecute16
16 21 pascal16 FindExecutable(ptr ptr ptr) FindExecutable16
17 22 pascal16 ShellAbout(word ptr ptr word) ShellAbout16
18 33 pascal16 AboutDlgProc(word word word long) AboutDlgProc16
19 34 pascal16 ExtractIcon(word ptr s_word) ExtractIcon16
20 36 pascal16 ExtractAssociatedIcon(word ptr ptr) ExtractAssociatedIcon
21 37 pascal DoEnvironmentSubst(ptr word) DoEnvironmentSubst
22 38 pascal FindEnvironmentString(ptr) FindEnvironmentString
23 39 pascal16 InternalExtractIcon(word ptr s_word word) InternalExtractIcon
24 40 stub ExtractIconEx
25 98 stub SHL3216_THUNKDATA16
26 99 stub SHL1632_THUNKDATA16
28 #100 4 0550 HERETHARBETYGARS exported, shared data
29 #101 8 010e FINDEXEDLGPROC exported, shared data
30 #101 DLLENTRYPOINT #win95 SHELL.DLL
32 102 pascal16 RegisterShellHook(ptr) RegisterShellHook
33 103 pascal16 ShellHookProc() ShellHookProc
35 # 157 RESTARTDIALOG
36 # 166 PICKICONDLG
38 262 pascal16 DriveType(long) GetDriveType16
40 # 263 SH16TO32DRIVEIOCTL
41 # 264 SH16TO32INT2526
42 # 300 SHGETFILEINFO
43 # 400 SHFORMATDRIVE
44 401 stub SHCHECKDRIVE
45 # 402 _RUNDLLCHECKDRIVE
47 # 8 WEP
48 #32 WCI