Release 940201
[wine.git] / if1632 / user.spec
blob5303a7511b02c1b2018fe16b7bf96a91e7c96b13
1 # $Id: user.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
3 name user
4 id 2
5 length 540
7 1 pascal MessageBox(word ptr ptr word) MessageBox(1 2 3 4)
8 5 pascal InitApp(word) USER_InitApp(1)
9 6 pascal PostQuitMessage(word) PostQuitMessage(1)
10 10 pascal SetTimer(word word word ptr) SetTimer(1 2 3 4)
11 11 pascal SetSystemTimer(word word word ptr) SetSystemTimer(1 2 3 4)
12 12 pascal KillTimer(word word) KillTimer(1 2)
13 13 pascal GetTickCount() GetTickCount()
14 14 return GetTimerResolution 0 1000
15 15 pascal GetCurrentTime() GetTickCount()
16 16 pascal ClipCursor(ptr) ClipCursor(1)
17 17 pascal GetCursorPos(ptr) GetCursorPos(1)
18 18 pascal SetCapture(word) SetCapture(1)
19 19 pascal ReleaseCapture() ReleaseCapture()
20 20 pascal SetDoubleClickTime(word) SetDoubleClickTime(1)
21 21 pascal GetDoubleClickTime() GetDoubleClickTime()
22 22 pascal SetFocus(word) SetFocus(1)
23 23 pascal GetFocus() GetFocus()
24 28 pascal ClientToScreen(word ptr) ClientToScreen(1 2)
25 29 pascal ScreenToClient(word ptr) ScreenToClient(1 2)
26 30 pascal WindowFromPoint(long) WindowFromPoint(1)
27 31 pascal IsIconic(word) IsIconic(1)
28 32 pascal GetWindowRect(word ptr) GetWindowRect(1 2)
29 33 pascal GetClientRect(word ptr) GetClientRect(1 2)
30 34 pascal EnableWindow(word word) EnableWindow(1 2)
31 35 pascal IsWindowEnabled(word) IsWindowEnabled(1)
32 36 pascal GetWindowText(word ptr word) GetWindowText(1 2 3)
33 37 pascal SetWindowText(word ptr) SetWindowText(1 2)
34 38 pascal GetWindowTextLength(word) GetWindowTextLength(1)
35 39 pascal BeginPaint(word ptr) BeginPaint(1 2)
36 40 pascal EndPaint(word ptr) EndPaint(1 2)
37 41 pascal CreateWindow(ptr ptr long s_word s_word s_word s_word word word word ptr)
38 CreateWindow(1 2 3 4 5 6 7 8 9 10 11)
39 42 pascal ShowWindow(word word) ShowWindow(1 2)
40 43 pascal CloseWindow(word) CloseWindow(1)
41 44 pascal OpenIcon(word) OpenIcon(1)
42 45 pascal BringWindowToTop(word) BringWindowToTop(1)
43 46 pascal GetParent(word) GetParent(1)
44 47 pascal IsWindow(word) IsWindow(1)
45 48 pascal IsChild(word word) IsChild(1 2)
46 49 pascal IsWindowVisible(word) IsWindowVisible(1)
47 50 pascal FindWindow(ptr ptr) FindWindow(1 2)
48 53 pascal DestroyWindow(word) DestroyWindow(1)
49 54 pascal EnumWindows(ptr long) EnumWindows(1 2)
50 55 pascal EnumChildWindows(word ptr long) EnumChildWindows(1 2 3)
51 56 pascal MoveWindow(word word word word word word)
52 MoveWindow(1 2 3 4 5 6)
53 57 pascal RegisterClass(ptr) RegisterClass(1)
54 58 pascal GetClassName(word ptr word) GetClassName(1 2 3)
55 59 pascal SetActiveWindow(word) SetActiveWindow(1)
56 60 pascal GetActiveWindow() GetActiveWindow()
57 61 pascal ScrollWindow(word s_word s_word ptr ptr) ScrollWindow(1 2 3 4 5)
58 62 pascal SetScrollPos(word word word word) SetScrollPos(1 2 3 4)
59 63 pascal GetScrollPos(word word) GetScrollPos(1 2)
60 64 pascal SetScrollRange(word word word word word) SetScrollRange(1 2 3 4 5)
61 65 pascal GetScrollRange(word word ptr ptr) GetScrollRange(1 2 3 4)
62 66 pascal GetDC(word) GetDC(1)
63 67 pascal GetWindowDC(word) GetWindowDC(1)
64 68 pascal ReleaseDC(word word) ReleaseDC(1 2)
65 69 pascal SetCursor(word) SetCursor(1)
66 70 pascal SetCursorPos(word word) SetCursorPos(1 2)
67 71 pascal ShowCursor(word) ShowCursor(1)
68 72 pascal SetRect(ptr s_word s_word s_word s_word) SetRect(1 2 3 4 5)
69 73 pascal SetRectEmpty(ptr) SetRectEmpty(1)
70 74 pascal CopyRect(ptr ptr) CopyRect(1 2)
71 75 pascal IsRectEmpty(ptr) IsRectEmpty(1)
72 76 pascal PtInRect(ptr long) PtInRect(1 2)
73 77 pascal OffsetRect(ptr s_word s_word) OffsetRect(1 2 3)
74 78 pascal InflateRect(ptr s_word s_word) InflateRect(1 2 3)
75 79 pascal IntersectRect(ptr ptr ptr) IntersectRect(1 2 3)
76 80 pascal UnionRect(ptr ptr ptr) UnionRect(1 2 3)
77 81 pascal FillRect(word ptr word) FillRect(1 2 3)
78 82 pascal InvertRect(word ptr) InvertRect(1 2)
79 83 pascal FrameRect(word ptr word) FrameRect(1 2 3)
80 84 pascal DrawIcon(word s_word s_word word) DrawIcon(1 2 3 4)
81 85 pascal DrawText(word ptr s_word ptr word) DrawText(1 2 3 4 5)
82 87 pascal DialogBox(word ptr word ptr) DialogBox(1 2 3 4)
83 88 pascal EndDialog(word s_word) EndDialog(1 2)
84 89 pascal CreateDialog(word ptr word ptr) CreateDialog(1 2 3 4)
85 90 pascal IsDialogMessage(word ptr) IsDialogMessage(1 2)
86 91 pascal GetDlgItem(word word) GetDlgItem(1 2)
87 92 pascal SetDlgItemText(word word ptr) SetDlgItemText(1 2 3)
88 93 pascal GetDlgItemText(word word ptr word) GetDlgItemText(1 2 3 4)
89 94 pascal SetDlgItemInt(word word word word) SetDlgItemInt(1 2 3 4)
90 95 pascal GetDlgItemInt(word word ptr word) GetDlgItemInt(1 2 3 4)
91 96 pascal CheckRadioButton(word word word word) CheckRadioButton(1 2 3 4)
92 97 pascal CheckDlgButton(word word word) CheckDlgButton(1 2 3)
93 98 pascal IsDlgButtonChecked(word word) IsDlgButtonChecked(1 2)
94 101 pascal SendDlgItemMessage(word word word word long)
95 SendDlgItemMessage(1 2 3 4 5)
96 102 pascal AdjustWindowRect(ptr long word) AdjustWindowRect(1 2 3)
97 103 pascal MapDialogRect(word ptr) MapDialogRect(1 2)
98 104 pascal MessageBeep(word) MessageBeep(1)
99 106 pascal GetKeyState(word) GetKeyState(1)
100 107 pascal DefWindowProc(word word word long) DefWindowProc(1 2 3 4)
101 108 pascal GetMessage(ptr word word word) GetMessage(1 2 3 4)
102 109 pascal PeekMessage(ptr word word word word) PeekMessage(1 2 3 4 5)
103 110 pascal PostMessage(word word word long) PostMessage(1 2 3 4)
104 111 pascal SendMessage(word word word long) SendMessage(1 2 3 4)
105 113 pascal TranslateMessage(ptr) TranslateMessage(1)
106 114 pascal DispatchMessage(ptr) DispatchMessage(1)
107 118 pascal RegisterWindowMessage(ptr) RegisterWindowMessage(1)
108 119 pascal GetMessagePos() GetMessagePos()
109 120 pascal GetMessageTime() GetMessageTime()
110 122 pascal CallWindowProc(ptr word word word long) CallWindowProc(1 2 3 4 5)
111 124 pascal UpdateWindow(word) UpdateWindow(1)
112 125 pascal InvalidateRect(word ptr word) InvalidateRect(1 2 3)
113 126 pascal InvalidateRgn(word word word) InvalidateRgn(1 2 3)
114 127 pascal ValidateRect(word ptr) ValidateRect(1 2)
115 128 pascal ValidateRgn(word word) ValidateRgn(1 2)
116 129 pascal GetClassWord(word s_word) GetClassWord(1 2)
117 130 pascal SetClassWord(word s_word word) SetClassWord(1 2 3)
118 131 pascal GetClassLong(word s_word) GetClassLong(1 2)
119 132 pascal SetClassLong(word s_word long) SetClassLong(1 2 3)
120 133 pascal GetWindowWord(word s_word) GetWindowWord(1 2)
121 134 pascal SetWindowWord(word s_word word) SetWindowWord(1 2 3)
122 135 pascal GetWindowLong(word s_word) GetWindowLong(1 2)
123 136 pascal SetWindowLong(word s_word long) SetWindowLong(1 2 3)
124 150 pascal LoadMenu(word ptr) LoadMenu(1 2)
125 151 pascal CreateMenu() CreateMenu()
126 152 pascal DestroyMenu(word) DestroyMenu(1)
127 154 pascal CheckMenuItem(word word word) CheckMenuItem(1 2 3)
128 155 pascal EnableMenuItem(word word word) EnableMenuItem(1 2 3)
129 156 pascal GetSystemMenu(word word) GetSystemMenu(1 2)
130 157 pascal GetMenu(word) GetMenu(1)
131 158 pascal SetMenu(word word) SetMenu(1 2)
132 159 pascal GetSubMenu(word word) GetSubMenu(1 2)
133 160 pascal DrawMenuBar(word) DrawMenuBar(1)
134 163 pascal CreateCaret(word word word word) CreateCaret(1 2 3 4)
135 164 pascal DestroyCaret() DestroyCaret()
136 165 pascal SetCaretPos(word word) SetCaretPos(1 2)
137 166 pascal HideCaret(word) HideCaret(1)
138 167 pascal ShowCaret(word) ShowCaret(1)
139 166 pascal SetCaretBlinkTime(word) SetCaretBlinkTime(1)
140 169 pascal GetCaretBlinkTime() GetCaretBlinkTime()
141 171 pascal WinHelp(word word long) WinHelp(1 2 3)
142 173 pascal LoadCursor(word ptr) LoadCursor(1 2)
143 174 pascal LoadIcon(word ptr) LoadIcon(1 2)
144 175 pascal LoadBitmap(word ptr) LoadBitmap(1 2)
145 176 pascal LoadString(word word ptr s_word) LoadString(1 2 3 4)
146 177 pascal LoadAccelerators(word ptr) LoadAccelerators(1 2)
147 178 pascal TranslateAccelerator(word word ptr) TranslateAccelerator(1 2 3)
148 179 pascal GetSystemMetrics(word) GetSystemMetrics(1)
149 180 pascal GetSysColor(word) GetSysColor(1)
150 181 pascal SetSysColors(word ptr ptr) SetSysColors(1 2 3)
151 182 pascal KillSystemTimer(word word) KillSystemTimer(1 2)
152 183 pascal GetCaretPos(ptr) GetCaretPos(1)
153 190 pascal GetUpdateRect(word ptr word) GetUpdateRect(1 2 3)
154 191 pascal ChildWindowFromPoint(word long) ChildWindowFromPoint(1 2)
155 200 pascal OpenComm(ptr word word) OpenComm(1 2 3)
156 201 pascal SetCommState(ptr) SetCommState(1)
157 202 pascal GetCommState(word ptr) GetCommState(1 2)
158 203 pascal GetCommError(word ptr) GetCommError(1 2)
159 204 pascal ReadComm(word ptr word) ReadComm(1 2 3)
160 205 pascal WriteComm(word ptr word) WriteComm(1 2 3)
161 206 pascal TransmitCommChar(word byte) TransmitCommChar (1 2)
162 207 pascal CloseComm(word) CloseComm(1)
163 208 pascal SetCommEventMask(word word) SetCommEventMask(1 2)
164 209 pascal GetCommEventMask(word word) GetCommEventMask(1 2)
165 210 pascal SetCommBreak(word) SetCommBreak(1)
166 211 pascal ClearCommBreak(word) ClearCommBreak(1)
167 212 pascal UngetCommChar(word byte) UngetCommChar(1 2)
168 213 pascal BuildCommDCB(ptr ptr) BuildCommDCB(1 2)
169 214 pascal EscapeCommFunction(word word) EscapeCommFunction(1 2)
170 215 pascal FlushComm(word word) FlushComm(1 2)
171 218 pascal DialogBoxIndirect(word word word ptr) DialogBoxIndirect(1 2 3 4)
172 219 pascal CreateDialogIndirect(word ptr word ptr)
173 CreateDialogIndirect(1 2 3 4)
174 221 pascal ScrollDC(word s_word s_word ptr ptr word ptr)
175 ScrollDC(1 2 3 4 5 6 7)
176 227 pascal GetNextDlgGroupItem(word word word) GetNextDlgGroupItem(1 2 3)
177 228 pascal GetNextDlgTabItem(word word word) GetNextDlgTabItem(1 2 3)
178 229 pascal GetTopWindow(word) GetTopWindow(1)
179 230 pascal GetNextWindow(word word) GetNextWindow(1 2)
180 232 pascal SetWindowPos(word word word word word word word)
181 SetWindowPos(1 2 3 4 5 6 7)
182 236 pascal GetCapture() GetCapture()
183 237 pascal GetUpdateRgn(word word word) GetUpdateRgn(1 2 3)
184 239 pascal DialogBoxParam(word ptr word ptr long) DialogBoxParam(1 2 3 4 5)
185 240 pascal DialogBoxIndirectParam(word word word ptr long)
186 DialogBoxIndirectParam(1 2 3 4 5)
187 241 pascal CreateDialogParam(word ptr word ptr long)
188 CreateDialogParam(1 2 3 4 5)
189 242 pascal CreateDialogIndirectParam(word ptr word ptr long)
190 CreateDialogIndirectParam(1 2 3 4 5)
191 244 pascal EqualRect(ptr ptr) EqualRect(1 2)
192 258 pascal MapWindowPoints(word word ptr word) MapWindowPoints(1 2 3 4)
193 262 pascal GetWindow(word word) GetWindow(1 2)
194 266 pascal SetMessageQueue(word) SetMessageQueue(1)
195 267 pascal ShowScrollBar(word word word) ShowScrollBar(1 2 3)
196 272 pascal IsZoomed(word) IsZoomed(1)
197 277 pascal GetDlgCtrlID(word) GetDlgCtrlID(1)
198 282 pascal SelectPalette(word word word) SelectPalette(1 2 3)
199 283 pascal RealizePalette(word) RealizePalette(1)
200 286 pascal GetDesktopWindow() GetDesktopWindow()
201 288 pascal GetMessageExtraInfo() GetMessageExtraInfo()
202 319 pascal ScrollWindowEx(word s_word s_word ptr ptr word ptr word)
203 ScrollWindowEx(1 2 3 4 5 6 7 8)
204 324 pascal FillWindow(word word word word) FillWindow(1 2 3 4)
205 325 pascal PaintRect(word word word word ptr) PaintRect(1 2 3 4 5)
206 334 pascal GetQueueStatus(word) GetQueueStatus(1)
207 335 pascal GetInputState() GetInputState()
208 359 pascal GetDCEx(word word long) GetDCEx(1 2 3)
209 370 pascal GetWindowPlacement(word ptr) GetWindowPlacement(1 2)
210 371 pascal SetWindowPlacement(word ptr) SetWindowPlacement(1 2)
211 373 pascal SubtractRect(ptr ptr ptr) SubtractRect(1 2 3)
212 403 pascal UnregisterClass(ptr word) UnregisterClass(1 2)
213 404 pascal GetClassInfo(word ptr ptr) GetClassInfo(1 2 3)
214 406 pascal CreateCursor(word word word word word ptr ptr)
215 CreateCursor(1 2 3 4 5 6 7)
216 410 pascal InsertMenu(word word word word ptr) InsertMenu(1 2 3 4 5)
217 411 pascal AppendMenu(word word word ptr) AppendMenu(1 2 3 4)
218 412 pascal RemoveMenu(word word word) RemoveMenu(1 2 3)
219 413 pascal DeleteMenu(word word word) DeleteMenu(1 2 3)
220 414 pascal ModifyMenu(word word word word ptr) ModifyMenu(1 2 3 4 5)
221 415 pascal CreatePopupMenu() CreatePopupMenu()
222 416 pascal TrackPopupMenu(word word word word word word ptr)
223 TrackPopupMenu(1 2 3 4 5 6 7)
224 418 pascal SetMenuItemBitmaps(word word word word word)
225 SetMenuItemBitmaps(1 2 3 4 5)
226 420 pascal wsprintf(ptr ptr) wsprintf(1 2)
227 421 pascal wvsprintf(ptr ptr ptr) wvsprintf(1 2 3)
228 430 pascal lstrcmp(ptr ptr) lstrcmp(1 2)
229 431 pascal AnsiUpper(ptr) AnsiUpper(1)
230 432 pascal AnsiLower(ptr) AnsiLower(1)
231 433 pascal IsCharAlpha(byte) IsCharAlpha(1)
232 434 pascal IsCharAlphanumeric(byte) IsCharAlphanumeric(1)
233 435 pascal IsCharUpper(byte) IsCharUpper(1)
234 436 pascal IsCharLower(byte) IsCharLower(1)
235 437 pascal AnsiUpperBuff(ptr word) AnsiUpperBuff(1 2)
236 438 pascal AnsiLowerBuff(ptr word) AnsiLowerBuff(1 2)
237 452 pascal CreateWindowEx(long ptr ptr long s_word s_word s_word s_word
238 word word word ptr)
239 CreateWindowEx(1 2 3 4 5 6 7 8 9 10 11 12)
240 454 pascal AdjustWindowRectEx(ptr long word long) AdjustWindowRectEx(1 2 3 4)
241 457 pascal DestroyIcon(word) DestroyIcon(1)
242 458 pascal DestroyCursor(word) DestroyCursor(1)
243 460 pascal GetInternalWindowPos(word ptr ptr) GetInternalWindowPos(1 2 3)
244 461 pascal SetInternalWindowPos(word word ptr ptr) SetInternalWindowPos(1 2 3 4)
245 466 pascal DrawFocusRect(word ptr) DrawFocusRect(1 2)
246 471 pascal lstrcmpi(ptr ptr) lstrcmpi(1 2)
247 472 pascal AnsiNext(ptr) AnsiNext(1 )
248 473 pascal AnsiPrev(ptr ptr) AnsiPrev(1 2)