msvcrt: Add scheduler_resource_allocation_error class implementation.
[wine.git] / dlls / combase / combase.spec
blobb612bef9c57535b913a80a5a7aed1cc8393965c9
1 @ stub ObjectStublessClient3
2 @ stub ObjectStublessClient4
3 @ stub ObjectStublessClient5
4 @ stub ObjectStublessClient6
5 @ stub ObjectStublessClient7
6 @ stub ObjectStublessClient8
7 @ stub ObjectStublessClient9
8 @ stub ObjectStublessClient10
9 @ stub ObjectStublessClient11
10 @ stub ObjectStublessClient12
11 @ stub ObjectStublessClient13
12 @ stub ObjectStublessClient14
13 @ stub ObjectStublessClient15
14 @ stub ObjectStublessClient16
15 @ stub ObjectStublessClient17
16 @ stub ObjectStublessClient18
17 @ stub ObjectStublessClient19
18 @ stub ObjectStublessClient20
19 @ stub ObjectStublessClient21
20 @ stub ObjectStublessClient22
21 @ stub ObjectStublessClient23
22 @ stub ObjectStublessClient24
23 @ stub ObjectStublessClient25
24 @ stub ObjectStublessClient26
25 @ stub ObjectStublessClient27
26 @ stub ObjectStublessClient28
27 @ stub ObjectStublessClient29
28 @ stub ObjectStublessClient30
29 @ stub ObjectStublessClient31
30 @ stub ObjectStublessClient32
31 @ stub NdrProxyForwardingFunction3
32 @ stub NdrProxyForwardingFunction4
33 @ stub NdrProxyForwardingFunction5
34 @ stub NdrProxyForwardingFunction6
35 @ stub NdrProxyForwardingFunction7
36 @ stub NdrProxyForwardingFunction8
37 @ stub NdrProxyForwardingFunction9
38 @ stub NdrProxyForwardingFunction10
39 @ stub NdrProxyForwardingFunction11
40 @ stub NdrProxyForwardingFunction12
41 @ stub NdrProxyForwardingFunction13
42 @ stub NdrProxyForwardingFunction14
43 @ stub NdrProxyForwardingFunction15
44 @ stub NdrProxyForwardingFunction16
45 @ stub NdrProxyForwardingFunction17
46 @ stub NdrProxyForwardingFunction18
47 @ stub NdrProxyForwardingFunction19
48 @ stub NdrProxyForwardingFunction20
49 @ stub NdrProxyForwardingFunction21
50 @ stub NdrProxyForwardingFunction22
51 @ stub NdrProxyForwardingFunction23
52 @ stub NdrProxyForwardingFunction24
53 @ stub NdrProxyForwardingFunction25
54 @ stub NdrProxyForwardingFunction26
55 @ stub NdrProxyForwardingFunction27
56 @ stub NdrProxyForwardingFunction28
57 @ stub NdrProxyForwardingFunction29
58 @ stub NdrProxyForwardingFunction30
59 @ stub NdrProxyForwardingFunction31
60 @ stub NdrProxyForwardingFunction32
61 @ stub NdrOleInitializeExtension
62 @ stub RoFailFastWithErrorContextInternal2
63 @ stub RoFailFastWithErrorContextInternal
64 @ stub UpdateProcessTracing
65 @ stub CLSIDFromOle1Class
66 @ stdcall CLSIDFromProgID(wstr ptr) ole32.CLSIDFromProgID
67 @ stdcall CLSIDFromString(wstr ptr) ole32.CLSIDFromString
68 @ stub CleanupOleStateInAllTls
69 @ stub CleanupTlsOleState
70 @ stub ClearCleanupFlag
71 @ stdcall CoAddRefServerProcess() ole32.CoAddRefServerProcess
72 @ stub CoAllowUnmarshalerCLSID
73 @ stub CoCancelCall
74 @ stdcall CoCopyProxy(ptr ptr) ole32.CoCopyProxy
75 @ stub CoCreateErrorInfo
76 @ stdcall CoCreateFreeThreadedMarshaler(ptr ptr) ole32.CoCreateFreeThreadedMarshaler
77 @ stdcall CoCreateGuid(ptr) ole32.CoCreateGuid
78 @ stdcall CoCreateInstance(ptr ptr long ptr ptr) ole32.CoCreateInstance
79 @ stdcall CoCreateInstanceEx(ptr ptr long ptr long ptr) ole32.CoCreateInstanceEx
80 @ stub CoCreateInstanceFromApp
81 @ stub CoCreateObjectInContext
82 @ stub CoDeactivateObject
83 @ stub CoDecodeProxy
84 @ stub CoDecrementMTAUsage
85 @ stub CoDisableCallCancellation
86 @ stub CoDisconnectContext
87 @ stdcall CoDisconnectObject(ptr long) ole32.CoDisconnectObject
88 @ stub CoEnableCallCancellation
89 @ stdcall CoFreeUnusedLibraries() ole32.CoFreeUnusedLibraries
90 @ stdcall CoFreeUnusedLibrariesEx(long long) ole32.CoFreeUnusedLibrariesEx
91 @ stdcall CoGetActivationState(int128 long ptr) ole32.CoGetActivationState
92 @ stub CoGetApartmentID
93 @ stdcall CoGetApartmentType(ptr ptr) ole32.CoGetApartmentType
94 @ stdcall CoGetCallContext(ptr ptr) ole32.CoGetCallContext
95 @ stdcall CoGetCallState(long ptr) ole32.CoGetCallState
96 @ stdcall CoGetCallerTID(ptr) ole32.CoGetCallerTID
97 @ stub CoGetCancelObject
98 @ stdcall CoGetClassObject(ptr long ptr ptr ptr) ole32.CoGetClassObject
99 @ stub CoGetClassVersion
100 @ stdcall CoGetContextToken(ptr) ole32.CoGetContextToken
101 @ stdcall CoGetCurrentLogicalThreadId(ptr) ole32.CoGetCurrentLogicalThreadId
102 @ stdcall CoGetCurrentProcess() ole32.CoGetCurrentProcess
103 @ stdcall CoGetDefaultContext(long ptr ptr) ole32.CoGetDefaultContext
104 @ stub CoGetErrorInfo
105 @ stdcall CoGetInstanceFromFile(ptr ptr ptr long long wstr long ptr) ole32.CoGetInstanceFromFile
106 @ stdcall CoGetInstanceFromIStorage(ptr ptr ptr long ptr long ptr) ole32.CoGetInstanceFromIStorage
107 @ stdcall CoGetInterfaceAndReleaseStream(ptr ptr ptr) ole32.CoGetInterfaceAndReleaseStream
108 @ stdcall CoGetMalloc(long ptr) ole32.CoGetMalloc
109 @ stdcall CoGetMarshalSizeMax(ptr ptr ptr long ptr long) ole32.CoGetMarshalSizeMax
110 @ stub CoGetModuleType
111 @ stdcall CoGetObjectContext(ptr ptr) ole32.CoGetObjectContext
112 @ stdcall CoGetPSClsid(ptr ptr) ole32.CoGetPSClsid
113 @ stub CoGetProcessIdentifier
114 @ stdcall CoGetStandardMarshal(ptr ptr long ptr long ptr) ole32.CoGetStandardMarshal
115 @ stub CoGetStdMarshalEx
116 @ stub CoGetSystemSecurityPermissions
117 @ stdcall CoGetTreatAsClass(ptr ptr) ole32.CoGetTreatAsClass
118 @ stdcall CoImpersonateClient() ole32.CoImpersonateClient
119 @ stub CoIncrementMTAUsage
120 @ stdcall CoInitializeEx(ptr long) ole32.CoInitializeEx
121 @ stdcall CoInitializeSecurity(ptr long ptr ptr long long ptr long ptr) ole32.CoInitializeSecurity
122 @ stdcall CoInitializeWOW(long long) ole32.CoInitializeWOW
123 @ stub CoInvalidateRemoteMachineBindings
124 @ stdcall CoIsHandlerConnected(ptr) ole32.CoIsHandlerConnected
125 @ stdcall CoLockObjectExternal(ptr long long) ole32.CoLockObjectExternal
126 @ stdcall CoMarshalHresult(ptr long) ole32.CoMarshalHresult
127 @ stdcall CoMarshalInterThreadInterfaceInStream(ptr ptr ptr) ole32.CoMarshalInterThreadInterfaceInStream
128 @ stdcall CoMarshalInterface(ptr ptr ptr long ptr long) ole32.CoMarshalInterface
129 @ stub CoPopServiceDomain
130 @ stub CoPushServiceDomain
131 @ stub CoQueryAuthenticationServices
132 @ stdcall CoQueryClientBlanket(ptr ptr ptr ptr ptr ptr ptr) ole32.CoQueryClientBlanket
133 @ stdcall CoQueryProxyBlanket(ptr ptr ptr ptr ptr ptr ptr ptr) ole32.CoQueryProxyBlanket
134 @ stub CoReactivateObject
135 @ stub CoRegisterActivationFilter
136 @ stdcall CoRegisterClassObject(ptr ptr long long ptr) ole32.CoRegisterClassObject
137 @ stdcall CoRegisterInitializeSpy(ptr ptr) ole32.CoRegisterInitializeSpy
138 @ stdcall CoRegisterMallocSpy(ptr) ole32.CoRegisterMallocSpy
139 @ stdcall CoRegisterMessageFilter(ptr ptr) ole32.CoRegisterMessageFilter
140 @ stdcall CoRegisterPSClsid(ptr ptr) ole32.CoRegisterPSClsid
141 @ stub CoRegisterSurrogate
142 @ stub CoRegisterSurrogateEx
143 @ stdcall CoReleaseMarshalData(ptr) ole32.CoReleaseMarshalData
144 @ stdcall CoReleaseServerProcess() ole32.CoReleaseServerProcess
145 @ stdcall CoResumeClassObjects() ole32.CoResumeClassObjects
146 @ stub CoRetireServer
147 @ stdcall CoRevertToSelf() ole32.CoRevertToSelf
148 @ stdcall CoRevokeClassObject(long) ole32.CoRevokeClassObject
149 @ stdcall CoRevokeInitializeSpy(int64) ole32.CoRevokeInitializeSpy
150 @ stdcall CoRevokeMallocSpy() ole32.CoRevokeMallocSpy
151 @ stub CoSetCancelObject
152 @ stub CoSetErrorInfo
153 @ stdcall CoSetProxyBlanket(ptr long long ptr long long ptr long) ole32.CoSetProxyBlanket
154 @ stdcall CoSuspendClassObjects() ole32.CoSuspendClassObjects
155 @ stdcall CoSwitchCallContext(ptr ptr) ole32.CoSwitchCallContext
156 @ stdcall CoTaskMemAlloc(long) ole32.CoTaskMemAlloc
157 @ stdcall CoTaskMemFree(ptr) ole32.CoTaskMemFree
158 @ stdcall CoTaskMemRealloc(ptr long) ole32.CoTaskMemRealloc
159 @ stub CoTestCancel
160 @ stdcall CoUninitialize() ole32.CoUninitialize
161 @ stub CoUnloadingWOW
162 @ stdcall CoUnmarshalHresult(ptr ptr) ole32.CoUnmarshalHresult
163 @ stdcall CoUnmarshalInterface(ptr ptr ptr) ole32.CoUnmarshalInterface
164 @ stub CoVrfCheckThreadState
165 @ stub CoVrfGetThreadState
166 @ stub CoVrfReleaseThreadState
167 @ stdcall CoWaitForMultipleHandles(long long long ptr ptr) ole32.CoWaitForMultipleHandles
168 @ stub CoWaitForMultipleObjects
169 @ stdcall CreateErrorInfo(ptr) ole32.CreateErrorInfo
170 @ stdcall CreateStreamOnHGlobal(ptr long ptr) ole32.CreateStreamOnHGlobal
171 @ stub DcomChannelSetHResult
172 @ stdcall DllDebugObjectRPCHook(long ptr) ole32.DllDebugObjectRPCHook
173 @ stub DllGetActivationFactory
174 @ stdcall -private DllGetClassObject(ptr ptr ptr) ole32.DllGetClassObject
175 @ stub EnableHookObject
176 @ stdcall FreePropVariantArray(long ptr) ole32.FreePropVariantArray
177 @ stub FreePropVariantArrayWorker
178 @ stub GetCatalogHelper
179 @ stdcall GetErrorInfo(long ptr) ole32.GetErrorInfo
180 @ stub GetFuncDescs
181 @ stdcall GetHGlobalFromStream(ptr ptr) ole32.GetHGlobalFromStream
182 @ stub GetHookInterface
183 @ stub GetRestrictedErrorInfo
184 @ stub HSTRING_UserFree
185 @ stub HSTRING_UserFree64
186 @ stub HSTRING_UserMarshal
187 @ stub HSTRING_UserMarshal64
188 @ stub HSTRING_UserSize
189 @ stub HSTRING_UserSize64
190 @ stub HSTRING_UserUnmarshal
191 @ stub HSTRING_UserUnmarshal64
192 @ stub HkOleRegisterObject
193 @ stdcall IIDFromString(wstr ptr) ole32.IIDFromString
194 @ stub InternalAppInvokeExceptionFilter
195 @ stub InternalCCFreeUnused
196 @ stub InternalCCGetClassInformationForDde
197 @ stub InternalCCGetClassInformationFromKey
198 @ stub InternalCCSetDdeServerWindow
199 @ stub InternalCMLSendReceive
200 @ stub InternalCallAsProxyExceptionFilter
201 @ stub InternalCallFrameExceptionFilter
202 @ stub InternalCallerIsAppContainer
203 @ stub InternalCanMakeOutCall
204 @ stub InternalCoIsSurrogateProcess
205 @ stub InternalCoRegisterDisconnectCallback
206 @ stub InternalCoRegisterSurrogatedObject
207 @ stub InternalCoStdMarshalObject
208 @ stub InternalCoUnregisterDisconnectCallback
209 @ stub InternalCompleteObjRef
210 @ stub InternalCreateCAggId
211 @ stub InternalCreateIdentityHandler
212 @ stub InternalDoATClassCreate
213 @ stub InternalFillLocalOXIDInfo
214 @ stub InternalFreeObjRef
215 @ stub InternalGetWindowPropInterface
216 @ stub InternalIrotEnumRunning
217 @ stub InternalIrotGetObject
218 @ stub InternalIrotGetTimeOfLastChange
219 @ stub InternalIrotIsRunning
220 @ stub InternalIrotNoteChangeTime
221 @ stub InternalIrotRegister
222 @ stub InternalIrotRevoke
223 @ stub InternalIsApartmentInitialized
224 @ stub InternalIsProcessInitialized
225 @ stub InternalMarshalObjRef
226 @ stub InternalNotifyDDStartOrStop
227 @ stub InternalOleModalLoopBlockFn
228 @ stub InternalRegisterWindowPropInterface
229 @ stub InternalReleaseMarshalObjRef
230 @ stub InternalSTAInvoke
231 @ stub InternalServerExceptionFilter
232 @ stub InternalSetAptCallCtrlOnTlsIfRequired
233 @ stub InternalSetOleThunkWowPtr
234 @ stub InternalStubInvoke
235 @ stub InternalTlsAllocData
236 @ stub InternalUnmarshalObjRef
237 @ stub IsErrorPropagationEnabled
238 @ stub NdrExtStubInitialize
239 @ stub NdrOleDllGetClassObject
240 @ stub NdrpFindInterface
241 @ stdcall ProgIDFromCLSID(ptr ptr) ole32.ProgIDFromCLSID
242 @ stdcall PropVariantClear(ptr) ole32.PropVariantClear
243 @ stdcall PropVariantCopy(ptr ptr) ole32.PropVariantCopy
244 @ stub ReleaseFuncDescs
245 @ stub RoActivateInstance
246 @ stub RoCaptureErrorContext
247 @ stub RoClearError
248 @ stub RoFailFastWithErrorContext
249 @ stub RoFreeParameterizedTypeExtra
250 @ stub RoGetActivatableClassRegistration
251 @ stdcall RoGetActivationFactory(ptr ptr ptr)
252 @ stub RoGetAgileReference
253 @ stub RoGetApartmentIdentifier
254 @ stub RoGetErrorReportingFlags
255 @ stub RoGetMatchingRestrictedErrorInfo
256 @ stub RoGetParameterizedTypeInstanceIID
257 @ stub RoGetServerActivatableClasses
258 @ stdcall RoInitialize(long)
259 @ stub RoInspectCapturedStackBackTrace
260 @ stub RoInspectThreadErrorInfo
261 @ stub RoOriginateError
262 @ stub RoOriginateErrorW
263 @ stub RoOriginateLanguageException
264 @ stub RoParameterizedTypeExtraGetTypeSignature
265 @ stub RoRegisterActivationFactories
266 @ stub RoRegisterForApartmentShutdown
267 @ stub RoReportCapabilityCheckFailure
268 @ stub RoReportFailedDelegate
269 @ stub RoReportUnhandledError
270 @ stub RoResolveRestrictedErrorInfoReference
271 @ stub RoRevokeActivationFactories
272 @ stub RoSetErrorReportingFlags
273 @ stub RoTransformError
274 @ stub RoTransformErrorW
275 @ stdcall RoUninitialize()
276 @ stub RoUnregisterForApartmentShutdown
277 @ stub SetCleanupFlag
278 @ stdcall SetErrorInfo(long ptr) ole32.SetErrorInfo
279 @ stub SetRestrictedErrorInfo
280 @ stdcall StringFromCLSID(ptr ptr) ole32.StringFromCLSID
281 @ stdcall StringFromGUID2(ptr ptr long) ole32.StringFromGUID2
282 @ stdcall StringFromIID(ptr ptr) ole32.StringFromIID
283 @ stub UpdateDCOMSettings
284 @ stdcall WdtpInterfacePointer_UserMarshal(ptr long ptr ptr ptr) ole32.WdtpInterfacePointer_UserMarshal
285 @ stub WdtpInterfacePointer_UserMarshal64
286 @ stdcall WdtpInterfacePointer_UserSize(ptr long ptr long ptr) ole32.WdtpInterfacePointer_UserSize
287 @ stub WdtpInterfacePointer_UserSize64
288 @ stdcall WdtpInterfacePointer_UserUnmarshal(ptr ptr ptr ptr) ole32.WdtpInterfacePointer_UserUnmarshal
289 @ stub WdtpInterfacePointer_UserUnmarshal64
290 @ stdcall WindowsCompareStringOrdinal(ptr ptr ptr)
291 @ stdcall WindowsConcatString(ptr ptr ptr)
292 @ stdcall WindowsCreateString(wstr long ptr)
293 @ stdcall WindowsCreateStringReference(wstr long ptr ptr)
294 @ stdcall WindowsDeleteString(ptr)
295 @ stdcall WindowsDeleteStringBuffer(ptr)
296 @ stdcall WindowsDuplicateString(ptr ptr)
297 @ stdcall WindowsGetStringLen(ptr)
298 @ stdcall WindowsGetStringRawBuffer(ptr ptr)
299 @ stub WindowsInspectString
300 @ stdcall WindowsIsStringEmpty(ptr)
301 @ stdcall WindowsPreallocateStringBuffer(long ptr ptr)
302 @ stdcall WindowsPromoteStringBuffer(ptr ptr)
303 @ stub WindowsReplaceString
304 @ stdcall WindowsStringHasEmbeddedNull(ptr ptr)
305 @ stdcall WindowsSubstring(ptr long ptr)
306 @ stdcall WindowsSubstringWithSpecifiedLength(ptr long long ptr)
307 @ stdcall WindowsTrimStringEnd(ptr ptr ptr)
308 @ stdcall WindowsTrimStringStart(ptr ptr ptr)