Adjust title underlines.
[wammu.git] / wammu.spec
blob329629d8fdfe2169861a884f31a08c69bf78ca7f
1 Name wammu
2 Version: 0.32
3 Release: 1
5 %define extension bz2
7 %define python_gammu_req 0.24
9 %{!?__python: %define __python python}
10 %define wammu_python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0)")
12 Summary: Mobile phone manager
13 Source: http://dl.cihar.com/%{name}/latest/%{name}-%{version}.tar.%{extension}
14 License: GPLv2
15 %if 0%{?suse_version}
16 Group: Hardware/Mobile
17 %else
18 Group: Applications/Communications
19 %endif
20 Vendor: Michal Čihař <michal@cihar.com>
22 Requires: wxPython >= 2.6, python-gammu >= %{python_gammu_req}, python-xml
23 BuildRequires: python-devel
24 %if 0%{?suse_version}
25 BuildRequires: update-desktop-files
26 %endif
27 %if 0%{?fedora_version} || 0%{?centos_version} || 0%{?rhel_version} || 0%{?fedora} || 0%{?rhel}
28 BuildRequires: desktop-file-utils
29 %endif
30 %{?py_requires}
32 Url: http://wammu.eu/
33 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34 # These distributions use /usr/lib for python on all architectures
35 %if 0%{?fedora_version} || 0%{?centos_version} || 0%{?rhel_version} || 0%{?fedora} || 0%{?rhel} || 0%{?mandriva_version}
36 BuildArch: noarch
37 %endif
39 %description
40 It works with any phone that Gammu supports, including many models from
41 Nokia, Siemens, and Alcatel. It has complete support (read, edit,
42 delete, copy) for contacts, todo, and calendar. It can read, save, and
43 send SMS. It includes an SMS composer for multi-part SMS messages, and
44 it can display SMS messages that include pictures. Currently, only text
45 and predefined bitmaps or sounds can be edited in the SMS composer. It
46 can export messages to an IMAP4 server (or other email storage).
48 This program does not support browsing files in phone, use gMobileMedia
49 instead.
52 %prep
53 %setup -q
55 %build
56 CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
58 %install
59 %if 0%{?suse_version} == 0
60 rm -rf %buildroot
61 mkdir %buildroot
62 %endif
63 %{__python} setup.py install --root=%buildroot --prefix=%{_prefix}
64 %if 0%{?fedora_version} || 0%{?centos_version} || 0%{?rhel_version} || 0%{?fedora} || 0%{?rhel}
65 %{__python} setup.py install -O1 --root=%buildroot --prefix=%{_prefix}
66 %endif
67 %find_lang %{name}
68 %if 0%{?suse_version}
69 %suse_update_desktop_file %{name}
70 %endif
71 %if 0%{?fedora_version} || 0%{?centos_version} || 0%{?rhel_version} || 0%{?fedora} || 0%{?rhel}
72 desktop-file-install --vendor "" \
73 --dir %buildroot%{_datadir}/applications \
74 --mode 0644 \
75 --remove-category=Application \
76 %buildroot%{_datadir}/applications/%{name}.desktop
77 %endif
79 %clean
80 rm -rf %buildroot
82 %files -f %name.lang
83 %defattr(-,root,root)
84 %doc COPYING AUTHORS FAQ README PKG-INFO ChangeLog
85 %{_mandir}/man1/*
86 %{_bindir}/%{name}
87 %{_bindir}/%{name}-configure
88 %{_datadir}/Wammu
89 %{_datadir}/pixmaps/*
90 %{_datadir}/applications/%{name}.desktop
91 %{wammu_python_sitelib}/*
93 %changelog
94 * Fri Apr 3 2009 Michal Čihař <michal@cihar.com> - 0.31-1
95 - do not define own %version, %name, %rel
96 - do not delete build root on SUSE
98 * Fri Oct 24 2008 Michal Čihař <michal@cihar.com> - 0.29-1
99 - fixed according to Fedora policy
101 * Wed Oct 8 2008 michal@cihar.com
102 - do not make it noarch package because it is sometimes in lib64 dir
103 * Mon Jan 05 2004 michal@cihar.com
104 - initial packaging
105 - see Git log for changelog