Release 1.14.0 -- Buddy photo & ADFS support, Web Ticket Optimizations
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob28c8c9ca96a8ef3dbbce1174dc23088892bd79b3
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL)
7 # Mandriva
8 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_11.4" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_11.4" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %define purple_develname libpurple-devel
83 %if 0%{?mdkversion} >= 200910
84 %ifarch x86_64
85 %define purple_develname lib64purple-devel
86 %endif
87 %if 0%{?mdkversion} >= 201000
88 %ifnarch x86_64
89 %define has_libnice 1
90 %endif
91 %endif
92 %endif
94 %if 0%{?suse_version}
95 %define nss_develname mozilla-nss-devel
96 %if 0%{?suse_version} >= 1120
97 %define has_libnice 1
98 %if 0%{?suse_version} > 1140
99 %define has_gstreamer 1
100 %if 0%{?suse_version} > 1210
101 %define build_telepathy 1
102 %endif
103 %endif
104 %endif
105 %else
106 %define nss_develname nss-devel
107 %endif
109 %if 0%{?suse_version} || 0%{?sles_version}
110 %define pkg_group Productivity/Networking/Instant Messenger
111 %endif
112 %if 0%{?fedora}
113 %define pkg_group Applications/Internet
114 %if 0%{?fedora} >= 11
115 %define has_libnice 1
116 %if 0%{?fedora} >= 15
117 %define has_gstreamer 1
118 %if 0%{?fedora} >= 17
119 %define build_telepathy 1
120 %define build_ktp 1
121 %endif
122 %endif
123 %endif
124 %endif
125 %if 0%{?mdkversion}
126 %define pkg_group Networking/Instant messaging
127 %else
128 %define pkg_group Applications/Internet
129 %endif
131 %if 0%{?purple_sipe_mingw32}
132 Name: mingw32-pidgin-sipe
133 %else
134 %if 0%{?purple_sipe_mingw64}
135 Name: mingw64-pidgin-sipe
136 %else
137 Name: pidgin-sipe
138 %endif
139 %endif
140 Summary: Pidgin protocol plugin to connect to MS Office Communicator
141 Version: 1.14.0
142 Release: 1
143 Source: pidgin-sipe-%{version}.tar.gz
144 Group: %{pkg_group}
145 License: GPL-2.0+
146 URL: http://sipe.sourceforge.net/
148 BuildRoot: %{_tmppath}/%{name}-%{version}-build
150 %if 0%{?mingw_prefix:1}
152 # Windows cross-compilation build setup
154 BuildArch: noarch
155 #!BuildIgnore: post-build-checks
157 BuildRequires: %{mingw_prefix}filesystem >= 23
158 BuildRequires: %{mingw_prefix}cross-gcc
159 BuildRequires: %{mingw_prefix}cross-binutils
160 BuildRequires: %{mingw_prefix}gettext-runtime
161 BuildRequires: %{mingw_prefix}cross-pkg-config
162 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
163 BuildRequires: %{mingw_prefix}libxml2-devel
164 BuildRequires: %{mingw_prefix}mozilla-nss-devel
165 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
166 BuildRequires: %{mingw_prefix}cross-nsis
168 # For directory ownership
169 BuildRequires: %{mingw_prefix}pidgin
171 # Make sure telepathy is disabled for Windows builds
172 %undefine build_telepathy
174 %else
176 # Standard Linux build setup
178 BuildRequires: %{purple_develname} >= 2.4.0
179 BuildRequires: libxml2-devel
180 BuildRequires: %{nss_develname}
181 BuildRequires: gettext-devel
182 # The following two are required to enable Voice & Video features
183 %if 0%{?has_libnice:1}
184 BuildRequires: libnice-devel
185 %endif
186 %if 0%{?has_gstreamer:1}
187 BuildRequires: pkgconfig(gstreamer-0.10)
188 %endif
189 # Requirements for telepathy backend
190 %if 0%{?build_telepathy:1}
191 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
192 BuildRequires: gmime-devel
193 BuildRequires: glib2-devel >= 2.28.0
194 %endif
196 # Configurable components
197 %if !0%{?_without_kerberos:1}
198 BuildRequires: krb5-devel
199 %endif
201 # For directory ownership
202 BuildRequires: pidgin
203 %if 0%{?build_telepathy:1}
204 BuildRequires: empathy
205 %endif
206 Requires: pidgin
207 %if 0%{?sles_version} == 10
208 BuildRequires: gnome-keyring-devel
209 %endif
211 # For OBS's "have choice for" for Fedora 11 (only)
212 %if 0%{?fedora_version} == 11
213 BuildRequires: libproxy-mozjs
214 BuildRequires: PolicyKit-gnome
215 %endif
217 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
218 %if 0%{?mdkversion} >= 201010
219 BuildRequires: polkit-gnome
220 %endif
222 # For OBS's "have choice for" for Mandriva 2011 (and up?)
223 %if 0%{?mdkversion} >= 201100
224 BuildRequires: packagekit-gstreamer-plugin
225 BuildRequires: gnome-packagekit-common
226 %endif
228 # End Windows cross-compilation/Linux build setup
229 %endif
231 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
232 BuildRequires: libtool
233 BuildRequires: intltool
234 BuildRequires: glib2-devel >= 2.12.0
237 %description
238 A third-party plugin for the Pidgin multi-protocol instant messenger.
239 It implements the extended version of SIP/SIMPLE used by various products:
241 * Microsoft Lync Server 2010
242 * Microsoft Office Communications Server (OCS 2007/2007 R2)
243 * Microsoft Live Communications Server (LCS 2003/2005)
244 * Reuters Messaging
246 With this plugin you should be able to replace your Microsoft Office
247 Communicator client with Pidgin.
249 This package provides the icon set for Pidgin.
252 %package -n %{purple_plugin}
253 Summary: Libpurple protocol plugin to connect to MS Office Communicator
254 Group: %{pkg_group}
255 License: GPL-2.0+
256 Obsoletes: purple-sipe
257 %if 0%{?build_telepathy:1}
258 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
259 %endif
261 %description -n %{purple_plugin}
262 A third-party plugin for the Pidgin multi-protocol instant messenger.
263 It implements the extended version of SIP/SIMPLE used by various products:
265 * Microsoft Lync Server 2010
266 * Microsoft Office Communications Server (OCS 2007/2007 R2)
267 * Microsoft Live Communications Server (LCS 2003/2005)
268 * Reuters Messaging
270 This package provides the protocol plugin for libpurple clients.
273 %if 0%{?build_telepathy:1}
274 %package -n %{empathy_files}
275 Summary: Telepathy connection manager to connect to MS Office Communicator
276 Group: %{pkg_group}
277 License: GPL-2.0+
278 Requires: empathy
279 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
281 %description -n %{empathy_files}
282 A Telepathy connection manager that implements the extended version of
283 SIP/SIMPLE used by various products:
285 * Microsoft Lync Server 2010
286 * Microsoft Office Communications Server (OCS 2007/2007 R2)
287 * Microsoft Live Communications Server (LCS 2003/2005)
288 * Reuters Messaging
290 This package provides the icon set for Empathy.
293 %if 0%{?build_ktp:1}
294 %package -n %{ktp_files}
295 Summary: Telepathy connection manager to connect to MS Office Communicator
296 Group: %{pkg_group}
297 License: GPL-2.0+
298 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
300 %description -n %{ktp_files}
301 A Telepathy connection manager that implements the extended version of
302 SIP/SIMPLE used by various products:
304 * Microsoft Lync Server 2010
305 * Microsoft Office Communications Server (OCS 2007/2007 R2)
306 * Microsoft Live Communications Server (LCS 2003/2005)
307 * Reuters Messaging
309 This package provides the profile for KTP account manager.
310 %endif
313 %package -n %{telepathy_plugin}
314 Summary: Telepathy connection manager to connect to MS Office Communicator
315 Group: %{pkg_group}
316 License: GPL-2.0+
317 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
319 %description -n %{telepathy_plugin}
320 A Telepathy connection manager that implements the extended version of
321 SIP/SIMPLE used by various products:
323 * Microsoft Lync Server 2010
324 * Microsoft Office Communications Server (OCS 2007/2007 R2)
325 * Microsoft Live Communications Server (LCS 2003/2005)
326 * Reuters Messaging
328 This package provides the protocol support for Telepathy clients.
331 %package -n %{common_files}
332 Summary: Common files for SIPE protocol plugins
333 Group: %{pkg_group}
334 License: GPL-2.0+
335 BuildArch: noarch
337 %description -n %{common_files}
338 This package provides common files for the SIPE protocol plugins:
340 * Localisation
341 %endif
344 %if 0%{?mingw_prefix:1}
345 %package -n %{nsis_package}
346 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
347 Group: %{pkg_group}
348 License: GPL-2.0+
350 %description -n %{nsis_package}
351 A third-party plugin for the Pidgin multi-protocol instant messenger.
352 It implements the extended version of SIP/SIMPLE used by various products:
354 * Microsoft Lync Server 2010
355 * Microsoft Office Communications Server (OCS 2007/2007 R2)
356 * Microsoft Live Communications Server (LCS 2003/2005)
357 * Reuters Messaging
359 This package contains the NSIS installer package of the protocol plugin
360 for Pidgin on Windows.
361 %endif
364 %{mingw_debug_package}
367 %prep
368 %setup -q -n pidgin-sipe-%{version}
370 %build
371 %if 0%{?mingw_prefix:1}
373 # Windows cross-compilation build
375 %{?env_options}
376 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
377 autoreconf --verbose --install --force
378 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
379 %{mingw_configure} \
380 --enable-purple \
381 %if 0%{?build_telepathy:1}
382 --enable-telepathy
383 %else
384 --disable-telepathy
385 %endif
386 %{mingw_make} %{_smp_mflags} || %{mingw_make}
388 %else
390 # Standard Linux build
392 %if 0%{?sles_version} == 10
393 export CFLAGS="%optflags -I%{_includedir}/gssapi"
394 %endif
395 %if 0%{?mdkversion}
396 autoreconf --verbose --install --force
397 %endif
398 %configure \
399 --enable-purple \
400 %if 0%{?build_telepathy:1}
401 --enable-telepathy
402 %else
403 --disable-telepathy
404 %endif
405 make %{_smp_mflags}
406 make %{_smp_mflags} check
408 # End Windows cross-compilation/Linux build setup
409 %endif
412 %install
413 %if 0%{?mingw_prefix:1}
415 # Windows cross-compilation install
417 %{mingw_makeinstall}
418 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
420 # generate NSIS installer package
421 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
422 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
423 >%{buildroot}/pidgin-sipe.nsi
425 set -e; \
426 cd %{buildroot}; \
427 makensis \
428 -DVERSION=%{version} \
429 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
430 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
431 pidgin-sipe.nsi \
433 rm -f %{buildroot}/pidgin-sipe.nsi
435 %else
437 # Standard Linux install
439 %makeinstall
441 # End Windows cross-compilation/Linux build setup
442 %endif
444 find %{buildroot} -type f -name "*.la" -delete -print
445 # SLES11 defines suse_version = 1110
446 %if 0%{?suse_version} && 0%{?suse_version} < 1120
447 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
448 %endif
449 # Pidgin doesn't have 24 or 32 pixel icons
450 rm -f \
451 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
452 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
453 %if 0%{?build_telepathy:1}
454 %if !0%{?build_ktp:1}
455 rm -r %{buildroot}%{_datadir}/telepathy
456 %endif
457 %endif
458 %find_lang pidgin-sipe
461 %clean
462 rm -rf %{buildroot}
465 %if 0%{?build_telepathy:1}
466 %files -n %{purple_plugin}
467 %else
468 %files -n %{purple_plugin} -f pidgin-sipe.lang
469 %endif
470 %defattr(-,root,root,-)
471 %doc AUTHORS ChangeLog COPYING NEWS README TODO
472 %if 0%{?mingw_prefix:1}
473 %{mingw_libdir}/purple-2/libsipe.dll
474 %else
475 %{_libdir}/purple-2/libsipe.so
476 %endif
479 %if 0%{?build_telepathy:1}
480 %files -n %{empathy_files}
481 %defattr(-,root,root,-)
482 %doc AUTHORS COPYING
483 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
484 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
487 %if 0%{?build_ktp:1}
488 %files -n %{ktp_files}
489 %defattr(-,root,root,-)
490 %doc AUTHORS COPYING
491 %{_datadir}/telepathy/profiles/sipe.profile
492 %endif
495 %files -n %{telepathy_plugin}
496 %defattr(-,root,root,-)
497 %doc AUTHORS ChangeLog COPYING NEWS README TODO
498 %{_datadir}/dbus-1/services/*.sipe.service
499 %{_libexecdir}/telepathy-sipe
502 %files -n %{common_files} -f pidgin-sipe.lang
503 %defattr(-,root,root,-)
504 %endif
507 %files
508 %defattr(-,root,root,-)
509 %doc AUTHORS COPYING
510 %if 0%{?mingw_prefix:1}
511 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
512 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
513 %else
514 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
515 # SLES11 defines suse_version = 1110
516 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
517 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
518 %endif
519 %endif
522 %if 0%{?mingw_prefix:1}
523 %files -n %{nsis_package}
524 %defattr(-, root, root)
525 /pidgin-sipe-%{version}.exe
526 %endif
529 %changelog
530 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
531 - update to 1.14.0
533 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
534 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
536 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
537 - BR telepathy-glib-devel >= 0.18.0
539 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
540 - BR telepathy-glib-devel >= 0.14.0
542 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
543 - really disable telepathy for Windows cross-compilation builds
545 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
546 - updates to enable telepathy build
548 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
549 - update to 1.13.3
551 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
552 - update to 1.13.2
554 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
555 - update to 1.13.1
557 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
558 - update to 1.13.0
560 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
561 - we do support Microsoft Lync Server 2010 now.
563 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
564 - update GPL2 license name
566 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
567 - add BR gmime-devel for Fedora to have at least one verification platform
569 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
570 - fix Mandriva 2011 unresolvable BR
572 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
573 - add BR nss-devel
575 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
576 - add NSIS package for mingw builds
578 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
579 - add mingw64 build
581 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
582 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
584 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
585 - update mingw32 build
586 - update descriptions
588 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
589 - update to 1.12.0
591 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
592 - add gstreamer-devel to enable Voice & Video features
594 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
595 - add optional subpackage for telepathy connection manager
597 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
598 - update to 1.11.2
600 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
601 - update to 1.11.1
603 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
604 - add mingw32 build configuration
606 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
607 - update to 1.11.0
609 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
610 - Mandriva config for OBS has changed
612 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
613 - add libnice build information discovered through OBS testing
615 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
616 - add NSS build information discovered through OBS testing
618 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
619 - release
621 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
622 - Mandriva has too old libtool version
624 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
625 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
627 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
628 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
630 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
631 - added --enable/--disable build options
633 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
634 - removed --with-krb5 configure option as it is autodetected now
636 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
637 - add SVG icon
639 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
640 - add BR glib2-devel >= 2.12.0
642 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
643 - add tests to build
645 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
646 - update to 1.9.1
648 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
649 - add BR libxml2-devel
651 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
652 - release
653 - dropped SLE 10 due to libpurple min version increase
654 - updated target distros in comment line
656 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
657 - increased libpurple build requisite to >= 2.4.0
659 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
660 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
662 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
663 - sync with RPM SPEC from contrib/rpm
665 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
666 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
667 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
669 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
670 - reinstated enable-quality-check
672 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
673 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
675 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
676 - Spec file modifications for openSUSE build service
678 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
679 - move non-Pidgin files to new sub-package purple-sipe
681 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
682 - remove directory for emoticon theme icons
684 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
685 - libpurple protocol plugins are located under %%{_libdir}/purple-2
687 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
688 - added directory for emoticon theme icons
690 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
691 - update to 1.6.3
693 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
694 - reduce libpurple-devel requirement to >= 2.3.1
696 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
697 - update to 1.6.2
699 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
700 - reduce libpurple-devel requirement to >= 2.4.1
702 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
703 - com_err.h only required for kerberos
705 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
706 - require libpurple-devel >= 2.5.0
708 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
709 - refactor configure parameters
710 - make kerberos configurable
711 - don't hard code prefix for git builds
713 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
714 - removed unnecessary zlib-devel
716 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
717 - fix prefix for git builds
719 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
720 - append -Wno-unused-parameter for GCC <4.4 compilation errors
722 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
723 - remove duplicate GPL2
725 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
726 - use "--with git" to build from git
727 - corrected download URL for release archive
728 - add missing BR gettext-devel
730 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
731 - use default rpmbuild CFLAGS also for git builds
732 - merge with SPEC files created by mricon & jberanek
734 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
735 - initial RPM SPEC example generated