Updated to release 1.12.0
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob62575c3daef735216e218d9c1e15f2d5589ce4b8
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL)
7 # Mandriva
8 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32)
12 # Build options
13 %define build_kopete 0
14 %define build_telepathy 0
16 # Check for mingw32 cross compilation build
18 # Manually add this repository to your private OBS project:
20 # <repository name="mingw32">
21 # <path repository="openSUSE_11.3" project="windows:mingw:win32"/>
22 # <arch>i586</arch>
23 # </repository>
25 # You might need to add & build mingw-pidgin package too.
27 %if "%{_repository}" == "mingw32"
28 %define purple_sipe_mingw32 1
29 %define __strip %{_mingw32_strip}
30 %define __objdump %{_mingw32_objdump}
31 %define _use_internal_dependency_generator 0
32 %define __find_requires %{_mingw32_findrequires}
33 %define __find_provides %{_mingw32_findprovides}
34 %define __os_install_post %{_mingw32_debug_install_post} \
35 %{_mingw32_install_post}
36 %endif
38 %define purple_plugin libpurple-plugin-sipe
40 %define purple_develname libpurple-devel
42 %if 0%{?mdkversion} >= 200910
43 %ifarch x86_64
44 %define purple_develname lib64purple-devel
45 %endif
46 %if 0%{?mdkversion} >= 201000
47 %ifnarch x86_64
48 %define has_libnice 1
49 %endif
50 %endif
51 %endif
53 %if 0%{?suse_version}
54 %define nss_develname mozilla-nss-devel
55 %if 0%{?suse_version} >= 1120
56 %define has_libnice 1
57 %endif
58 %else
59 %define nss_develname nss-devel
60 %endif
62 %if 0%{?suse_version} || 0%{?sles_version}
63 %define pkg_group Productivity/Networking/Instant Messenger
64 %endif
65 %if 0%{?fedora}
66 %define pkg_group Applications/Internet
67 %if 0%{?fedora} >= 11
68 %define has_libnice 1
69 %if 0%{?fedora} >= 15
70 %define has_gstreamer 1
71 %endif
72 %endif
73 %endif
74 %if 0%{?mdkversion}
75 %define pkg_group Networking/Instant messaging
76 %else
77 %define pkg_group Applications/Internet
78 %endif
80 Name: pidgin-sipe
81 Summary: Pidgin protocol plugin to connect to MS Office Communicator
82 Version: 1.12.0
83 Release: 1
84 Source: %{name}-%{version}.tar.gz
85 Group: %{pkg_group}
86 License: GPLv2+
87 URL: http://sipe.sourceforge.net/
89 BuildRoot: %{_tmppath}/%{name}-%{version}-build
91 %if 0%{?purple_sipe_mingw32}
93 # Windows cross-compilation build setup
95 BuildArch: noarch
97 BuildRequires: mingw32-filesystem >= 23
98 BuildRequires: mingw32-cross-gcc
99 BuildRequires: mingw32-cross-binutils
100 BuildRequires: mingw32-libpurple-devel >= 2.4.0
101 BuildRequires: mingw32-glib2-devel >= 2.12.0
102 # Required for successful autoreconf
103 BuildRequires: glib2-devel >= 2.12.0
104 BuildRequires: mingw32-libxml2-devel
105 BuildRequires: pkgconfig
106 BuildRequires: libtool
107 BuildRequires: intltool
108 BuildRequires: mingw32-gettext-runtime
110 # For directory ownership
111 BuildRequires: mingw32-pidgin
112 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
114 # Handle .debug files
115 %{_mingw32_debug_package}
117 %else
119 # Standard Linux build setup
121 BuildRequires: %{purple_develname} >= 2.4.0
122 BuildRequires: glib2-devel >= 2.12.0
123 BuildRequires: libxml2-devel
124 #BuildRequires: %{nss_develname}
125 BuildRequires: libtool
126 BuildRequires: intltool
127 BuildRequires: gettext-devel
128 # The following two are required to enable Voice & Video features
129 %if 0%{?has_libnice:1}
130 BuildRequires: libnice-devel
131 %endif
132 %if 0%{?has_gstreamer:1}
133 BuildRequires: gstreamer-devel
134 %endif
136 # Configurable components
137 %if !0%{?_without_kerberos:1}
138 BuildRequires: krb5-devel
139 %endif
141 # For directory ownership
142 BuildRequires: pidgin
143 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
144 %if %{build_telepathy}
145 BuildRequires: pkgconfig(telepathy-glib)
146 %endif
147 Requires: pidgin
148 %if 0%{?sles_version} == 10
149 BuildRequires: gnome-keyring-devel
150 %endif
152 # For OBS's "have choice for" for Fedora 11 (only)
153 %if 0%{?fedora_version} == 11
154 BuildRequires: libproxy-mozjs
155 BuildRequires: PolicyKit-gnome
156 %endif
158 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
159 %if 0%{?mdkversion} >= 201010
160 BuildRequires: polkit-gnome
161 %endif
163 # End Windows cross-compilation/Linux build setup
164 %endif
167 %description
168 SIPE is an open source project that implements the extended version of
169 SIP/SIMPLE used by various products:
171 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
172 * Microsoft Live Communications Server (LCS 2003/2005)
173 * Reuters Messaging
175 This package provides the icon set for Pidgin.
178 %package -n %{purple_plugin}
179 Summary: Libpurple protocol plugin to connect to MS Office Communicator
180 Group: %{pkg_group}
181 License: GPLv2+
182 Obsoletes: purple-sipe
184 %description -n %{purple_plugin}
185 SIPE is an open source project that implements the extended version of
186 SIP/SIMPLE used by various products:
188 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
189 * Microsoft Live Communications Server (LCS 2003/2005)
190 * Reuters Messaging
192 This package provides the third-party protocol plugin for libpurple clients.
195 %if %{build_telepathy}
196 %package -n telepathy-plugin-sipe
197 Summary: Telepathy connection manager for MS Office Communicator
198 Group: %{pkg_group}
199 License: GPLv2+
201 %description -n telepathy-plugin-sipe
202 SIPE is an open source project that implements the extended version of
203 SIP/SIMPLE used by various products:
205 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
206 * Microsoft Live Communications Server (LCS 2003/2005)
207 * Reuters Messaging
209 This package provides the connection manager for the telepathy multi-protocol
210 instant messaging core.
211 %endif
214 %prep
215 %setup -q
217 %build
218 %if 0%{?purple_sipe_mingw32}
220 # Windows cross-compilation build
222 %{?env_options}
223 echo "lt_cv_deplibs_check_method='pass_all'" >>%{_mingw32_cache}
224 autoreconf --verbose --install --force
225 MINGW32_LDFLAGS="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
226 %{_mingw32_configure} \
227 --enable-purple \
228 %if %{build_telepathy}
229 --enable-telepathy
230 %else
231 --disable-telepathy
232 %endif
233 %{_mingw32_make} %{_smp_mflags}
235 %else
237 # Standard Linux build
239 %if 0%{?sles_version} == 10
240 export CFLAGS="%optflags -I%{_includedir}/gssapi"
241 %endif
242 %if 0%{?mdkversion}
243 autoreconf --verbose --install --force
244 %endif
245 %configure \
246 --enable-purple \
247 %if %{build_telepathy}
248 --enable-telepathy
249 %else
250 --disable-telepathy
251 %endif
252 make %{_smp_mflags}
253 make %{_smp_mflags} check
255 # End Windows cross-compilation/Linux build setup
256 %endif
259 %install
260 %if 0%{?purple_sipe_mingw32}
262 # Windows cross-compilation install
264 %{_mingw32_makeinstall}
265 rm -f %{buildroot}%{_mingw32_libdir}/purple-2/*.dll.a
267 %else
269 # Standard Linux install
271 %makeinstall
273 # End Windows cross-compilation/Linux build setup
274 %endif
276 find %{buildroot} -type f -name "*.la" -delete -print
277 # SLES11 defines suse_version = 1110
278 %if 0%{?suse_version} && 0%{?suse_version} < 1120
279 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
280 %endif
281 %find_lang %{name}
284 %clean
285 rm -rf %{buildroot}
288 %files -n %{purple_plugin} -f %{name}.lang
289 %defattr(-,root,root,-)
290 %doc AUTHORS ChangeLog COPYING NEWS README TODO
291 %if 0%{?purple_sipe_mingw32}
292 %{_mingw32_libdir}/purple-2/libsipe.dll
293 %else
294 %{_libdir}/purple-2/libsipe.so
295 %endif
298 %files
299 %defattr(-,root,root,-)
300 %doc AUTHORS COPYING
301 %if 0%{?purple_sipe_mingw32}
302 %{_mingw32_datadir}/pixmaps/pidgin/protocols/*/sipe.png
303 %{_mingw32_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
304 %else
305 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
306 # SLES11 defines suse_version = 1110
307 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
308 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
309 %endif
310 %endif
313 %if %{build_telepathy}
314 %files -n telepathy-plugin-sipe
315 %defattr(-, root, root)
316 %{_libexecdir}/telepathy-sipe
317 %endif}
320 %changelog
321 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
322 - add gstreamer-devel to enable Voice & Video features
324 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
325 - add optional subpackage for telepathy connection manager
327 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
328 - update to 1.11.2
330 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
331 - update to 1.11.1
333 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
334 - add mingw32 build configuration
336 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
337 - update to 1.11.0
339 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
340 - Mandriva config for OBS has changed
342 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
343 - add libnice build information discovered through OBS testing
345 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
346 - add NSS build information discovered through OBS testing
348 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
349 - release
351 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
352 - Mandriva has too old libtool version
354 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
355 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
357 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
358 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
360 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
361 - added --enable/--disable build options
363 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
364 - removed --with-krb5 configure option as it is autodetected now
366 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
367 - add SVG icon
369 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
370 - add BR glib2-devel >= 2.12.0
372 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
373 - add tests to build
375 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
376 - update to 1.9.1
378 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
379 - add BR libxml2-devel
381 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
382 - release
383 - dropped SLE 10 due to libpurple min version increase
384 - updated target distros in comment line
386 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
387 - increased libpurple build requisite to >= 2.4.0
389 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
390 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
392 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
393 - sync with RPM SPEC from contrib/rpm
395 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
396 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
397 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
399 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
400 - reinstated enable-quality-check
402 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
403 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
405 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
406 - Spec file modifications for openSUSE build service
408 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
409 - move non-Pidgin files to new sub-package purple-sipe
411 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
412 - remove directory for emoticon theme icons
414 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
415 - libpurple protocol plugins are located under %%{_libdir}/purple-2
417 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
418 - added directory for emoticon theme icons
420 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
421 - update to 1.6.3
423 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
424 - reduce libpurple-devel requirement to >= 2.3.1
426 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
427 - update to 1.6.2
429 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
430 - reduce libpurple-devel requirement to >= 2.4.1
432 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
433 - com_err.h only required for kerberos
435 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
436 - require libpurple-devel >= 2.5.0
438 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
439 - refactor configure parameters
440 - make kerberos configurable
441 - don't hard code prefix for git builds
443 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
444 - removed unnecessary zlib-devel
446 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
447 - fix prefix for git builds
449 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
450 - append -Wno-unused-parameter for GCC <4.4 compilation errors
452 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
453 - remove duplicate GPL2
455 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
456 - use "--with git" to build from git
457 - corrected download URL for release archive
458 - add missing BR gettext-devel
460 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
461 - use default rpmbuild CFLAGS also for git builds
462 - merge with SPEC files created by mricon & jberanek
464 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
465 - initial RPM SPEC example generated