frobtads: Add 1.2.2, delete old
[gentoo-interactive-fiction.git] / games-engines / frobtads / frobtads-1.2.2.ebuild
blob79b84cec3f48f51f051a5af0fb9006940f206fee
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=2
6 if [ "$PV" == "9999" ]; then
7 # The package uses AM_SILENT_RULES which is only available in automake
8 # 1.11 and later.
9 WANT_AUTOMAKE="1.11"
10 SRC_URI=""
11 EGIT_REPO_URI="git://git.assembla.com/frobtads.git"
12 KEYWORDS=""
13 inherit autotools git-2
15 inherit flag-o-matic games
17 DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
18 HOMEPAGE="http://www.tads.org/frobtads.htm"
19 if [ "$PV" != "9999" ]; then
20 SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz"
21 KEYWORDS="~amd64 ~x86"
23 LICENSE="TADS2 TADS3"
24 SLOT="0"
25 RESTRICT="!tads3compiler? ( test )"
26 IUSE="debug +tads2compiler +tads3compiler"
28 DEPEND="sys-libs/ncurses
29 net-misc/curl"
30 RDEPEND="${DEPEND}"
32 src_unpack() {
33 if [ "${PV}" == "9999" ]; then
34 git-2_src_unpack
35 cd "${S}"
36 einfo "Regenerating autotools files..."
37 eautoreconf
38 else
39 base_src_unpack
43 src_configure() {
44 egamesconf \
45 $(use_enable debug t3debug) \
46 $(use_enable tads2compiler t2-compiler) \
47 $(use_enable tads3compiler t3-compiler) \
48 || die "egamesconf failed"
51 src_test() {
52 #if use debug; then
53 # emake check || die "TADS 3 compiler test suite failed"
54 #fi
56 emake sample || die "Failed to build test game"
57 ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
58 save
59 testsave.sav
60 restore
61 testsave.sav
62 END_FROB_TEST
63 [[ $? -eq 0 ]] || die "Failed to run test game"
66 src_install() {
67 emake DESTDIR="${D}" install || die "emake install failed"
68 dodoc doc/{AUTHORS,BUGS,NEWS,README,SRC_GUIDELINES,THANKS}
69 prepgamesdirs