qtads-9999: Remove CREDITS from DOCS
[gentoo-interactive-fiction.git] / games-engines / qtads / qtads-9999.ebuild
blobfbc67b69b3109dcfbaaf850a3de7389726507d6e
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="3"
7 inherit games git qt4-r2
9 EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}/${PN}"
11 DESCRIPTION="Multimedia interpreter for TADS text adventures"
12 HOMEPAGE="http://qtads.sourceforge.net"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
19 # Note that for sdl-sound, we need the "mp3", not the "mpeg" USE flag. "mpeg"
20 # uses the SMPEG lib for decoding, which plays some MP3s at double speed. "mp3"
21 # uses SDL_sound's internal MPGLIB, which doesn't have that problem. It's OK
22 # if both "mp3" as well as "mpeg" are enabled, because SDL_sound tries MPGLIB
23 # first, and only if that fails will it use SMPEG.
24 DEPEND="x11-libs/qt-gui:4
25 media-libs/libsdl[audio]
26 media-libs/sdl-mixer[midi,vorbis]
27 media-libs/sdl-sound[mp3]"
28 RDEPEND="${DEPEND}"
30 DOCS="AUTHORS BUGS NEWS QTADS_LICENSE_NOTE SOURCE_README README"
32 src_unpack() {
33 git_src_unpack
36 src_install() {
37 dogamesbin qtads || die
38 doman qtads.6.gz || die
39 dodoc ${DOCS} || die
40 make_desktop_entry qtads QTads
41 prepgamesdirs