wmtime - Fix compiler and linker flags in Makefile.
[dockapps.git] / wmtime / debian / rules
blob5e50ce69c816f86b11bf6dcd8e501ee7af62c0b1
1 #!/usr/bin/make -f
3 # debian/rules file for wmtime.
4 # Copyright (C) 2003 Software in the Public Interest.
6 # This program is free software; you can redistribute it and/or modify
7 # it under the terms of the GNU General Public License as published by
8 # the Free Software Foundation; either version 2 of the License, or (at
9 # your option) any later version.
11 # This program is distributed in the hope that it will be useful, but
12 # WITHOUT ANY WARRANTY; without even the implied warranty of
13 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
14 # General Public License for more details.
16 # You should have received a copy of the GNU General Public License
17 # along with this program; if not, write to the Free Software
18 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
20 # Based on the sample debian/rules that uses debhelper.
21 # GNU copyright 1997 to 1999 by Joey Hess.
23 # Uncomment this to turn on verbose mode.
24 #export DH_VERBOSE=1
26 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
27 CFLAGS += -g
28 endif
29 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
30 INSTALL_PROGRAM += -s
31 endif
33 build: build-stamp
35 build-stamp:
36 dh_testdir
38 cd wmtime; $(MAKE)
40 touch build-stamp
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp
47 -cd wmtime; $(MAKE) clean
49 dh_clean
51 install: build
52 dh_testdir
53 dh_testroot
54 dh_clean -k
55 dh_installdirs
57 install -m 755 wmtime/wmtime $(CURDIR)/debian/wmtime/usr/bin
59 # Build architecture-independent files here.
60 binary-indep: build install
61 # We have nothing to do by default.
63 # Build architecture-dependent files here.
64 binary-arch: build install
65 dh_testdir
66 dh_testroot
67 dh_installdebconf
68 dh_installdocs
69 dh_installexamples
70 dh_installmenu
71 # dh_installlogrotate
72 # dh_installemacsen
73 # dh_installpam
74 # dh_installmime
75 # dh_installinit
76 # dh_installcron
77 dh_installman
78 # dh_installinfo
79 dh_installchangelogs CHANGES
80 dh_link
81 dh_strip
82 dh_compress
83 dh_fixperms
84 # dh_makeshlibs
85 dh_installdeb
86 # dh_perl
87 dh_shlibdeps
88 dh_gencontrol
89 dh_md5sums
90 dh_builddeb
92 binary: binary-indep binary-arch
93 .PHONY: build clean binary-indep binary-arch binary install