Include chrome.manifest in debian package, prepare new Debian upload
[conkeror.git] / debian / rules
blob731227a2133a133b83c03ac3f0b711ae543510b1
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # This has to be exported to make some magic below work.
7 export DH_OPTIONS
9 # Generating a xulrunner build id and other strings
10 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
12 BUILDID := $(shell echo -n `whoami`@`hostname`)_$(shell date +%s)
14 include /usr/share/quilt/quilt.make
16 configure: configure-stamp
17 configure-stamp: $(QUILT_STAMPFN)
18 dh_testdir
19 # Add here commands to configure the package.
21 touch configure-stamp
23 # Architecture
24 build: build-arch build-indep
26 build-arch: build-arch-stamp
27 build-arch-stamp: configure-stamp
28 # Add here commands to compile the arch part of the package.
29 make
31 touch $@
33 build-indep: build-indep-stamp
34 build-indep-stamp: configure-stamp
35 # Add here commands to compile the indep part of the package.
36 #$(MAKE) doc
38 touch $@
40 clean: unpatch
41 dh_testdir
42 dh_testroot
43 rm -f build-arch-stamp build-indep-stamp configure-stamp
45 # Add here commands to clean up after the build process.
46 $(MAKE) clean
48 dh_clean
50 install: install-indep install-arch
51 install-indep:
52 dh_testdir
53 dh_testroot
54 dh_prep -i
55 dh_installdirs -i
57 # Add here commands to install the indep part of the package into
58 # debian/<package>
59 cp -pr branding chrome components content defaults \
60 locale modules search-engines help style \
61 chrome.manifest \
62 $(CURDIR)/debian/conkeror/usr/share/conkeror/
63 mkdir -p $(CURDIR)/debian/conkeror/usr/share/conkeror/contrib/
64 cp -pr contrib/xrev contrib/art contrib/modules \
65 $(CURDIR)/debian/conkeror/usr/share/conkeror/contrib/
66 # Add generated Build ID and Debian version to version output
67 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' application.ini \
68 > $(CURDIR)/debian/conkeror/usr/share/conkeror/application.ini
69 # Use Debian version for M-x version output
70 sed -e 's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' components/application.js \
71 > $(CURDIR)/debian/conkeror/usr/share/conkeror/components/application.js
72 cp -p debian/conkeror.bin $(CURDIR)/debian/conkeror/usr/bin/conkeror
73 cp -p debian/conkeror.desktop $(CURDIR)/debian/conkeror/usr/share/applications/
75 dh_install -i
77 install-arch:
78 dh_testdir
79 dh_testroot
80 dh_prep -s
81 dh_installdirs -s
83 # Add here commands to install the arch part of the package into
84 # debian/tmp.
85 cp -p conkeror-spawn-helper $(CURDIR)/debian/conkeror-spawn-process-helper/usr/lib/conkeror/
86 ln -s /usr/lib/conkeror/conkeror-spawn-helper $(CURDIR)/debian/conkeror-spawn-process-helper/usr/share/conkeror/
88 dh_install -s
90 # Must not depend on anything. This is to be called by
91 # binary-arch/binary-indep in another 'make' thread.
92 binary-common:
93 dh_testdir
94 dh_testroot
95 dh_installchangelogs
96 dh_installdocs
97 # dh_installexamples
98 dh_installmenu
99 # dh_installemacsen
100 dh_installman
101 dh_bugfiles
102 dh_lintian
103 dh_link
104 dh_strip
105 dh_compress
106 dh_fixperms
107 dh_makeshlibs
108 dh_installdeb
109 dh_shlibdeps
110 dh_gencontrol
111 dh_md5sums
112 dh_builddeb
114 # Build architecture independant packages using the common target.
115 binary-indep: build-indep install-indep
116 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
118 # Build architecture dependant packages using the common target.
119 binary-arch: build-arch install-arch
120 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
122 binary: binary-arch binary-indep
123 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure