Initial commit of KAM fork of ucw-cs (comes from 2000, by Martin Mares)
[ucwcs-console.git] / debian / rules
blob300acfd612836696c4621c34006c1b7db6bdfa3b
1 #!/usr/bin/make -f
2 # Rules for building of ucwcs-console Debian package
3 # (c) 2000 Martin Mares <mj@ucw.cz>
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 build: build-stamp
9 build-stamp:
10 dh_testdir
11 touch build-stamp
13 clean:
14 dh_testdir
15 dh_testroot
16 rm -f build-stamp
17 dh_clean
19 binary-indep: build
21 binary-arch: build
22 dh_testdir
23 dh_testroot
24 dh_clean -k
25 dh_installdirs usr/share/keymaps/ucw usr/share/consolefonts usr/share/consoletrans
26 cp kbd/* debian/tmp/usr/share/keymaps/ucw
27 cp fonts/* debian/tmp/usr/share/consolefonts
28 cp trans/* debian/tmp/usr/share/consoletrans
29 dh_installdocs
30 # dh_installexamples
31 # dh_installmenu
32 dh_installinit
33 # dh_installcron
34 # dh_installmanpages
35 # dh_undocumented
36 dh_installchangelogs
37 # dh_strip
38 # dh_compress
39 dh_fixperms
40 # dh_suidregister
41 dh_installdeb
42 # dh_shlibdeps
43 dh_gencontrol
44 # dh_makeshlibs
45 dh_md5sums
46 dh_builddeb
48 binary: binary-indep binary-arch
50 .PHONY: build clean binary-indep binary-arch binary