cleanup
[ub0rlay.git] / net-libs / curlpp / curlpp-0.7.2.ebuild
blob7ac2a62bea763e8ff8b2991b12ab8472be9396c8
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit autotools
7 DESCRIPTION="C++ bindings of libcurl"
8 HOMEPAGE="http://rrette.com/textpattern/index.php?s=cURLpp"
9 SRC_URI="http://rrette.com/files/curlpp/curlpp-0.7/${P}.tar.gz"
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
16 DEPEND="net-misc/curl"
18 src_unpack()
20 unpack ${A}
21 cd ${S}
22 sed -i -e "s:@CURLPP_CFLAGS@:@CURLPP_CXXFLAGS@:" curlpp-config.in
23 epatch ${FILESDIR}/disable-examples-build.patch #example18 doesnt build
24 eautoreconf
27 src_install()
29 emake DESTDIR=${D} install || die "install failed"
30 dodoc CHANGES AUTHORS TODO COPYING doc/guide.pdf
31 insinto /usr/share/${P}
32 doins examples/*