cleanup
[ub0rlay.git] / kde-misc / icemon / icemon-1.0-r1.ebuild
blob7b8bbaadd36b5734546a66c9b05ae5244af1cc47
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit kde
7 MY_P="${PN}-kde3"
8 S="${WORKDIR}/${MY_P}"
10 DESCRIPTION="Icemon is a KDE monitor program for use with Icecream compile clusters."
11 HOMEPAGE="http://www.opensuse.org/icecream"
12 SRC_URI="http://www.cs.tcd.ie/~furlongm/gentoo/packages/${MY_P}-${PV}.tar.bz2"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
17 DEPEND="virtual/libc kde-base/kdelibs:3.5 !<=sys-devel/icecream-0.7.6"
18 IUSE=""
20 src_compile() {
22 use amd64 && export CFLAGS="${CFLAGS} -fPIC -DPIC"
23 use amd64 && export CXXFLAGS="${CXXFLAGS} -fPIC -DPIC"
24 kde_src_compile 'all' || die "error compiling"