cleanup
[ub0rlay.git] / dev-util / dsss / dsss-0.75.ebuild
blob50346363b318fbf985a1cb323706f1300eb51a79
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils
7 DESCRIPTION="the D Shared Software System"
8 HOMEPAGE="http://www.dsource.org/projects/dsss"
9 SRC_URI="http://svn.dsource.org/projects/dsss/downloads/${PV}/${P}.tar.bz2"
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
16 DEPEND="!dev-libs/phobos
17 !dev-libs/tango"
18 RDEPEND=""
20 pkg_setup(){
22 if ! built_with_use sys-devel/gcc d; then
23 eerror " "
24 eerror "you need to compile sys-devel/gcc with d useflag "
25 eerror " "
26 die "No suitable D compiler found!"
31 src_compile(){
33 emake -j1 -f Makefile.gdc.posix || die "make failed"
37 src_install(){
39 ./dsss install --prefix=${D}/usr/ --sysconfdir=${D}/etc/ \
40 --includedir=${D}/usr/include/d/ || die "install failed"