clean old ebuilds
[ub0rlay.git] / sys-fs / encfs / encfs-9999.ebuild
blob2b9a0f1b84da578beafb52fb93d1b4be714160fd
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 inherit eutils subversion
6 DESCRIPTION="Encrypted Filesystem module for Linux"
7 ESVN_REPO_URI="http://encfs.googlecode.com/svn/trunk/"
8 ESVN_PROJECT="encfs"
9 ESVN_BOOTSTRAP="sh ./reconfig.sh"
10 HOMEPAGE="http://arg0.net/encfs"
11 LICENSE="GPL-2"
12 KEYWORDS=""
13 SLOT="0"
14 IUSE="nls"
16 DEPEND=">=dev-libs/openssl-0.9.7
17 >=sys-fs/fuse-2.6
18 >=dev-libs/rlog-1.3.6
19 >=dev-libs/boost-1.34
20 nls? ( >=sys-devel/gettext-0.14.1 )"
22 src_compile() {
23 libtoolize --copy --force
24 econf `use_enable nls` --with-boost-filesystem=boost_filesystem-mt || die
25 emake || die
28 src_install() {
29 make DESTDIR="${D}" install || die "make install failed"
30 dodoc AUTHORS ChangeLog README
33 pkg_postinst() {
34 einfo "Please see http://www.arg0.net/encfsintro"
35 einfo "if this is your first time using encfs."