clean old ebuilds
[ub0rlay.git] / sys-fs / encfs / encfs-1.5.2.ebuild
blobf570503f676c07f4f9e3f1c12cbe7c423553c87a
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.4.2.ebuild,v 1.3 2008/05/17 15:04:01 vanquirius Exp $
5 inherit eutils
6 inherit versionator
7 MY_PV=$(replace_version_separator 2 '-')
9 DESCRIPTION="Encrypted Filesystem module for Linux"
10 SRC_URI="http://encfs.googlecode.com/files/encfs-${MY_PV}.tgz"
11 HOMEPAGE="http://arg0.net/encfs"
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~sparc ~x86"
14 SLOT="0"
15 IUSE="nls"
17 DEPEND=">=dev-libs/openssl-0.9.7
18 >=sys-fs/fuse-2.6
19 >=dev-libs/rlog-1.3.6
20 >=dev-libs/boost-1.34
21 nls? ( >=sys-devel/gettext-0.14.1 )"
23 src_unpack() {
24 unpack ${A}
25 S="${WORKDIR}/encfs-$(get_version_component_range 1-2)"
26 cd "${S}"
29 src_compile() {
30 econf `use_enable nls` --with-boost-filesystem=boost_filesystem-mt || die
31 emake || die
34 src_install() {
35 make DESTDIR="${D}" install || die "make install failed"
36 dodoc AUTHORS ChangeLog README
39 pkg_postinst() {
40 einfo "Please see http://www.arg0.net/encfsintro"
41 einfo "if this is your first time using encfs."