fix mani
[ub0rlay.git] / dev-java / icedtea-bin / icedtea-bin-1.7.0.ebuild
blob0428bbc15e0740adc627dcb6850db55ee79d2292
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils java-pkg-2 java-vm-2 rpm toolchain-funcs
7 DESCRIPTION="Java Plugin for 64 Bit Browsers"
8 HOMEPAGE="http://icedtea.classpath.org"
9 FEDORA_V="1.7.0.0-0.19.b21.snapshot.fc8.x86_64"
10 BASE_URI="http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/8/Fedora/x86_64/os/Packages"
11 SRC_URI="${BASE_URI}/java-${PV}-icedtea-${FEDORA_V}.rpm
12 ${BASE_URI}/java-${PV}-icedtea-devel-${FEDORA_V}.rpm
13 nsplugin? ( ${BASE_URI}/java-${PV}-icedtea-plugin-${FEDORA_V}.rpm )"
14 SLOT="1.7"
15 LICENSE="OSGPL-0.0"
16 KEYWORDS="-* ~amd64"
17 IUSE="nsplugin"
19 RDEPEND=">=sys-devel/gcc-4.2"
21 S="${WORKDIR}"
23 pkg_setup() {
24 java-vm-2_pkg_setup
25 java-pkg-2_pkg_setup
27 if [ $(gcc-version) != "4.2" ]; then
28 ewarn "${P} is a binary package, and needs gcc-4.2 to be installed and"
29 ewarn "set as currently active compiler!"
30 sleep 5
34 src_unpack() {
35 rpm_src_unpack
38 src_compile() {
39 elog "We install a Fedora binary distribution. Nothing to compile."
42 src_install() {
43 dodir /usr/lib64
44 cp -a usr/lib/jvm* ${D}/usr/lib64
46 if use nsplugin; then
47 install_mozilla_plugin \
48 /usr/lib64/jvm/java-${PV}-icedtea-${PV}.0.x86_64/jre/lib/amd64/gcjwebplugin.so
51 set_java_env