dnsmasq: re-apply original Tomato specific code
[tomato.git] / release / src / router / dnsmasq / PKGBUILD
blob6b5ec5eff1dd0a569d8915ab3e555209afb2385d
1 # Maintainer: Sung Pae <self@sungpae.com>
2 pkgname=dnsmasq-nerv
3 pkgver=
4 pkgrel=1
5 pkgdesc="Custom dnsmasq build"
6 arch=('x86_64')
7 url="https://github.com/guns/dnsmasq"
8 license=('GPL')
9 groups=('nerv')
10 backup=('etc/dnsmasq/dnsmasq.conf'
11         'etc/dnsmasq/resolv.conf')
12 depends=('glibc' 'libidn')
13 install=dnsmasq.install
14 makedepends=('git')
15 provides=('dnsmasq')
16 conflicts=('dnsmasq')
17 replaces=('dnsmasq-guns')
19 envmake() {
20     DESTDIR="$pkgdir/" PREFIX=/usr BINDIR=/usr/bin RCDIR= \
21     make -e -j $(grep -c ^processor /proc/cpuinfo) "$@"
24 pkgver() {
25     printf %s "$(git describe --long | tr - .)"
28 build() {
29     cd "$startdir"
30     envmake all-i18n
33 package() {
34     cd "$startdir"
35     envmake install