Dnsmasq: update to 2.66TEST16
[tomato.git] / release / src / router / dnsmasq / debian / rules
blob00028c6db07cb4eac1c9d403db0ae4e7d252bc4c
1 #!/usr/bin/make -f
2 # debian/rules file - for dnsmasq.
3 # Copyright 2001-2011 by Simon Kelley
4 # Based on the sample in the debian hello package which carries the following:
5 # Copyright 1994,1995 by Ian Jackson.
6 # I hereby give you perpetual unlimited permission to copy,
7 # modify and relicense this file, provided that you do not remove
8 # my name from the file itself. (I assert my moral right of
9 # paternity under the Copyright, Designs and Patents Act 1988.)
10 # This file may have to be extensively modified
12 package=dnsmasq-base
14 CFLAGS = $(shell export DEB_BUILD_OPTIONS=$(DEB_BUILD_OPTIONS); dpkg-buildflags --get CFLAGS)
15 CFLAGS += $(shell dpkg-buildflags --get CPPFLAGS)
16 CFLAGS += -Wall -W
18 LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
20 COPTS =
22 TARGET = install-i18n
24 DEB_BUILD_ARCH_OS := $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
26 ifeq (,$(filter nodbus,$(DEB_BUILD_OPTIONS)))
27 COPTS += -DHAVE_DBUS
28 endif
30 ifeq (,$(filter noconntrack,$(DEB_BUILD_OPTIONS)))
31 ifeq ($(DEB_BUILD_ARCH_OS),linux)
32 COPTS += -DHAVE_CONNTRACK
33 endif
34 endif
36 ifneq (,$(filter nodhcp6,$(DEB_BUILD_OPTIONS)))
37 COPTS += -DNO_DHCP6
38 endif
40 ifneq (,$(filter noipv6,$(DEB_BUILD_OPTIONS)))
41 COPTS += -DNO_IPV6
42 endif
44 ifneq (,$(filter notftp,$(DEB_BUILD_OPTIONS)))
45 COPTS += -DNO_TFTP
46 endif
48 ifneq (,$(filter nodhcp,$(DEB_BUILD_OPTIONS)))
49 COPTS += -DNO_DHCP
50 endif
52 ifneq (,$(filter noscript,$(DEB_BUILD_OPTIONS)))
53 COPTS += -DNO_SCRIPT
54 endif
56 ifneq (,$(filter nortc,$(DEB_BUILD_OPTIONS)))
57 COPTS += -DHAVE_BROKEN_RTC
58 endif
60 ifneq (,$(filter noi18n,$(DEB_BUILD_OPTIONS)))
61 TARGET = install
62 ifeq (,$(filter noidn, $(DEB_BUILD_OPTIONS)))
63 COPTS += -DHAVE_IDN
64 endif
65 endif
67 ifneq (,$(filter uselua,$(DEB_BUILD_OPTIONS)))
68 COPTS += -DHAVE_LUASCRIPT
69 endif
71 clean:
72 $(checkdir)
73 rm -rf debian/daemon debian/base debian/utils debian/*~ debian/files debian/substvars debian/utils-substvars
74 make clean
75 make -C contrib/wrt clean
77 binary-indep: checkroot
78 $(checkdir)
79 rm -rf debian/daemon
80 install -m 755 \
81 -d debian/daemon/DEBIAN \
82 -d debian/daemon/usr/share/doc \
83 -d debian/daemon/etc/init.d \
84 -d debian/daemon/etc/dnsmasq.d \
85 -d debian/daemon/etc/resolvconf/update.d \
86 -d debian/daemon/usr/lib/resolvconf/dpkg-event.d \
87 -d debian/daemon/etc/default \
88 -d debian/daemon/lib/systemd/system \
89 -d debian/daemon/etc/insserv.conf.d
90 install -m 644 debian/conffiles debian/daemon/DEBIAN
91 install -m 755 debian/postinst debian/postrm debian/prerm debian/daemon/DEBIAN
92 install -m 755 debian/init debian/daemon/etc/init.d/dnsmasq
93 install -m 755 debian/resolvconf debian/daemon/etc/resolvconf/update.d/dnsmasq
94 install -m 755 debian/resolvconf-package debian/daemon/usr/lib/resolvconf/dpkg-event.d/dnsmasq
95 install -m 644 debian/default debian/daemon/etc/default/dnsmasq
96 install -m 644 dnsmasq.conf.example debian/daemon/etc/dnsmasq.conf
97 install -m 644 debian/readme.dnsmasq.d debian/daemon/etc/dnsmasq.d/README
98 install -m 644 debian/systemd.service debian/daemon/lib/systemd/system/dnsmasq.service
99 install -m 644 debian/insserv debian/daemon/etc/insserv.conf.d/dnsmasq
100 ln -s $(package) debian/daemon/usr/share/doc/dnsmasq
101 cd debian/daemon && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
102 dpkg-gencontrol -pdnsmasq -Pdebian/daemon
103 chown -R root.root debian/daemon
104 chmod -R g-ws debian/daemon
105 dpkg --build debian/daemon ..
107 binary-arch: checkroot
108 $(checkdir)
109 rm -rf debian/base
110 install -m 755 \
111 -d debian/base/DEBIAN \
112 -d debian/base/etc/dbus-1/system.d \
113 -d debian/base/usr/share/doc/$(package) \
114 -d debian/base/usr/share/doc/$(package)/examples \
115 -d debian/base/var/run \
116 -d debian/base/var/lib/misc
117 make $(TARGET) PREFIX=/usr DESTDIR=`pwd`/debian/base CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(COPTS)" CC=gcc
118 ifeq (,$(findstring nodocs,$(DEB_BUILD_OPTIONS)))
119 install -m 644 doc.html debian/base/usr/share/doc/$(package)/.
120 install -m 644 setup.html debian/base/usr/share/doc/$(package)/.
121 install -m 644 dnsmasq.conf.example debian/base/usr/share/doc/$(package)/examples/.
122 install -m 644 FAQ debian/base/usr/share/doc/$(package)/.
123 gzip -9 debian/base/usr/share/doc/$(package)/FAQ
124 install -m 644 CHANGELOG debian/base/usr/share/doc/$(package)/changelog
125 gzip -9 debian/base/usr/share/doc/$(package)/changelog
126 install -m 644 CHANGELOG.archive debian/base/usr/share/doc/$(package)/changelog.archive
127 gzip -9 debian/base/usr/share/doc/$(package)/changelog.archive
128 install -m 644 dbus/DBus-interface debian/base/usr/share/doc/$(package)/.
129 gzip -9 debian/base/usr/share/doc/$(package)/DBus-interface
130 endif
131 install -m 644 debian/dnsmasq-base.conffiles debian/base/DEBIAN/conffiles
132 install -m 755 debian/dnsmasq-base.postinst debian/base/DEBIAN/postinst
133 install -m 755 debian/dnsmasq-base.postrm debian/base/DEBIAN/postrm
134 install -m 644 debian/changelog debian/base/usr/share/doc/$(package)/changelog.Debian
135 gzip -9 debian/base/usr/share/doc/$(package)/changelog.Debian
136 install -m 644 debian/readme debian/base/usr/share/doc/$(package)/README.Debian
137 install -m 644 debian/copyright debian/base/usr/share/doc/$(package)/copyright
138 install -m 644 debian/dbus.conf debian/base/etc/dbus-1/system.d/dnsmasq.conf
139 gzip -9 debian/base/usr/share/man/man8/dnsmasq.8
140 for f in debian/base/usr/share/man/*; do \
141 if [ -f $$f/man8/dnsmasq.8 ]; then \
142 gzip -9 $$f/man8/dnsmasq.8 ; \
143 fi \
144 done
145 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
146 strip -R .note -R .comment debian/base/usr/sbin/dnsmasq
147 endif
148 cd debian/base && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
149 dpkg-shlibdeps debian/base/usr/sbin/dnsmasq
150 dpkg-gencontrol -pdnsmasq-base -Pdebian/base
151 chown -R root.root debian/base
152 chmod -R g-ws debian/base
153 dpkg --build debian/base ..
155 ifeq ($(DEB_BUILD_ARCH_OS),linux)
156 rm -rf debian/utils
157 install -m 755 -d debian/utils/DEBIAN \
158 -d debian/utils/usr/share/man/man1 \
159 -d debian/utils/usr/bin \
160 -d debian/utils/usr/share/doc/dnsmasq-utils
161 make -C contrib/wrt PREFIX=/usr DESTDIR=`pwd`/debian/utils CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(COPTS)" CC=gcc
162 install -m 755 contrib/wrt/dhcp_release debian/utils/usr/bin/dhcp_release
163 install -m 644 contrib/wrt/dhcp_release.1 debian/utils/usr/share/man/man1/dhcp_release.1
164 gzip -9 debian/utils/usr/share/man/man1/dhcp_release.1
165 install -m 755 contrib/wrt/dhcp_lease_time debian/utils/usr/bin/dhcp_lease_time
166 install -m 644 contrib/wrt/dhcp_lease_time.1 debian/utils/usr/share/man/man1/dhcp_lease_time.1
167 install -m 644 debian/copyright debian/utils/usr/share/doc/dnsmasq-utils/copyright
168 install -m 644 debian/changelog debian/utils/usr/share/doc/dnsmasq-utils/changelog.Debian
169 gzip -9 debian/utils/usr/share/doc/dnsmasq-utils/changelog.Debian
170 gzip -9 debian/utils/usr/share/man/man1/dhcp_lease_time.1
171 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
172 strip -R .note -R .comment debian/utils/usr/bin/dhcp_release
173 strip -R .note -R .comment debian/utils/usr/bin/dhcp_lease_time
174 endif
175 cd debian/utils && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
176 dpkg-shlibdeps -Tdebian/utils-substvars debian/utils/usr/bin/dhcp_release debian/utils/usr/bin/dhcp_lease_time
177 dpkg-gencontrol -Tdebian/utils-substvars -pdnsmasq-utils -Pdebian/utils
178 chown -R root.root debian/utils
179 chmod -R g-ws debian/utils
180 dpkg --build debian/utils ..
181 endif
183 define checkdir
184 test -f Makefile -a -f debian/rules
185 endef
187 # Below here is fairly generic really
189 binary: binary-arch binary-indep
191 build:
192 build-arch:
193 build-indep:
195 checkroot:
196 test root = "`whoami`"
198 .PHONY: binary binary-arch binary-indep clean checkroot