Merge from master at 9412097ee1c780c94431520810a4406d3057fa6d
[tagua/yd.git] / debian / rules
blob1599b43aa6e80867b4516232040141d4b48855d4
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
14 #export DH_VERBOSE=1
16 # This has to be exported to make some magic below work.
17 export DH_OPTIONS
19 configure: CMakeCache.txt
20 CMakeCache.txt:
21 dh_testdir
22 rm -f CMakeCache.txt
23 cmake \
24 -DSYSTEM_LUA=yes \
25 -DCMAKE_INSTALL_PREFIX:PATH=/usr \
26 -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake-qt4
29 #Architecture
30 build: build-arch build-indep
32 build-arch: build-stamp
33 build-stamp: CMakeCache.txt
35 $(MAKE)
36 touch $@
38 build-indep:
39 # nothing to do here
41 clean:
42 dh_testdir
43 dh_testroot
44 rm -f build-stamp
46 rm -f CMakeCache.txt
47 rm -rf CMakeTmp
48 $(MAKE) clean
50 dh_clean
52 install: SHELL=/bin/bash
53 install:
54 dh_testdir
55 dh_testroot
56 dh_clean -k
58 $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
59 cd debian/tmp && mv usr/bin usr/games
61 dh_movefiles
62 test -z "$$(find debian/tmp ! -type d | tee >(cat >&2))"
64 dh_install
66 # Must not depend on anything. This is to be called by
67 # binary-arch/binary-indep
68 # in another 'make' thread.
69 binary-common:
70 dh_testdir
71 dh_testroot
72 dh_installchangelogs CHANGELOG
73 dh_installdocs
74 dh_installexamples
75 dh_installmenu
76 # dh_installdebconf
77 # dh_installmime
78 # dh_python
79 # dh_installinfo
80 dh_installman
81 dh_link
82 dh_strip
83 dh_compress
84 dh_fixperms
85 # dh_perl
86 dh_makeshlibs
87 dh_installdeb
88 dh_shlibdeps
89 dh_gencontrol
90 dh_md5sums
91 dh_builddeb
93 # Build architecture independant packages using the common target.
94 binary-indep: build-indep install
95 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
97 # Build architecture dependant packages using the common target.
98 binary-arch: build-arch install
99 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
101 binary: binary-arch binary-indep
102 .PHONY: build clean binary-indep binary-arch binary install configure