Release 1.20.0 -- SRTP, Conference URL & TLS-DSK Improvements
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob0f1c2969f8333020f1b26ff04c478a752bc3698f
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20150106gitced3e52
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.20.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: pkgconfig(purple) >= 2.4.0
45 BuildRequires: pkgconfig(glib-2.0) >= 2.12.0
46 BuildRequires: pkgconfig(gmodule-2.0) >= 2.12.0
47 BuildRequires: gmime-devel
48 BuildRequires: pkgconfig(libxml-2.0)
49 BuildRequires: pkgconfig(nss)
50 BuildRequires: libtool
51 BuildRequires: intltool
52 BuildRequires: gettext-devel
53 # Use "--without vv" to disable Voice & Video features
54 %if !0%{?_without_vv:1}
55 BuildRequires: pkgconfig(purple) >= 2.8.0
56 BuildRequires: pkgconfig(nice) >= 0.1.0
57 %if 0%{?fedora} >= 20
58 # Dependency required when gstreamer support is split into two packages
59 %define requires_libnice_gstreamer 1
60 %endif
61 BuildRequires: pkgconfig(gstreamer-0.10)
62 %endif
63 # Use "--without telepathy" to disable telepathy
64 %if !0%{?_without_telepathy:1}
65 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
66 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
67 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
68 BuildRequires: pkgconfig(gobject-2.0)
69 BuildRequires: pkgconfig(dbus-glib-1)
70 %endif
72 # Configurable components
73 # Use "--without kerberos" to disable krb5
74 %if !0%{?_without_kerberos:1}
75 BuildRequires: krb5-devel
76 %if 0%{?fedora} >= 21
77 BuildRequires: gssntlmssp-devel >= 0.5.0
78 %define requires_gssntlmssp 1
79 %endif
80 %endif
82 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
85 %description
86 A third-party plugin for the Pidgin multi-protocol instant messenger.
87 It implements the extended version of SIP/SIMPLE used by various products:
89 * Microsoft Office 365
90 * Microsoft Business Productivity Online Suite (BPOS)
91 * Microsoft Lync Server
92 * Microsoft Office Communications Server (OCS 2007/2007 R2)
93 * Microsoft Live Communications Server (LCS 2003/2005)
94 * Reuters Messaging
96 With this plugin you should be able to replace your Microsoft Office
97 Communicator client with Pidgin.
99 This package provides the icon set for Pidgin.
102 %package -n %{purple_plugin}
103 Summary: Libpurple protocol plugin to connect to MS Office Communicator
104 Group: %{pkg_group}
105 License: GPL-2.0+
106 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
108 %if 0%{?requires_libnice_gstreamer}
109 Requires: libnice-gstreamer
110 %endif
111 %if 0%{?requires_gssntlmssp}
112 Requires: gssntlmssp >= 0.5.0
113 %endif
115 %description -n %{purple_plugin}
116 A third-party plugin for the Pidgin multi-protocol instant messenger.
117 It implements the extended version of SIP/SIMPLE used by various products:
119 * Microsoft Office 365
120 * Microsoft Business Productivity Online Suite (BPOS)
121 * Microsoft Lync Server
122 * Microsoft Office Communications Server (OCS 2007/2007 R2)
123 * Microsoft Live Communications Server (LCS 2003/2005)
124 * Reuters Messaging
126 This package provides the protocol plugin for libpurple clients.
129 %if !0%{?_without_telepathy:1}
130 %package -n %{empathy_files}
131 Summary: Telepathy connection manager to connect to MS Office Communicator
132 Group: %{pkg_group}
133 License: GPL-2.0+
134 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
136 %description -n %{empathy_files}
137 A Telepathy connection manager that implements the extended version of
138 SIP/SIMPLE used by various products:
140 * Microsoft Office 365
141 * Microsoft Business Productivity Online Suite (BPOS)
142 * Microsoft Lync Server
143 * Microsoft Office Communications Server (OCS 2007/2007 R2)
144 * Microsoft Live Communications Server (LCS 2003/2005)
145 * Reuters Messaging
147 This package provides the icon set for Empathy.
150 %package -n %{ktp_files}
151 Summary: Telepathy connection manager to connect to MS Office Communicator
152 Group: %{pkg_group}
153 License: GPL-2.0+
154 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
156 %description -n %{ktp_files}
157 A Telepathy connection manager that implements the extended version of
158 SIP/SIMPLE used by various products:
160 * Microsoft Office 365
161 * Microsoft Business Productivity Online Suite (BPOS)
162 * Microsoft Lync Server
163 * Microsoft Office Communications Server (OCS 2007/2007 R2)
164 * Microsoft Live Communications Server (LCS 2003/2005)
165 * Reuters Messaging
167 This package provides the profile for KTP account manager.
170 %package -n %{telepathy_plugin}
171 Summary: Telepathy connection manager to connect to MS Office Communicator
172 Group: %{pkg_group}
173 License: GPL-2.0+
174 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
176 %if 0%{?requires_libnice_gstreamer}
177 # @TODO: remove comment when telepathy plugin supports Voice & Video features
178 #Requires: libnice-gstreamer
179 %endif
180 %if 0%{?requires_gssntlmssp}
181 Requires: gssntlmssp >= 0.5.0
182 %endif
184 %description -n %{telepathy_plugin}
185 A Telepathy connection manager that implements the extended version of
186 SIP/SIMPLE used by various products:
188 * Microsoft Office 365
189 * Microsoft Business Productivity Online Suite (BPOS)
190 * Microsoft Lync Server
191 * Microsoft Office Communications Server (OCS 2007/2007 R2)
192 * Microsoft Live Communications Server (LCS 2003/2005)
193 * Reuters Messaging
195 This package provides the protocol support for Telepathy clients.
196 %endif
199 %package -n %{common_files}
200 Summary: Common files for SIPE protocol plugins
201 Group: %{pkg_group}
202 License: GPL-2.0+
203 BuildArch: noarch
205 %description -n %{common_files}
206 This package provides common files for the SIPE protocol plugins:
208 * Localisation
211 %prep
212 %if 0%{?_with_git:1}
213 %setup -q -n %{name}-%{git}
214 %else
215 %setup -q
216 %endif
219 %build
220 %if 0%{?_with_git:1}
221 ./autogen.sh
222 %endif
223 %configure \
224 %if 0%{?_without_vv:1}
225 --without-vv \
226 %endif
227 --enable-purple \
228 %if !0%{?_without_telepathy:1}
229 --enable-telepathy
230 %else
231 --disable-telepathy
232 %endif
233 make %{_smp_mflags}
234 make %{_smp_mflags} check
237 %install
238 %makeinstall
239 find %{buildroot} -type f -name "*.la" -delete -print
240 # Pidgin doesn't have 24 or 32 pixel icons
241 rm -f \
242 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
243 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
244 %find_lang %{name}
247 %clean
248 rm -rf %{buildroot}
251 %files -n %{purple_plugin}
252 %defattr(-,root,root,-)
253 %doc AUTHORS ChangeLog COPYING NEWS README TODO
254 %{_libdir}/purple-2/libsipe.so
257 %if !0%{?_without_telepathy:1}
258 %files -n %{empathy_files}
259 %defattr(-,root,root,-)
260 %doc AUTHORS COPYING
261 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
262 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
265 %files -n %{ktp_files}
266 %defattr(-,root,root,-)
267 %doc AUTHORS COPYING
268 %{_datadir}/telepathy/profiles/sipe.profile
271 %files -n %{telepathy_plugin}
272 %defattr(-,root,root,-)
273 %doc AUTHORS ChangeLog COPYING NEWS README TODO
274 %{_datadir}/dbus-1/services/*.sipe.service
275 %{_libexecdir}/telepathy-sipe
276 %endif
279 %files -n %{common_files} -f %{name}.lang
280 %defattr(-,root,root,-)
283 %files
284 %defattr(-,root,root,-)
285 %doc AUTHORS COPYING
286 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
287 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
290 %changelog
291 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
292 - update to 1.20.0
294 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
295 - update to 1.19.1
297 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
298 - update to 1.19.0
300 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
301 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
302 - enable Voice & Video features by default
303 - move dependency on libnice-gstreamer to correct packages
305 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
306 - update to 1.18.5
308 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
309 - update to 1.18.4
311 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
312 - update to 1.18.3
314 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
315 - update to 1.18.2
317 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
318 - update to 1.18.1
320 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
321 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
323 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
324 - F20+ require libnice-gstreamer for correct operation
326 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
327 - update to 1.18.0
329 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
330 - update to 1.17.3
332 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
333 - update to 1.17.2
335 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
336 - update to 1.17.1
338 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
339 - update to 1.17.0
341 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
342 - update to 1.16.1
344 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
345 - update to 1.16.0
347 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
348 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
350 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
351 - update to 1.15.1
353 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
354 - update package description texts
356 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
357 - update to 1.15.0
359 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
360 - update to 1.14.1
362 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
363 - update to 1.14.0
365 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
366 - BR telepathy-glib-devel >= 0.18.0
368 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
369 - BR telepathy-glib-devel >= 0.14.0
371 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
372 - add ktp-accounts-kcm-sipe package
374 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
375 - telepathy now requires glib-2.0 >= 2.22.0
376 - use "--without telepathy" to disable telepathy packages
378 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
379 - add empathy-sipe package
381 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
382 - add telepathy-sipe & sipe-common packages
384 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
385 - update to 1.13.3
387 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
388 - update to 1.13.2
390 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
391 - update to 1.13.1
393 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
394 - update to 1.13.0
396 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
397 - we do support Microsoft Lync Server 2010 now.
399 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
400 - update GPL2 license name
402 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
403 - add BR gmime-devel
405 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
406 - add BR nss-devel
408 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
409 - update to 1.12.0
411 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
412 - add "--with vv" option to enable Voice & Video features
414 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
415 - update to 1.11.2
417 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
418 - update to 1.11.1
420 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
421 - update to 1.11.0
423 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
424 - add (commented out) BR libnice-devel
426 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
427 - update to 1.10.1
429 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
430 - add (commented out) BR nss-devel
432 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
433 - update to 1.10.0
435 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
436 - changed --with/--without options to --enable/--disable
438 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
439 - removed --with-krb5 configure option as it is autodetected now
441 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
442 - add SVG icon
444 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
445 - add BR glib2-devel >= 2.12.0
447 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
448 - add tests to build
450 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
451 - update to 1.9.1
453 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
454 - add BR libxml2-devel
456 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
457 - update to 1.9.0
459 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
460 - increased libpurple build requisite to >= 2.4.0
462 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
463 - sync with RPM SPEC from contrib/OBS
465 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
466 - update package summary & description
468 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
469 - update to 1.8.1
471 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
472 - update to 1.8.0
474 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
475 - autogen.sh no longer runs configure
477 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
478 - add configure parameters for purple and telepathy
480 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
481 - add Epoch: for git packages to avoid update clash with official packages
483 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
484 - update to 1.7.1
486 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
487 - add missing Group: to purple-sipe
489 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
490 - update to 1.7.0
492 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
493 - move non-Pidgin files to new sub-package purple-sipe
495 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
496 - remove directory for emoticon theme icons
498 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
499 - libpurple protocol plugins are located under %{_libdir}/purple-2
501 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
502 - added directory for emoticon theme icons
504 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
505 - update to 1.6.3
507 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
508 - reduce libpurple-devel requirement to >= 2.3.1
510 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
511 - update to 1.6.2
513 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
514 - reduce libpurple-devel requirement to >= 2.4.1
516 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
517 - com_err.h only required for kerberos
519 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
520 - require libpurple-devel >= 2.5.0
522 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
523 - refactor configure parameters
524 - make kerberos configurable
525 - don't hard code prefix for git builds
527 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
528 - removed unnecessary zlib-devel
530 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
531 - fix prefix for git builds
533 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
534 - append -Wno-unused-parameter for GCC <4.4 compilation errors
536 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
537 - remove duplicate GPL2
539 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
540 - use "--with git" to build from git
541 - corrected download URL for release archive
542 - add missing BR gettext-devel
544 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
545 - use default rpmbuild CFLAGS also for git builds
546 - merge with SPEC files created by mricon & jberanek
548 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
549 - initial RPM SPEC example generated