contrib: raise BR purple >= 2.7.0
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobb6db7af7bd8b484aa1cb615fa9e3905d25793392
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box for any current Fedora or RHEL release.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20160405git4fedafa
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.23.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: http://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPLv2+
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
43 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
44 BuildRequires: pkgconfig(dbus-1)
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(nss)
47 BuildRequires: pkgconfig(purple) >= 2.7.0
48 %if 0%{?_with_git:1}
49 BuildRequires: autoconf
50 BuildRequires: automake
51 %endif
52 BuildRequires: gettext
53 BuildRequires: intltool
54 BuildRequires: libtool
55 # Use "--without vv" to disable Voice & Video features
56 %if !0%{?_without_vv:1}
57 BuildRequires: pkgconfig(purple) >= 2.8.0
58 BuildRequires: pkgconfig(farstream-0.2)
59 BuildRequires: pkgconfig(gio-2.0)
60 BuildRequires: pkgconfig(nice) >= 0.1.0
61 %if 0%{?fedora} >= 22
62 BuildRequires: pkgconfig(gstreamer-1.0)
63 %else
64 %if 0%{?fedora} >= 20
65 # Dependency required when gstreamer support is split into two packages
66 %define requires_libnice_gstreamer 1
67 %endif
68 BuildRequires: pkgconfig(gstreamer-0.10)
69 %endif
70 %endif
71 # Use "--without telepathy" to disable telepathy
72 %if !0%{?_without_telepathy:1}
73 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
74 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
75 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
76 BuildRequires: pkgconfig(gobject-2.0)
77 BuildRequires: pkgconfig(dbus-glib-1)
78 BuildRequires: gmime-devel
79 %endif
81 # Configurable components
82 # Use "--without kerberos" to disable krb5
83 %if !0%{?_without_kerberos:1}
84 BuildRequires: krb5-devel
85 %if 0%{?fedora} >= 21
86 BuildRequires: gssntlmssp-devel >= 0.5.0
87 %define requires_gssntlmssp 1
88 %endif
89 %endif
91 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
94 %description
95 A third-party plugin for the Pidgin multi-protocol instant messenger.
96 It implements the extended version of SIP/SIMPLE used by various products:
98 * Skype for Business
99 * Microsoft Office 365
100 * Microsoft Business Productivity Online Suite (BPOS)
101 * Microsoft Lync Server
102 * Microsoft Office Communications Server (OCS 2007/2007 R2)
103 * Microsoft Live Communications Server (LCS 2003/2005)
105 With this plugin you should be able to replace your Microsoft Office
106 Communicator client with Pidgin.
108 This package provides the icon set for Pidgin.
111 %package -n %{purple_plugin}
112 Summary: Libpurple protocol plugin to connect to MS Office Communicator
113 Group: %{pkg_group}
114 License: GPLv2+
115 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
117 %if 0%{?requires_libnice_gstreamer}
118 Requires: libnice-gstreamer
119 %endif
120 %if 0%{?requires_gssntlmssp}
121 Requires: gssntlmssp >= 0.5.0
122 %endif
124 %description -n %{purple_plugin}
125 A third-party plugin for the Pidgin multi-protocol instant messenger.
126 It implements the extended version of SIP/SIMPLE used by various products:
128 * Skype for Business
129 * Microsoft Office 365
130 * Microsoft Business Productivity Online Suite (BPOS)
131 * Microsoft Lync Server
132 * Microsoft Office Communications Server (OCS 2007/2007 R2)
133 * Microsoft Live Communications Server (LCS 2003/2005)
135 This package provides the protocol plugin for libpurple clients.
138 %if !0%{?_without_telepathy:1}
139 %package -n %{empathy_files}
140 Summary: Telepathy connection manager to connect to MS Office Communicator
141 Group: %{pkg_group}
142 License: GPLv2+
143 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
145 %description -n %{empathy_files}
146 A Telepathy connection manager that implements the extended version of
147 SIP/SIMPLE used by various products:
149 * Skype for Business
150 * Microsoft Office 365
151 * Microsoft Business Productivity Online Suite (BPOS)
152 * Microsoft Lync Server
153 * Microsoft Office Communications Server (OCS 2007/2007 R2)
154 * Microsoft Live Communications Server (LCS 2003/2005)
156 This package provides the icon set for Empathy.
159 %package -n %{ktp_files}
160 Summary: Telepathy connection manager to connect to MS Office Communicator
161 Group: %{pkg_group}
162 License: GPLv2+
163 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
165 %description -n %{ktp_files}
166 A Telepathy connection manager that implements the extended version of
167 SIP/SIMPLE used by various products:
169 * Skype for Business
170 * Microsoft Office 365
171 * Microsoft Business Productivity Online Suite (BPOS)
172 * Microsoft Lync Server
173 * Microsoft Office Communications Server (OCS 2007/2007 R2)
174 * Microsoft Live Communications Server (LCS 2003/2005)
176 This package provides the profile for KTP account manager.
179 %package -n %{telepathy_plugin}
180 Summary: Telepathy connection manager to connect to MS Office Communicator
181 Group: %{pkg_group}
182 License: GPLv2+
183 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
185 %if 0%{?requires_libnice_gstreamer}
186 # @TODO: remove comment when telepathy plugin supports Voice & Video features
187 #Requires: libnice-gstreamer
188 %endif
189 %if 0%{?requires_gssntlmssp}
190 Requires: gssntlmssp >= 0.5.0
191 %endif
193 %description -n %{telepathy_plugin}
194 A Telepathy connection manager that implements the extended version of
195 SIP/SIMPLE used by various products:
197 * Skype for Business
198 * Microsoft Office 365
199 * Microsoft Business Productivity Online Suite (BPOS)
200 * Microsoft Lync Server
201 * Microsoft Office Communications Server (OCS 2007/2007 R2)
202 * Microsoft Live Communications Server (LCS 2003/2005)
204 This package provides the protocol support for Telepathy clients.
205 %endif
208 %package -n %{common_files}
209 Summary: Common files for SIPE protocol plugins
210 Group: %{pkg_group}
211 License: GPLv2+
212 BuildArch: noarch
214 %description -n %{common_files}
215 This package provides common files for the SIPE protocol plugins:
217 * Localisation
220 %prep
221 %if 0%{?_with_git:1}
222 %setup -q -n %{name}-%{git}
223 %else
224 %setup -q
225 %endif
228 %build
229 %if 0%{?_with_git:1}
230 ./autogen.sh
231 %endif
232 %configure \
233 %if 0%{?_without_vv:1}
234 --without-vv \
235 %endif
236 %if !0%{?_without_kerberos:1}
237 --with-krb5 \
238 %endif
239 --enable-purple \
240 %if !0%{?_without_telepathy:1}
241 --enable-telepathy
242 %else
243 --disable-telepathy
244 %endif
245 make %{?_smp_mflags}
246 make %{?_smp_mflags} check
249 %install
250 %makeinstall
251 find %{buildroot} -type f -name "*.la" -delete -print
252 # Pidgin doesn't have 24 or 32 pixel icons
253 rm -f \
254 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
255 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
256 %find_lang %{name}
259 %clean
260 rm -rf %{buildroot}
263 %files -n %{purple_plugin}
264 %defattr(-,root,root,-)
265 %doc AUTHORS ChangeLog COPYING NEWS README TODO
266 %{_libdir}/purple-2/libsipe.so
269 %if !0%{?_without_telepathy:1}
270 %files -n %{empathy_files}
271 %defattr(-,root,root,-)
272 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
273 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
276 %files -n %{ktp_files}
277 %defattr(-,root,root,-)
278 %doc AUTHORS COPYING
279 %{_datadir}/telepathy/profiles/sipe.profile
282 %files -n %{telepathy_plugin}
283 %defattr(-,root,root,-)
284 %doc AUTHORS ChangeLog COPYING NEWS README TODO
285 %{_datadir}/dbus-1/services/*.sipe.service
286 %{_libexecdir}/telepathy-sipe
287 %endif
290 %files -n %{common_files} -f %{name}.lang
291 %defattr(-,root,root,-)
294 %files
295 %defattr(-,root,root,-)
296 %{_datadir}/appdata/%{name}.metainfo.xml
297 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
298 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
301 %changelog
302 * DDD MMM DD 2017 J. D. User <jduser@noreply.com> 1.23.0
303 - update to 1.23.0
304 - raise BR glib-2.0 >= 2.18.0
305 - raise BR purple >= 2.7.0
307 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
308 - add BR dbus-1
310 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
311 - update to 1.22.1
313 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
314 - update to 1.22.0
316 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
317 - add BR gio-2.0
319 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
320 - add BR farstream-0.2
322 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
323 - update to 1.21.1
325 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
326 - update to 1.21.0
328 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
329 - align with Fedora SPEC file
331 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
332 - add AppStream metadata file
334 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
335 - add dependency on pkgconfig(gstreamer-1.0) for F22+
337 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
338 - update to 1.20.1
340 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
341 - we also support "Skype for Business"
343 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
344 - update to 1.20.0
346 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
347 - update to 1.19.1
349 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
350 - update to 1.19.0
352 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
353 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
354 - enable Voice & Video features by default
355 - move dependency on libnice-gstreamer to correct packages
357 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
358 - update to 1.18.5
360 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
361 - update to 1.18.4
363 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
364 - update to 1.18.3
366 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
367 - update to 1.18.2
369 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
370 - update to 1.18.1
372 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
373 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
375 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
376 - F20+ require libnice-gstreamer for correct operation
378 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
379 - update to 1.18.0
381 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
382 - update to 1.17.3
384 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
385 - update to 1.17.2
387 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
388 - update to 1.17.1
390 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
391 - update to 1.17.0
393 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
394 - update to 1.16.1
396 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
397 - update to 1.16.0
399 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
400 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
402 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
403 - update to 1.15.1
405 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
406 - update package description texts
408 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
409 - update to 1.15.0
411 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
412 - update to 1.14.1
414 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
415 - update to 1.14.0
417 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
418 - BR telepathy-glib-devel >= 0.18.0
420 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
421 - BR telepathy-glib-devel >= 0.14.0
423 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
424 - add ktp-accounts-kcm-sipe package
426 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
427 - telepathy now requires glib-2.0 >= 2.22.0
428 - use "--without telepathy" to disable telepathy packages
430 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
431 - add empathy-sipe package
433 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
434 - add telepathy-sipe & sipe-common packages
436 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
437 - update to 1.13.3
439 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
440 - update to 1.13.2
442 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
443 - update to 1.13.1
445 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
446 - update to 1.13.0
448 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
449 - we do support Microsoft Lync Server 2010 now.
451 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
452 - update GPL2 license name
454 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
455 - add BR gmime-devel
457 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
458 - add BR nss-devel
460 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
461 - update to 1.12.0
463 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
464 - add "--with vv" option to enable Voice & Video features
466 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
467 - update to 1.11.2
469 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
470 - update to 1.11.1
472 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
473 - update to 1.11.0
475 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
476 - add (commented out) BR libnice-devel
478 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
479 - update to 1.10.1
481 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
482 - add (commented out) BR nss-devel
484 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
485 - update to 1.10.0
487 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
488 - changed --with/--without options to --enable/--disable
490 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
491 - removed --with-krb5 configure option as it is autodetected now
493 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
494 - add SVG icon
496 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
497 - add BR glib2-devel >= 2.12.0
499 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
500 - add tests to build
502 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
503 - update to 1.9.1
505 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
506 - add BR libxml2-devel
508 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
509 - update to 1.9.0
511 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
512 - increased libpurple build requisite to >= 2.4.0
514 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
515 - sync with RPM SPEC from contrib/OBS
517 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
518 - update package summary & description
520 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
521 - update to 1.8.1
523 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
524 - update to 1.8.0
526 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
527 - autogen.sh no longer runs configure
529 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
530 - add configure parameters for purple and telepathy
532 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
533 - add Epoch: for git packages to avoid update clash with official packages
535 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
536 - update to 1.7.1
538 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
539 - add missing Group: to purple-sipe
541 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
542 - update to 1.7.0
544 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
545 - move non-Pidgin files to new sub-package purple-sipe
547 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
548 - remove directory for emoticon theme icons
550 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
551 - libpurple protocol plugins are located under %%{_libdir}/purple-2
553 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
554 - added directory for emoticon theme icons
556 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
557 - update to 1.6.3
559 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
560 - reduce libpurple-devel requirement to >= 2.3.1
562 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
563 - update to 1.6.2
565 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
566 - reduce libpurple-devel requirement to >= 2.4.1
568 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
569 - com_err.h only required for kerberos
571 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
572 - require libpurple-devel >= 2.5.0
574 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
575 - refactor configure parameters
576 - make kerberos configurable
577 - don't hard code prefix for git builds
579 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
580 - removed unnecessary zlib-devel
582 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
583 - fix prefix for git builds
585 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
586 - append -Wno-unused-parameter for GCC <4.4 compilation errors
588 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
589 - remove duplicate GPL2
591 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
592 - use "--with git" to build from git
593 - corrected download URL for release archive
594 - add missing BR gettext-devel
596 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
597 - use default rpmbuild CFLAGS also for git builds
598 - merge with SPEC files created by mricon & jberanek
600 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
601 - initial RPM SPEC example generated