Release 1.20.1 -- Bug Fixes I
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobd86db5e711f11e1f03b0fd56f4b58f99aad00812
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20150106gitced3e52
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.20.1
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: pkgconfig(purple) >= 2.4.0
45 BuildRequires: pkgconfig(glib-2.0) >= 2.12.0
46 BuildRequires: pkgconfig(gmodule-2.0) >= 2.12.0
47 BuildRequires: gmime-devel
48 BuildRequires: pkgconfig(libxml-2.0)
49 BuildRequires: pkgconfig(nss)
50 BuildRequires: libtool
51 BuildRequires: intltool
52 BuildRequires: gettext-devel
53 # Use "--without vv" to disable Voice & Video features
54 %if !0%{?_without_vv:1}
55 BuildRequires: pkgconfig(purple) >= 2.8.0
56 BuildRequires: pkgconfig(nice) >= 0.1.0
57 %if 0%{?fedora} >= 20
58 # Dependency required when gstreamer support is split into two packages
59 %define requires_libnice_gstreamer 1
60 %endif
61 BuildRequires: pkgconfig(gstreamer-0.10)
62 %endif
63 # Use "--without telepathy" to disable telepathy
64 %if !0%{?_without_telepathy:1}
65 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
66 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
67 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
68 BuildRequires: pkgconfig(gobject-2.0)
69 BuildRequires: pkgconfig(dbus-glib-1)
70 %endif
72 # Configurable components
73 # Use "--without kerberos" to disable krb5
74 %if !0%{?_without_kerberos:1}
75 BuildRequires: krb5-devel
76 %if 0%{?fedora} >= 21
77 BuildRequires: gssntlmssp-devel >= 0.5.0
78 %define requires_gssntlmssp 1
79 %endif
80 %endif
82 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
85 %description
86 A third-party plugin for the Pidgin multi-protocol instant messenger.
87 It implements the extended version of SIP/SIMPLE used by various products:
89 * Skype for Business
90 * Microsoft Office 365
91 * Microsoft Business Productivity Online Suite (BPOS)
92 * Microsoft Lync Server
93 * Microsoft Office Communications Server (OCS 2007/2007 R2)
94 * Microsoft Live Communications Server (LCS 2003/2005)
95 * Reuters Messaging
97 With this plugin you should be able to replace your Microsoft Office
98 Communicator client with Pidgin.
100 This package provides the icon set for Pidgin.
103 %package -n %{purple_plugin}
104 Summary: Libpurple protocol plugin to connect to MS Office Communicator
105 Group: %{pkg_group}
106 License: GPL-2.0+
107 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
109 %if 0%{?requires_libnice_gstreamer}
110 Requires: libnice-gstreamer
111 %endif
112 %if 0%{?requires_gssntlmssp}
113 Requires: gssntlmssp >= 0.5.0
114 %endif
116 %description -n %{purple_plugin}
117 A third-party plugin for the Pidgin multi-protocol instant messenger.
118 It implements the extended version of SIP/SIMPLE used by various products:
120 * Skype for Business
121 * Microsoft Office 365
122 * Microsoft Business Productivity Online Suite (BPOS)
123 * Microsoft Lync Server
124 * Microsoft Office Communications Server (OCS 2007/2007 R2)
125 * Microsoft Live Communications Server (LCS 2003/2005)
126 * Reuters Messaging
128 This package provides the protocol plugin for libpurple clients.
131 %if !0%{?_without_telepathy:1}
132 %package -n %{empathy_files}
133 Summary: Telepathy connection manager to connect to MS Office Communicator
134 Group: %{pkg_group}
135 License: GPL-2.0+
136 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
138 %description -n %{empathy_files}
139 A Telepathy connection manager that implements the extended version of
140 SIP/SIMPLE used by various products:
142 * Skype for Business
143 * Microsoft Office 365
144 * Microsoft Business Productivity Online Suite (BPOS)
145 * Microsoft Lync Server
146 * Microsoft Office Communications Server (OCS 2007/2007 R2)
147 * Microsoft Live Communications Server (LCS 2003/2005)
148 * Reuters Messaging
150 This package provides the icon set for Empathy.
153 %package -n %{ktp_files}
154 Summary: Telepathy connection manager to connect to MS Office Communicator
155 Group: %{pkg_group}
156 License: GPL-2.0+
157 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
159 %description -n %{ktp_files}
160 A Telepathy connection manager that implements the extended version of
161 SIP/SIMPLE used by various products:
163 * Skype for Business
164 * Microsoft Office 365
165 * Microsoft Business Productivity Online Suite (BPOS)
166 * Microsoft Lync Server
167 * Microsoft Office Communications Server (OCS 2007/2007 R2)
168 * Microsoft Live Communications Server (LCS 2003/2005)
169 * Reuters Messaging
171 This package provides the profile for KTP account manager.
174 %package -n %{telepathy_plugin}
175 Summary: Telepathy connection manager to connect to MS Office Communicator
176 Group: %{pkg_group}
177 License: GPL-2.0+
178 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
180 %if 0%{?requires_libnice_gstreamer}
181 # @TODO: remove comment when telepathy plugin supports Voice & Video features
182 #Requires: libnice-gstreamer
183 %endif
184 %if 0%{?requires_gssntlmssp}
185 Requires: gssntlmssp >= 0.5.0
186 %endif
188 %description -n %{telepathy_plugin}
189 A Telepathy connection manager that implements the extended version of
190 SIP/SIMPLE used by various products:
192 * Skype for Business
193 * Microsoft Office 365
194 * Microsoft Business Productivity Online Suite (BPOS)
195 * Microsoft Lync Server
196 * Microsoft Office Communications Server (OCS 2007/2007 R2)
197 * Microsoft Live Communications Server (LCS 2003/2005)
198 * Reuters Messaging
200 This package provides the protocol support for Telepathy clients.
201 %endif
204 %package -n %{common_files}
205 Summary: Common files for SIPE protocol plugins
206 Group: %{pkg_group}
207 License: GPL-2.0+
208 BuildArch: noarch
210 %description -n %{common_files}
211 This package provides common files for the SIPE protocol plugins:
213 * Localisation
216 %prep
217 %if 0%{?_with_git:1}
218 %setup -q -n %{name}-%{git}
219 %else
220 %setup -q
221 %endif
224 %build
225 %if 0%{?_with_git:1}
226 ./autogen.sh
227 %endif
228 %configure \
229 %if 0%{?_without_vv:1}
230 --without-vv \
231 %endif
232 --enable-purple \
233 %if !0%{?_without_telepathy:1}
234 --enable-telepathy
235 %else
236 --disable-telepathy
237 %endif
238 make %{_smp_mflags}
239 make %{_smp_mflags} check
242 %install
243 %makeinstall
244 find %{buildroot} -type f -name "*.la" -delete -print
245 # Pidgin doesn't have 24 or 32 pixel icons
246 rm -f \
247 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
248 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
249 %find_lang %{name}
252 %clean
253 rm -rf %{buildroot}
256 %files -n %{purple_plugin}
257 %defattr(-,root,root,-)
258 %doc AUTHORS ChangeLog COPYING NEWS README TODO
259 %{_libdir}/purple-2/libsipe.so
262 %if !0%{?_without_telepathy:1}
263 %files -n %{empathy_files}
264 %defattr(-,root,root,-)
265 %doc AUTHORS COPYING
266 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
267 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
270 %files -n %{ktp_files}
271 %defattr(-,root,root,-)
272 %doc AUTHORS COPYING
273 %{_datadir}/telepathy/profiles/sipe.profile
276 %files -n %{telepathy_plugin}
277 %defattr(-,root,root,-)
278 %doc AUTHORS ChangeLog COPYING NEWS README TODO
279 %{_datadir}/dbus-1/services/*.sipe.service
280 %{_libexecdir}/telepathy-sipe
281 %endif
284 %files -n %{common_files} -f %{name}.lang
285 %defattr(-,root,root,-)
288 %files
289 %defattr(-,root,root,-)
290 %doc AUTHORS COPYING
291 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
292 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
295 %changelog
296 * Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
297 - update to 1.20.1
299 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
300 - we also support "Skype for Business"
302 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
303 - update to 1.20.0
305 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
306 - update to 1.19.1
308 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
309 - update to 1.19.0
311 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
312 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
313 - enable Voice & Video features by default
314 - move dependency on libnice-gstreamer to correct packages
316 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
317 - update to 1.18.5
319 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
320 - update to 1.18.4
322 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
323 - update to 1.18.3
325 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
326 - update to 1.18.2
328 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
329 - update to 1.18.1
331 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
332 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
334 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
335 - F20+ require libnice-gstreamer for correct operation
337 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
338 - update to 1.18.0
340 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
341 - update to 1.17.3
343 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
344 - update to 1.17.2
346 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
347 - update to 1.17.1
349 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
350 - update to 1.17.0
352 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
353 - update to 1.16.1
355 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
356 - update to 1.16.0
358 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
359 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
361 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
362 - update to 1.15.1
364 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
365 - update package description texts
367 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
368 - update to 1.15.0
370 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
371 - update to 1.14.1
373 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
374 - update to 1.14.0
376 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
377 - BR telepathy-glib-devel >= 0.18.0
379 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
380 - BR telepathy-glib-devel >= 0.14.0
382 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
383 - add ktp-accounts-kcm-sipe package
385 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
386 - telepathy now requires glib-2.0 >= 2.22.0
387 - use "--without telepathy" to disable telepathy packages
389 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
390 - add empathy-sipe package
392 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
393 - add telepathy-sipe & sipe-common packages
395 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
396 - update to 1.13.3
398 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
399 - update to 1.13.2
401 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
402 - update to 1.13.1
404 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
405 - update to 1.13.0
407 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
408 - we do support Microsoft Lync Server 2010 now.
410 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
411 - update GPL2 license name
413 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
414 - add BR gmime-devel
416 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
417 - add BR nss-devel
419 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
420 - update to 1.12.0
422 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
423 - add "--with vv" option to enable Voice & Video features
425 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
426 - update to 1.11.2
428 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
429 - update to 1.11.1
431 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
432 - update to 1.11.0
434 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
435 - add (commented out) BR libnice-devel
437 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
438 - update to 1.10.1
440 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
441 - add (commented out) BR nss-devel
443 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
444 - update to 1.10.0
446 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
447 - changed --with/--without options to --enable/--disable
449 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
450 - removed --with-krb5 configure option as it is autodetected now
452 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
453 - add SVG icon
455 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
456 - add BR glib2-devel >= 2.12.0
458 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
459 - add tests to build
461 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
462 - update to 1.9.1
464 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
465 - add BR libxml2-devel
467 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
468 - update to 1.9.0
470 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
471 - increased libpurple build requisite to >= 2.4.0
473 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
474 - sync with RPM SPEC from contrib/OBS
476 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
477 - update package summary & description
479 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
480 - update to 1.8.1
482 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
483 - update to 1.8.0
485 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
486 - autogen.sh no longer runs configure
488 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
489 - add configure parameters for purple and telepathy
491 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
492 - add Epoch: for git packages to avoid update clash with official packages
494 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
495 - update to 1.7.1
497 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
498 - add missing Group: to purple-sipe
500 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
501 - update to 1.7.0
503 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
504 - move non-Pidgin files to new sub-package purple-sipe
506 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
507 - remove directory for emoticon theme icons
509 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
510 - libpurple protocol plugins are located under %{_libdir}/purple-2
512 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
513 - added directory for emoticon theme icons
515 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
516 - update to 1.6.3
518 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
519 - reduce libpurple-devel requirement to >= 2.3.1
521 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
522 - update to 1.6.2
524 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
525 - reduce libpurple-devel requirement to >= 2.4.1
527 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
528 - com_err.h only required for kerberos
530 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
531 - require libpurple-devel >= 2.5.0
533 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
534 - refactor configure parameters
535 - make kerberos configurable
536 - don't hard code prefix for git builds
538 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
539 - removed unnecessary zlib-devel
541 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
542 - fix prefix for git builds
544 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
545 - append -Wno-unused-parameter for GCC <4.4 compilation errors
547 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
548 - remove duplicate GPL2
550 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
551 - use "--with git" to build from git
552 - corrected download URL for release archive
553 - add missing BR gettext-devel
555 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
556 - use default rpmbuild CFLAGS also for git builds
557 - merge with SPEC files created by mricon & jberanek
559 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
560 - initial RPM SPEC example generated