Release 1.21.0 -- Lync File Transfer
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob04ae7bb0ec22c3e4a3f1e2388001d48e09b5dd93
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20160405git4fedafa
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.21.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: http://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPLv2+
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(glib-2.0) >= 2.12.0
43 BuildRequires: pkgconfig(gmodule-2.0) >= 2.12.0
44 BuildRequires: pkgconfig(libxml-2.0)
45 BuildRequires: pkgconfig(nss)
46 BuildRequires: pkgconfig(purple) >= 2.4.0
47 %if 0%{?_with_git:1}
48 BuildRequires: autoconf
49 BuildRequires: automake
50 %endif
51 BuildRequires: gettext
52 BuildRequires: intltool
53 BuildRequires: libtool
54 # Use "--without vv" to disable Voice & Video features
55 %if !0%{?_without_vv:1}
56 BuildRequires: pkgconfig(purple) >= 2.8.0
57 BuildRequires: pkgconfig(nice) >= 0.1.0
58 %if 0%{?fedora} >= 22
59 BuildRequires: pkgconfig(gstreamer-1.0)
60 %else
61 %if 0%{?fedora} >= 20
62 # Dependency required when gstreamer support is split into two packages
63 %define requires_libnice_gstreamer 1
64 %endif
65 BuildRequires: pkgconfig(gstreamer-0.10)
66 %endif
67 %endif
68 # Use "--without telepathy" to disable telepathy
69 %if !0%{?_without_telepathy:1}
70 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
71 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
72 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
73 BuildRequires: pkgconfig(gobject-2.0)
74 BuildRequires: pkgconfig(dbus-glib-1)
75 BuildRequires: gmime-devel
76 %endif
78 # Configurable components
79 # Use "--without kerberos" to disable krb5
80 %if !0%{?_without_kerberos:1}
81 BuildRequires: krb5-devel
82 %if 0%{?fedora} >= 21
83 BuildRequires: gssntlmssp-devel >= 0.5.0
84 %define requires_gssntlmssp 1
85 %endif
86 %endif
88 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
91 %description
92 A third-party plugin for the Pidgin multi-protocol instant messenger.
93 It implements the extended version of SIP/SIMPLE used by various products:
95 * Skype for Business
96 * Microsoft Office 365
97 * Microsoft Business Productivity Online Suite (BPOS)
98 * Microsoft Lync Server
99 * Microsoft Office Communications Server (OCS 2007/2007 R2)
100 * Microsoft Live Communications Server (LCS 2003/2005)
101 * Reuters Messaging
103 With this plugin you should be able to replace your Microsoft Office
104 Communicator client with Pidgin.
106 This package provides the icon set for Pidgin.
109 %package -n %{purple_plugin}
110 Summary: Libpurple protocol plugin to connect to MS Office Communicator
111 Group: %{pkg_group}
112 License: GPLv2+
113 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
115 %if 0%{?requires_libnice_gstreamer}
116 Requires: libnice-gstreamer
117 %endif
118 %if 0%{?requires_gssntlmssp}
119 Requires: gssntlmssp >= 0.5.0
120 %endif
122 %description -n %{purple_plugin}
123 A third-party plugin for the Pidgin multi-protocol instant messenger.
124 It implements the extended version of SIP/SIMPLE used by various products:
126 * Skype for Business
127 * Microsoft Office 365
128 * Microsoft Business Productivity Online Suite (BPOS)
129 * Microsoft Lync Server
130 * Microsoft Office Communications Server (OCS 2007/2007 R2)
131 * Microsoft Live Communications Server (LCS 2003/2005)
132 * Reuters Messaging
134 This package provides the protocol plugin for libpurple clients.
137 %if !0%{?_without_telepathy:1}
138 %package -n %{empathy_files}
139 Summary: Telepathy connection manager to connect to MS Office Communicator
140 Group: %{pkg_group}
141 License: GPLv2+
142 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
144 %description -n %{empathy_files}
145 A Telepathy connection manager that implements the extended version of
146 SIP/SIMPLE used by various products:
148 * Skype for Business
149 * Microsoft Office 365
150 * Microsoft Business Productivity Online Suite (BPOS)
151 * Microsoft Lync Server
152 * Microsoft Office Communications Server (OCS 2007/2007 R2)
153 * Microsoft Live Communications Server (LCS 2003/2005)
154 * Reuters Messaging
156 This package provides the icon set for Empathy.
159 %package -n %{ktp_files}
160 Summary: Telepathy connection manager to connect to MS Office Communicator
161 Group: %{pkg_group}
162 License: GPLv2+
163 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
165 %description -n %{ktp_files}
166 A Telepathy connection manager that implements the extended version of
167 SIP/SIMPLE used by various products:
169 * Skype for Business
170 * Microsoft Office 365
171 * Microsoft Business Productivity Online Suite (BPOS)
172 * Microsoft Lync Server
173 * Microsoft Office Communications Server (OCS 2007/2007 R2)
174 * Microsoft Live Communications Server (LCS 2003/2005)
175 * Reuters Messaging
177 This package provides the profile for KTP account manager.
180 %package -n %{telepathy_plugin}
181 Summary: Telepathy connection manager to connect to MS Office Communicator
182 Group: %{pkg_group}
183 License: GPLv2+
184 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
186 %if 0%{?requires_libnice_gstreamer}
187 # @TODO: remove comment when telepathy plugin supports Voice & Video features
188 #Requires: libnice-gstreamer
189 %endif
190 %if 0%{?requires_gssntlmssp}
191 Requires: gssntlmssp >= 0.5.0
192 %endif
194 %description -n %{telepathy_plugin}
195 A Telepathy connection manager that implements the extended version of
196 SIP/SIMPLE used by various products:
198 * Skype for Business
199 * Microsoft Office 365
200 * Microsoft Business Productivity Online Suite (BPOS)
201 * Microsoft Lync Server
202 * Microsoft Office Communications Server (OCS 2007/2007 R2)
203 * Microsoft Live Communications Server (LCS 2003/2005)
204 * Reuters Messaging
206 This package provides the protocol support for Telepathy clients.
207 %endif
210 %package -n %{common_files}
211 Summary: Common files for SIPE protocol plugins
212 Group: %{pkg_group}
213 License: GPLv2+
214 BuildArch: noarch
216 %description -n %{common_files}
217 This package provides common files for the SIPE protocol plugins:
219 * Localisation
222 %prep
223 %if 0%{?_with_git:1}
224 %setup -q -n %{name}-%{git}
225 %else
226 %setup -q
227 %endif
230 %build
231 %if 0%{?_with_git:1}
232 ./autogen.sh
233 %endif
234 %configure \
235 %if 0%{?_without_vv:1}
236 --without-vv \
237 %endif
238 %if !0%{?_without_kerberos:1}
239 --with-krb5 \
240 %endif
241 --enable-purple \
242 %if !0%{?_without_telepathy:1}
243 --enable-telepathy
244 %else
245 --disable-telepathy
246 %endif
247 make %{?_smp_mflags}
248 make %{?_smp_mflags} check
251 %install
252 %makeinstall
253 find %{buildroot} -type f -name "*.la" -delete -print
254 # Pidgin doesn't have 24 or 32 pixel icons
255 rm -f \
256 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
257 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
258 %find_lang %{name}
261 %clean
262 rm -rf %{buildroot}
265 %files -n %{purple_plugin}
266 %defattr(-,root,root,-)
267 %doc AUTHORS ChangeLog COPYING NEWS README TODO
268 %{_libdir}/purple-2/libsipe.so
271 %if !0%{?_without_telepathy:1}
272 %files -n %{empathy_files}
273 %defattr(-,root,root,-)
274 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
275 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
278 %files -n %{ktp_files}
279 %defattr(-,root,root,-)
280 %doc AUTHORS COPYING
281 %{_datadir}/telepathy/profiles/sipe.profile
284 %files -n %{telepathy_plugin}
285 %defattr(-,root,root,-)
286 %doc AUTHORS ChangeLog COPYING NEWS README TODO
287 %{_datadir}/dbus-1/services/*.sipe.service
288 %{_libexecdir}/telepathy-sipe
289 %endif
292 %files -n %{common_files} -f %{name}.lang
293 %defattr(-,root,root,-)
296 %files
297 %defattr(-,root,root,-)
298 %{_datadir}/appdata/%{name}.metainfo.xml
299 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
300 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
303 %changelog
304 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
305 - update to 1.21.0
307 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
308 - align with Fedora SPEC file
310 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
311 - add AppStream metadata file
313 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
314 - add dependency on pkgconfig(gstreamer-1.0) for F22+
316 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
317 - update to 1.20.1
319 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
320 - we also support "Skype for Business"
322 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
323 - update to 1.20.0
325 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
326 - update to 1.19.1
328 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
329 - update to 1.19.0
331 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
332 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
333 - enable Voice & Video features by default
334 - move dependency on libnice-gstreamer to correct packages
336 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
337 - update to 1.18.5
339 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
340 - update to 1.18.4
342 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
343 - update to 1.18.3
345 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
346 - update to 1.18.2
348 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
349 - update to 1.18.1
351 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
352 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
354 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
355 - F20+ require libnice-gstreamer for correct operation
357 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
358 - update to 1.18.0
360 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
361 - update to 1.17.3
363 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
364 - update to 1.17.2
366 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
367 - update to 1.17.1
369 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
370 - update to 1.17.0
372 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
373 - update to 1.16.1
375 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
376 - update to 1.16.0
378 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
379 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
381 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
382 - update to 1.15.1
384 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
385 - update package description texts
387 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
388 - update to 1.15.0
390 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
391 - update to 1.14.1
393 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
394 - update to 1.14.0
396 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
397 - BR telepathy-glib-devel >= 0.18.0
399 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
400 - BR telepathy-glib-devel >= 0.14.0
402 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
403 - add ktp-accounts-kcm-sipe package
405 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
406 - telepathy now requires glib-2.0 >= 2.22.0
407 - use "--without telepathy" to disable telepathy packages
409 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
410 - add empathy-sipe package
412 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
413 - add telepathy-sipe & sipe-common packages
415 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
416 - update to 1.13.3
418 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
419 - update to 1.13.2
421 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
422 - update to 1.13.1
424 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
425 - update to 1.13.0
427 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
428 - we do support Microsoft Lync Server 2010 now.
430 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
431 - update GPL2 license name
433 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
434 - add BR gmime-devel
436 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
437 - add BR nss-devel
439 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
440 - update to 1.12.0
442 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
443 - add "--with vv" option to enable Voice & Video features
445 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
446 - update to 1.11.2
448 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
449 - update to 1.11.1
451 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
452 - update to 1.11.0
454 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
455 - add (commented out) BR libnice-devel
457 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
458 - update to 1.10.1
460 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
461 - add (commented out) BR nss-devel
463 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
464 - update to 1.10.0
466 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
467 - changed --with/--without options to --enable/--disable
469 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
470 - removed --with-krb5 configure option as it is autodetected now
472 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
473 - add SVG icon
475 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
476 - add BR glib2-devel >= 2.12.0
478 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
479 - add tests to build
481 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
482 - update to 1.9.1
484 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
485 - add BR libxml2-devel
487 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
488 - update to 1.9.0
490 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
491 - increased libpurple build requisite to >= 2.4.0
493 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
494 - sync with RPM SPEC from contrib/OBS
496 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
497 - update package summary & description
499 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
500 - update to 1.8.1
502 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
503 - update to 1.8.0
505 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
506 - autogen.sh no longer runs configure
508 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
509 - add configure parameters for purple and telepathy
511 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
512 - add Epoch: for git packages to avoid update clash with official packages
514 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
515 - update to 1.7.1
517 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
518 - add missing Group: to purple-sipe
520 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
521 - update to 1.7.0
523 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
524 - move non-Pidgin files to new sub-package purple-sipe
526 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
527 - remove directory for emoticon theme icons
529 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
530 - libpurple protocol plugins are located under %%{_libdir}/purple-2
532 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
533 - added directory for emoticon theme icons
535 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
536 - update to 1.6.3
538 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
539 - reduce libpurple-devel requirement to >= 2.3.1
541 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
542 - update to 1.6.2
544 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
545 - reduce libpurple-devel requirement to >= 2.4.1
547 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
548 - com_err.h only required for kerberos
550 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
551 - require libpurple-devel >= 2.5.0
553 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
554 - refactor configure parameters
555 - make kerberos configurable
556 - don't hard code prefix for git builds
558 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
559 - removed unnecessary zlib-devel
561 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
562 - fix prefix for git builds
564 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
565 - append -Wno-unused-parameter for GCC <4.4 compilation errors
567 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
568 - remove duplicate GPL2
570 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
571 - use "--with git" to build from git
572 - corrected download URL for release archive
573 - add missing BR gettext-devel
575 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
576 - use default rpmbuild CFLAGS also for git builds
577 - merge with SPEC files created by mricon & jberanek
579 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
580 - initial RPM SPEC example generated