Updated to release 1.10.1 (Bugfixes release only)
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobfef75f5305d2dd58881b84a46ff305d6837f053f
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define pkg_group Applications/Internet
22 Name: pidgin-sipe
23 Summary: Pidgin protocol plugin to connect to MS Office Communicator
24 Version: 1.10.1
25 %if 0%{?_with_git:1}
26 Release: %{gitcount}.%{git}%{?dist}
27 Source: %{name}-%{git}.tar.bz2
28 # git package overrides official released package
29 Epoch: 1
30 %else
31 Release: 1%{?dist}
32 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
33 %endif
34 Group: %{pkg_group}
35 License: GPLv2+
36 URL: http://sipe.sourceforge.net/
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40 BuildRequires: libpurple-devel >= 2.4.0
41 BuildRequires: glib2-devel >= 2.12.0
42 BuildRequires: libxml2-devel
43 BuildRequires: libtool
44 BuildRequires: intltool
45 BuildRequires: gettext-devel
47 # Configurable components
48 %if !0%{?_without_kerberos:1}
49 BuildRequires: krb5-devel
50 %endif
52 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
55 %description
56 A third-party plugin for the Pidgin multi-protocol instant messenger.
57 It implements the extended version of SIP/SIMPLE used by various products:
59 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
60 * Microsoft Live Communications Server (LCS 2003/2005)
61 * Reuters Messaging
63 With this plugin you should be able to replace your Microsoft Office
64 Communicator client with Pidgin.
66 This package provides the icon set for Pidgin.
69 %package -n %{purple_plugin}
70 Summary: Libpurple protocol plugin to connect to MS Office Communicator
71 Group: %{pkg_group}
72 License: GPLv2+
74 %description -n %{purple_plugin}
75 A third-party plugin for the Pidgin multi-protocol instant messenger.
76 It implements the extended version of SIP/SIMPLE used by various products:
78 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
79 * Microsoft Live Communications Server (LCS 2003/2005)
80 * Reuters Messaging
82 This package provides the protocol plugin for libpurple clients.
85 %prep
86 %if 0%{?_with_git:1}
87 %setup -q -n %{name}-%{git}
88 %else
89 %setup -q
90 %endif
93 %build
94 %if 0%{?_with_git:1}
95 ./autogen.sh
96 %endif
97 %configure \
98 --enable-purple \
99 --disable-telepathy
100 make %{_smp_mflags}
101 make %{_smp_mflags} check
104 %install
105 %makeinstall
106 find %{buildroot} -type f -name "*.la" -delete -print
107 %find_lang %{name}
110 %clean
111 rm -rf %{buildroot}
114 %files -n %{purple_plugin} -f %{name}.lang
115 %defattr(-,root,root,-)
116 %doc AUTHORS ChangeLog COPYING NEWS README TODO
117 %{_libdir}/purple-2/libsipe.so
120 %files
121 %defattr(-,root,root,-)
122 %doc AUTHORS COPYING
123 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
124 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
127 %changelog
128 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
129 - update to 1.10.1
131 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
132 - update to 1.10.0
134 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
135 - changed --with/--without options to --enable/--disable
137 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
138 - removed --with-krb5 configure option as it is autodetected now
140 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
141 - add SVG icon
143 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
144 - add BR glib2-devel >= 2.12.0
146 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
147 - add tests to build
149 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
150 - update to 1.9.1
152 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
153 - add BR libxml2-devel
155 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
156 - update to 1.9.0
158 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
159 - increased libpurple build requisite to >= 2.4.0
161 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
162 - sync with RPM SPEC from contrib/OBS
164 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
165 - update package summary & description
167 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
168 - update to 1.8.1
170 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
171 - update to 1.8.0
173 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
174 - autogen.sh no longer runs configure
176 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
177 - add configure parameters for purple and telepathy
179 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
180 - add Epoch: for git packages to avoid update clash with official packages
182 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
183 - update to 1.7.1
185 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
186 - add missing Group: to purple-sipe
188 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
189 - update to 1.7.0
191 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
192 - move non-Pidgin files to new sub-package purple-sipe
194 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
195 - remove directory for emoticon theme icons
197 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
198 - libpurple protocol plugins are located under %{_libdir}/purple-2
200 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
201 - added directory for emoticon theme icons
203 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
204 - update to 1.6.3
206 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
207 - reduce libpurple-devel requirement to >= 2.3.1
209 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
210 - update to 1.6.2
212 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
213 - reduce libpurple-devel requirement to >= 2.4.1
215 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
216 - com_err.h only required for kerberos
218 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
219 - require libpurple-devel >= 2.5.0
221 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
222 - refactor configure parameters
223 - make kerberos configurable
224 - don't hard code prefix for git builds
226 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
227 - removed unnecessary zlib-devel
229 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
230 - fix prefix for git builds
232 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
233 - append -Wno-unused-parameter for GCC <4.4 compilation errors
235 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
236 - remove duplicate GPL2
238 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
239 - use "--with git" to build from git
240 - corrected download URL for release archive
241 - add missing BR gettext-devel
243 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
244 - use default rpmbuild CFLAGS also for git builds
245 - merge with SPEC files created by mricon & jberanek
247 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
248 - initial RPM SPEC example generated