Updated to release 1.12.0
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob689c9ed9fc5f1b53914bf01ae3deeb2d92a230bf
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define pkg_group Applications/Internet
22 Name: pidgin-sipe
23 Summary: Pidgin protocol plugin to connect to MS Office Communicator
24 Version: 1.12.0
25 %if 0%{?_with_git:1}
26 Release: %{gitcount}.%{git}%{?dist}
27 Source: %{name}-%{git}.tar.bz2
28 # git package overrides official released package
29 Epoch: 1
30 %else
31 Release: 1%{?dist}
32 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
33 %endif
34 Group: %{pkg_group}
35 License: GPLv2+
36 URL: http://sipe.sourceforge.net/
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40 BuildRequires: libpurple-devel >= 2.4.0
41 BuildRequires: glib2-devel >= 2.12.0
42 BuildRequires: libxml2-devel
43 #BuildRequires: nss-devel
44 BuildRequires: libtool
45 BuildRequires: intltool
46 BuildRequires: gettext-devel
47 # Use "--with vv" to enable Voice & Video features
48 %if 0%{?_with_vv:1}
49 BuildRequires: libpurple-devel >= 2.8.0
50 BuildRequires: glib2-devel >= 2.28.0
51 BuildRequires: libnice-devel >= 0.1.0
52 BuildRequires: gstreamer-devel
53 %endif
55 # Configurable components
56 %if !0%{?_without_kerberos:1}
57 BuildRequires: krb5-devel
58 %endif
60 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
63 %description
64 A third-party plugin for the Pidgin multi-protocol instant messenger.
65 It implements the extended version of SIP/SIMPLE used by various products:
67 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
68 * Microsoft Live Communications Server (LCS 2003/2005)
69 * Reuters Messaging
71 With this plugin you should be able to replace your Microsoft Office
72 Communicator client with Pidgin.
74 This package provides the icon set for Pidgin.
77 %package -n %{purple_plugin}
78 Summary: Libpurple protocol plugin to connect to MS Office Communicator
79 Group: %{pkg_group}
80 License: GPLv2+
82 %description -n %{purple_plugin}
83 A third-party plugin for the Pidgin multi-protocol instant messenger.
84 It implements the extended version of SIP/SIMPLE used by various products:
86 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
87 * Microsoft Live Communications Server (LCS 2003/2005)
88 * Reuters Messaging
90 This package provides the protocol plugin for libpurple clients.
93 %prep
94 %if 0%{?_with_git:1}
95 %setup -q -n %{name}-%{git}
96 %else
97 %setup -q
98 %endif
101 %build
102 %if 0%{?_with_git:1}
103 ./autogen.sh
104 %endif
105 %configure \
106 --enable-purple \
107 --disable-telepathy
108 make %{_smp_mflags}
109 make %{_smp_mflags} check
112 %install
113 %makeinstall
114 find %{buildroot} -type f -name "*.la" -delete -print
115 %find_lang %{name}
118 %clean
119 rm -rf %{buildroot}
122 %files -n %{purple_plugin} -f %{name}.lang
123 %defattr(-,root,root,-)
124 %doc AUTHORS ChangeLog COPYING NEWS README TODO
125 %{_libdir}/purple-2/libsipe.so
128 %files
129 %defattr(-,root,root,-)
130 %doc AUTHORS COPYING
131 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
132 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
135 %changelog
136 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
137 - update to 1.12.0
139 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
140 - add "--with vv" option to enable Voice & Video features
142 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
143 - update to 1.11.2
145 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
146 - update to 1.11.1
148 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
149 - update to 1.11.0
151 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
152 - add (commented out) BR libnice-devel
154 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
155 - update to 1.10.1
157 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
158 - add (commented out) BR nss-devel
160 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
161 - update to 1.10.0
163 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
164 - changed --with/--without options to --enable/--disable
166 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
167 - removed --with-krb5 configure option as it is autodetected now
169 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
170 - add SVG icon
172 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
173 - add BR glib2-devel >= 2.12.0
175 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
176 - add tests to build
178 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
179 - update to 1.9.1
181 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
182 - add BR libxml2-devel
184 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
185 - update to 1.9.0
187 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
188 - increased libpurple build requisite to >= 2.4.0
190 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
191 - sync with RPM SPEC from contrib/OBS
193 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
194 - update package summary & description
196 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
197 - update to 1.8.1
199 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
200 - update to 1.8.0
202 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
203 - autogen.sh no longer runs configure
205 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
206 - add configure parameters for purple and telepathy
208 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
209 - add Epoch: for git packages to avoid update clash with official packages
211 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
212 - update to 1.7.1
214 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
215 - add missing Group: to purple-sipe
217 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
218 - update to 1.7.0
220 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
221 - move non-Pidgin files to new sub-package purple-sipe
223 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
224 - remove directory for emoticon theme icons
226 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
227 - libpurple protocol plugins are located under %{_libdir}/purple-2
229 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
230 - added directory for emoticon theme icons
232 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
233 - update to 1.6.3
235 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
236 - reduce libpurple-devel requirement to >= 2.3.1
238 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
239 - update to 1.6.2
241 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
242 - reduce libpurple-devel requirement to >= 2.4.1
244 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
245 - com_err.h only required for kerberos
247 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
248 - require libpurple-devel >= 2.5.0
250 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
251 - refactor configure parameters
252 - make kerberos configurable
253 - don't hard code prefix for git builds
255 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
256 - removed unnecessary zlib-devel
258 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
259 - fix prefix for git builds
261 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
262 - append -Wno-unused-parameter for GCC <4.4 compilation errors
264 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
265 - remove duplicate GPL2
267 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
268 - use "--with git" to build from git
269 - corrected download URL for release archive
270 - add missing BR gettext-devel
272 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
273 - use default rpmbuild CFLAGS also for git builds
274 - merge with SPEC files created by mricon & jberanek
276 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
277 - initial RPM SPEC example generated