Release 1.19.1 -- Bug Fixes I
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob2fa6802acc57fc749df1d0cfba5e0bb2289eda8b
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20150106gitced3e52
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.19.1
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: pkgconfig(purple) >= 2.4.0
45 BuildRequires: pkgconfig(glib-2.0) >= 2.12.0
46 BuildRequires: pkgconfig(gmodule-2.0) >= 2.12.0
47 BuildRequires: gmime-devel
48 BuildRequires: pkgconfig(libxml-2.0)
49 BuildRequires: pkgconfig(nss)
50 BuildRequires: libtool
51 BuildRequires: intltool
52 BuildRequires: gettext-devel
53 # Use "--without vv" to disable Voice & Video features
54 %if !0%{?_without_vv:1}
55 BuildRequires: pkgconfig(purple) >= 2.8.0
56 BuildRequires: pkgconfig(nice) >= 0.1.0
57 %if 0%{?fedora} >= 20
58 # Dependency required when gstreamer support is split into two packages
59 %define requires_libnice_gstreamer 1
60 %endif
61 BuildRequires: pkgconfig(gstreamer-0.10)
62 %endif
63 # Use "--without telepathy" to disable telepathy
64 %if !0%{?_without_telepathy:1}
65 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
66 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
67 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
68 BuildRequires: pkgconfig(gobject-2.0)
69 BuildRequires: pkgconfig(dbus-glib-1)
70 %endif
72 # Configurable components
73 # Use "--without kerberos" to disable krb5
74 %if !0%{?_without_kerberos:1}
75 BuildRequires: krb5-devel
76 %if 0%{?fedora} >= 21
77 BuildRequires: gssntlmssp-devel >= 0.5.0
78 %define requires_gssntlmssp 1
79 %endif
80 %endif
82 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
85 %description
86 A third-party plugin for the Pidgin multi-protocol instant messenger.
87 It implements the extended version of SIP/SIMPLE used by various products:
89 * Microsoft Office 365
90 * Microsoft Business Productivity Online Suite (BPOS)
91 * Microsoft Lync Server
92 * Microsoft Office Communications Server (OCS 2007/2007 R2)
93 * Microsoft Live Communications Server (LCS 2003/2005)
94 * Reuters Messaging
96 With this plugin you should be able to replace your Microsoft Office
97 Communicator client with Pidgin.
99 This package provides the icon set for Pidgin.
102 %package -n %{purple_plugin}
103 Summary: Libpurple protocol plugin to connect to MS Office Communicator
104 Group: %{pkg_group}
105 License: GPL-2.0+
106 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
108 %if 0%{?requires_libnice_gstreamer}
109 Requires: libnice-gstreamer
110 %endif
111 %if 0%{?requires_gssntlmssp}
112 Requires: gssntlmssp >= 0.5.0
113 %endif
115 %description -n %{purple_plugin}
116 A third-party plugin for the Pidgin multi-protocol instant messenger.
117 It implements the extended version of SIP/SIMPLE used by various products:
119 * Microsoft Office 365
120 * Microsoft Business Productivity Online Suite (BPOS)
121 * Microsoft Lync Server
122 * Microsoft Office Communications Server (OCS 2007/2007 R2)
123 * Microsoft Live Communications Server (LCS 2003/2005)
124 * Reuters Messaging
126 This package provides the protocol plugin for libpurple clients.
129 %if !0%{?_without_telepathy:1}
130 %package -n %{empathy_files}
131 Summary: Telepathy connection manager to connect to MS Office Communicator
132 Group: %{pkg_group}
133 License: GPL-2.0+
134 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
136 %description -n %{empathy_files}
137 A Telepathy connection manager that implements the extended version of
138 SIP/SIMPLE used by various products:
140 * Microsoft Office 365
141 * Microsoft Business Productivity Online Suite (BPOS)
142 * Microsoft Lync Server
143 * Microsoft Office Communications Server (OCS 2007/2007 R2)
144 * Microsoft Live Communications Server (LCS 2003/2005)
145 * Reuters Messaging
147 This package provides the icon set for Empathy.
150 %package -n %{ktp_files}
151 Summary: Telepathy connection manager to connect to MS Office Communicator
152 Group: %{pkg_group}
153 License: GPL-2.0+
154 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
156 %description -n %{ktp_files}
157 A Telepathy connection manager that implements the extended version of
158 SIP/SIMPLE used by various products:
160 * Microsoft Office 365
161 * Microsoft Business Productivity Online Suite (BPOS)
162 * Microsoft Lync Server
163 * Microsoft Office Communications Server (OCS 2007/2007 R2)
164 * Microsoft Live Communications Server (LCS 2003/2005)
165 * Reuters Messaging
167 This package provides the profile for KTP account manager.
170 %package -n %{telepathy_plugin}
171 Summary: Telepathy connection manager to connect to MS Office Communicator
172 Group: %{pkg_group}
173 License: GPL-2.0+
174 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
176 %if 0%{?requires_libnice_gstreamer}
177 # @TODO: remove comment when telepathy plugin supports Voice & Video features
178 #Requires: libnice-gstreamer
179 %endif
180 %if 0%{?requires_gssntlmssp}
181 Requires: gssntlmssp >= 0.5.0
182 %endif
184 %description -n %{telepathy_plugin}
185 A Telepathy connection manager that implements the extended version of
186 SIP/SIMPLE used by various products:
188 * Microsoft Office 365
189 * Microsoft Business Productivity Online Suite (BPOS)
190 * Microsoft Lync Server
191 * Microsoft Office Communications Server (OCS 2007/2007 R2)
192 * Microsoft Live Communications Server (LCS 2003/2005)
193 * Reuters Messaging
195 This package provides the protocol support for Telepathy clients.
196 %endif
199 %package -n %{common_files}
200 Summary: Common files for SIPE protocol plugins
201 Group: %{pkg_group}
202 License: GPL-2.0+
203 BuildArch: noarch
205 %description -n %{common_files}
206 This package provides common files for the SIPE protocol plugins:
208 * Localisation
211 %prep
212 %if 0%{?_with_git:1}
213 %setup -q -n %{name}-%{git}
214 %else
215 %setup -q
216 %endif
219 %build
220 %if 0%{?_with_git:1}
221 ./autogen.sh
222 %endif
223 %configure \
224 %if 0%{?_without_vv:1}
225 --without-vv \
226 %endif
227 --enable-purple \
228 %if !0%{?_without_telepathy:1}
229 --enable-telepathy
230 %else
231 --disable-telepathy
232 %endif
233 make %{_smp_mflags}
234 make %{_smp_mflags} check
237 %install
238 %makeinstall
239 find %{buildroot} -type f -name "*.la" -delete -print
240 # Pidgin doesn't have 24 or 32 pixel icons
241 rm -f \
242 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
243 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
244 %find_lang %{name}
247 %clean
248 rm -rf %{buildroot}
251 %files -n %{purple_plugin}
252 %defattr(-,root,root,-)
253 %doc AUTHORS ChangeLog COPYING NEWS README TODO
254 %{_libdir}/purple-2/libsipe.so
257 %if !0%{?_without_telepathy:1}
258 %files -n %{empathy_files}
259 %defattr(-,root,root,-)
260 %doc AUTHORS COPYING
261 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
262 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
265 %files -n %{ktp_files}
266 %defattr(-,root,root,-)
267 %doc AUTHORS COPYING
268 %{_datadir}/telepathy/profiles/sipe.profile
271 %files -n %{telepathy_plugin}
272 %defattr(-,root,root,-)
273 %doc AUTHORS ChangeLog COPYING NEWS README TODO
274 %{_datadir}/dbus-1/services/*.sipe.service
275 %{_libexecdir}/telepathy-sipe
276 %endif
279 %files -n %{common_files} -f %{name}.lang
280 %defattr(-,root,root,-)
283 %files
284 %defattr(-,root,root,-)
285 %doc AUTHORS COPYING
286 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
287 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
290 %changelog
291 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
292 - update to 1.19.1
294 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
295 - update to 1.19.0
297 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
298 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
299 - enable Voice & Video features by default
300 - move dependency on libnice-gstreamer to correct packages
302 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
303 - update to 1.18.5
305 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
306 - update to 1.18.4
308 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
309 - update to 1.18.3
311 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
312 - update to 1.18.2
314 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
315 - update to 1.18.1
317 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
318 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
320 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
321 - F20+ require libnice-gstreamer for correct operation
323 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
324 - update to 1.18.0
326 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
327 - update to 1.17.3
329 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
330 - update to 1.17.2
332 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
333 - update to 1.17.1
335 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
336 - update to 1.17.0
338 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
339 - update to 1.16.1
341 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
342 - update to 1.16.0
344 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
345 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
347 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
348 - update to 1.15.1
350 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
351 - update package description texts
353 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
354 - update to 1.15.0
356 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
357 - update to 1.14.1
359 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
360 - update to 1.14.0
362 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
363 - BR telepathy-glib-devel >= 0.18.0
365 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
366 - BR telepathy-glib-devel >= 0.14.0
368 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
369 - add ktp-accounts-kcm-sipe package
371 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
372 - telepathy now requires glib-2.0 >= 2.22.0
373 - use "--without telepathy" to disable telepathy packages
375 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
376 - add empathy-sipe package
378 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
379 - add telepathy-sipe & sipe-common packages
381 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
382 - update to 1.13.3
384 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
385 - update to 1.13.2
387 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
388 - update to 1.13.1
390 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
391 - update to 1.13.0
393 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
394 - we do support Microsoft Lync Server 2010 now.
396 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
397 - update GPL2 license name
399 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
400 - add BR gmime-devel
402 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
403 - add BR nss-devel
405 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
406 - update to 1.12.0
408 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
409 - add "--with vv" option to enable Voice & Video features
411 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
412 - update to 1.11.2
414 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
415 - update to 1.11.1
417 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
418 - update to 1.11.0
420 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
421 - add (commented out) BR libnice-devel
423 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
424 - update to 1.10.1
426 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
427 - add (commented out) BR nss-devel
429 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
430 - update to 1.10.0
432 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
433 - changed --with/--without options to --enable/--disable
435 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
436 - removed --with-krb5 configure option as it is autodetected now
438 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
439 - add SVG icon
441 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
442 - add BR glib2-devel >= 2.12.0
444 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
445 - add tests to build
447 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
448 - update to 1.9.1
450 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
451 - add BR libxml2-devel
453 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
454 - update to 1.9.0
456 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
457 - increased libpurple build requisite to >= 2.4.0
459 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
460 - sync with RPM SPEC from contrib/OBS
462 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
463 - update package summary & description
465 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
466 - update to 1.8.1
468 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
469 - update to 1.8.0
471 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
472 - autogen.sh no longer runs configure
474 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
475 - add configure parameters for purple and telepathy
477 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
478 - add Epoch: for git packages to avoid update clash with official packages
480 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
481 - update to 1.7.1
483 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
484 - add missing Group: to purple-sipe
486 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
487 - update to 1.7.0
489 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
490 - move non-Pidgin files to new sub-package purple-sipe
492 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
493 - remove directory for emoticon theme icons
495 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
496 - libpurple protocol plugins are located under %{_libdir}/purple-2
498 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
499 - added directory for emoticon theme icons
501 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
502 - update to 1.6.3
504 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
505 - reduce libpurple-devel requirement to >= 2.3.1
507 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
508 - update to 1.6.2
510 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
511 - reduce libpurple-devel requirement to >= 2.4.1
513 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
514 - com_err.h only required for kerberos
516 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
517 - require libpurple-devel >= 2.5.0
519 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
520 - refactor configure parameters
521 - make kerberos configurable
522 - don't hard code prefix for git builds
524 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
525 - removed unnecessary zlib-devel
527 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
528 - fix prefix for git builds
530 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
531 - append -Wno-unused-parameter for GCC <4.4 compilation errors
533 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
534 - remove duplicate GPL2
536 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
537 - use "--with git" to build from git
538 - corrected download URL for release archive
539 - add missing BR gettext-devel
541 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
542 - use default rpmbuild CFLAGS also for git builds
543 - merge with SPEC files created by mricon & jberanek
545 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
546 - initial RPM SPEC example generated