fix compiler warnings, oops
[ruby_posix_mq.git] / GNUmakefile
blob5c9d1ae5958ed60480058ad968cb08a549e93947
1 all::
2 RSYNC_DEST := bogomips.org:/srv/bogomips/ruby_posix_mq
3 rfproject := qrp
4 rfpackage := posix_mq
5 man-rdoc: man html
6 for i in $(man1_rdoc); do echo > $$i; done
7 doc:: man-rdoc
8 include pkg.mk
9 ifneq ($(VERSION),)
10 release::
11 $(RAKE) raa_update VERSION=$(VERSION)
12 $(RAKE) publish_news VERSION=$(VERSION)
13 endif
15 base_bins := posix-mq-rb
16 bins := $(addprefix bin/, $(base_bins))
17 man1_rdoc := $(addsuffix _1, $(base_bins))
18 man1_bins := $(addsuffix .1, $(base_bins))
19 man1_paths := $(addprefix man/man1/, $(man1_bins))
21 clean:
22 -$(MAKE) -C Documentation clean
24 man html:
25 $(MAKE) -C Documentation install-$@
27 pkg_extra += $(man1_paths)
29 doc::
30 install -m644 COPYING-GPL2 doc/COPYING-GPL2
31 $(RM) $(man1_rdoc)
32 .PHONY: man html