set close-on-exec in pipe size modification check
[ruby_io_splice.git] / io_splice.gemspec
blobbc3c477a7f946bf33bba300071381a3c6b738ab6
1 # -*- encoding: binary -*-
2 ENV["VERSION"] or abort "VERSION= must be specified"
3 manifest = File.readlines('.manifest').map! { |x| x.chomp! }
4 require 'wrongdoc'
5 extend Wrongdoc::Gemspec
6 name, summary, title = readme_metadata
8 Gem::Specification.new do |s|
9   s.name = %q{io_splice}
10   s.version = ENV["VERSION"].dup
11   s.authors = ["Ruby io_splice hackers"]
12   s.date = Time.now.utc.strftime('%Y-%m-%d')
13   s.description = readme_description
14   s.email = %q{ruby.io.splice@librelist.org}
15   s.extensions = %w(ext/io_splice/extconf.rb)
16   s.extra_rdoc_files = extra_rdoc_files(manifest)
17   s.files = manifest
18   s.homepage = Wrongdoc.config[:rdoc_url]
19   s.summary = summary
20   s.rdoc_options = rdoc_options
21   s.rubyforge_project = %q{qrp}
22   s.test_files = Dir['test/test_*.rb']
23   s.add_development_dependency('wrongdoc', '~> 1.5')
24   s.add_development_dependency('rack', '~> 1.2')
26   # s.licenses = %w(LGPL) # accessor not compatible with older RubyGems
27 end