Merged from mwolson@gnu.org--2006 (patch 32-33)
[planner-el.git] / debian / rules
blob9e5b91c68de3877d2f917fb4ad2c7c9f8f9a357f
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 PACKAGE = planner-el
9 PKGDIR = debian/${PACKAGE}
10 DOCDIR = /usr/share/doc/${PACKAGE}
11 LISPDIR = /usr/share/emacs/site-lisp/${PACKAGE}
13 configure: configure-stamp
14 configure-stamp:
15 dh_testdir
16 # Add here commands to configure the package.
18 touch configure-stamp
20 build: build-stamp
22 build-stamp: configure-stamp
23 dh_testdir
25 # Add here commands to compile the package.
26 # $(MAKE)
27 $(MAKE) autoloads
28 LANG=en_US makeinfo planner-el.texi
29 texi2html planner-el.texi
30 touch build-stamp
32 clean:
33 dh_testdir
34 dh_testroot
35 rm -f build-stamp configure-stamp
37 # Add here commands to clean up after the build process.
38 -$(MAKE) realclean
39 dh_clean
41 install: build
42 dh_testdir
43 dh_testroot
44 dh_clean -k
45 dh_installdirs
47 # Add here commands to install the package into debian/tmp.
48 install -d $(PKGDIR)$(LISPDIR) $(PKGDIR)$(LISPDIR)/contrib
49 install -d ${PKGDIR}${DOCDIR}
50 install -m 644 *.el $(PKGDIR)$(LISPDIR)
51 install -m 644 contrib/*.el $(PKGDIR)$(LISPDIR)/contrib
52 install -m 0644 AUTHORS ${PKGDIR}${DOCDIR}/AUTHORS
53 install -m 0644 COMMENTARY ${PKGDIR}${DOCDIR}/COMMENTARY
54 install -m 0644 NEWS ${PKGDIR}${DOCDIR}/NEWS
55 install -m 0644 README ${PKGDIR}${DOCDIR}/README
56 install -m 0644 ChangeLog.2006 ${PKGDIR}${DOCDIR}/changelog
57 cat ChangeLog.2005 >> ${PKGDIR}${DOCDIR}/changelog
58 cat ChangeLog.2004 >> ${PKGDIR}${DOCDIR}/changelog
60 # Build architecture-independent files here.
61 binary-indep: build install
62 dh_testdir
63 dh_testroot
64 dh_installchangelogs
65 dh_installdocs
66 # dh_installexamples
67 # dh_install
68 # dh_installmenu
69 # dh_installdebconf
70 # dh_installlogrotate
71 dh_installemacsen --priority=51
72 # dh_installpam
73 # dh_installmime
74 # dh_installinit
75 # dh_installcron
76 dh_installinfo
77 dh_installman
78 dh_link
79 dh_strip
80 dh_compress
81 dh_fixperms
82 # dh_perl
83 # dh_python
84 # dh_makeshlibs
85 dh_installdeb
86 # dh_shlibdeps
87 dh_gencontrol
88 dh_md5sums
89 dh_builddeb
91 # Build architecture-dependent files here.
92 binary-arch: build install
94 binary: binary-indep binary-arch
95 .PHONY: build clean binary-indep binary-arch binary install configure