games-arcade/performous-9999: changed git url
[otih-overlay.git] / games-arcade / performous / performous-9999.ebuild
blob6b49636b93917554bb852fc6604dda5df494c8e2
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /cvsroot/ultrastar-ng/UltraStar-ng/portage-overlay/games-arcade/performous/performous-9999.ebuild,v 1.10 2007/09/29 13:04:19 yoda-jm Exp $
5 inherit games git cmake-utils
7 RESTRICT="nostrip"
9 SONGS_PN=ultrastar-songs
11 DESCRIPTION="Karaoke game similar to Singstar"
12 HOMEPAGE="http://performous.org"
13 SRC_URI="songs? (
14 mirror://sourceforge/${PN}/${SONGS_PN}-jc-1.zip
15 mirror://sourceforge/${PN}/${SONGS_PN}-libre-3.zip
16 mirror://sourceforge/${PN}/${SONGS_PN}-restricted-3.zip
17 mirror://sourceforge/${PN}/${SONGS_PN}-shearer-1.zip
20 EGIT_REPO_URI="git://git.performous.org/gitroot/performous/performous"
22 LICENSE="GPL-2
23 songs? (
24 CCPL-Attribution-ShareAlike-NonCommercial-2.5
25 CCPL-Attribution-NonCommercial-NoDerivs-2.5
27 SLOT="0"
28 KEYWORDS=""
30 IUSE="debug alsa portaudio pulseaudio jack songs gstreamer"
32 RDEPEND="gnome-base/librsvg
33 dev-libs/boost
34 x11-libs/pango
35 dev-cpp/libxmlpp
36 media-libs/glew
37 >=media-video/ffmpeg-0.4.9_p20070616-r20
38 alsa? ( media-libs/alsa-lib )
39 jack? ( media-sound/jack-audio-connection-kit )
40 portaudio? ( media-libs/portaudio )
41 gstreamer? ( media-libs/gstreamer )
42 pulseaudio? ( media-sound/pulseaudio )
43 sys-apps/help2man
44 !games-arcade/ultrastar-ng"
45 DEPEND="${RDEPEND}
46 >=dev-util/cmake-2.6.0"
48 pkg_setup() {
49 games_pkg_setup
50 if ! built_with_use --missing true dev-libs/boost threads ; then
51 eerror "Please emerge dev-libs/boost with USE=threads"
55 src_unpack() {
56 git_src_unpack
57 if use songs; then
58 cd "${S}"
59 unpack "${SONGS_PN}-jc-1.zip"
60 unpack "${SONGS_PN}-libre-3.zip"
61 unpack "${SONGS_PN}-restricted-3.zip"
62 unpack "${SONGS_PN}-shearer-1.zip"
63 pwd
67 src_compile() {
68 mkdir build
69 cd build
70 plugins="-DLIBDA_AUTODETECT_PLUGINS=false -DLIBDA_PLUGIN_TESTING=false"
71 if use alsa ; then
72 plugins="$plugins -DLIBDA_PLUGIN_ALSA=true"
73 else
74 plugins="$plugins -DLIBDA_PLUGIN_ALSA=false"
76 if use jack ; then
77 plugins="$plugins -DLIBDA_PLUGIN_JACK=true"
78 else
79 plugins="$plugins -DLIBDA_PLUGIN_JACK=false"
81 if use gstreamer ; then
82 plugins="$plugins -DLIBDA_PLUGIN_GSTREAMER=true"
83 else
84 plugins="$plugins -DLIBDA_PLUGIN_GSTREAMER=false"
86 if use portaudio ; then
87 plugins="$plugins -DLIBDA_PLUGIN_PORTAUDIO=true"
88 else
89 plugins="$plugins -DLIBDA_PLUGIN_PORTAUDIO=false"
91 if use pulseaudio ; then
92 plugins="$plugins -DLIBDA_PLUGIN_PULSE=true"
93 else
94 plugins="$plugins -DLIBDA_PLUGIN_PULSE=false"
96 cmake \
97 -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
98 -DCMAKE_INSTALL_PREFIX="/usr" \
99 $plugins \
100 .. || die "cmake failed"
101 emake || die "emake failed"
104 src_install() {
105 cd build
106 emake DESTDIR="${D}" install || die "make install failed"
107 keepdir "/usr/ultrastar/songs"
108 rm -rf "${D}/usr/share/${PN}"/{applications,pixmaps}
109 if use songs; then
110 insinto "/usr/share/games/ultrastar"
111 doins -r ../songs || die "doins songs failed"
113 doicon data/${PN}.xpm
114 domenu data/${PN}.desktop
115 dodoc ../docs/*.txt
116 prepgamesdirs