Copy from Berkano Overlay
[otih-overlay.git] / media-libs / libdvdread / .svn / text-base / libdvdread-9999.ebuild.svn-base
blob88e8c6f386b8c5e3b0dbc3cce2c6cd0ac5ed28fe
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 WANT_AUTOCONF="2.5"
7 inherit eutils autotools multilib subversion
9 DESCRIPTION="Library for DVD navigation tools"
10 HOMEPAGE="http://mplayerhq.hu/"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="debug"
17 ESVN_REPO_URI="svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdread"
18 ESVN_PROJECT="libdvdread"
20 DEPEND="!<=media-libs/libdvdnav-4.1.2"
21 RDEPEND="$DEPEND"
23 src_compile() {
24         ./configure2 --prefix=/usr --libdir=/usr/$(get_libdir) \
25                 --shlibdir=/usr/$(get_libdir) --enable-static --enable-shared \
26                 --disable-strip --disable-opts $(use_enable debug) \
27                 --extra-cflags=${CFLAGS}  --extra-ldflags="${LDFLAGS}" \
28                 || die "configure died"
29         emake version.h || die "emake version.h died"
30         emake || die "emake died"
33 src_install () {
34         emake -j1 DESTDIR="${D}" install || die "emake install died"
35         dodoc AUTHORS DEVELOPMENT-POLICY.txt ChangeLog TODO README