ThirdParty packages: modification for calling make another compiler than gcc
[openfoam-extend-OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / metis-5.0pre2.spec
blobe0ab2c4cfa1e07130f99b239e0de1d4680d46627
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for metis-5.0pre2
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name metis
65 %define release %{_WM_OPTIONS}
66 %define version 5.0pre2
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: metis
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/OLD
77 Source: %url/%{name}-%{version}.tar.gz
78 Prefix: %{_prefix}
79 Group: Development/Tools
80 Patch0: metis-5.0pre2_patch_darwin
82 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
84 %description
85 %{summary}
87 %prep
88 %setup -q
90 %ifos darwin
91 %patch0 -p1
92 %endif
94 %build
95 [ -n "$WM_CC" ] && export CC="$WM_CC"
96 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
97 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
98 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
99 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
101 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
103 %ifos darwin
104 # The parameter -D_POSIX_C_SOURCE=200809 has a side effect on Mac OS X
105 (cd GKlib/trunk && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC")
106 (cd libmetis && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC")
107 %else
108 (cd GKlib/trunk && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC -D_POSIX_C_SOURCE=200809" CC=$CC)
109 (cd libmetis && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC -D_POSIX_C_SOURCE=200809" CC=$CC)
110 %endif
112 %install
113 # Manual installation
114 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include
115 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
116 cp GKlib/builds/*/libGKlib.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
117 cp build/*/libmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
118 cp include/metis.h $RPM_BUILD_ROOT/%{_installPrefix}/include
120 # Creation of OpenFOAM specific .csh and .sh files"
122 echo ""
123 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
124 echo ""
126 # Generate package specific .sh file for OpenFOAM
128 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
129 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 export METIS_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
134 export METIS_BIN_DIR=\$METIS_DIR/bin
135 export METIS_LIB_DIR=\$METIS_DIR/lib
136 export METIS_INCLUDE_DIR=\$METIS_DIR/include
138 # Enable access to the package runtime applications and libraries
139 [ -d \$METIS_BIN_DIR ] && _foamAddPath \$METIS_BIN_DIR
140 [ -d \$METIS_LIB_DIR ] && _foamAddLib \$METIS_LIB_DIR
142 DOT_SH_EOF
145 # Generate package specific .csh file for OpenFOAM
147 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
148 # Load %{name}-%{version} libraries and binaries if available
149 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
150 setenv METIS_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
151 setenv METIS_BIN_DIR \$METIS_DIR/bin
152 setenv METIS_LIB_DIR \$METIS_DIR/lib
153 setenv METIS_INCLUDE_DIR \$METIS_DIR/include
155 if ( -e \$METIS_BIN_DIR ) then
156 _foamAddPath \$METIS_BIN_DIR
157 endif
159 if ( -e \$METIS_LIB_DIR ) then
160 _foamAddLib \$METIS_LIB_DIR
161 endif
162 DOT_CSH_EOF
164 #finally, generate a .tgz file for systems where using rpm for installing packages
165 # as a non-root user might be a problem.
166 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
169 %clean
170 rm -rf %{buildroot}
172 %Files
173 %defattr(-,root,root)
174 %{_installPrefix}/*