ThirdParty packages: modification for calling make another compiler than gcc
[openfoam-extend-OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / ParMGridGen-1.0.spec
blob5249f9fb5e30f745a9716001e70f7b2eca81e786
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for ParMGridGen-1.0
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name ParMGridGen
65 %define release %{_WM_OPTIONS}
66 %define version 1.0
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: ParMGridGen
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: http://www.mgnet.org/mgnet/Codes/parmgridgen
77 Source: %url/%{name}-%{version}.tar.gz
78 Prefix: %{_prefix}
79 Group: Development/Tools
80 Patch0: ParMGridGen-1.0.patch_darwin
81 Patch1: ParMGridGen-1.0.patch
83 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
85 %description
86 %{summary}
88 %prep
89 %setup -q
91 %ifos darwin
92 %patch0 -p1
93 %else
94 %patch1 -p1
95 %endif
97 %build
98 [ -n "$WM_CC" ] && export CC="$WM_CC"
99 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
100 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
101 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
102 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
104 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
106 make -j $WM_NCOMPPROCS CC=$CC
108 %install
109 # Manual installation
110 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/Lib
111 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/IMlib
112 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
114 cp ./MGridGen/Lib/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/Lib
115 cp ./MGridGen/IMlib/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/IMlib
117 cp ./MGridGen/IMlib/libIMlib.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
118 cp ./MGridGen/Lib/libMGridGen.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
120 # Creation of OpenFOAM specific .csh and .sh files"
122 echo ""
123 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
124 echo ""
126 # Generate package specific .sh file for OpenFOAM
128 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
129 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 export PARMGRIDGEN_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
134 export PARMGRIDGEN_BIN_DIR=\$PARMGRIDGEN_DIR/bin
135 export PARMGRIDGEN_LIB_DIR=\$PARMGRIDGEN_DIR/lib
136 export PARMGRIDGEN_INCLUDE_DIR=\$PARMGRIDGEN_DIR/include
138 # Enable access to the runtime package applications and libraries
139 [ -d \$PARMGRIDGEN_BIN_DIR ] && _foamAddPath \$PARMGRIDGEN_BIN_DIR
140 [ -d \$PARMGRIDGEN_LIB_DIR ] && _foamAddLib \$PARMGRIDGEN_LIB_DIR
141 DOT_SH_EOF
144 # Generate package specific .csh file for OpenFOAM
146 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
147 # Load %{name}-%{version} libraries and binaries if available
148 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
149 setenv PARMGRIDGEN_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
150 setenv PARMGRIDGEN_BIN_DIR \$PARMGRIDGEN_DIR/bin
151 setenv PARMGRIDGEN_LIB_DIR \$PARMGRIDGEN_DIR/lib
152 setenv PARMGRIDGEN_INCLUDE_DIR \$PARMGRIDGEN_DIR/include
154 if ( -e \$PARMGRIDGEN_BIN_DIR ) then
155 _foamAddPath \$PARMGRIDGEN_BIN_DIR
156 endif
158 if ( -e \$PARMGRIDGEN_LIB_DIR ) then
159 _foamAddLib \$PARMGRIDGEN_LIB_DIR
160 endif
161 DOT_CSH_EOF
163 #finally, generate a .tgz file for systems where using rpm for installing packages
164 # as a non-root user might be a problem.
165 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
168 %clean
169 rm -rf %{buildroot}
171 %Files
172 %defattr(-,root,root)
173 %{_installPrefix}/include
174 %{_installPrefix}/lib/*
175 %{_installPrefix}/etc/*