tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / sablevm / sablevm_1.1.9.bb
blob7c5198c0e6b708dd263d0d21623aab78fd299341
1 DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
2 HOMEPAGE = "http://sablevm.org"
3 LICENSE = "LGPL"
4 PRIORITY = "optional"
5 SECTION = "interpreters"
6 PR = "r1"
8 DEPENDS = "libffi libtool popt \
9 sablevm-classpath"
10 # unzip"
11 RRECOMMENDS = "sablevm-classpath (${PV})"
13 SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz"
15 inherit autotools update-alternatives
17 EXTRA_OECONF = "--enable-real-life-brokenness \
18 --disable-errors-on-warnings --disable-signals-for-exceptions"
20 PROVIDES = "virtual/java"
21 ALTERNATIVE_NAME = "java"
22 ALTERNATIVE_PATH = "${bindir}/java-sablevm"
23 ALTERNATIVE_PRIORITY = "350"
25 PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
27 FILES_${PN} = "${bindir} \
28 ${libdir}/${PN}/bin"
30 FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
32 FILES_lib${PN}-dev = "${includedir}/jni* \
33 ${libdir}/lib${PN}.so \
34 ${libdir}/lib${PN}.la"
36 do_install_append() {
37 install -d ${D}${docdir}
38 mv ${D}${datadir}/${PN} ${D}${docdir}/
40 # symlink only present in the deb...
41 install -d ${D}${libdir}/${PN}/bin
42 cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java