tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / sablevm / sablevm-classpath_1.11.3.bb
blob0546dcacd689793b81b07c871c2e1aa4333065b3
1 DESCRIPTION = "GNU Classpath modified to work with SableVM"
2 HOMEPAGE = "http://sablevm.org"
3 LICENSE = "Classpath"
4 PRIORITY = "optional"
5 SECTION = "libs"
7 DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst virtual/javac-native zip-native"
8 RDEPENDS_${PN} = "${PN}-native (>= ${PV})"
10 SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz \
11 file://disable-automake-checks.patch;patch=1"
13 inherit autotools
15 EXTRA_OECONF = "--with-compressed-classes=zip"
17 PACKAGES += " ${PN}-native"
19 FILES_${PN} = "${datadir}/${PN} \
20 ${libdir}/sablevm"
21 FILES_${PN}-native = "${libdir}/${PN}"
23 do_install() {
24 autotools_do_install
25 mv ${D}${libdir}/security ${D}${libdir}/${PN}